12383

Логические функции

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторная работа Логические функции. Оборудование: ПЭВМ Программное обеспечение: Windows EXCEL. Цель работы: приобретение и закрепление практических навыков при использовании логических функций Теоретическая часть. Логические функции в ...

Русский

2013-04-26

67 KB

4 чел.

Лабораторная работа

Логические функции.

  1.  Оборудование:   ПЭВМ
  2.  Программное обеспечение: Windows, EXCEL.
  3.  Цель работы:  приобретение и закрепление практических навыков при использовании логических функций  

Теоретическая часть.

Логические функции в EXCEL (CALC):

  1.  ЕСЛИ IF ( Условие; Выражение   А; Выражение  В )  →   (ЕСЛИ       ТО       ИНАЧЕ)
  2.  И AND (Условие  1;   Условие  2  )  →   Должны выполняться оба условия одновременно.
  3.  ЕСЛИ (И (Условие  1;   Условие  2  ); Выражение   А; Выражение  В )
  4.  ИЛИ OR (Условие  1;   Условие  2  )

Задание:

  1.  Запустить редактор.
  2.  Решить систему уравнений и представить в табличной форме.

Y=

SIN (X),    для  Х>0.5

COS (X),   для  Х<=0.5

 

Порядок выполнения задания.

  1.  Создать таблицу  и занести расчетные формулы.

Для записи формулы с условием нужно щелкнуть по кнопке fx     (вставка функции), выбрать категорию «Логические»,  в первой строке записать логическое выражение, во второй строке выражение, которое удовлетворяет условию, в третьей – выражение, которое не удовлетворяет условию.

Например,  если нужно заполнить столбец Y (X<=0.5) , а значения Х записано в ячейке B4, то в первой строке нужно записать  B4<=0.5,  во второй  - SIN(x),  в третьей – знак пробел в кавычках  “  ”. Текст всегда нужно выводить в кавычках.

A

B

C

D

E

  1.  

Решение уравнений

  1.  

  1.  

X

SIN(x)

COS(x)

Y (X<=0,5)

Y (X>0,5)

  1.  

0,1

= SIN(A4)

= COS(A4)

=ЕСЛИ(A4<=0,5; COS(A4);" ")

=ЕСЛИ (A4>0,5; SIN(A4);" ")

  1.  

0,2

  1.  

0,3

  1.  

0,4

  1.  

0,5

  1.  

0,6

  1.  

0,7

  1.  

0,8

  1.  

0,9

  1.  

1

  1.  

  1.  Занесите в таблицу формулы.
  2.  Установите показ двух знаков после запятой. ( Формат / Ячейки / Формат чисел /
  3.  Установить внешние и внутренние границы.

Перейти на лист 2

Задание.

Создать таблицу «Табель успеваемости»  для пяти человек.

Если средний бал студента выше 4,0  и количество пропусков меньше или равно 10 часам, то в столбце «Итог» вывести “Зачет”.

  1.  Количество пропусков выбирайте случайным образом в интервале от 0 до 100 с округлением до ближайшего целого по формуле:

= Слчис()*100                   

= RAND()*100

  1.  Оценки по предметам - целые случайные числа в интервале от 3 до 5 введите сами.
  2.  В столбце "Итог"  введите формулу по следующему принципу (Вместо слов "" и "" должны быть указаны названия ячеек):

=ЕСЛИ(AND('Сред. Бал'>4; 'Пропуски'<20); "Зачет"; "Выговор")

  1.  Занести в таблицу  формулы.

Табель успеваемости

№№

Ф.И.О

Матем.

Физика

ЭВМ

Сред. бал

Пропуски

Итог

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

Перейти на лист 3

  1.  Продавцы в зависимости от объема продаж получают комиссионные в следующих размерах:

До  50 000  руб. 3 %

от  50 000  руб.до   75 000  руб. 4 %

свыше   75 000 руб 5 %

Если объем продаж превышает  100 000 руб., то продавец получает  премию в размере 50% от суммы, превышающей 100000 руб. Решить задачу для 10 продавцов в виде таблицы. Объем продаж выбирайте случайным образом в интервале от 0 до 150 000 руб. с двумя знаками после запятой в денежном формате.

  1.  Создать таблицу для начисления зарплаты продавцам.

Расчет зарплаты

№№

Ф.И.О.

Объём  продаж

Комиссионные

Премия

Итого

1

2

..

..

9

10

Итого:       

Примечание: формулы с логическими выражениями  можно писать вручную в строке формул, или вставлять через вставка \ функции \ логические

Объём  продаж:  =округл(слчис()*150000;2)

Комиссионные:  =если(С4<50000;С4*3%;если(и (С4>=50000; С4<75000); С4*4%; С4*5%))

Премия: =если(С4>100000; (С4 -100000)*50%;0)

  1.  Занести в таблицу формулы.
  2.  Сохранить книгу
  3.  Завершить работу в редакторе.
  4.  Оформить отчет по работе.

Выводы по работе:


 

А также другие работы, которые могут Вас заинтересовать

84879. Aging and Blind Tracks 30 KB
  Once your dog can complete a three-turn track 200 yards in length (50 yards for each of four legs), then use only the single track at each training session. As tracks have been getting longer, they have naturally been aging for a few minutes.
84880. Additional Motivation 29 KB
  These include food, double-laid tracks, interspersing short, easy tracks and walks in the field. I discovered the latter technique a few years ago, and have found it to be the most productive method...
84881. Before You Finish TD. Tracking Philosophy 50 KB
  Your goal might be to work on multiple articles for one session. It might be to work crosstracks in another. Often, your goal might just be to create an easy workout for the dog for motivation after a tough previous workout. A goal might be to lay off a week or two.
84882. Teaching turns or Overshooting corners 36.5 KB
  I lay my dogs a normal track but about 6-10 feet before I make a corner I shorten my step to make at clear to the dog something has changed. the corner I lay very well after after the corner I place a tidbit, most of my dogs when they came to a strong change like this they slowed checked it out more...
84884. Tracking Dog Training Into the Wind 33 KB
  Bring the dog into the sent pad with the wind to it’s back until he figures out that the damaged ground contains the food. After a couple weeks start bringing the dog to the sent pad at different angles according to the wind.
84885. Tracking to fast 31.5 KB
  I was on the road to correcting this problem working with YYY. Like I mentioned, suggestions such as more food, incredibly tasty food, pinch, double lines, butt strap, more intricate corners, tiny articles, etc., etc. came from some very accomplished trainers.
84886. Article Indication by Dennis Helms 296 KB
  The proper way for a dog to indicate an article when found is for the dog to lie down in a straight line with the track. The article should be between the dog’s front feet and he should touch it with his chin.
84887. Article Indication 31.5 KB
  First you will need some articles. Start with articles around 3 inches square, pieces of leather, wood, and carpet samples work very well. Use different materials and train on different surfaces including grass and dirt.