12383

Логические функции

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторная работа Логические функции. Оборудование: ПЭВМ Программное обеспечение: Windows EXCEL. Цель работы: приобретение и закрепление практических навыков при использовании логических функций Теоретическая часть. Логические функции в ...

Русский

2013-04-26

67 KB

4 чел.

Лабораторная работа

Логические функции.

  1.  Оборудование:   ПЭВМ
  2.  Программное обеспечение: Windows, EXCEL.
  3.  Цель работы:  приобретение и закрепление практических навыков при использовании логических функций  

Теоретическая часть.

Логические функции в EXCEL (CALC):

  1.  ЕСЛИ IF ( Условие; Выражение   А; Выражение  В )  →   (ЕСЛИ       ТО       ИНАЧЕ)
  2.  И AND (Условие  1;   Условие  2  )  →   Должны выполняться оба условия одновременно.
  3.  ЕСЛИ (И (Условие  1;   Условие  2  ); Выражение   А; Выражение  В )
  4.  ИЛИ OR (Условие  1;   Условие  2  )

Задание:

  1.  Запустить редактор.
  2.  Решить систему уравнений и представить в табличной форме.

Y=

SIN (X),    для  Х>0.5

COS (X),   для  Х<=0.5

 

Порядок выполнения задания.

  1.  Создать таблицу  и занести расчетные формулы.

Для записи формулы с условием нужно щелкнуть по кнопке fx     (вставка функции), выбрать категорию «Логические»,  в первой строке записать логическое выражение, во второй строке выражение, которое удовлетворяет условию, в третьей – выражение, которое не удовлетворяет условию.

Например,  если нужно заполнить столбец Y (X<=0.5) , а значения Х записано в ячейке B4, то в первой строке нужно записать  B4<=0.5,  во второй  - SIN(x),  в третьей – знак пробел в кавычках  “  ”. Текст всегда нужно выводить в кавычках.

A

B

C

D

E

  1.  

Решение уравнений

  1.  

  1.  

X

SIN(x)

COS(x)

Y (X<=0,5)

Y (X>0,5)

  1.  

0,1

= SIN(A4)

= COS(A4)

=ЕСЛИ(A4<=0,5; COS(A4);" ")

=ЕСЛИ (A4>0,5; SIN(A4);" ")

  1.  

0,2

  1.  

0,3

  1.  

0,4

  1.  

0,5

  1.  

0,6

  1.  

0,7

  1.  

0,8

  1.  

0,9

  1.  

1

  1.  

  1.  Занесите в таблицу формулы.
  2.  Установите показ двух знаков после запятой. ( Формат / Ячейки / Формат чисел /
  3.  Установить внешние и внутренние границы.

Перейти на лист 2

Задание.

Создать таблицу «Табель успеваемости»  для пяти человек.

Если средний бал студента выше 4,0  и количество пропусков меньше или равно 10 часам, то в столбце «Итог» вывести “Зачет”.

  1.  Количество пропусков выбирайте случайным образом в интервале от 0 до 100 с округлением до ближайшего целого по формуле:

= Слчис()*100                   

= RAND()*100

  1.  Оценки по предметам - целые случайные числа в интервале от 3 до 5 введите сами.
  2.  В столбце "Итог"  введите формулу по следующему принципу (Вместо слов "" и "" должны быть указаны названия ячеек):

=ЕСЛИ(AND('Сред. Бал'>4; 'Пропуски'<20); "Зачет"; "Выговор")

  1.  Занести в таблицу  формулы.

Табель успеваемости

№№

Ф.И.О

Матем.

Физика

ЭВМ

Сред. бал

Пропуски

Итог

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

Перейти на лист 3

  1.  Продавцы в зависимости от объема продаж получают комиссионные в следующих размерах:

До  50 000  руб. 3 %

от  50 000  руб.до   75 000  руб. 4 %

свыше   75 000 руб 5 %

Если объем продаж превышает  100 000 руб., то продавец получает  премию в размере 50% от суммы, превышающей 100000 руб. Решить задачу для 10 продавцов в виде таблицы. Объем продаж выбирайте случайным образом в интервале от 0 до 150 000 руб. с двумя знаками после запятой в денежном формате.

  1.  Создать таблицу для начисления зарплаты продавцам.

Расчет зарплаты

№№

Ф.И.О.

Объём  продаж

Комиссионные

Премия

Итого

1

2

..

..

9

10

Итого:       

Примечание: формулы с логическими выражениями  можно писать вручную в строке формул, или вставлять через вставка \ функции \ логические

Объём  продаж:  =округл(слчис()*150000;2)

Комиссионные:  =если(С4<50000;С4*3%;если(и (С4>=50000; С4<75000); С4*4%; С4*5%))

Премия: =если(С4>100000; (С4 -100000)*50%;0)

  1.  Занести в таблицу формулы.
  2.  Сохранить книгу
  3.  Завершить работу в редакторе.
  4.  Оформить отчет по работе.

Выводы по работе:


 

А также другие работы, которые могут Вас заинтересовать

16064. Адвокатура в Российской Федерации 2.01 MB
  Происходящая в России демократизация политической и экономической системы, конституционное провозглашение правового социального государства вызывает необходимость коренной реорганизации форм и методов деятельности...
16065. Основи ораторського мистецтва 320 KB
  ББК 83. 079 Стец В.А. Стец І.І. Костючик М.Ю. Основи ораторського мистецтва. Навчальний посібник. Економічна думка Тернопіль 1998. 60 с. Посібник дає систематичне уявлення про ораторське мистецтво як прикладну і теоретичну дисципліну. Всебічно проаналізований процес о
16066. Сущность исполнения наказания 1.12 MB
  В монографии освещаются вопросы становления науки уголовно-исполнительного права, излагаются основы теории уголовно-исполнительного права, анализируется уголовно-исполнительная деятельность...
16067. Кримінально-виконавче право України 1.79 MB
  Навчальне видання Кримінальновиконавче право України Підручник За редакцією професора А. X. Степанюка Видання друге виправлене і доповнене Редактор А. В. Єфименко Комп'ютерна верстка і дизайн В. М. Зеленька Підписано до друку з оригіналмакета 01.11.2005. Формат ...
16068. Відповідальність юридичних осіб за податкові правопорушення 1.02 MB
  В книзі розглянуто види відповідальності за порушення податкового законодавства суб'єктами підприємницької діяльності. Зміст книги побудований на власному адвокатському досвіді автора, публікаціях фахівців з податкового права та чинному законодавстві. Акцент при викладенні матеріалу і при розгляді тих чи інших питань свідомо робиться з позицій платників податків.
16070. риміналістична характеристика злочинів 250.5 KB
  Старушкевич А.В. Криміналістична характеристика злочинів: Навч. посібник. К. 1997. 44 с. Вступ Боротьба зі злочинністю е одним із головних державних завдань на будь якій стадії суспільного розвитку. Особливого значення вона набуває в умовах реформування діяльності
16071. Біржова справа 20.06 MB
  Підручник складається з трьох частин і двадцяти розділів. Кожен розділ завершується коротким резюме, контрольними запитаннями, переліком посилань і рекомендованої літератури, тестами для перевірки знань (усього 300), ситуаційними задачами