12493

Динамическая маршрутизация

Лабораторная работа

Информатика, кибернетика и программирование

Во время лабораторной работы мы научились строить топологию с настройкой динамической маршрутизации. Научиться строить топологию с настройкой динамической маршрутизации.

Русский

2014-12-05

582.43 KB

6 чел.

Звіт

з лабораторної роботи №4

на тему: «Динамическая маршрутизация

з дисципліни: «Комп’ютерні мережі»


Тема: Динамическая маршрутизация

Мета: Научиться строить топологию с настройкой динамической маршрутизации.

Виконання завдань лабораторної роботи:

Рисунок 1 – Топология практической части лабораторной работы

Динамическая маршрутизация RIP

Конфигурация маршрутизатора 1:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router1

!

enable password 123

!

interface FastEthernet0/0

description Ethernet interface on Router 1

ip address 10.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

ip address 172.16.10.1 255.255.255.0

clock rate 64000

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router rip

network 10.0.0.0

network 172.16.0.0

!

ip classless

!

line con 0

line vty 0 4

password 123

login

!

end

Конфигурация маршрутизатора 2:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router2

!

interface FastEthernet0/0

ip address 10.1.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router rip

network 10.0.0.0

!

ip classless

!

line con 0

line vty 0 4

login

!

end

Конфигурация маршрутизатора 4:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router4

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

ip address 172.16.10.2 255.255.255.0

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router rip

network 172.16.0.0

!

ip classless

!

line con 0

line vty 0 4

login

!

end

Динамическая маршрутизация IGRP

Конфигурация маршрутизатора 1:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router1

!

enable password 123

!

!

interface FastEthernet0/0

description Ethernet interface on Router 1

ip address 10.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

ip address 172.16.10.1 255.255.255.0

clock rate 64000

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router eigrp 100

network 172.16.0.0

network 10.0.0.0

auto-summary

!

ip classless

!

line con 0

line vty 0 4

password 123

login

!

end

Конфигурация маршрутизатора 2:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router2

!

interface FastEthernet0/0

ip address 10.1.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router eigrp 100

network 10.0.0.0

auto-summary

!

router rip

!

ip classless

!

line con 0

line vty 0 4

login

!

end

Конфигурация маршрутизатора 4:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router4

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

ip address 172.16.10.2 255.255.255.0

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router eigrp 100

network 172.16.0.0

auto-summary

!

ip classless

!

line con 0

line vty 0 4

login

!

end

Динамическая маршрутизация OSPF

Конфигурация маршрутизатора 1:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router1

!

enable password 123

!

interface FastEthernet0/0

description Ethernet interface on Router 1

ip address 10.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

ip address 172.16.10.1 255.255.255.0

clock rate 64000

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router ospf 100

log-adjacency-changes

network 172.16.10.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.255 area 0

!

ip classless

!

line con 0

line vty 0 4

password 123

login

!

end

Конфигурация маршрутизатора 2:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router2

!

interface FastEthernet0/0

ip address 10.1.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

no ip address

shutdown

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router ospf 100

log-adjacency-changes

network 10.1.1.0 0.0.0.255 area 0

!

router rip

!

ip classless

!

line con 0

line vty 0 4

login

!

end

Конфигурация маршрутизатора 4:

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname router4

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet1/0

no ip address

duplex auto

speed auto

shutdown

!

interface Serial2/0

ip address 172.16.10.2 255.255.255.0

!

interface Serial3/0

no ip address

shutdown

!

interface FastEthernet4/0

no ip address

shutdown

!

interface FastEthernet5/0

no ip address

shutdown

!

router ospf 100

log-adjacency-changes

network 172.16.10.0 0.0.0.255 area 0

!

ip classless

!

line con 0

line vty 0 4

 login

!

end

Практическая часть:

Рисунок 2 – Топология самостоятельной работы лабораторной работы

14.1.1.0

14.1.2.0

14.1.3.0

14.1.4.0

14.1.5.0

14.1.6.0

Router1

S0:14.1.1.1

S1:14.1.3.1

Е0:14.1.4.1

Router2

S0:14.1.1.2

S1:14.1.2.1

Е0:14.1.5.1

Router3

S0:14.1.2.2

S1:14.1.3.2

Е0:14.1.6.1

PC1

Е0:14.1.4.2

PC2

Е0:14.1.5.2

PC3

Е0:14.1.6.2

Таблица 1 – Адресса узлов сети согласно варианту.

Динамическая маршрутизация RIP

Команды настройки маршрутизации:

router rip

r1

network 14.1.4.0

network 14.1.3.0

network 14.1.1.0

r2

network 14.1.5.0

network 14.1.1.0

network 14.1.2.0

r3

network 14.1.6.0

network 14.1.3.0

network 14.1.2.0

Рисунок 3 – Просмотр маршрутизации Роутера 1 командой Show ip route

Рисунок 4 – Просмотр маршрутизации Роутера 2 командой Show ip route

Рисунок 5 – Просмотр маршрутизации Роутера 1\3 командой Show ip route

Рисунок 6 – Выполнение трассировки из ПК1 в ПК2 и ПК3 командой Tracert

Рисунок 7 – Выполнение трассировки из ПК2 в ПК1 и ПК3 командой Tracert

Рисунок 8 – Выполнение трассировки из ПК3 в ПК1 и ПК2 командой Tracert

Динамическая маршрутизация IGRP

Команды настройки маршрутизации:

router eigrp 100

r1

network 14.1.4.0

network 14.1.3.0

network 14.1.1.0

r2

network 14.1.5.0

network 14.1.1.0

network 14.1.2.0

r3

network 14.1.6.0

network 14.1.3.0

network 14.1.2.0

Рисунок 9 – Просмотр маршрутизации Роутера 1 командой Show ip route

Рисунок 10 – Просмотр маршрутизации Роутера 2 командой Show ip route

Рисунок 11 – Просмотр маршрутизации Роутера 3 командой Show ip route

Динамическая маршрутизация OSPF

Команды настройки маршрутизации:

router ospf 100

r1

network 14.1.4.0 0.0.0.255 area 0

network 14.1.3.0 0.0.0.255 area 0

network 14.1.1.0 0.0.0.255 area 0

r2

network 14.1.5.0 0.0.0.255 area 0

network 14.1.1.0 0.0.0.255 area 0

network 14.1.2.0 0.0.0.255 area 0

r3

network 14.1.6.0 0.0.0.255 area 0

network 14.1.3.0 0.0.0.255 area 0

network 14.1.2.0 0.0.0.255 area 0

Рисунок 12 – Просмотр маршрутизации Роутера 1 командой Show ip route

Рисунок 13 – Просмотр маршрутизации Роутера 2 командой Show ip route

Рисунок 14 – Просмотр маршрутизации Роутера 3 командой Show ip route

Висновки: Во время лабораторной работы мы научились строить топологию с настройкой динамической маршрутизации.


 

А также другие работы, которые могут Вас заинтересовать

43200. Монтаж одноэтажного промышленного здания 148.5 KB
  Перемещение и монтаж элементов и конструкций над перекрытиями, под которыми находятся люди, допускаются в исключительных случаях по письменному распоряжению I главного инженера генподрядной строительно-монтажной организации при возведении зданий, имеющих более пяти этажей, после разработки мероприятии, обеспечивающих безопасное производство работ. При монтажных работах на высоте должна быть определена и хорошо обозначена видимыми предупредительными знаками опасная зона для нахождения и перемещения людей. В необходимых случаях, кроме этого, подают предупредительные звуковые сигналы.
43201. Проектування приводу до стрічкового конвеєра за схемою та графіком навантаження 1.3 MB
  Курсовий проект з деталей машин – перша самостійна розрахунково-конструкторська робота, під час виконанні якої, студент набуває навичок практичного прикладання своїх теоретичних знань, що були отримані при вивченні фундаментальних та загально технічних дисциплін. На перших етапах роботи над проектом дуже важливо опанувати досвід проектування, що був накопичен в промисловості та відображен в ГОСТах та ДСТУ.
43202. Проектирование смесителя лопастного 3.17 MB
  В гравитационных смесителях в результате подъема и сбрасывания смеси внутри вращающегося барабана рисунок 1. В смесителях непрерывного действия поступление компонентов и выход готовой смеси происходит непрерывно. При переналадке на :смесь новой марки они уступают смесителям циклического действия. а схема смесителя; 1 двигатель; 2 клиноременная передача; 3 редуктор; 4 зубчатая передача; 5 разгрузочный затвор; 6 лопастные валы; 7 лопасть; 8 корыто смесителя.
43203. Синтез и расчёт кулисного механизма 631 KB
  В механизмах привода поперечно строгальных станков используется механизм, обеспечивающий главное возвратно-поступательное движение резания. Основная масса механизмов использующихся в данных станках это кулисные механизмы. Они обеспечивают заданную скорость рабочего хода и повышенную скорость холостого хода. Расчёт и проектирование данных механизмов является важным этапом в образовании инженера. В курсе предмета «Теория машин, механизмов и манипуляторов» получаются навыки расчёта механизмов машин. Комплексным подходом к закреплению полученных знаний является выполнение курсового проекта по данному курсу. В курсовом проекте осуществляется синтез и расчёт кулисного механизма, построение и расчёт зубчатого зацепления и кулачкового механизма. При выполнении работы используются все знания, полученные за курс предмета.
43204. Разработка эскизного проекта автоматической линии 379.5 KB
  Технические требования к детали Технологичность конструкции детали с точки зрения обработки на автоматической линии. Технические требования к детали К данной детали вал-шестерня применяются следующие технические требования: 1. Масса детали 1.
43205. Разработка канала для комплексной скважинной аппаратуры 1.35 MB
  Основная погрешность канала измерения температуры Дополнительная погрешность канала измерения температуры Основная погрешность канала измерения влажности Дополнительная погрешность влагомера Влажность нефти является одним из важнейших технологических параметров. На разных этапах добычи и подготовки нефти она определяет правильность эксплуатации нефтяного пласта, интенсивность эмульгирования водо-нефтяной смеси в процессе ее перекачки, эффективность процессов деэмульсации и качество товарной нефти, поступающей на переработку. С влагосодержанием тесно связано также содержание солей, которые причиняют немалый вред оборудованию нефтеперерабатывающих заводов.
43206. АНДРЕЙ БИТОВ, ЗАХАР ПРИЛЕПИН, МИХАИЛ ЕЛИЗАРОВ: ХУДОЖЕСТВЕННЫЕ (ЛИТЕРАТУРНЫЕ) ПАРАЛЛЕЛИ 450.5 KB
  Объект нашей дипломной работы – литературный экстремизм всех трёх авторов, находящий выражение как в индивидуальных авторских стилях, так и во взаимодействии поэтических и прозаических элементов, так и в определённой философской системе, выстраиваемой в ходе повествования.
43207. Привод шаровой мельницы 2.03 MB
  Выбираем асинхронный электродвигатель закрытый обдуваемый единой серии АИР мощностью = 15 кВт и синхронной частотой вращения = 3000 об/мин
43208. Проектування привіду до стрічкового конвейєра за схемою та графіком навантаження 1.35 MB
  Закриті зубчасті передачі при коловій швидкості змащуються зануренням їх в мастило, а також за рахунок масляного туману, який утворюється за рахунок великої колової швидкості. Контактне напруження при швидкості дорівнює 475 МПа. За цими даними вибираємо необхідну в’язкість мастила і вибираємо мастило: індустріальне леговане, для зубчастих передач ИРП-150. одноступінчатого редуктора.