13433

ВБУДОВАНІ ФУНКЦІЇ MS EXCEL та ОФОРМЛЕННЯ РОБОЧИХ АРКУШІВ

Лабораторная работа

Информатика, кибернетика и программирование

МЕТОДИЧНІ ВКАЗІВКИ ДО ЛАБОРАТОРНОЇ РОБОТИ №3 ВБУДОВАНІ ФУНКЦІЇ MS EXCEL та ОФОРМЛЕННЯ РОБОЧИХ АРКУШІВ 1. Мета та завдання роботи Придбання навичок роботи з вбудованими функціями Microsoft Excel та оволодіння можливостями оформлення робочих аркушів. 2. Зміст робот

Украинкский

2013-05-11

180 KB

16 чел.

МЕТОДИЧНІ ВКАЗІВКИ ДО ЛАБОРАТОРНОЇ РОБОТИ №3

ВБУДОВАНІ ФУНКЦІЇ MS EXCEL 

та ОФОРМЛЕННЯ РОБОЧИХ АРКУШІВ

1. Мета та завдання роботи

Придбання навичок роботи з вбудованими функціями Microsoft Excel та оволодіння можливостями оформлення робочих аркушів.

 

2. Зміст роботи

2.1 Завантажити оболонку ОС Windows та завантажити табличний процесор Microsoft Excel.

2.2 Обрахувати ряд стандартних функцій згідно завдання п.5.1.

2.3 Відформатувати таблицю рамками і кольором згідно завдання п.5.2.

 

3. Вимоги до звіту

Звіт повинен включати:

титульний лист з назвою і номером роботи, відомостями про виконавця;

постановку задачі і відомості про послідовність її  виконання;

відповіді на контрольні питання п.6 вказівок;

таблиці з розрахунками.

До звіту додається дискета з виконаним завданням.

 

4. Загальні положення

4.1. Обчислювальні можливості і робота з функціями

Основні правила запису формул:

запис формул в Microsoft Excel починається зі знаку „дорівнює”;

формули можуть включати звернення до однієї або декількох функцій;

після імені кожної функції в дужках задаються аргументи, які використовуються функцією.  Функції Microsoft Excel є обчислювальними інструментами, котрі можуть бути використані в робочому аркуші для автоматичного прийняття обчислень, виконання дій і обчислення значень.  Microsoft Excel надає широкий набір вбудованих функцій, котрі виконують різноманітні типи обчислень.

Будь-яка функція в Microsoft Excel включає в себе дві частини: ім’я функції, наприклад, „СРЗНАЧ” (середнє значення) і необхідні аргументи.

Аргументи - це інформація, яку функція використовує, щоб обчислити нове значення або провести дію. Аргументи завжди знаходяться справа від імені функції і поміщені в дужки.

Аргументом може бути число, ім’я  комірки, посилання на комірку або інша функція. Рівень вкладеності функцій в формулах може достигати семи.

Якщо функція не використовує аргументів,  то за її ім’ям ідуть пусті дужки ()без пробілів між ними, наприклад,  поточна дата: „СЕГОДНЯ ()”.

Аргументи в функціях відокремлюються один від одного крапками з комами, наприклад, =СРЗНАЧ(1;2;3;4;5) дорівнює 3, але =СРЗНАЧ(;;1;2;3;4;5) дорівнює 2,14);

На прикладі функції „СУММ”, яка обчислює суму своїх аргументів і може сприймати  їх від 1 до 30, розглянемо можливі варіанти завдання аргументів.

4.2. Приклад використання аргументів

Аргументи функції „СУММ” можуть бути одним з чотирьох нижченаведених видів.

Число, наприклад:

=СУММ(1;10;100)

Формула, котра своїм результатом має число, наприклад:

=СУММ(0,5+0,5;СРЗНАЧ(5;5);10^2)

Функції,  які використовуються як аргументи інших функцій, як в попередньому прикладі, називаються вкладеними функціями. В цьому прикладі вкладена функція „СРЗНАЧ” є аргументом функції „СУММ”.

Посилання на комірку або на інтервал комірок, котрий містить числа або формули, які поставляють числа, наприклад:

=СУММ(A1; A2)

=СУММ(A1: A5).

У другому прикладі в якості аргументів наведених функцій, задається інтервал комірок. Він задається адресою комірки, в котрій знаходиться перша цифра стовпця, потім записується оператор зв’язку - двокрапка (:) і адреса комірки, в якій знаходиться остання цифра. Інший еквівалентний приклад формули:

=СУММ(A1;A2;A3;A4;A5).

Перевага використання інтервалу полягає в тому, що аргумент A1:A5 приймається за один аргумент, в той час як А1, А2, А3, А4, А5  -  за п’ять аргументів. Якщо потрібно скласти більш 30 чисел, то обов’язково прийдеться використовувати інтервали, тому що функція не може мати більше чим 30 аргументів.

Ім’я, яке посилається на константу, формулу, комірку або інтервал комірок, що містять числа або формули, що поставляють числа, наприклад:

=СУММ(Основа; Приріст)

В даному прикладі використовуються власні імена „Приріст” та „Основа”. Імена призначаються константам, інтервалам, формулам і роблять формули більш зручними для читання, розуміння і роботи.

4.2. Майстер функцій

„Майстер функцій” дозволяє в діалоговому режимі переглядати списки усіх функцій, розподілених по категоріям, вибрати будь-яку з них і задати її аргументи.

Звернутися до „Майстра функцій” можна:

1) за допомогою пункту меню „Вставка  Функція”;

2) комбінацією клавіш <Shift>+<F3>;

3) кнопкою на панелі інструментів: .

Після виклику „Майстра функцій” з’являється перше діалогове вікно „Шаг1 з 2” (рис. 3.1), в якому відображаються категорії та імена функцій, рядок формул та кнопки. Функції перераховані по категоріям, такими як: „Фінансові”, „Математичні”,  „Статистичні” та ін. При переміщенні по списку категорій, список імен функцій справа також змінюється. Вибір категорії підтверджується  клацанням лівою кнопкою миші на відповідному рядку. При виборі функції зі списку в правій частині діалогового вікна, в рядку формул автоматично з’являється визначення функції, а також правильно розташовані дужки та крапки з комою, котрі розділяють аргументи функції.

Рис. 3.1. Майстер функцій: крок 1 з 2

 

Після вибору потрібної функції і натисненні на кнопку „Шаг >” відбувається перехід до другого діалогового вікна. На цьому кроці (рис. 3.2) здійснюється уведення аргументів вибраної функції з клавіатури в спеціальне вікно уведення, де знаходиться курсор у вигляді вертикальної риски. Інтервал комірок можна також виділити безпосередньо на робочому аркуші, тоді він автоматично заноситься у вікно уведення. Після натиснення кнопки „Закінчити”, „Майстер” поміщає ці дані у рядок формул робочого аркушу таблиці, а в комірці з’являється результат обчислень по даній функції..

Рис. 3.2 Майстер функцій: крок 2 з 2

 

Кнопка „Скасування”  дозволяє відмовитись від уведення. У цьому випадку, якщо допущена некоректність при уведенні аргументів або самої функції,  з’явиться повідомлення про помилку. Багато імен аргументів вказують на те, яку інформацію потрібно задавати в якості фактичного значення аргументу. Якщо в імені аргументу використовуються скорочення „чис”, ссыл” або „лог”, то це означає, що аргумент повинен бути числом, посиланням або логічним значенням.

Наприклад, у функції „ОКРУГЛ(число; количество_цифр) ”, обидва аргументи повинні бути числами, де перший аргумент - число, яке округляється, і друге - кількість знаків після коми.

4.3. Оформлення робочих аркушів

Перетворення, які Microsoft Excel виконує з оформленням символів в комірці, називаються форматуванням. Воно включає:

шрифтове і кольорове оформлення;

вирівнювання даних у комірках;

встановлення формату виведення чисел і т. ін.

Форматування можна виконувати за допомогою кнопок  панелі інструментів „Форматування”  (рис.3.3). 

Рис. 3.3. Панель інструментів „Форматування”

Текст призначення будь-якої кнопки панелі, з’являється під кнопкою, якщо навести на її нижній край курсор. Однак найбільший арсенал засобів форматування Microsoft Excel надає, якщо скористатися командою „Формат  Формат комірок”  (рис. 3.4).

Рис. 3.4. Ярличок „Шрифт” діалогового вікна „Формат комірок”

Діалогове вікно „Формат ячеек” надає шість ярличків для виклику підменю:

Число” - задає кількість десяткових знаків для будь-якого числа даної комірки; з’ясовує чи потрібно давати знак долара або процента; чи є число датою і т. ін.

Вирівнювання” - визначає,  яким чином розміщується зміст усередині комірки. Зазвичай, числа друкують з правого краю комірки, текст - з лівого, а заголовки центрують.

Шрифти” - визначають розмір, форму і товщину кожного символу усередині комірки. Одиницею виміру  шрифту служить пункт; чим більше пунктів, тим більший символ.

Рамка” - дозволяє обвести частини таблиці в рамки, добавити лінії під стовпцями.

Вид” - дозволяє задати зафарбовування комірки (колір та візерунок).

Захист - керує приховуванням даних і дозволяє встановити блокування комірок, що робить неможливим будь-яку зміну даних.

За допомогою команди „Формат  Автоформат”  можна швидко відформатувати виділену область таблиці або весь робочий аркуш, застосувавши один з запропонованих зразків оформлення таблиці.

 

5. Методичні рекомендації

5.1  Використання вбудованих функцій

Створити і заповнити нижче приведену таблицю, використовуючи для обчислень можливості „Майстра функцій”.

Таблиця 3.1

Математичні і тригонометричні функції

Аргумент   Х

LN

EXP

X*LN

ABS

КОРЕНЬ

SIN

COS

ОКРУГЛ

1

2

3

4

5

6

7

8

9

 

 

1) Заповніть стовпець 1 значеннями від –100 до 100 з кроком 10, виконавши копіювання або автозаповнення.

2)  Значення в стовпцях 2  і 3 підрахуйте тільки для позитивних х (визначивши їх  за допомогою функції „ЕСЛИ”), для негативних – уведіть  0.

Приклад:

= ЕСЛИ (А3>0; LN(A3); 0);

Примітка 1. У даному прикладі функція LN є вкладеною функцією, тому що використовується як аргумент  функції „ЕСЛИ”. Щоб вставити „функцію Б” в якості аргументу „функції А” потрібно при уведенні аргументу для „функції А” у другому діалоговому вікні, повторно викликати „Майстер функцій”, клацнувши лівою кнопкою на його значку поруч з рядком уведення.

Примітка 2. Якщо функція усередині формули після її уведення в комірку взята в подвійні лапки, наприклад:

=ЕСЛИ(A1>0; ”LN(A1)”;0)),

то вона сприймається, як текст і обрахування по ній виконуватись не будуть. Для видалення лапок увійдіть в режим редагування комірки за допомогою функціональної клавіші <F2>, або подвійним клацанням лівою кнопкою миші на комірці.

3) Для обрахування значень в стовпці 4 використовуйте функцію „ПРОИЗВЕД”, наприклад:

=ПРОИЗВЕД (А3:В3).

4) При обрахуванні значень 6 стовпця використовуйте абсолютні величини значень аргументу.

5) При обрахуванні тригонометричних функцій в стовпцях 7 і 8 аргумент повинен бути заданий в радіанах. Для переводу градусів в радіани можна використовувати множення на і ділення на 180, але значно простіше використовувати функцію „РАДИАНЫ”. Враховуючи, що значення аргументу задані в градусах, зробіть відповідні обчислення. наприклад:

= SIN(А3*ПИ/180)

= SIN(РАДИАНЫ(А3))

  1.  В 9 стовпець внесіть декілька округлених значень функції „COS”, наприклад:

= ОКРУГЛ(H3, 0) – округлення до цілого;

= ОКРУГЛ(H4, 1) – округлення до десяткових значень;

7) Продовжте таблицю, додавши за останнім значенням аргументу наступні графи: середнє значення, максимум, мінімум.

8)  Здійсніть відповідні обчислення по всім стовпцям таблиці.

 

5.2. Оформлення робочого аркуша

1) Переформатуйте усі комірки з числами і переконайтесь, що всі стовпці вирівняні правильно.

2) Оформіть заголовки  стовпців крупним напівжирним шрифтом, щоб вони ясно ідентифікували кожний стовпець. Використовуйте темний фон і напівжирний білий курсив, щоб ваші заголовки виділялись найбільш виразно.

3) Щоб виділити перший стовпець, окресліть його для більшої виразності подвійною лінією. Інші стовпці окресліть одинарною рамкою.

4) Використовуйте тонування світло-жовтим кольором для полів, зайнятих даними: це найбільш сприятливий колір для сприйняття, ніж звичайний різкий білий тон.

5) Приберіть звичайні лінії сітки Microsoft Excel за допомогою команди „Сервіс  Параметри  Вид Сітка”: відразу стануть ясно видні усі дані в таблиці.

6) Захистіть робочий аркуш.

Увага! Для виділення всього робочого аркушу необхідно клацнути лівою кнопкою миші на сірій кнопці в лівому верхньому куті вікна робочого аркушу (вона знаходиться прямо над першим рядком таблиці, ліворуч від стовпця А). У виділеному повністю робочому аркуші всі призначені опції форматування будуть застосовані для всього аркушу. Майте на увазі, що можна відформатувати комірку (або групу комірок),  навіть якщо вона порожня.

6. Контрольні питання

6.1 Перерахуйте основні категорії функцій Excel. Як до них звернутись?

6.2 До якої категорії відносяться функції для знаходження максимального, мінімального, середнього значення у списку?

6.3 Якими способами можна вставити значення аргументів функції?

6.4 Що розуміють під форматуванням комірок таблиці?

6.5 Якими способами виконують вирівнювання змісту комірок? Які види вирівнювання існують?

6.6 Які різновиди шрифту існують в Excel?  Як здійснити вибір шрифту?

6.7 Як задати в таблиці лінії і рамки, колір і тонування?

7. Рекомендована література

7.1. Зацерковний В.І. Конспект лекцій по дисципліні „Інформатика і програмування”, Чернігів, ЧДЕІУ -2007, ч.ІІІ Microsoft Excel;

7.2 Информатика: Учебник / Под ред. проф. Н.В.Макаровой. - М.: Финансы и статистика, 1997- С. 528.

7.3 Осейко Н. Excel 5.0 для пользователя: - К.:Торгово- издательское   бюро ВНИ, 1994 - 416 с.

7.4 Харвей Г. Excel 5.0 для “чайников” - К.: Диалектика, 1995 - 288 с.

7.5 Николь Н., Альбрехт Р. Электронные таблицы Excel 5.0: практ. пособ./пер. с нем. - М.: ЭКОМ, 1996 - 352 с.

PAGE  25


 

А также другие работы, которые могут Вас заинтересовать

1821. Развитие исторического образования в университетах России во второй половине XVIII – начале XX века 1.33 MB
  Влияние культуры классицизма на развитие русской исторической науки и образования. Эпоха Великих реформ и формирование принципов дальнейшего развития исторического образования в российских университетах. Реорганизация учебного процесса на историко-филологических факультетах в университетах России в конце 70-80-х гг. XIX в.
1822. Дидактическое структурирование процесса обучения студентов в педагогическом вузе 1.33 MB
  Структурирование процесса обучения в вузе как педагогическая проблема. Характеристики структур педагогических систем с позиции концепции структурно-количественного анализа. Дидактические оценки использования резюме как методологического компонента структуры процесса обучения математике в вузе. Взаимосвязь структурных характеристик умственной деятельности обучаемых с показателями эффективности решения математических задач и оценками качеств личности.
1823. МИГРАЦИОННАЯ ПОЛИТИКА ЕВРОПЕЙСКОГО СОЮЗА 1.33 MB
  Интеграционные процессы в Западной Европе во второй половине ХХ столетия и создание Европейских Сообществ. Возникновение и деятельность межправительственных групп по выработке основных направлений миграционной политики ЕС. Формирование единого европейского законодательства в области регулирования миграционных процессов.
1824. ГАРНИТУРА ШРИФТА КАК ФАКТОР РЕГУЛЯЦИИ ВОСПРИЯТИЯ ТЕКСТА 1.33 MB
  Научно-теоретические и практические аспекты проблемы исследования регулирующей функции гарнитуры шрифта. Функции гарнитуры шрифта с позиций прагматики и эстетики. Регулирующая функция гарнитуры шрифта в аспекте теории деятельности. Психолингвистическая интерпретация гарнитурно-шрифтовых регулирующих факторов.
1825. КОНСТИТУЦИОННЫЕ ГАРАНТИИ ЗАЩИТЫ ПРАВ И СВОБОД ГРАЖДАН ОТ НЕПРАВОМЕРНЫХ ДЕЙСТВИЙ (БЕЗДЕЙСТВИЙ) СУБЪЕКТОВ ПРАВООХРАНИТЕЛЬНОЙ СИСТЕМЫ РОССИЙСКОЙ ФЕДЕРАЦИИ 1.33 MB
  Конституционные гарантии прав и свобод человека и гражданина в Российской Федерации. Функции юридических гарантий обеспечения прав и свобод человека и гражданина. Персональная ответственность государственного служащего правоохранительного органа. Конституционно-правовой механизм защиты прав и свобод граждан от неправомерных действий (бездействий) должностных лиц правоохранительных органов.