13478

Создание новой информационной базы

Лабораторная работа

Информатика, кибернетика и программирование

Документы Лабораторная работа Задача 1. Создание новой информационной базы. 1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор. 2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить. 3. В появившемся окне Добавление информационной базы/г

Русский

2013-05-11

199 KB

4 чел.

Документы

Лабораторная работа

Задача 1. Создание новой информационной базы.

1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор.

2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить.

3. В появившемся окне Добавление информационной базы/группы выберите опцию Добавление новой информационной базы и щелкните по кнопке Далее.

4. В появившемся окне Добавление информационной базы/группы выберите опцию Создание информационной базы без конфигурации и щелкните по кнопке Далее.

5. В появившемся окне Добавление информационной базы/группы в поле Укажите наименование информационной базы укажите Моя база1 и в разделе Выберите тип расположения информационной базы выберите опцию На данном компьютере или на компьютере в локальной сети и щелкните по кнопке Далее.

6. В появившемся окне Добавление информационной базы/группы в поле Каталог информационной базы укажите необходимую папку расположения и щелкните по кнопке Готово.

Задача 2. Создание справочника.

1. Создайте справочник Фирмы (дополнительных реквизитов не требуется).

2. Перейдите в режим 1С:Предприятие и внесите в него несколько записей. Затем вернитесь в окно конфигуратора.

3. Создайте справочник Номенклатура.

4. Перейдите в режим 1С:Предприятие и внесите в него несколько записей. Затем вернитесь в окно конфигуратора.

Задача 3. Работа с документами.

1. В окне Конфигурация щелкните правой кнопкой мыши по Документы и в появившемся контекстном меню выберите пункт Добавить.

2. Щелкните в поле Имя и укажите имя создаваемого документа – Заказ.

3. Перейдите на закладку Данные. В области шапки размесите реквизит Заказчик (тип данных – СправочникСсылка.Фирмы).

4. Создайте табличную часть Перечень и разместите в ней два реквизита – Товар (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – число без дробной части).

5. Перейдите в режим 1С:Предприятие и создайте несколько документов.

Задача 4. Работа с документами. Создание обработки

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите РаботаСДокументами.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки (имя формы - ФормаДляТеста). После этого щелкните по кнопке Готово.

4. Добавьте в форму элемент управления – поле ввода. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите элемент Поле ввода. В качестве имени укажите ФирмаЗаказчик, а в качестве типа данных – СправочникСсылка.Фирмы.

5. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НовыйЗаказ = Документы.Заказ.СоздатьДокумент();

НовыйЗаказ.Дата = ТекущаяДата();

НовыйЗаказ.Заказчик = ФирмаЗаказчик;

НовыйЗаказ.Записать();

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и просмотрите результаты работы. В списке документов Заказ появятся новые документы с внесенными датой и фирмой. После завершения просмотра, вернитесь в окно конфигуратора.

Задача 5. Работа с документами. Создание обработки поиска документов

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ВыборкаДокументов.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

4. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента:

  •  Поле ввода Дата1 (тип данных – Дата);
  •  Поле ввода Дата2 (тип данных – Дата);
  •  ПолеСписка ПереченьДокументов.

5. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НачальнаяДата = НачалоДня(Дата1);

КонечнаяДата = КонецДня(Дата2);

ВыборкаЗаказ = Документы.Заказ.Выбрать(НачальнаяДата,КонечнаяДата);

ПереченьДокументов.Очистить();

Пока ВыборкаЗаказ.Следующий() Цикл

Информация = "НомерДокумента: " + ВыборкаЗаказ.Номер +

                                     " Дата документа: " + ВыборкаЗаказ.Дата;

 ПереченьДокументов.Добавить(Информация);

 КонецЦикла;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие, откройте форму обработки и установите даты. В результате будет получен перечень документов:

Задача 6. Работа с документами. Создание обработки поиска документов по условию.

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ВыборкаДокументов1.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

4. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента:

  •  Поле ввода Фирма (тип данных – СправочникСсылка.Фирмы);
  •  ПолеСписка ПереченьДокументов1.

5. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Упорядочивание = "Дата Возр";

ВыборкаДокументов1 = Документы.Заказ.Выбрать(,,,Упорядочивание);

ПереченьДокументов1.Очистить();

Пока ВыборкаДокументов1.Следующий() Цикл

Если ВыборкаДокументов1.Заказчик = Фирма Тогда

Информация = "НомерДокумента: " + ВыборкаДокументов1.Номер +

                                     " Дата документа: " + ВыборкаДокументов1.Дата;

 ПереченьДокументов1.Добавить(Информация);

КонецЕсли;

 КонецЦикла;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие, откройте форму обработки и установите даты. В результате будет получен перечень документов:

Замечание. В системе 1С:Предприятие имеется объект ДокументОбъект, который позволяет обратиться к значениям реквизитов.

Пример.

Процедура КнопкаВыполнитьНажатие(Кнопка)

ВыборкаЗаказ = Документы.Заказ.Выбрать();

Пока ВыборкаЗаказ.Следующий() Цикл

 Объект = ВыборкаЗаказ.ПолучитьОбъект();

 Объект.Дата = ТекущаяДата();

 Объект.Записать();

КонецЦикла;

КонецПроцедуры

Задача 7. Работа с документами. Заполнение документа на основании имеющихся данных.

1. В окне Конфигурация щелкните правой кнопкой мыши по Документы и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите Заявка.

3. Перейдите на закладку Данные. В области шапки документа укажите один дополнительный реквизит – ФирмаЗаказчик (тип данных – СправочникСсылка.Фирмы). Для табличной части документа выберите имя ПереченьТоваров и внесите в нее два реквизита – Номенклатура (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – Число без дробной части).

4. Перейдите в режим 1С:Предприятие и заполните несколько документов по созданному шаблону. После завершения работы, вернитесь в окно конфигуратора.

5. Создадим обработку, автоматически заполняющую документ Заказ на основе документа Заявки. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

6. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите РаботаСДокументами1.

7. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

8. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента: поле ввода Заявка (тип данных – ДокументСсылка.Заявка).

9. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НовыйЗаказ = Документы.Заказ.СоздатьДокумент();

НовыйЗаказ.Заказчик = Заявка.ФирмаЗаказчик;

НовыйЗаказ.Дата = ТекущаяДата();

Для Каждого СтрокаЗаявка Из Заявка.ПереченьТоваров  Цикл

 СтрокаЗаказТовар = НовыйЗаказ.Перечень.Добавить();

 СтрокаЗаказТовар.Товар = СтрокаЗаявка.Номенклатура;

 СтрокаЗаказТовар.Количество = СтрокаЗаявка.Количество;

КонецЦикла;

НовыйЗаказ.Записать();

КонецПроцедуры

10. Перейдите в режим 1С:Предприятие, откройте форму обработки и выберите заявку. В результате будет получен новый документ:

Замечание. Воспользовавшись событием ПриЗаписи можно отменить запись объекта в базу данных.

11. Вернитесь в окно конфигуратора. В окне редактирования документа Заказ перейдите на закладку Прочее и воспользуйтесь кнопкой Модуль объекта. Напишите текст процедуры:

Процедура ПриЗаписи(Отказ)

Если ЭтотОбъект.Дата < ТекущаяДата() Тогда

 Отказ = Истина;

КонецЕсли;

КонецПроцедуры;

Замечание. Воспользовавшись событием ПередУдалением можно отменить удаление объекта из базы данных.

12. Вернитесь в окно конфигуратора. В окне редактирования документа Заказ перейдите на закладку Прочее и воспользуйтесь кнопкой Модуль объекта. Напишите текст процедуры:

Процедура ПередУдалением(Отказ)

Если ЭтотОбъект.Дата < Дата(2008,08,05) Тогда

 Отказ = Истина;

КонецЕсли;

КонецПроцедуры;


 

А также другие работы, которые могут Вас заинтересовать

15140. Антонио Гауди-и-Корнет 226.5 KB
  Реферат по истории искусств на тему: Антонио ГаудииКорнет архитектор. Анто́нио Пла́сид Гильем Гауди́иКорне́т исп. Antonio Plácido Guillermo Gaudí y Cornet; кат. Antoni Plàcid Guillem Gaudí i Cornet; 25 июня 1852 Реус Каталония 10 июня 1926 Барселона выдающийся каталонский архитектор бо...
15141. Брестский мир 22.81 KB
  Брестский мир 1918 г. Брестский мир 1918 мирный договор между Россией с одной стороны и Германией АвстроВенгрией Болгарией и Турцией с другой заключён в БрестЛитовск
15142. Василий Иванович Чапаев 19.31 KB
  Василий Иванович Чапаев Василий Иванович Чапаев легендарный полководец начдив командир Красной Армии. Всем нам он хорошо известен по замечательному произведению Дмитрия Фурманова Чапаев дававшему молодому поколению 20х годов боевую зарядку и стра...
15143. Иван александрович Хлестаков в комедии Ревизор 29.41 KB
  Иван Александрович Хлестаков в комедии Ревизор И.А.Хлестаков появляется в городке в тот момент когда там все ждут появления ревизора. Чиновники испуганы городничему от страха видятся во сне крысы. Степень боязни и страха чиновников пря...
15144. Иван Сергеевич Шмелёв 71.83 KB
  Иван Сергеевич Шмелёв Иван Сергеевич Шмелев родился в Кадашевской слободе Замоскворечья 21 сентября 1873 года. Дед Ивана Сергеевича государственный крестьянин из Гуслиц Богородского уезда Московской губернии поселился в Москве после пожара 1812 г. Отец писателя прин
15145. Наполеон Бонапарт 24.62 KB
  Наполеон Бонапарт Свою профессиональную военную службу начал в 1785 в чине младшего лейтенанта артиллерии; выдвинулся в период Великой французской революции достигнув при Директории чина бригадного после взятия Тулона 17 декабря 1793...
15146. Никита Сергевич Хрущёв 16.63 KB
  Никита Сергевич Хрущёв Первый секретарь ЦК КПСС с 1953 по 1964 годы Председатель Совета Министров СССР с 1958 по 1964 годы. Герой Советского Союза Трижды Герой Социалистического Труда. Первый лауреат Шевченковской премии. Краткая биография Никита Сергеевич Хрущёв родился в ...
15147. Тургенев Иван Сергеевич 22.47 KB
  Иван Сергеевич Тургенев Иван Тургенев родился 28 октября 1818 года в Орле. Отец Сергей Николаевич отставной полковн