13478

Создание новой информационной базы

Лабораторная работа

Информатика, кибернетика и программирование

Документы Лабораторная работа Задача 1. Создание новой информационной базы. 1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор. 2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить. 3. В появившемся окне Добавление информационной базы/г

Русский

2013-05-11

199 KB

4 чел.

Документы

Лабораторная работа

Задача 1. Создание новой информационной базы.

1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор.

2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить.

3. В появившемся окне Добавление информационной базы/группы выберите опцию Добавление новой информационной базы и щелкните по кнопке Далее.

4. В появившемся окне Добавление информационной базы/группы выберите опцию Создание информационной базы без конфигурации и щелкните по кнопке Далее.

5. В появившемся окне Добавление информационной базы/группы в поле Укажите наименование информационной базы укажите Моя база1 и в разделе Выберите тип расположения информационной базы выберите опцию На данном компьютере или на компьютере в локальной сети и щелкните по кнопке Далее.

6. В появившемся окне Добавление информационной базы/группы в поле Каталог информационной базы укажите необходимую папку расположения и щелкните по кнопке Готово.

Задача 2. Создание справочника.

1. Создайте справочник Фирмы (дополнительных реквизитов не требуется).

2. Перейдите в режим 1С:Предприятие и внесите в него несколько записей. Затем вернитесь в окно конфигуратора.

3. Создайте справочник Номенклатура.

4. Перейдите в режим 1С:Предприятие и внесите в него несколько записей. Затем вернитесь в окно конфигуратора.

Задача 3. Работа с документами.

1. В окне Конфигурация щелкните правой кнопкой мыши по Документы и в появившемся контекстном меню выберите пункт Добавить.

2. Щелкните в поле Имя и укажите имя создаваемого документа – Заказ.

3. Перейдите на закладку Данные. В области шапки размесите реквизит Заказчик (тип данных – СправочникСсылка.Фирмы).

4. Создайте табличную часть Перечень и разместите в ней два реквизита – Товар (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – число без дробной части).

5. Перейдите в режим 1С:Предприятие и создайте несколько документов.

Задача 4. Работа с документами. Создание обработки

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите РаботаСДокументами.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки (имя формы - ФормаДляТеста). После этого щелкните по кнопке Готово.

4. Добавьте в форму элемент управления – поле ввода. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите элемент Поле ввода. В качестве имени укажите ФирмаЗаказчик, а в качестве типа данных – СправочникСсылка.Фирмы.

5. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НовыйЗаказ = Документы.Заказ.СоздатьДокумент();

НовыйЗаказ.Дата = ТекущаяДата();

НовыйЗаказ.Заказчик = ФирмаЗаказчик;

НовыйЗаказ.Записать();

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и просмотрите результаты работы. В списке документов Заказ появятся новые документы с внесенными датой и фирмой. После завершения просмотра, вернитесь в окно конфигуратора.

Задача 5. Работа с документами. Создание обработки поиска документов

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ВыборкаДокументов.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

4. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента:

  •  Поле ввода Дата1 (тип данных – Дата);
  •  Поле ввода Дата2 (тип данных – Дата);
  •  ПолеСписка ПереченьДокументов.

5. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НачальнаяДата = НачалоДня(Дата1);

КонечнаяДата = КонецДня(Дата2);

ВыборкаЗаказ = Документы.Заказ.Выбрать(НачальнаяДата,КонечнаяДата);

ПереченьДокументов.Очистить();

Пока ВыборкаЗаказ.Следующий() Цикл

Информация = "НомерДокумента: " + ВыборкаЗаказ.Номер +

                                     " Дата документа: " + ВыборкаЗаказ.Дата;

 ПереченьДокументов.Добавить(Информация);

 КонецЦикла;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие, откройте форму обработки и установите даты. В результате будет получен перечень документов:

Задача 6. Работа с документами. Создание обработки поиска документов по условию.

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ВыборкаДокументов1.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

4. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента:

  •  Поле ввода Фирма (тип данных – СправочникСсылка.Фирмы);
  •  ПолеСписка ПереченьДокументов1.

5. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Упорядочивание = "Дата Возр";

ВыборкаДокументов1 = Документы.Заказ.Выбрать(,,,Упорядочивание);

ПереченьДокументов1.Очистить();

Пока ВыборкаДокументов1.Следующий() Цикл

Если ВыборкаДокументов1.Заказчик = Фирма Тогда

Информация = "НомерДокумента: " + ВыборкаДокументов1.Номер +

                                     " Дата документа: " + ВыборкаДокументов1.Дата;

 ПереченьДокументов1.Добавить(Информация);

КонецЕсли;

 КонецЦикла;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие, откройте форму обработки и установите даты. В результате будет получен перечень документов:

Замечание. В системе 1С:Предприятие имеется объект ДокументОбъект, который позволяет обратиться к значениям реквизитов.

Пример.

Процедура КнопкаВыполнитьНажатие(Кнопка)

ВыборкаЗаказ = Документы.Заказ.Выбрать();

Пока ВыборкаЗаказ.Следующий() Цикл

 Объект = ВыборкаЗаказ.ПолучитьОбъект();

 Объект.Дата = ТекущаяДата();

 Объект.Записать();

КонецЦикла;

КонецПроцедуры

Задача 7. Работа с документами. Заполнение документа на основании имеющихся данных.

1. В окне Конфигурация щелкните правой кнопкой мыши по Документы и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите Заявка.

3. Перейдите на закладку Данные. В области шапки документа укажите один дополнительный реквизит – ФирмаЗаказчик (тип данных – СправочникСсылка.Фирмы). Для табличной части документа выберите имя ПереченьТоваров и внесите в нее два реквизита – Номенклатура (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – Число без дробной части).

4. Перейдите в режим 1С:Предприятие и заполните несколько документов по созданному шаблону. После завершения работы, вернитесь в окно конфигуратора.

5. Создадим обработку, автоматически заполняющую документ Заказ на основе документа Заявки. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

6. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите РаботаСДокументами1.

7. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

8. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента: поле ввода Заявка (тип данных – ДокументСсылка.Заявка).

9. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НовыйЗаказ = Документы.Заказ.СоздатьДокумент();

НовыйЗаказ.Заказчик = Заявка.ФирмаЗаказчик;

НовыйЗаказ.Дата = ТекущаяДата();

Для Каждого СтрокаЗаявка Из Заявка.ПереченьТоваров  Цикл

 СтрокаЗаказТовар = НовыйЗаказ.Перечень.Добавить();

 СтрокаЗаказТовар.Товар = СтрокаЗаявка.Номенклатура;

 СтрокаЗаказТовар.Количество = СтрокаЗаявка.Количество;

КонецЦикла;

НовыйЗаказ.Записать();

КонецПроцедуры

10. Перейдите в режим 1С:Предприятие, откройте форму обработки и выберите заявку. В результате будет получен новый документ:

Замечание. Воспользовавшись событием ПриЗаписи можно отменить запись объекта в базу данных.

11. Вернитесь в окно конфигуратора. В окне редактирования документа Заказ перейдите на закладку Прочее и воспользуйтесь кнопкой Модуль объекта. Напишите текст процедуры:

Процедура ПриЗаписи(Отказ)

Если ЭтотОбъект.Дата < ТекущаяДата() Тогда

 Отказ = Истина;

КонецЕсли;

КонецПроцедуры;

Замечание. Воспользовавшись событием ПередУдалением можно отменить удаление объекта из базы данных.

12. Вернитесь в окно конфигуратора. В окне редактирования документа Заказ перейдите на закладку Прочее и воспользуйтесь кнопкой Модуль объекта. Напишите текст процедуры:

Процедура ПередУдалением(Отказ)

Если ЭтотОбъект.Дата < Дата(2008,08,05) Тогда

 Отказ = Истина;

КонецЕсли;

КонецПроцедуры;


 

А также другие работы, которые могут Вас заинтересовать

81787. Становление социальных и гуманитарных наук 36.39 KB
  Если на этапе преднауки как первичные идеальные объекты так и их отношения соответственно смыслы основных терминов языка и правила оперирования с ними выводились непосредственно из практики и лишь затем внутри созданной системы знания языка формировались новые идеальные объекты то теперь познание делает следующий шаг. Оно начинает строить фундамент новой системы знания как бы сверху по отношению к реальной практике и лишь после этого путем ряда опосредствований проверяет созданные из идеальных объектов конструкции сопоставляя их с...
81788. Научное знание как система, его особенности и структура 31.63 KB
  Рассмотрим основные особенности научного познания или критерии научности. Его основная задача обнаружение объективных законов действительности природных социальных общественных законов самого познания мышления и др. Нацеленность науки на изучение не только объектов преобразуемых в сегодняшней практике но и тех которые могут стать предметом практического освоения в будущем является важной отличительной чертой научного познания. Существенным признаком научного познания является его системность...
81789. Эмпирический и теоретический уровни научного знания, критерии их различия 30.8 KB
  Эмпирический уровень научного познания включает в себя наблюдение эксперимент группировку классификацию и описание результатов наблюдения и эксперимента моделирование. Теоретический уровень научного познания включает в себя выдвижение построение и разработку научных гипотез и теорий; формулирование законов; выведение логических следствий из законов; сопоставление друг с другом различных гипотез и теорий теоретическое моделирование а также процедуры объяснения предсказания и обобщения. Соотношение эмпирического и теоретического...
81790. Структура эмпирического знания. Эмпирический факт 32.87 KB
  Вторым более высоким уровнем эмпирического знания являются факты. Научные факты представляют собой индуктивные обобщения протоколов это обязательно общие утверждения статистического или универсального характера. Понятие факт имеет следующие основные значения: 1 Некоторый фрагмент действительности объективные события результаты относящиеся либо к объективной реальности факты действительности либо к сфере сознания и познания факты сознания . Эйнштейн считал предрассудком убеждение в том будто факты сами по себе без свободного...
81791. Специфика теоретического познания. Структура и функции научной теории 42.94 KB
  Структура и функции научной теории. Гипотеза является необходимым элементом естественнонаучного познания которое обязательно включает в себя: а собирание описание систематизацию и изучение фактов; б составление гипотезы или предположения о причинной связи явлений; в опытную проверку логических следствий из гипотез; г превращение гипотез в достоверные теории или отбрасывание ранее принятой гипотезы и выдвижение новой. В результате этой проверки гипотеза либо переходит в ранг научной теории или опровергается сходит в научной сцены . В...
81792. Основания науки и их структура. Идеалы и нормы исследования 29.55 KB
  Под основаниями науки понимают систему различных регулятивов детерминирующих цель и способы получения научного познания представление и понимание изучаемой реальности а также формы и степень обоснованности научного знания и его включения в человеческую культуру. В данной дефиниции ясно видна и структура оснований науки: цель и способы научного познания определяются идеалами нормами и критериями обобщенное представление и понимание исследуемой реальности воплощается в научной картине мира формы и степень обоснованности научного знания и...
81793. Научная картина мира, ее исторические формы и функции 36.34 KB
  В познании структуры и свойств универсума большое значение имеет научная картина мира являющаяся формой систематизации и обобщения научных знаний. Научная картина мира НКМ система общих представлений о фундаментальных свойствах и закономерностях универсума возникающая и развивающаяся на основе обобщения и синтеза основных научных фактов понятий и принципов. Современная научная картина мира состоит из трех относительно самостоятельных блоков естественнонаучного технического и социальногуманитарного единство которых обеспечивают...
81794. Философские основания науки. Роль философских идей и принципов в обосновании научного знания 32.6 KB
  Социальное познание исторически первоначально развивалось в рамках философии истории раздела философии связанного с интерпретацией исторического процесса и исторического познания. Термин философия истории используется в настоящее время в следующих основных значениях: а учение об исторической реальности в ее целостности и развитии общая теория исторического процесса как единства прошлого настоящего и будущего; б часть философии науки исследующая историческое познание рациональными средствами и методами т. Это философская версия...