13478

Создание новой информационной базы

Лабораторная работа

Информатика, кибернетика и программирование

Документы Лабораторная работа Задача 1. Создание новой информационной базы. 1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор. 2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить. 3. В появившемся окне Добавление информационной базы/г

Русский

2013-05-11

199 KB

4 чел.

Документы

Лабораторная работа

Задача 1. Создание новой информационной базы.

1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор.

2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить.

3. В появившемся окне Добавление информационной базы/группы выберите опцию Добавление новой информационной базы и щелкните по кнопке Далее.

4. В появившемся окне Добавление информационной базы/группы выберите опцию Создание информационной базы без конфигурации и щелкните по кнопке Далее.

5. В появившемся окне Добавление информационной базы/группы в поле Укажите наименование информационной базы укажите Моя база1 и в разделе Выберите тип расположения информационной базы выберите опцию На данном компьютере или на компьютере в локальной сети и щелкните по кнопке Далее.

6. В появившемся окне Добавление информационной базы/группы в поле Каталог информационной базы укажите необходимую папку расположения и щелкните по кнопке Готово.

Задача 2. Создание справочника.

1. Создайте справочник Фирмы (дополнительных реквизитов не требуется).

2. Перейдите в режим 1С:Предприятие и внесите в него несколько записей. Затем вернитесь в окно конфигуратора.

3. Создайте справочник Номенклатура.

4. Перейдите в режим 1С:Предприятие и внесите в него несколько записей. Затем вернитесь в окно конфигуратора.

Задача 3. Работа с документами.

1. В окне Конфигурация щелкните правой кнопкой мыши по Документы и в появившемся контекстном меню выберите пункт Добавить.

2. Щелкните в поле Имя и укажите имя создаваемого документа – Заказ.

3. Перейдите на закладку Данные. В области шапки размесите реквизит Заказчик (тип данных – СправочникСсылка.Фирмы).

4. Создайте табличную часть Перечень и разместите в ней два реквизита – Товар (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – число без дробной части).

5. Перейдите в режим 1С:Предприятие и создайте несколько документов.

Задача 4. Работа с документами. Создание обработки

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите РаботаСДокументами.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки (имя формы - ФормаДляТеста). После этого щелкните по кнопке Готово.

4. Добавьте в форму элемент управления – поле ввода. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите элемент Поле ввода. В качестве имени укажите ФирмаЗаказчик, а в качестве типа данных – СправочникСсылка.Фирмы.

5. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НовыйЗаказ = Документы.Заказ.СоздатьДокумент();

НовыйЗаказ.Дата = ТекущаяДата();

НовыйЗаказ.Заказчик = ФирмаЗаказчик;

НовыйЗаказ.Записать();

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и просмотрите результаты работы. В списке документов Заказ появятся новые документы с внесенными датой и фирмой. После завершения просмотра, вернитесь в окно конфигуратора.

Задача 5. Работа с документами. Создание обработки поиска документов

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ВыборкаДокументов.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

4. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента:

  •  Поле ввода Дата1 (тип данных – Дата);
  •  Поле ввода Дата2 (тип данных – Дата);
  •  ПолеСписка ПереченьДокументов.

5. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НачальнаяДата = НачалоДня(Дата1);

КонечнаяДата = КонецДня(Дата2);

ВыборкаЗаказ = Документы.Заказ.Выбрать(НачальнаяДата,КонечнаяДата);

ПереченьДокументов.Очистить();

Пока ВыборкаЗаказ.Следующий() Цикл

Информация = "НомерДокумента: " + ВыборкаЗаказ.Номер +

                                     " Дата документа: " + ВыборкаЗаказ.Дата;

 ПереченьДокументов.Добавить(Информация);

 КонецЦикла;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие, откройте форму обработки и установите даты. В результате будет получен перечень документов:

Задача 6. Работа с документами. Создание обработки поиска документов по условию.

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ВыборкаДокументов1.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

4. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента:

  •  Поле ввода Фирма (тип данных – СправочникСсылка.Фирмы);
  •  ПолеСписка ПереченьДокументов1.

5. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Упорядочивание = "Дата Возр";

ВыборкаДокументов1 = Документы.Заказ.Выбрать(,,,Упорядочивание);

ПереченьДокументов1.Очистить();

Пока ВыборкаДокументов1.Следующий() Цикл

Если ВыборкаДокументов1.Заказчик = Фирма Тогда

Информация = "НомерДокумента: " + ВыборкаДокументов1.Номер +

                                     " Дата документа: " + ВыборкаДокументов1.Дата;

 ПереченьДокументов1.Добавить(Информация);

КонецЕсли;

 КонецЦикла;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие, откройте форму обработки и установите даты. В результате будет получен перечень документов:

Замечание. В системе 1С:Предприятие имеется объект ДокументОбъект, который позволяет обратиться к значениям реквизитов.

Пример.

Процедура КнопкаВыполнитьНажатие(Кнопка)

ВыборкаЗаказ = Документы.Заказ.Выбрать();

Пока ВыборкаЗаказ.Следующий() Цикл

 Объект = ВыборкаЗаказ.ПолучитьОбъект();

 Объект.Дата = ТекущаяДата();

 Объект.Записать();

КонецЦикла;

КонецПроцедуры

Задача 7. Работа с документами. Заполнение документа на основании имеющихся данных.

1. В окне Конфигурация щелкните правой кнопкой мыши по Документы и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите Заявка.

3. Перейдите на закладку Данные. В области шапки документа укажите один дополнительный реквизит – ФирмаЗаказчик (тип данных – СправочникСсылка.Фирмы). Для табличной части документа выберите имя ПереченьТоваров и внесите в нее два реквизита – Номенклатура (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – Число без дробной части).

4. Перейдите в режим 1С:Предприятие и заполните несколько документов по созданному шаблону. После завершения работы, вернитесь в окно конфигуратора.

5. Создадим обработку, автоматически заполняющую документ Заказ на основе документа Заявки. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

6. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите РаботаСДокументами1.

7. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

8. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента: поле ввода Заявка (тип данных – ДокументСсылка.Заявка).

9. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НовыйЗаказ = Документы.Заказ.СоздатьДокумент();

НовыйЗаказ.Заказчик = Заявка.ФирмаЗаказчик;

НовыйЗаказ.Дата = ТекущаяДата();

Для Каждого СтрокаЗаявка Из Заявка.ПереченьТоваров  Цикл

 СтрокаЗаказТовар = НовыйЗаказ.Перечень.Добавить();

 СтрокаЗаказТовар.Товар = СтрокаЗаявка.Номенклатура;

 СтрокаЗаказТовар.Количество = СтрокаЗаявка.Количество;

КонецЦикла;

НовыйЗаказ.Записать();

КонецПроцедуры

10. Перейдите в режим 1С:Предприятие, откройте форму обработки и выберите заявку. В результате будет получен новый документ:

Замечание. Воспользовавшись событием ПриЗаписи можно отменить запись объекта в базу данных.

11. Вернитесь в окно конфигуратора. В окне редактирования документа Заказ перейдите на закладку Прочее и воспользуйтесь кнопкой Модуль объекта. Напишите текст процедуры:

Процедура ПриЗаписи(Отказ)

Если ЭтотОбъект.Дата < ТекущаяДата() Тогда

 Отказ = Истина;

КонецЕсли;

КонецПроцедуры;

Замечание. Воспользовавшись событием ПередУдалением можно отменить удаление объекта из базы данных.

12. Вернитесь в окно конфигуратора. В окне редактирования документа Заказ перейдите на закладку Прочее и воспользуйтесь кнопкой Модуль объекта. Напишите текст процедуры:

Процедура ПередУдалением(Отказ)

Если ЭтотОбъект.Дата < Дата(2008,08,05) Тогда

 Отказ = Истина;

КонецЕсли;

КонецПроцедуры;


 

А также другие работы, которые могут Вас заинтересовать

54490. Система уроков по теме «Музыка» 275 KB
  Ученики отвечают на вопросы. Ученики задают вопросы ученику возле доски ученик отвечает. Ученики слушают отвечают на вопросы. Ученики работают у доски и с места.
54491. The magic world of music 34.5 KB
  It is difficult to imagine our life without music .It helps us to live and relax. We are going to speak about music because it plays a great role in our lives. Music is everywhere It is in the streets, in the shops, in the parks, on the television sets.
54492. Жанры украинской народной музыки 940 KB
  Цель. Закрепить представления учащихся о жанровых особенностях украинской народной музыки. Повторить календарно-обрядные, исторические, колыбельные, шуточные песни, учащиеся должны продемонстрировать знания песенных жанров народной песни, ее особенностей, характерных признаков. Развивать вокально–хоровые навыки, эмоционально-чувствительный опыт учащихся. Воспитывать интерес к народной песне и уважение к народным традициям. Воспитывать эстетический вкус учащихся.
54493. Загадки про музичні інструменти 81.5 KB
  УДАРНІ ІНСТРУМЕНТИ Живий мертвого бє Живий мовчить а мертвий реве Барабан Тратата тратата Зверху шкіра знизу теж Всередині пустота. Барабан В руки палочки беремНе желаем его бьемТрамтамтам трамтамтам. Барабан Его не жалко никому Колотят палкой по нему. Барабан Сам пустий голос густий Дріб вибиває дітей збирає.
54494. Musik in unserem Leben 239.5 KB
  Anne-Sophie Mutter ist eine weltberühmte Geigerin. Schon als Kind wusste sie, was sie wollte, und bald hat sie ihren Traum verwirklicht. Im Alter von 7 Jahren gewann sie den Wettbewerb „Jugend musiziert“. 1976 fiel sie dem bekannten österreichischen Dirigenten Herbert von Karajan auf. Ein Jahr später trat sie schon als Solistin seines Orchesters bei den Salzburger Konzerten auf. Diese Zusammenarbeit öffnete der Geigerin die Tür zum internationalen Erfolg.
54495. Musik. Die größten Komponisten der Ukraine und Deutschlands 97.5 KB
  Das Thema der heutigen Stunde lautet: Musik. Die größten Komponisten der Ukraine und Deutschlands. Lernziele sind: Wortschatz festigen und erweitern, Fragen stellen und beantworten, den Text lesen, Dialoge führen.
54496. Музика як мова почуттів 54.5 KB
  Мета уроку: Закріпити в учнів отримані на протязі вивчення теми знання про композиторів та їх творчість. Виявити рівень володіння і розуміння супутньої темі музичної термінології. На конкретних прикладах показати можливості музичного мистецтва виражати різноманітні настрої та почуття людини.
54497. Проблема выбора в экономике. Кривая производственных возможностей 41.58 KB
  В условиях рыночной экономики производитель ставит перед собой цель получения максимально возможного дохода, отбирая для производства наиболее подходящие для этой цели материальные блага
54498. Диференційований підхід до розкриття творчого потенціалу учнів на уроках музики 50.5 KB
  Предлогаемий материал,конечно. знаком многим из вас,кто-то возможно, на своих уроках осуществляет дифференцированный подход в обучении. Но в педагогике очень сложно что-либо открыть новое,необходимо лишь глубже изучать теорию,преломлять ее на процесс преподавания,чтобы затем эти практические наработки и становились материалом для творческих работ на категорию.