13478

Создание новой информационной базы

Лабораторная работа

Информатика, кибернетика и программирование

Документы Лабораторная работа Задача 1. Создание новой информационной базы. 1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор. 2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить. 3. В появившемся окне Добавление информационной базы/г

Русский

2013-05-11

199 KB

4 чел.

Документы

Лабораторная работа

Задача 1. Создание новой информационной базы.

1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор.

2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить.

3. В появившемся окне Добавление информационной базы/группы выберите опцию Добавление новой информационной базы и щелкните по кнопке Далее.

4. В появившемся окне Добавление информационной базы/группы выберите опцию Создание информационной базы без конфигурации и щелкните по кнопке Далее.

5. В появившемся окне Добавление информационной базы/группы в поле Укажите наименование информационной базы укажите Моя база1 и в разделе Выберите тип расположения информационной базы выберите опцию На данном компьютере или на компьютере в локальной сети и щелкните по кнопке Далее.

6. В появившемся окне Добавление информационной базы/группы в поле Каталог информационной базы укажите необходимую папку расположения и щелкните по кнопке Готово.

Задача 2. Создание справочника.

1. Создайте справочник Фирмы (дополнительных реквизитов не требуется).

2. Перейдите в режим 1С:Предприятие и внесите в него несколько записей. Затем вернитесь в окно конфигуратора.

3. Создайте справочник Номенклатура.

4. Перейдите в режим 1С:Предприятие и внесите в него несколько записей. Затем вернитесь в окно конфигуратора.

Задача 3. Работа с документами.

1. В окне Конфигурация щелкните правой кнопкой мыши по Документы и в появившемся контекстном меню выберите пункт Добавить.

2. Щелкните в поле Имя и укажите имя создаваемого документа – Заказ.

3. Перейдите на закладку Данные. В области шапки размесите реквизит Заказчик (тип данных – СправочникСсылка.Фирмы).

4. Создайте табличную часть Перечень и разместите в ней два реквизита – Товар (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – число без дробной части).

5. Перейдите в режим 1С:Предприятие и создайте несколько документов.

Задача 4. Работа с документами. Создание обработки

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите РаботаСДокументами.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки (имя формы - ФормаДляТеста). После этого щелкните по кнопке Готово.

4. Добавьте в форму элемент управления – поле ввода. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите элемент Поле ввода. В качестве имени укажите ФирмаЗаказчик, а в качестве типа данных – СправочникСсылка.Фирмы.

5. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НовыйЗаказ = Документы.Заказ.СоздатьДокумент();

НовыйЗаказ.Дата = ТекущаяДата();

НовыйЗаказ.Заказчик = ФирмаЗаказчик;

НовыйЗаказ.Записать();

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и просмотрите результаты работы. В списке документов Заказ появятся новые документы с внесенными датой и фирмой. После завершения просмотра, вернитесь в окно конфигуратора.

Задача 5. Работа с документами. Создание обработки поиска документов

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ВыборкаДокументов.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

4. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента:

  •  Поле ввода Дата1 (тип данных – Дата);
  •  Поле ввода Дата2 (тип данных – Дата);
  •  ПолеСписка ПереченьДокументов.

5. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НачальнаяДата = НачалоДня(Дата1);

КонечнаяДата = КонецДня(Дата2);

ВыборкаЗаказ = Документы.Заказ.Выбрать(НачальнаяДата,КонечнаяДата);

ПереченьДокументов.Очистить();

Пока ВыборкаЗаказ.Следующий() Цикл

Информация = "НомерДокумента: " + ВыборкаЗаказ.Номер +

                                     " Дата документа: " + ВыборкаЗаказ.Дата;

 ПереченьДокументов.Добавить(Информация);

 КонецЦикла;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие, откройте форму обработки и установите даты. В результате будет получен перечень документов:

Задача 6. Работа с документами. Создание обработки поиска документов по условию.

1. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ВыборкаДокументов1.

3. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

4. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента:

  •  Поле ввода Фирма (тип данных – СправочникСсылка.Фирмы);
  •  ПолеСписка ПереченьДокументов1.

5. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Упорядочивание = "Дата Возр";

ВыборкаДокументов1 = Документы.Заказ.Выбрать(,,,Упорядочивание);

ПереченьДокументов1.Очистить();

Пока ВыборкаДокументов1.Следующий() Цикл

Если ВыборкаДокументов1.Заказчик = Фирма Тогда

Информация = "НомерДокумента: " + ВыборкаДокументов1.Номер +

                                     " Дата документа: " + ВыборкаДокументов1.Дата;

 ПереченьДокументов1.Добавить(Информация);

КонецЕсли;

 КонецЦикла;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие, откройте форму обработки и установите даты. В результате будет получен перечень документов:

Замечание. В системе 1С:Предприятие имеется объект ДокументОбъект, который позволяет обратиться к значениям реквизитов.

Пример.

Процедура КнопкаВыполнитьНажатие(Кнопка)

ВыборкаЗаказ = Документы.Заказ.Выбрать();

Пока ВыборкаЗаказ.Следующий() Цикл

 Объект = ВыборкаЗаказ.ПолучитьОбъект();

 Объект.Дата = ТекущаяДата();

 Объект.Записать();

КонецЦикла;

КонецПроцедуры

Задача 7. Работа с документами. Заполнение документа на основании имеющихся данных.

1. В окне Конфигурация щелкните правой кнопкой мыши по Документы и в появившемся контекстном меню выберите пункт Добавить.

2. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите Заявка.

3. Перейдите на закладку Данные. В области шапки документа укажите один дополнительный реквизит – ФирмаЗаказчик (тип данных – СправочникСсылка.Фирмы). Для табличной части документа выберите имя ПереченьТоваров и внесите в нее два реквизита – Номенклатура (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – Число без дробной части).

4. Перейдите в режим 1С:Предприятие и заполните несколько документов по созданному шаблону. После завершения работы, вернитесь в окно конфигуратора.

5. Создадим обработку, автоматически заполняющую документ Заказ на основе документа Заявки. В окне Конфигурация щелкните правой кнопкой мыши по Обработки и в появившемся контекстном меню выберите пункт Добавить.

6. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите РаботаСДокументами1.

7. Перейдите на закладку Формы. В разделе Основные формы щелкните по кнопке и выполните необходимые установки. После этого щелкните по кнопке Готово.

8. Добавьте в форму элементы управления. Для этого в меню Форма выберите пункт Вставить элемент управления и укажите вид элемента: поле ввода Заявка (тип данных – ДокументСсылка.Заявка).

9. Перейдите на закладку Модуль и оформите процедуру обработки нажатия на кнопку Выполнить:

Процедура КнопкаВыполнитьНажатие(Кнопка)

НовыйЗаказ = Документы.Заказ.СоздатьДокумент();

НовыйЗаказ.Заказчик = Заявка.ФирмаЗаказчик;

НовыйЗаказ.Дата = ТекущаяДата();

Для Каждого СтрокаЗаявка Из Заявка.ПереченьТоваров  Цикл

 СтрокаЗаказТовар = НовыйЗаказ.Перечень.Добавить();

 СтрокаЗаказТовар.Товар = СтрокаЗаявка.Номенклатура;

 СтрокаЗаказТовар.Количество = СтрокаЗаявка.Количество;

КонецЦикла;

НовыйЗаказ.Записать();

КонецПроцедуры

10. Перейдите в режим 1С:Предприятие, откройте форму обработки и выберите заявку. В результате будет получен новый документ:

Замечание. Воспользовавшись событием ПриЗаписи можно отменить запись объекта в базу данных.

11. Вернитесь в окно конфигуратора. В окне редактирования документа Заказ перейдите на закладку Прочее и воспользуйтесь кнопкой Модуль объекта. Напишите текст процедуры:

Процедура ПриЗаписи(Отказ)

Если ЭтотОбъект.Дата < ТекущаяДата() Тогда

 Отказ = Истина;

КонецЕсли;

КонецПроцедуры;

Замечание. Воспользовавшись событием ПередУдалением можно отменить удаление объекта из базы данных.

12. Вернитесь в окно конфигуратора. В окне редактирования документа Заказ перейдите на закладку Прочее и воспользуйтесь кнопкой Модуль объекта. Напишите текст процедуры:

Процедура ПередУдалением(Отказ)

Если ЭтотОбъект.Дата < Дата(2008,08,05) Тогда

 Отказ = Истина;

КонецЕсли;

КонецПроцедуры;


 

А также другие работы, которые могут Вас заинтересовать

78756. Сражаюсь, верую, люблю! 100 KB
  На сцене в противоположних углах стоят стулья с участниками со стороны Э. Асадова и Б. Окуджавы, а так же два юноши и две девушки в стилизованых костюмах. На экране появляються первые слайды презентации Под музику «Как здорово, что все мы здесь сегодня собрались» выходят ведущие вечера.
78757. Я люблю Україну 144 KB
  Мета: навчальна – поглибити знання учнів про Україну, її символи, традиції, впроваджувати елементи естетичного виховання культури спілкування; розвивальна – розвивати українське мовлення учнів, культуру поведінки; уміння приймати рішення в нестандартних ситуаціях, колективну творчість...
78758. Сценарий выступления 11 класса на выпускном вечере 70.5 KB
  Есть за домами за лесами Маленькая страна. Маленькая страна Маленькая страна Каждый расскажет и покажет Вот она вот она На сцену поднимается ещё одна выпускница девочки берутся за руки и вместе поют вторую часть припева.
78759. ИЗ СВЕТЛЯНДИИ ПРИВЕТ – ЭТО СКАЗКА ПРО БЮДЖЕТ 38 KB
  Голос ребёнка: За горами, за лесами есть чудесная страна! И Светляндским королевством называется она. И живут в том королевстве человечки – светлячки: Дети, тётеньки и дяди, бабушки и старички! Во главе же государства стоит дяденька король. И зовут его Светлун, а фамилия Второй!
78760. Книга та комп’ютер – наші друзі 112 KB
  Адже це дійсно так. Особливо ці слова, сказані англійським прем’єр міністром у минулому столітті, є актуальними сьогодні. У наш час стрімкого розвитку інноваційних технологій дуже важливо володіти своєчасною та актуальною інформацією. З кожним роком обсяг інформації зростає, також скорочується час для пошуку інформації.
78761. Хай сонцю і квітам всміхаються діти 717.5 KB
  Організаційна робота. Прийом дітей в пришкільний табір. Знайомство з вожатими та дітьми Знайомство з вожатими. Хто запам’ятав, як звуть вожатих? Знайомство-жарт з дітьми. З нами ви вже познайомились. А тепер ми хочемо познайомитись з вами. Я рахую до трьох, на рахунок «три» кожний викрикує своє ім’я.
78762. У Марійки Підгірянки, мов із золота співанки 80 KB
  Однак незважаючи на її велике бажання вчитися батько - незаможний лісник не міг дати освіту всім дітям тому в сімейному колі вирішили що вчитися буде син а дівчатка займатимуться хатньою роботою. Допомагав дочці батько котрий досконало володів німецькою мовою добре знав математику біологію.
78763. ЛІТЕРАТУРНИЙ ВЕЧІР ЗА ТВОРАМИ ГРИЦЬКА БОЙКА 73 KB
  Добрий день, дорогі гості. Ми дуже раді, що ви прийшли на наше свято. Ми зможемо сьогодні розвеселити вас і зробити вам приємне, значит наша праця не буде марною. Як відомо, кожна людина ставить перед собою завдання і намагається його виконати.
78764. Бармен. Особливості приготування коктейлів 1.39 MB
  Професію бармена відносять до типу професій «людина — людина», тому що головним предметом праці для неї є людина, а головною метою праці цієї професії є оперативне обслуговування відвідувачів та розрахунок з ними.