13479

Создание регистра накопления остатков

Лабораторная работа

Информатика, кибернетика и программирование

Регистры накопления Лабораторная работа Задача 1. Создание регистра накопления остатков. 1. Откройте базу МояБаза1 в режиме конфигуратора. 2. Создайте документ Поступление. В области шапки документа укажите один дополнительный реквизит – Заказчик тип данных – Спра...

Русский

2013-05-11

279.5 KB

6 чел.

Регистры накопления

Лабораторная работа

Задача 1. Создание регистра накопления остатков.

1. Откройте базу МояБаза1 в режиме конфигуратора.

2. Создайте документ Поступление. В области шапки документа укажите один дополнительный реквизит – Заказчик (тип данных – СправочникСсылка.Фирмы). Для табличной части документа выберите имя Перечень и внесите в нее два реквизита – Товар (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – Число без дробной части).

3. Перейдите в режим 1С:Предприятие и заполните несколько документов. Затем вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши по Регистры накопления и в появившемся контекстном меню выберите пункт Добавить.

5. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ИнформацияОТоварах. В поле Вид регистра укажите – Остатки.

6. Перейдите на закладку Данные. Создайте для данного регистра: измерение – Организация (тип данных – СправочникСсылка.Фирмы), измерение – Товар (тип данных – СправочникСсылка.Номенклатура) и ресурс Количество (тип данных – Число).

7. Откройте документ Поступление и перейдите на закладку Движения.

8. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОТоварах.

9. Щелкните по кнопке Конструктор движений и запустите соответствующее окно диалога:

10. В поле Табличная часть укажите Перечень.

11. Укажите соответствие полей регистра накопления и реквизитов документа. Для этого воспользуйтесь кнопкой Заполнить выражения (или щелкните в поле Выражение, а затем двойной щелчок по реквизиту).

12. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Поступление.

13. Создайте документ и заполните его информацией.

14. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОТоварах

Задача 2. Создание регистра расходов.

1. Создайте документ Отгрузка, который будет уменьшать ресурс регистра. Структура документа аналогична Поступление.

3. Откройте документ Отгрузка и перейдите на закладку Движения.

4. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОТоварах.

5. Щелкните по кнопке Конструктор движений и заполните поля:

6. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Отгрузка.

7. Создайте документ и заполните его информацией.

8. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОТоварах

Задача 3. Создание оборотного регистра накопления.

1. Создайте регистр накопления ИнформацияОЗаявках. В поле Вид Регистра укажите – Обороты.

2. Перейдите на закладку Данные. Создайте для данного регистра: измерение – Фирма (тип данных – СправочникСсылка.Фирмы), измерение – Товар (тип данных – СправочникСсылка.Номенклатура) и ресурс Количество (тип данных – Число).

3. Откройте документ Отгрузка и перейдите на закладку Движения.

4. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОЗаявках.

5. Щелкните по кнопке Конструктор движений и заполните поля:

6. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Заявка.

7. Создайте заявку и заполните ее информацией.

8. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОЗаказах

Задача 4. Создание обработки для извлечения информации из регистра.

1. Создайте обработку Получение выборки в режиме конфигуратора.

2. На форме обработки разместите поле списка с названием ПереченьДокументов.

3. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

РегистрЗаказ = РегистрыНакопления.ИнформацияОЗаявках;

Данные = РегистрЗаказ.Выбрать();

ПереченьДокументов.Очистить();

Пока Данные.Следующий() Цикл

 Информация = "Регистратор: " + Данные.Регистратор +

                                     " Номенклатура: " + Данные.Товар +

    " Количество: " + Данные.Количество;

 ПереченьДокументов.Добавить(Информация);

КонецЦикла;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте работу обработки:

Задача 5. Создание обработки для извлечения информации об остатках.

1. Создайте обработку ПолучениеОстатков в режиме конфигуратора.

2. На форме обработки разместите поле ввода Товар (тип данных – СправочникСсылка.Номенклатура).

3. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

РегистрЗаказОстатки = РегистрыНакопления.ИнформацияОТоварах;

ОтборПоТовару = Новый Структура();

ОтборПоТовару.Вставить("Товар", Товар);

Данные = РегистрЗаказОстатки.Остатки(,ОтборПоТовару);

Если Данные.Количество()>0 Тогда

 Товары = Данные.Итог("Количество");

 Сообщить("Количество данных товаров " + Товары);

КонецЕсли;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте работу обработки:


 

А также другие работы, которые могут Вас заинтересовать

21157. Технология Hyper-Threading 701.5 KB
  Фактически технология HyperThreading позволяет организовать два логических процессора в одном физическом. После активации каждый из логических процессоров может самостоятельно и независимо от другого процессора выполнять свою задачу обрабатывать прерывания либо блокироваться. Таким образом от реальной двухпроцессорной конфигурации новая технология отличается только тем что оба логических процессора используют одни и те же исполняющие ресурсы одну и ту же разделяемую между двумя потоками кэшпамять и одну и ту же системную шину....
21158. Технология изготовления печатных плат 70.5 KB
  [2] Процесс изготовления печатной платы [3] Сравнительные характеристики методов производства и обоснование применяемого в данном проекте. [10] Основные характеристики: [11] Основы безопасности производства печатных плат. Особенностями производства ЭВМ на современном этапе являются: Использование большого количества стандартных элементов. Массовое производство стандартных блоков с использованием новых элементов унификация элементов создают условия для автоматизации их производства.
21159. Транзисторы сегодня и завтра 519.5 KB
  Принцип работы транзистора Традиционной планарный транзистор представляет собой крохотную кремневую пластинку обогащенную примесью ртипа и называемую подложкой. Такое состояние транзистора условно называют открытым. Однако прогресс стремителен и современные транзисторы вполне уверенно выдерживают частоты в 263 ТГц За счет чего были достигнуты столь впечатляющие улучшения Чтобы ответить на этот вопрос давайте сначала рассмотрим основные недостатки обычного планарного транзистора. 1 Фотография транзистора предназначенного для...
21162. ОБЛІК ВЛАСНОГО КАПІТАЛУ І РОЗПОДІЛУ ПРИБУТКУ В КОРПОРАЦІЯХ 128 KB
  Суть та порядок створення корпорацій. Облік організаційних витрат та їх амортизації. Капітал корпорації. Характеристика акцій, їх оцінка. Облік випуску (продажу) простих (звичайних) та привілейованих акцій. Облік викупу власних акцій.
21163. Чипы памяти. Проектирование модулей памяти 43.5 KB
  Поскольку частота синхронизации внешних и внутренних цепей любого совершенствующегося DRAMинтерфейса постоянно увеличивается особое внимание должно уделяться целостности цифрового сигнала: его логическим уровням фоновым шумам шумам коммутации терминированию топологии сигнальных трасс рассеиваемой мощности терморегуляции и уменьшению влияния ЭМИ. Электромагнитная интерференция Высокие частоты критические условия большие значения силы тока прохождение и ветвление сигнальных трасс все это способствует возникновению самого опасного...
21164. ЭКОЛОГИЯ ПРОИЗВОДСТВА СВТ 299.5 KB
  Вредные вещества в помещении находятся в виде пыли тонкодисперсного тумана паров и газов. Обработка на станках сопровождается выделением пыли стружки туманов масел и эмульсий которые через вентиляционную систему выбрасываются из помещений. Количество выделяющейся пыли зависит от размеров и твердости обрабатываемого материала. При обработке текстолита выделение пыли составляет от 20 г ч до 120 г ч на единицу оборудования; стеклоткани от 9 г ч до 20 г ч; органического стекла от 800 г ч до 950 г ч.