13479

Создание регистра накопления остатков

Лабораторная работа

Информатика, кибернетика и программирование

Регистры накопления Лабораторная работа Задача 1. Создание регистра накопления остатков. 1. Откройте базу МояБаза1 в режиме конфигуратора. 2. Создайте документ Поступление. В области шапки документа укажите один дополнительный реквизит Заказчик тип данных Спра...

Русский

2013-05-11

279.5 KB

6 чел.

Регистры накопления

Лабораторная работа

Задача 1. Создание регистра накопления остатков.

1. Откройте базу МояБаза1 в режиме конфигуратора.

2. Создайте документ Поступление. В области шапки документа укажите один дополнительный реквизит – Заказчик (тип данных – СправочникСсылка.Фирмы). Для табличной части документа выберите имя Перечень и внесите в нее два реквизита – Товар (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – Число без дробной части).

3. Перейдите в режим 1С:Предприятие и заполните несколько документов. Затем вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши по Регистры накопления и в появившемся контекстном меню выберите пункт Добавить.

5. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ИнформацияОТоварах. В поле Вид регистра укажите – Остатки.

6. Перейдите на закладку Данные. Создайте для данного регистра: измерение – Организация (тип данных – СправочникСсылка.Фирмы), измерение – Товар (тип данных – СправочникСсылка.Номенклатура) и ресурс Количество (тип данных – Число).

7. Откройте документ Поступление и перейдите на закладку Движения.

8. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОТоварах.

9. Щелкните по кнопке Конструктор движений и запустите соответствующее окно диалога:

10. В поле Табличная часть укажите Перечень.

11. Укажите соответствие полей регистра накопления и реквизитов документа. Для этого воспользуйтесь кнопкой Заполнить выражения (или щелкните в поле Выражение, а затем двойной щелчок по реквизиту).

12. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Поступление.

13. Создайте документ и заполните его информацией.

14. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОТоварах

Задача 2. Создание регистра расходов.

1. Создайте документ Отгрузка, который будет уменьшать ресурс регистра. Структура документа аналогична Поступление.

3. Откройте документ Отгрузка и перейдите на закладку Движения.

4. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОТоварах.

5. Щелкните по кнопке Конструктор движений и заполните поля:

6. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Отгрузка.

7. Создайте документ и заполните его информацией.

8. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОТоварах

Задача 3. Создание оборотного регистра накопления.

1. Создайте регистр накопления ИнформацияОЗаявках. В поле Вид Регистра укажите – Обороты.

2. Перейдите на закладку Данные. Создайте для данного регистра: измерение – Фирма (тип данных – СправочникСсылка.Фирмы), измерение – Товар (тип данных – СправочникСсылка.Номенклатура) и ресурс Количество (тип данных – Число).

3. Откройте документ Отгрузка и перейдите на закладку Движения.

4. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОЗаявках.

5. Щелкните по кнопке Конструктор движений и заполните поля:

6. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Заявка.

7. Создайте заявку и заполните ее информацией.

8. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОЗаказах

Задача 4. Создание обработки для извлечения информации из регистра.

1. Создайте обработку Получение выборки в режиме конфигуратора.

2. На форме обработки разместите поле списка с названием ПереченьДокументов.

3. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

РегистрЗаказ = РегистрыНакопления.ИнформацияОЗаявках;

Данные = РегистрЗаказ.Выбрать();

ПереченьДокументов.Очистить();

Пока Данные.Следующий() Цикл

 Информация = "Регистратор: " + Данные.Регистратор +

                                     " Номенклатура: " + Данные.Товар +

    " Количество: " + Данные.Количество;

 ПереченьДокументов.Добавить(Информация);

КонецЦикла;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте работу обработки:

Задача 5. Создание обработки для извлечения информации об остатках.

1. Создайте обработку ПолучениеОстатков в режиме конфигуратора.

2. На форме обработки разместите поле ввода Товар (тип данных – СправочникСсылка.Номенклатура).

3. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

РегистрЗаказОстатки = РегистрыНакопления.ИнформацияОТоварах;

ОтборПоТовару = Новый Структура();

ОтборПоТовару.Вставить("Товар", Товар);

Данные = РегистрЗаказОстатки.Остатки(,ОтборПоТовару);

Если Данные.Количество()>0 Тогда

 Товары = Данные.Итог("Количество");

 Сообщить("Количество данных товаров " + Товары);

КонецЕсли;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте работу обработки:


 

А также другие работы, которые могут Вас заинтересовать

58444. Герої мультфільмів 36 KB
  Jane came to visit Vicky. Look at picture b. What are they doing? Do you know this cartoon? Do you like it? Who are the characters in this cartoon? Do Jane and Vicky like it?icture. This is Sue again. Whats she wearing?
58445. Той ще не музика, хто в дудку дме. А. Григорук Той ще не музика, хто в дудку дме 35 KB
  У яку групу обєднаємо слова останньої групи Музичні інструменти. Як ви їх розумієте Прочитайте слова і вирази правильно наголошуючи один одному напівголосно. Поясніть її слова. Чому він винувато посміхнувся Чи підтримали їхню думку інші члени сімї
58446. Посилення колоніальної політики Російської імперії. Спроби ліквідації гетьманства 75.5 KB
  Спроби ліквідації гетьманства Становище в Україні після Полтавської битви. Заходи щодо економіки Гетьманщини. Україна від гетьманування Івана Скоропадського до Правління гетьманського уряду. Гетьман Іван Скоропадський.
58447. ПОДБОР И РАСЧЕТ ОСНОВНЫХЭЛЕМЕНТОВ ОДНОСТУПЕНЧАТОЙ ПАРОКОМПРЕССИОННОЙ ХОЛОДИЛЬНОЙ МАШИНЫ 237.93 KB
  Проведем тепловой, конструктивный и гидромеханический расчет теплообменных аппаратов: конденсатора и испарителя. Конденсатор выберем горизонтальный кожухотрубный с водяным охлаждением. Испаритель выбираем горизонтальный кожухотрубный затопленного типа.
58448. Регуляторні системи організму людини 33.5 KB
  Продовжити знайомити учнів з фізіологічними та функціональними системами організму людини; особливу увагу звернути на регуляції функцій та регуляторні системи організму; формувати уявлення про організм як цілісну саморегулювальну систему.
58449. АВТОМАТИЗАЦИЯ КОРМОПРОИЗВОДСТВА. АВТОМАТИЗАЦИЯ КОМБИКОРМОВЫХ АГРИГАТОВ 3.52 MB
  Оборудование комбикормовых цехов (ОКЦ) предназначено для производства рассыпных полнорационных комбикормов в сельскохозяйственных предприятиях и на межхозяйственных комбикормовых заводах.
58450. Доба Мейдзі в Японії 71 KB
  Мета: навчальна схарактеризувати соціальноекономічний і політичний розвиток Японії в другій половині ХІХ ст.; визначити причини та напрямки зовнішньополітичної експансії Японії; розвиваюча розвивати в учнів уміння аналізувати і узагальнювати історичний матеріал...
58451. Різдво в Україні 76 KB
  Good morning, Sue! Nice to see you! Hello, Ralf!How is life? Hi, Seon! How are you getting on? What season is it now? What are winter months? Do you like winter? What can we do in winter? What else is good about winter?re are a lot of wonderful holidays...
58452. Їжа. Food. Dishes 51.5 KB
  This is a picture of our New Years party. This is my family: My Mum, Dad, my little sister Ann and our dog. Mum is watching TV/eating the cake. Dad is watching TV/sleeping. Ann is singing/dancing. She looks happy!