13479

Создание регистра накопления остатков

Лабораторная работа

Информатика, кибернетика и программирование

Регистры накопления Лабораторная работа Задача 1. Создание регистра накопления остатков. 1. Откройте базу МояБаза1 в режиме конфигуратора. 2. Создайте документ Поступление. В области шапки документа укажите один дополнительный реквизит – Заказчик тип данных – Спра...

Русский

2013-05-11

279.5 KB

6 чел.

Регистры накопления

Лабораторная работа

Задача 1. Создание регистра накопления остатков.

1. Откройте базу МояБаза1 в режиме конфигуратора.

2. Создайте документ Поступление. В области шапки документа укажите один дополнительный реквизит – Заказчик (тип данных – СправочникСсылка.Фирмы). Для табличной части документа выберите имя Перечень и внесите в нее два реквизита – Товар (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – Число без дробной части).

3. Перейдите в режим 1С:Предприятие и заполните несколько документов. Затем вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши по Регистры накопления и в появившемся контекстном меню выберите пункт Добавить.

5. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ИнформацияОТоварах. В поле Вид регистра укажите – Остатки.

6. Перейдите на закладку Данные. Создайте для данного регистра: измерение – Организация (тип данных – СправочникСсылка.Фирмы), измерение – Товар (тип данных – СправочникСсылка.Номенклатура) и ресурс Количество (тип данных – Число).

7. Откройте документ Поступление и перейдите на закладку Движения.

8. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОТоварах.

9. Щелкните по кнопке Конструктор движений и запустите соответствующее окно диалога:

10. В поле Табличная часть укажите Перечень.

11. Укажите соответствие полей регистра накопления и реквизитов документа. Для этого воспользуйтесь кнопкой Заполнить выражения (или щелкните в поле Выражение, а затем двойной щелчок по реквизиту).

12. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Поступление.

13. Создайте документ и заполните его информацией.

14. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОТоварах

Задача 2. Создание регистра расходов.

1. Создайте документ Отгрузка, который будет уменьшать ресурс регистра. Структура документа аналогична Поступление.

3. Откройте документ Отгрузка и перейдите на закладку Движения.

4. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОТоварах.

5. Щелкните по кнопке Конструктор движений и заполните поля:

6. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Отгрузка.

7. Создайте документ и заполните его информацией.

8. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОТоварах

Задача 3. Создание оборотного регистра накопления.

1. Создайте регистр накопления ИнформацияОЗаявках. В поле Вид Регистра укажите – Обороты.

2. Перейдите на закладку Данные. Создайте для данного регистра: измерение – Фирма (тип данных – СправочникСсылка.Фирмы), измерение – Товар (тип данных – СправочникСсылка.Номенклатура) и ресурс Количество (тип данных – Число).

3. Откройте документ Отгрузка и перейдите на закладку Движения.

4. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОЗаявках.

5. Щелкните по кнопке Конструктор движений и заполните поля:

6. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Заявка.

7. Создайте заявку и заполните ее информацией.

8. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОЗаказах

Задача 4. Создание обработки для извлечения информации из регистра.

1. Создайте обработку Получение выборки в режиме конфигуратора.

2. На форме обработки разместите поле списка с названием ПереченьДокументов.

3. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

РегистрЗаказ = РегистрыНакопления.ИнформацияОЗаявках;

Данные = РегистрЗаказ.Выбрать();

ПереченьДокументов.Очистить();

Пока Данные.Следующий() Цикл

 Информация = "Регистратор: " + Данные.Регистратор +

                                     " Номенклатура: " + Данные.Товар +

    " Количество: " + Данные.Количество;

 ПереченьДокументов.Добавить(Информация);

КонецЦикла;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте работу обработки:

Задача 5. Создание обработки для извлечения информации об остатках.

1. Создайте обработку ПолучениеОстатков в режиме конфигуратора.

2. На форме обработки разместите поле ввода Товар (тип данных – СправочникСсылка.Номенклатура).

3. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

РегистрЗаказОстатки = РегистрыНакопления.ИнформацияОТоварах;

ОтборПоТовару = Новый Структура();

ОтборПоТовару.Вставить("Товар", Товар);

Данные = РегистрЗаказОстатки.Остатки(,ОтборПоТовару);

Если Данные.Количество()>0 Тогда

 Товары = Данные.Итог("Количество");

 Сообщить("Количество данных товаров " + Товары);

КонецЕсли;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте работу обработки:


 

А также другие работы, которые могут Вас заинтересовать

64968. К ИСТОРИИ ОТРАРА МОНГОЛО-ТИМУРИДСКОГО ВРЕМЕНИ 41 KB
  Имеется уникальная возможность сопоставить данные двух независимых друг от друга источников какими являются письменные и археологические материалы и реконструировать на их основе не которые важнейшие события истории Отрара.
64971. РОССИЯ, СИБИРЬ И СОПРЕДЕЛЬНЫЕ СТРАНЫ ВОСТОКА 55.5 KB
  Литосовым признали себя подданными русского царя сказав: Рад де я быти под ево царскою высокою рукою и во всем добра хотети и на их государьское жалованье и милостивое призрение надежен В ходе переговоров Сенге...
64972. Ярлык в традиции политической культуры Восточной Европы в XIV веке. Вопросы истории 71 KB
  В Москве всегда внимательно следили за всеми перипетиями внутриполитичес­кой борьбы в улусе Джучи, особенно в период великой замятии, когда в Орде в борьбе за Новосарайский престол боролись правители-однодневки. Это отразилось в русских летописях, которые позволяют судить о многих аспектах политической ис­тории Орды в данный период.
64973. АНАЛИЗ МОДЕЛЕЙ ОБРАЗОВАНИЯ ФРАЗЕОЛОГИЧЕСКИХ ЕДИНИЦ В МОНГОЛЬСКИХ ЯЗЫКАХ 162 KB
  Фразеология монгольских языков неоднократно становилась объектом лингвистических исследований. В русской фразеологии принято считать, что в языке не существует настолько оригинальных фразеологизмов, что на них не распространяются законы языка.
64974. Идентичность «Танну-Урянхая» и «Урянхайская проблема» 260.5 KB
  Круг выступает также как проекция шара, признаваемая идеальным телом в мифопоэтической (религиозно-мифологической), так и в древнейшей научно-философской традиции (ср. идеи Ксенофана о шаре как образе единства ограниченности и безграничности и о шарообразности божества).
64975. Поволжье в составе Золотой Орды 148.5 KB
  Поволжье в составе Золотой Орды Монгольское завоевание в XIII в. волжские булгары в дальнейшем оказались в орбите нового политического союза Золотой Орды где в силу обширности территорий объединялись многие народы. После образования Золотой Орды где не было официальной общепринятой государственной религии среди наибольшей части местного...
64976. МОНГОЛЬСКАЯ ЛИТЕРАТУРА 79 KB
  Самым ранним образцом воспринятой монголами письменности считается надпись на так называемом Чингисовом камне в которой прославляется искусная стрельба из лука Исункэ племянника Чингиса. Вторая часть занимающая три 684 четверти всего сказания посвящена рассказу о жизни и деятельности Чингиса как создателя Монгольского государства.