13479

Создание регистра накопления остатков

Лабораторная работа

Информатика, кибернетика и программирование

Регистры накопления Лабораторная работа Задача 1. Создание регистра накопления остатков. 1. Откройте базу МояБаза1 в режиме конфигуратора. 2. Создайте документ Поступление. В области шапки документа укажите один дополнительный реквизит – Заказчик тип данных – Спра...

Русский

2013-05-11

279.5 KB

6 чел.

Регистры накопления

Лабораторная работа

Задача 1. Создание регистра накопления остатков.

1. Откройте базу МояБаза1 в режиме конфигуратора.

2. Создайте документ Поступление. В области шапки документа укажите один дополнительный реквизит – Заказчик (тип данных – СправочникСсылка.Фирмы). Для табличной части документа выберите имя Перечень и внесите в нее два реквизита – Товар (тип данных – СправочникСсылка.Номенклатура) и Количество (тип данных – Число без дробной части).

3. Перейдите в режим 1С:Предприятие и заполните несколько документов. Затем вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши по Регистры накопления и в появившемся контекстном меню выберите пункт Добавить.

5. В появившемся окне редактирования объекта конфигурации щелкните в поле Имя и укажите ИнформацияОТоварах. В поле Вид регистра укажите – Остатки.

6. Перейдите на закладку Данные. Создайте для данного регистра: измерение – Организация (тип данных – СправочникСсылка.Фирмы), измерение – Товар (тип данных – СправочникСсылка.Номенклатура) и ресурс Количество (тип данных – Число).

7. Откройте документ Поступление и перейдите на закладку Движения.

8. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОТоварах.

9. Щелкните по кнопке Конструктор движений и запустите соответствующее окно диалога:

10. В поле Табличная часть укажите Перечень.

11. Укажите соответствие полей регистра накопления и реквизитов документа. Для этого воспользуйтесь кнопкой Заполнить выражения (или щелкните в поле Выражение, а затем двойной щелчок по реквизиту).

12. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Поступление.

13. Создайте документ и заполните его информацией.

14. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОТоварах

Задача 2. Создание регистра расходов.

1. Создайте документ Отгрузка, который будет уменьшать ресурс регистра. Структура документа аналогична Поступление.

3. Откройте документ Отгрузка и перейдите на закладку Движения.

4. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОТоварах.

5. Щелкните по кнопке Конструктор движений и заполните поля:

6. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Отгрузка.

7. Создайте документ и заполните его информацией.

8. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОТоварах

Задача 3. Создание оборотного регистра накопления.

1. Создайте регистр накопления ИнформацияОЗаявках. В поле Вид Регистра укажите – Обороты.

2. Перейдите на закладку Данные. Создайте для данного регистра: измерение – Фирма (тип данных – СправочникСсылка.Фирмы), измерение – Товар (тип данных – СправочникСсылка.Номенклатура) и ресурс Количество (тип данных – Число).

3. Откройте документ Отгрузка и перейдите на закладку Движения.

4. В разделе Регистры накопления выберите регистр накопления, по которому организуется движение. В нашем случае – ИнформацияОЗаявках.

5. Щелкните по кнопке Конструктор движений и заполните поля:

6. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Для этого в меню Операции выберите пункт Документы, а затем Заявка.

7. Создайте заявку и заполните ее информацией.

8. В меню Операции выберите пункт Регистр накопления, а затем ИнформацияОЗаказах

Задача 4. Создание обработки для извлечения информации из регистра.

1. Создайте обработку Получение выборки в режиме конфигуратора.

2. На форме обработки разместите поле списка с названием ПереченьДокументов.

3. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

РегистрЗаказ = РегистрыНакопления.ИнформацияОЗаявках;

Данные = РегистрЗаказ.Выбрать();

ПереченьДокументов.Очистить();

Пока Данные.Следующий() Цикл

 Информация = "Регистратор: " + Данные.Регистратор +

                                     " Номенклатура: " + Данные.Товар +

    " Количество: " + Данные.Количество;

 ПереченьДокументов.Добавить(Информация);

КонецЦикла;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте работу обработки:

Задача 5. Создание обработки для извлечения информации об остатках.

1. Создайте обработку ПолучениеОстатков в режиме конфигуратора.

2. На форме обработки разместите поле ввода Товар (тип данных – СправочникСсылка.Номенклатура).

3. Перейдите на закладку Модуль и напишите текст процедуры:

Процедура КнопкаВыполнитьНажатие(Кнопка)

РегистрЗаказОстатки = РегистрыНакопления.ИнформацияОТоварах;

ОтборПоТовару = Новый Структура();

ОтборПоТовару.Вставить("Товар", Товар);

Данные = РегистрЗаказОстатки.Остатки(,ОтборПоТовару);

Если Данные.Количество()>0 Тогда

 Товары = Данные.Итог("Количество");

 Сообщить("Количество данных товаров " + Товары);

КонецЕсли;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте работу обработки:


 

А также другие работы, которые могут Вас заинтересовать

73877. Пєзомодулі кварцу – графічна інтерпритація 52 KB
  Компоненти dmnk являють собою компоненти тензора третього рангу; за індексами n і k у виразі малось на увазі підсумовування. У повному записі з цього рівняння випливає, що для кристалів найнижчої симетрії тензор dmnk відповідно до рівняння міг би мати
73878. Прямий пєзоелектричний eфeкт 53.5 KB
  Прямий пєзоефект спонукає нецентросиметричні кристали або текстури перетворювати механічну енергію в електричну. Цей ефект може бути описаний різними лінійними співвідношеннями залежно від поєднання тих чи тих граничних умов, відповідно до яких використовують або досліджують пєзоелектрик
73879. Обратный пьезоелектрический эффект 32.86 KB
  Пъезоэффект возникает только в 20 кристаллах из 32 возможных каждый из которых отличается своей группой симметрии. Эти группы включают в себя элементы симметрии – оси после поворота кристалла на определенный угол новое его положение точно совпадает с выходным плоскости зеркально отображает все элементы кристалла по обе ее стороны и центры симметрии. Используется в современной технике – это структура что характеризируется осью симметрии бесконечного порядка и плоскостью m проходящую через эту ось. Полярнаю ось симметрии направлена по...
73884. Тензор механічної напруги 30.65 KB
  Однорідний протяжний пружний стрижень одновимірний кристал на який діє механічне напруження показано на рис. Механічне напруження не вектор і тому позначається парою стрілок однакових за величиною і протилежних за напрямом.
73885. Фізична природа власної полярності кристалів 40 KB
  Природа спонтанної поляризації піроелекrpиків (і, тим більше, власної полярності пєзоелекrpиків) не зводиться тільки до зсувів іонних пiдгpаток, але має бути врахована конфіrypація структури кристала.