13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

29847. Резервы повышения развития средств хозяйствования 18.46 KB
  В масштабах всего народного хозяйства создаются общегосударственные резервы средств производства и ведется подготовка трудовых резервов т. Это направление анализа резервов имеет очень важное значение для расчета обоснованных норм резервных запасов их ограничения действительно необходимыми для обеспечения непрерывности и ритмичности производства. Выявление резервов в таком понимании и определение реальных путей и сроков их мобилизации являются основными задачами экономического анализа деятельности хозяйствующих субъектов. Для...
29848. Федеральные фонды:порядок формирования и использование средств 18.82 KB
  Законодательные представительные органы не имеют права создавать свои резервные фонды а также выполнять отдельные функции по исполнению бюджетов за исключением органов местного самоуправления совмещающих функции законодательных и исполнительных органов. ФЕДЕРАЛЬНЫЕ ФОНДЫ 1. Фонды военноучебных заведений РГВИА РГВА 8.
29849. Совершенствование кредитования юридических и индивидуальных предпринимателей 19.4 KB
  В банке необходимо будет сориентироваться в процентных ставках и сроках кредита а главное правильно разъяснить цель кредита. Такой формой кредита могут воспользоваться как индивидуальные предприниматели так и юридические лица. Такой вид кредита как овердрафт позволяет бизнесменам осуществлять расчеты со своими партнерами своевременно и бесперебойно что безусловно способствует сохранению хорошей репутации. Процентные ставки на овердрафт как правило очень удобные для заемщика и всегда у заемщика есть возможность договориться с банком об...
29850. НИОКР в системе финансовых приоритетов современной организации 15.98 KB
  НИОКР в системе финансовых приоритетов современной организации Научноисследовательские опытноконструкторские и технологические работы совокупность работ направленных на получение новых знаний и их практическое применение при создании нового изделия или технологии. Виды НИОКР В соответствии с нормативным регулированием по способу учета затрат НИОКР подразделяются на: Товарные НИОКР текущие заказные – работы относящиеся к обычному виду деятельности организации результаты которых предназначены для реализации заказчику. Капитальные...
29851. Дефицит и профицит бюджета. Пути оптимизации и достижения сбалансированности 12.93 KB
  Дефицит и профицит бюджета. Дефицит бюджета превышение расходов бюджета над его доходами. Классификация источников финансирования дефицита бюджета ст.23 БК – группировка заемных средств привлекаемых РФ субъектами Российской Федерации и муниципальными образованиями для покрытия дефицитов соответствующих бюджетов: внутренние источники – применяются для всех уровней бюджета – кредиты от кредитных органов гос.
29852. Приоритетные национальные проекты России 14.98 KB
  Приоритетные национальные проекты России Приоритетные национальные проекты программа по росту человеческого капитала в России объявленная президентом России В. Проекты Программа приоритетных национальных проектов была сформулирована президентом России Владимиром Путиным 5 сентября 2005 года в обращении к правительству парламенту и руководителям регионов. Позднее на сайте появился документ Уточненные направления реализации приоритетного национального проекта Доступное и комфортное жилье гражданам России“ на 2009 2012 годы...
29853. Основные виды финансовых стратегии организации 14.33 KB
  Генеральной финансовой стратегией называют финансовую стратегию определяющую деятельность предприятия. Например взаимоотношения с бюджетами всех уровней образование и использование дохода предприятия потребности в финансовых ресурсах и источниках их формирования на год. [4; 322] Главной стратегической целью финансов является обеспечение предприятия необходимыми и достаточными финансовыми ресурсами. Финансовая стратегия предприятия в соответствии с главной стратегической целью обеспечивает: 1 формирование финансовых ресурсов и...
29854. Роль региональных и местных бюджетов в социально-экономическом развитии территорий 15.14 KB
  Роль региональных и местных бюджетов в социальноэкономическом развитии территорий Бюдже́т от старонормандского bougette кошель сумка кожаный мешок схема доходов и расходов определённого лица семьи бизнеса организации государства и т. Бюджет это важнейшая концепция как в микроэкономике так и в макроэкономике государственный бюджет. Изучением бюджета занимается наука финансы. Региональный бюджет совокупность валют правил и норм их использования взаимного обмена применения в качестве платежных средств а также...
29855. Валютные операции коммерческих банков, в России и за рубежом 18.25 KB
  Валютный рынок это вся совокупность конверсионных и кредитнодепозитных операций в иностранных валютах осуществляемых между контрагентами участниками валютного рынка. Валютные рынки можно классифицировать по следующим признакам: по виду операций. Например существует мировой рынок конверсионных операций в нём можно выделить сегменты конверсионных операций типа евро доллар или доллар иена а также мировой рынок кредитнодепозитных операций; по территориальному признаку. Текущие конверсионные операции по обмену одной валюты на другую а...