13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

78565. Правила життя в суспільстві 39 KB
  Мета. Ознайомити учнів із правилами життя в суспільстві, підвищувати рівень правової освіти учнів; розвивати вміння аналізувати, узагальнювати; виховувати повагу до людини, її прав, доброзичливість, миролюбність.
78566. Правила для учнів 128.5 KB
  Обговорення відомих правил для учнів Заходить вчитель треба встать Коли тобі дозволять сядь Сказати хочеш не гукай А тільки руку піднімай. Сьогодні ми продовжимо складати нові правила для учнів запамятовувати їх і виконувати. Друге правило для учнів Вчасно йди завжди до школи Та не спізнюйся ніколи.
78567. Вчимо правила безпечної поведінки, граючи 94.5 KB
  Мета: Навчити учнів дотримуватися правил безпечного переходу вулиць і доріг повторити правила дорожнього руху розглянути причини ДТП вчити запобігати їх виникнення. Я допомагаю машинам і пішоходам виконувати правила дорожнього руху.
78568. ОСНОВНІ ПРАВОПОРУШЕННЯ 32.5 KB
  Мета: Сформулювати уявлення про правопорушення; познайомити з видами правопорушень; вчити учнів бути чесними громадянами України; виховувати негативне ставлення до правопорушень норм моралі та прав людини. Сьогодні на уроці ми поговоримо про правопорушення.
78569. Мы школьниками стали 43 KB
  Ведущий: Ну, конечно, в первый! Мы проучились в нем...месяца и стали настоящими учениками. Приглашаем всех на весёлый праздник - «Мы школьниками стали». 3-й ученик: Пусть зовут нас «шестилетки»! пусть не ставят нам отметки! Не ведём мы дневники!
78570. Повторення вивченого про прикметник. Спостереження за роллю прикметників у мовленні 90 KB
  Прикметники-синоніми прикметники-антоніми та прикметники багатозначні слова. Спиши вставляючи в речення потрібні за змістом прикметники. Випиши прикметники. Опиши поданий український вишитий рушник використовуючи різні прикметники.
78571. Водойми, їх різноманіття 49 KB
  Вода. Під горою під крутою не ріка тече струною Це холодна бє вода із старого Джерела. Яке значення має вода на Землі Які водойми суші ви знаєте Яким кольором позначають воду на карті глобусі IV Вивчення нового матеріалу 1. Вода напуває Землю яка годує людину.
78572. Збережемо природу Землі разом 95 KB
  Мета. Поглибити і розширити знання учнів про вплив людини на природу Землі. Підвести дітей до усвідомлення необхідності зберігати та примножувати природні багатства, раціонально їх використовувати.
78573. Що належить до природи. Жива і нежива природа 35.5 KB
  Мета: розширити знання учнів про різноманітність природи; формувати уявлення про живу та неживу природу; вчити відрізняти предмети природи від речей виготовлених людиною; розвивати вміння спостерігати за обєктами природи; виховувати дбайливе ставлення до природи речей створених людиною.