13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

28001. Проблемы производства экологически безопасной с/х продукции. Экономический механизм стимулирования производства экологически безопасной продукции 8.6 KB
  Экономический механизм стимулирования производства экологически безопасной продукции. Принципы экономического стимулирования выработаны и продолжают вырабатываться практикой. Комплексность системность всесторонность стимулирования означающая обязательность стимулирования использования современных технологических процессов если они имеют целью ресурсосбережение и проводятся экологически приемлемыми методами а также и собственно природоохранных мероприятий утилизация отходов строительство очистных сооружений в целях...
28002. Радионуклиды в агроэкосистеме: перенос радионуклидов по с/х цепочкам и их миграция в агроценозах 2.32 KB
  Основными источниками техногенных радионуклидов в агросфере являются остаточные количества долгоживущих радв поступивших в нее в результате испытаний ядерного взрыва выбросов и сбросов радов при работе атомных электростанций и др предприятий полного ядерного топливного цикла. Рост химизации с х ведет к увеличению применения удобрений и мелиорантов с повышенным содержанием естественных радов. Почва обладает уникальной сорбционной способностью по отношению к поступающим в нее радов.
28003. Сравнительный анализ функционирования естественных экосистем и агроэкосистем. Устойчивость эко(агроэко)системы: толерантность, уязвимость, гетерогенность агроценозов 5.26 KB
  Экосистемы исторически сложившееся в биосфере и на той или иной территории открытые но целостные и устойчивые системы живых организмов. Агроэкосистемы вторичные измененные человеком биогеоценозы основу которых составляют искусственно созданные биотические сообщества объединяемые видами живых организмов. Особенность агросистем в отличии от экосистем их неусточивость то есть к способности саморегуляции.
28004. Формирование биогенной нагрузки в природных аграрных системах. Естественные потери биогенных веществ в земледелии, животноводстве и селитебных территорий 4.24 KB
  Естественные потери биогенных веществ в земледелии животноводстве и селитебных территорий. Интенсивно развивающееся сельское хозяйство это наиболее активный источник поступления биогенных элементов. Влияние с х как источника поступления биогенных веществ в природные ресурсы возрастает в связи с увеличением распаханности территорий трансформацию угодий мощной техникой развитием процессов химизации на основе минеральных и органических удобрений. Потери биогенных веществ в растениеводстве условно можно разделить на...
28005. Функционирование агроэкосистем в условиях техногенеза 4.85 KB
  Функционирование агроэкосистем в условиях техногенеза. Агроэкосистема АЭС совокупность биогенных и абиогенных компонентов участков суши преобразованных человеком используемых для производства сельхозпродукции. Основа АгроЭкоСистем почва с х угодия. Типы АгроЭкоСистем: Пропашное земледелие Многолетнее земледелие Многоурожайное земледелие МезоАЭС крупномасштабная МикроАЭС грядка Суша занимает площадь 149 млрд.
28006. Экологизация сельскохозяйственного производства 4.56 KB
  Природоразрушающий ресурсоемкий тип развития АПК требует пересмотра сложившейся теории и на практике техногенной концепции развития АПК. Главным принципом развития АПК должна стать экологизация с х производства всех мероприятий по развитию с х учет природных особенностей функционирования земельных ресурсов. для изменения приоритетов в распределении ресурсов капитальных вложений в АПК усилить природоохранную роль затрат. Для преодоления негативных тенденций в развитии АПК скорейшего решения...
28007. Экологическая биотехнология. Возможности увеличения производства экологически безопасной продукции на основе биопроизводства 2.52 KB
  Возможности увеличения производства экологически безопасной продукции на основе биопроизводства. Среди новых направлений биотехнологии способствующих получению экологически безопасной продукции следует отметить применение микробиологических удобрений промышленную переработку бытовых отходов индустриальную технологию компостирования отходов животноводства и др. микробиологические удобрения повышают продуктивность растений и кол во растительной продукции. Азотфиксирующие микроорганизмы служат прекрасной основой для...
28008. Экологически безопасные технологии и оптимизация обработки почвы 3.73 KB
  Поэтому нужна разработка таких сельскохозяйственных машин и орудий которые при общей эффективности должны оказывать минимальный вред окружающей среде а именно: Сократить выбросы от с х машин и орудий Уменьшить нагрузку на почву путем изменения конструктивной особенности техники Внедрение двигателей с высоким КПД но низким потреблением топлива.
28009. Экологические аспекты применения сточных вод при орошении. Ценность сточных вод в повышении плодородия почв. Контроль загрязнения почв 12.86 KB
  Ценность сточных вод в повышении плодородия почв. Сточные воды используются для орошения на специальных участках земледельческих полях орошения ЗПО. Под последними понимаются водохозяйственные объекты оборудованные для непрерывного приема определенного количества сточных вод в течение всего года с целью их очистки или доочистки и использования для орошения.