13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

30747. Причины зарождения и сущность фашизма 24 KB
  в конкретной исторической обстановке фашизм нужен определенным кругам империализма чтобы справиться с возрастанием революционного движения разрешить в свою пользу классовые противоречия которые нельзя разрешить старыми методами и формами борьбы. Мировому капиталу фашизм был нужен чтобы разрушить главной оплот международного революционного процесса и антиимпериалистической борьбы – СССР. Германский фашизм сопровождался политическими убийствами погромами и др.
30748. Латинская Америка: что принесли неолиберальные преобразования (на опыте 1980 - 1990-х гг.) 27 KB
  стимулировал экономический рост Латинской Америки в начале 90х гг. Другая болевая точка современной Латинской Америки безработица принявшая беспрецедентные масштабы. Финансовоэкономическая стратегия Латинской Америки на 90е гг. В задачи консенсуса входило преодоление инфляции сокращение бюджетного дефицита укрепление национальных валют Латинской Америки.
30749. Причины и характер первой мировой войны, цели воюющих сторон. (28 июля 1914 — 11 ноября 1918) 23.5 KB
  28 июля 1914 11 ноября 1918 стремление к переделу мира в результате противостояния двух военных блоков: Тройственного Союза Германия АвстроВенгрия Италия и Антанты Англия Франция Россия борющихся за гегемонию на континенте. слабое рабочее движение в результате в ряде стран победили партии войны в правящих кругах ряда Западных стран Германия Великобритания АвстроВенгрия и Франция. Цели: Германия – создать Новую Европу где влияния Англии Франции и России свелись бы к нулю. АвстроВенгрия как и Германия за...
30750. Бетонирование колонн, стен, перекрытий 14.54 KB
  При возведении стен в разборнопереставной опалубке смесь укладывают участками высотой не более 3 м. В стены толщиной более 05 м при слабом армировании подают бетонную смесь подвижностью 4. Бетонную смесь подают непосредственно в опалубку в нескольких точках по длине участка бадьями виброжелобами бетононасосами. При высоте стен более 3 м используют звеньевые хоботы при этом смесь укладывают горизонтальными слоями толщиной 03.
30751. Назначение и виды опалубок. Требования к опалубке. Оборачиваемость опалубных форм 16.57 KB
  Поверхность опалубки непосредственно примыкающая к бетону должна быть плотной иметь малую с бетоном адгезию и не иметь щелей чтобы не вытекало цементное молоко. Важнейшим показателем качества опалубки является ее оборачиваемость т. Применение инвентарной многооборачиваемой опалубки из унифицированных элементов с модульным изменением размеров и укрупненных блоков способствует снижению трудоемкости и стоимости опалубочных работ. Для изготовления опалубки используют доски из древесины II III и IV сортов хвойных пород допускается...
30752. Разборно-переставная опалубка. Область применения, конструкция 15.58 KB
  Технологический процесс устройства опалубки состоит в следующем. Щиты опалубки или собранные из них крупные опалубочные элементы устанавливают вручную или краном и закрепляют в проектном положении. Масса элемента этой опалубки до 70 кг. Щиты опалубки изготовляют из досок толщиной 19.
30753. Объёмно-переставная опалубка. Конструкция, область применения 17.24 KB
  Секции при соединении образуют туннели опалубки на квартиру или на всю ширину здания. Секции опалубки могут иметь переменную ширину в зависимости от принятого шага стен и различную длину. П и Гобразные секции опалубки устанавливают на перекрытии ранее забетонированного этажа выверяют и закрепляют между собой в продольном и поперечном направлениях. Общие конструктивные признаки опалубки: наличие системы механических домкратов для выверки и установки в проектное положение; катучие опоры для перемещения секций опалубки при монтаже и...
30754. Скользящая опалубка. Технология бетонирования стен в скользящей опалубке 14.52 KB
  При бетонировании следят за вертикальностью домкратного стержня и за бетонной поверхностью Применение скользящей опалубки особенно эффективно при строительстве высотных зданий и сооружений с минимальным количеством оконных и дверных проемов конструктивных швов и закладных элементов. К ним относятся силосы для хранилища материалов дымовые трубы и градирни ядра жесткости высотных зданий резервуары для воды радиотелевизионные башни. Другая потенциальная область использования скользящей опалубки строительство зданий атомных реакторов...
30755. Состав арматурных работ на строительной площадке. Классификация арматуры. Арматурные изделия. Устройство защитного слоя арматуры 17.79 KB
  Классификация арматуры. Устройство защитного слоя арматуры. При монтаже сборных железобетонных конструкций выполняются сварка выпусков арматуры и закладных деталей натяжение проволоки и канатов преднапряженных конструкциях а также создание каркаса или внешнего армирования при усилении конструкции реконструируемых зданий и сооружений. В состав арматурных работ на строительной площадке входят: разгрузка приемка и складирование поступающих арматурных изделий и товарной арматуры; изготовление нестандартных арматурных изделий; укрупнительная...