13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

59648. Оживає дух козацький: Театралізований вечір-конкурс 37 KB
  Отаман: За дніпровськими порогами за південними дорогами за степами за широкими Наші прадіди жили Мали Січ козацьку сильную Цінували волю вільную Україну свою рідну Як зіницю берегли. Отаман: Дякую тобі лицарю добрі були слова твої...
59649. Ой, завю вінки... Сценарій народного свята на Троїцю 51.5 KB
  На сцену у справжньому народному одязі виходить ведуча. ВЕДУЧА: Добридень люди добрі Вітаємо з святою Троїцею Саме сьогодні весна передала літу своє зелене вбрання. 1 ДІВЧИНА: Молодець Катруся А зараз понесімо радість усім людям нашого селаВедуча дає дітям крашанки та цукерки.
59650. Число ПИ «π» 807 KB
  «Число Пи - это математическая константа, через которую выражается отношение длины окружности к её диаметру. И это число приблизительно равно 3,14.». Одним из первых заметил и высчитал такую интересную зависимость между длиной окружности и её диаметром Архимед
59651. Під срібні переливи бандури: Сценарій літературно-мистецького вечора 39.5 KB
  Ведуча ІІ: Походження української кобзибандури сягає кінця ХУпочатку ХVІ ст. Ведуча І: Гей на татарських полях На козацьких шляхах То не вовкисі романці Квилять...
59653. Перлини українського романсу: Матеріали до сценарію літературно-музичної композиції 54 KB
  Народжується романс. Український романс. Виростаючи з ліричної народної пісні романс поступово набирає ознак самостійного жанру якому частіше притаманна не куплетна форма взаємозумовленість слова і музики простота і щирість естетична краса широкий між жанровий звязок.
59654. Поріс чорнобилем Чорнобиль - бідою нашою поріс: Сценарії вечора памяті до дня Чорнобильської трагедії 46.5 KB
  У ніч з 25 на 26 квітня 1986 року о першій годині 23 хв. 40 сек., коли всі спали безтурботним сном, над 4-м реактором Чорнобильської атомної електростанції несподівано розірвало нічну темряву велетенське полумя. Почався новий відлік українського часу. Болісний, Гіркий. Печальний...
59655. Система кадрового делопроизводства железнодорожной станции В 1.11 MB
  Исследовать теоретические основы системы кадрового делопроизводства и определить её место в системе управления персоналом; исследовать методику оценки состояния системы кадрового делопроизводства и её совершенствования; провести анализ системы кадрового делопроизводства железнодорожной станции В и дать оценку её состояния...
59656. Роде наш красний: Сценарій сімейного свята для дітей 57 KB
  недаремно назвала саме ці сім’ї, адже вони прийшли з найстаршими представниками родини - бабусями та дідусями і, навіть, прабабусями та прадідусями. Ми раді басити Вас, ми щиро вітаємо Вас на нашому святі.