13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

43747. Колодкові гальма підйомно-транспортних машин та механізмів 313 KB
  У підйомно-транспортному машинобудуванні широке застосування знайшли гальма, конструкція важільної системи яких забезпечує можливість використання для замикання електромагнітів як змінного (гальма типу ТКТ із електромагнітами типу МО-Б), так і постійного (гальма типу ТКП із електромагнітами типу МП) струму .
43748. Разработка технических и технологических мероприятий по созданию централизованной системы водоотведения 862.13 KB
  Город Кириши расположен в зоне дерново-подзолистых почвы и легко- и среднесуглинистого механического состава. Такие почвы бедные, с плохой структурой и отличающиеся значительной кислотностью. По механическому составу они большей частью тяжелосуглинистые, но встречаются суглинистые и супесчаные.
43749. Спроектирован участок механической обработки детали и произведен расчет и анализ условий труда и безопасности жизнедеятельности 1.2 MB
  Штамп с верхним прижимом предназначен для вырубки листа сердечника электродвигателя ВАО44502 асинхронный трехфазный двигатель с короткозамкнутым ротором обдуваемый взрывозащищенный. В данном дипломном проекте разрабатывается технология изготовления матрицы для вырубного штампа форма и размеры которой унифицированы т. данный тип матрицы используется во многих штампах листовой штамповки матрицы которых отличаются только профилем вырубаемого листа. Ведомость по заказам матриц для вырубных штампов Заводпотребитель Условный годовой...
43750. Розробка Інтернет-магазину «Компьютерна техніка» 2.29 MB
  Характерними рисами інтернет-магазинів є те, що вони можуть пропонувати значно більшу кількість товарів та послуг, ніж реальні магазини і забезпечувати споживачів значно більшим обсягом інформації, необхідної для прийняття рішення про покупку
43751. Система и меры антикризисного управления 174 KB
  В данном направлении государство осуществляет следующие виды регулирования: Правовое регулирование создается правовая основа антикризисного регулирования проводятся экспертизы на наличие случаев преднамеренного и фиктивного банкротства; Методическое регулирование проведение мониторинга состояния организации и методическое обеспечение профилактика ее банкротства судебные процедуры а также санации если возникнет факт несостоятельности; Информационное регулирование производит учет и анализ платежеспособности экономически и социально...
43752. Страхові послуги 649.5 KB
  В ній виділена фінансова діяльність код 65 яка включає фінансове посередництво грошове посередництво фінансовий лізинг страхування код 66 яка представлена значною кількістю фінансових послуг. Страховий продукт це набір основних і додаткових послуг що надаються страхувальнику при укладенні договору страхування. З точки зору цивільного права – це визначений договором страхування та іншими нормативними актами в системі цивільноправових відносин комплекс заходів які страховик зобов’язується здійснити в інтересах страхувальника....
43753. СТРАХОВІ НАКОПИЧУВАЛЬНІ ПОСЛУГИ 80 KB
  На практиці найчастіше договори страхування життя мають змішаний характер, тобто поєднують у собі страхування як на випадок смерті, так і на випадок дожиття. Тому одноразова нетто-ставка в цьому випадку дорівнює сумі розрахованих нетто-ставок за кожним ризиком.