13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

15329. Редактор материалов. Создание текстур материалов 3.9 MB
  Тема 4: Редактор материалов. Создание текстур материалов 1. Создание текстуры древесины Создайте объект типа Box рис. 1.1 Рис. 1.1 Откройте редактор материалов выполнив последовательность команд: Rendering ~Material Editor или нажав кнопку
15330. Создание интерьера бассейна в 3Ds Max 1.96 MB
  Тема 6: Создание интерьера бассейна В результате выполнения этой работы Вы должны получить визуализированную сцену изображенную на рисунке. 1. Двумерные формы. Модификаторы двумерных форм Цель: освоить технологию создания д
15332. Основы работ со статическими изображениями в программе трехмерной графики 3ds max 4.96 MB
  Тема 5: Основы работ со статическими изображениями в программе трехмерной графики 3ds max. Этапы создания трехмерных сцен Проект Создадим уголок части комнаты в которой располагается стол. На столе стоит бокал со льдом. Для указанно...
15333. Процессы включения и отключения цепи с конденсатором 1.71 MB
  Рассчитать докоммутационные t = 0 начальные t = 0 и установившиеся t → ∞ значения токов и напряжения на конденсаторе в цепи Рис. 1. в двух случаях: 1. ключ размыкается; 2. ключ замыкается. R1= 330 Ом; R2=220 Ом; U= 15 В; С= 10 мкФ Рису...
15334. Процессы включения и отключения цепи с катушкой индуктивности 75 KB
  Общие сведения Цепь с одной катушкой индуктивности так же как и цепь с одним конденсатором описывается дифференциальным уравнением первого порядка. Поэтому все токи и напряжения в переходном режиме изменяются по экспоненциальному закону с одной и той же постоянной вр
15335. Исследование переходных процессов в линейных электрических цепях 94 KB
  Подготовка к работе В замкнутом контуре рис.1 после отключении его от источника постоянного или переменного напряжения могут возникнуть затухающие синусоидальные колебания обусловленные начальным запасом энергии в электрическом поле конденсатора и в магнитном
15336. Изучение алгоритма Дейкстры и реализация его для заданного графа на языке программирования С++ 344.5 KB
  Лабораторная работа №1 по дисциплине Структуры и алгоритмы обработки данных Цель работы: Изучение алгоритма Дейкстры и реализация его для заданного графа на языке программирования С. Алгоритм Дейкстры англ. Dijkstras algorithm алгоритм на графах изобретённый н
15337. Изучение алгоритма пирамидальной сортировки и реализация его на языке программирования С++ 49 KB
  Лабораторная работа №2 по дисциплине Структуры и алгоритмы обработки данных Цель работы: Изучение алгоритма пирамидальной сортировки и реализация его на языке программирования С. Задание на работу Написать программу генерирующую числовой массив ра