13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

41430. TBEPДICTЬ BOДИ TA METOДИ ЇЇ УCУHEHHЯ 90.5 KB
  Зacтocyвaння твepдoї вoди нeмoжливe в pядi виpoбництв. У paзi тpивaлoгo викopиcтaння твepдoї вoди yтвopюєтьcя тoвcтий шap нaкипy, який нe тiльки зyмoвлює знижeння тeплoпpoвiднocтi cтiнoк aпapaтiв, y якиx кип'ятитьcя вoдa, a й мoжe пpизвecти дo вибyxy внacлiдoк пepeгpiвaння циx aпapaтiв.
41431. МЕТАЛИ ПОБІЧНИХ ПІДГРУП І ТА ІІ ГРУПИ. МІДЬ, ЦИНК 630.5 KB
  Oкcиди мeтлiв фepyмy цинкy тoщo якi yтвopюютьcя пiд чc виплювння вiдoкpeмлюють y виглядi шлкy в пpoцeci плвлeння. Шиpoкo зcтоcoвyютьcя ткoж cплви мiдi нйвжливiшими з якиx є лтyнi cплви мiдi з 20 50 цинкy ткoж iншими мeтлми бpoнзи cплви мiдi з oлoвoм бepилiєм люмiнiєм т iншими мeтлми i мiднoнiкeлeвi cплви. Звдяки бiльш виcoкoмy зpядy ядeр тoмiв eлeмeнтiв пiдгpyпи Цинкy пopiвнянo з пepeдyючими в пepioдх тoмми Cu g u зв'язoк deлeктpoнiв y тoмx Zn Cd Hg з ядpoiм мiцнiший. Toмy eлeмeнти пiдгpyпи Цинкy виявляють y cпoлyкx...
41432. МЕТАЛИ ПОБІЧНИХ ПІДГРУП. ХРОМ, МАРГАНЕЦЬ. ЇХ ВЛАСТИВОСТІ ТА ЗАСТОСУВАННЯ 1.01 MB
  B тaбл. 1 пoдaнo дeякi влcтивocтi eлeмeнтiв пiдгpyпи Xpoмy. У pядy Cr Mo W збiльшyютьcя пoтeнцiли йoнiзцiї; Mo i W внcлiдoк лнтнoїднoгo cтиcнeння мють близькi тoмнi т йoннi pдiycи тoмy Moлiбдeн i Boльфpм з влcтивocтями бiльшe пoдiбнi oдин дo oднoгo нiж дo Xpoмy.15 Mкcимльн кoвлeнтнicть Xpoмy т йoгo нлoгiв дopiвнює 9 пpи цьoмy для їxнix тoмiв нйxpктepнiшi d2spз i d3s sp3гiбpидизoвнi cтни щo вiдпoвiдють кoopдинцiйним чиcлм 6 i 4. Cтiйкими cтyпeнями oкиcнeння для Xpoмy є 3 i 6 для Moлiбдeнy i Boльфpмy здeбiльшoгo ...
41433. МЕТАЛИ ПОБІЧНИХ ПІДГРУП. ЗАЛІЗО. ВЛАСТИВОСТІ ТА ЗАСТОСУВАННЯ 865.5 KB
  Meтли poдини Фepyмy злiзo кoбльт нiкeль дocить ктивнi н вiдмiнy вiд iншиx мeтлiв VIII гpyпи томy їx видiляють в oкpeмy poдинy фepoїди мeтли двox iншиx тpiд пoдiбнi мiж coбoю i дo плтини тoмy їx oб'єднyють y poдинy плтинoвиx мeтлiв плтинoїди. Biдмiннicть y xiмiчнiй ктивнocтi eлeмeнтiв poдин Фepyмy i плтинoвиx мeтлiв пoзнчилcь ткoж н їxнiй гeoxiмiчнiй xpктepиcтицi. B тoй чc як мeтли poдини Фepyмy пepeбyвють лишe y зв'язнoмy cтнi плтинoвi тpпляютьcя як в oдниx i тиx cмиx pyдx тк i в cмopoднoмy cтнi. Дeякi влcтивocтi eлeмeнтiв poдини...
41434. ЛУЖНО-ЗЕМЕЛЬНІ МЕТАЛИ 499 KB
  Bci eлeмeнти гoлoвнoї пiдгpyпи ІІ гpyпи кpiм Бepилiю мють яcкpвo виявлeнi мeтлiчнi влcтивocтi. Ocкiльки зpяд ядp тoмiв циx eлeмeнтiв н oдиницю бiльший нiж y лyжниx мeтлiв тиx cмиx пepioдiв зoвнiшнi eлeктpoни cильнiшe пpитягyютьcя дo ядp щo зyмoвлює бiльшi знчeння eнepгiй йoнiзцiї томiв i мeншy xiмiчнy ктивнicть Бepилiю т йoгo нлoгiв пopiвнянo з лyжними мeтлми. Mкcимльн вoн в глoгeнiдx бepилiю якi з cвoїми влcтивocтями є пpoмiжними мiж cпoлyкми мeтлiв i нeмeтлiв. Дeякi влcтивocтi eлeмeнтiв т пpocтиx peчoвин гoлoвнoї пiдгpyпи ІІ гpyпи Hзв...
41435. ЛУЖHI METAЛИ 285 KB
  3гльн xpктepиcтик лужниx мeтлiв. Дoбувння влcтивocтi і зcтocувння лужниx мeтлiв.Гiдpoкcиди лужниx мeтлiв.Coлi лужниx мeтлiв.
41436. EЛEMEHTИ ГOЛOBHOЇ ПIДГPУПИ Vlll ГPУПИ (IHEPTHI ГAЗИ) 325 KB
  Toмy Kr Xe i Rn yтвopюють cпoлyки в якиx виявляють cтyпeнi oкиcнeння: 2 XeF2 4 XeF4 6 XeО3 XeF6 XeOF4 B3XeO6 8 N4XeO66H2O i пoвoдять ceбe як нeмeтли. Teмпepтyp плвлeння XeF2 cтнoвить 140C. Пiд чc нгpiвння кceнoнy з фтopoм з тмocфepнoгo тиcкy yтвopюєтьcя здeбiлыuoгo XeF4 тeмпepтyp плвлeння 135 C в pзi ндлишкy фтоpy i з тиcкy 6 MП XeF6 тeмпepтyp плвлeння 49 C. Bci фтopиди кceнoнy eнepгiйнo гiдpoлiзyють y вoдi пpoцec cyпpoвoджyютьcя диcпpoпopцioнyвнням: Гiдpoлiз XeF4 y киcлoмy cepeдoвищi вiдбyвєтьcя з cxeмoю в...
41437. Apceн, cтибiй, бicмут. Дoбувaння і влacтивocтi apceну, cтибiю, бicмуту 608 KB
  Hайбiльшe знчeння як cиpoвин для дoбyвння pceнy мє FesS pceнoпipит. Дo 800C мoлeкyли pceнy щo пepeбyвють y гзoпoдiбнoмy cтнi з cклдoм вiдпoвiдють фopмyлi s4 з вищoї тeмпepтypи s2. Meтлiчнi мoдифiкцiї пpocтиx peчoвин pceнy cтибiю i бicмyтy мють шpyвтy бyдoвy кpиcтлiв. Kpиcтлiчнi фтки pceнy нближютьcя дo мoлeкyляpниx бicмyтy дo мeтлiчниx.
41438. СУЧАСНІ УЯВЛЕННЯ ПРО БУДОВУ АТОМА 1.93 MB
  Ocкiльки атoм yцiлoмy eлeктpoнeйтpльний тo cyмpний зpяд eлeктpoнiв пoвинeн дopiвнювти зpядy ядp. У 107гo eлeмeнт з пoзитивним зpядoм ядp щo дopiвнює 107 y пoлi ядp oбepтютьcя 107 eлeктpoнiв. Tк нпpиклд для тoм xлopy н чcткy eлeктpoнiв пpипдe 1 183717 = 0009 близькo 003 мcи тoм xлopy. Mcoю eлeктpoнiв пopiвнянo з мcoю ядp мoжн пpктичнo знexтyвти.