13480

Организация непериодических регистров сведений

Лабораторная работа

Информатика, кибернетика и программирование

Регистры сведений Лабораторная работа Задача 1. Организация непериодических регистров сведений. Пусть в организации имеется несколько филиалов каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственно

Русский

2013-05-11

163 KB

2 чел.

Регистры сведений

Лабораторная работа

Задача 1. Организация непериодических регистров сведений.

Пусть в организации имеется несколько филиалов, каждый из которых включает несколько подразделений. В каждом конкретном подразделении филиала определено ответственное лицо.

Филиал

Подразделение

Ответственный за поставки

Окский

1

Петров Л.В.

Окский

2

Иванов О.В.

Волжский

1

Сидорова О.М.

Волжский

3

Николаев Л.Т.

Комбинация названия филиала и номера подразделения является уникальной.

1. Создайте базу МояБаза2 и откройте в режиме конфигуратора.

2. Создайте перечисление Филиалы и занесите информацию о названиях филиалов: Окский, Волжский и Центральный.

3. Создайте справочник Сотрудники без дополнительных реквизитов и в режиме 1С:Предпиятие внесите в него несколько фамилий. После завершения работы вернитесь в окно конфигуратора.

4. В окне Конфигурация щелкните правой кнопкой мыши на Регистры сведений и выберите пункт Добавить в контекстном меню. Заполните появившееся окно информацией:

Непериодический – означает, что время в качестве вспомогательного аргумента использоваться не будет. Независимый – возможность записи информации напрямую в регистр сведений.

5. Перейдите на закладку Данные. Укажите измерение Филиал (тип – Перечисление.Ссылка.Филиалы), измерение Подразделение (тип данных – число), ресурс Ответственный (тип – СправочникСсылка.Сотрудники).

6. Перейдите в режим 1С:Предприятие в внесите несколько записей. После этого вернитесь в окно конфигуратора.

Задача 2. Создание справочника Номенклатура.

1. Создайте справочник Номенклатура.

2. После создания справочника перейдите в режим 1С:Предприятие и внесите несколько товаров. Затем вернитесь в окно конфигуратора.

3. Создайте документ Поступление:

Типы данных реквизитов: Филиал – ПеречислениеСсылка.Филиалы; Подразделение – Число; Ответственный – СправочникСсылка.Сотрудники. В табличной части документа выполните установки: Название – СправочникСсылка.Номенклатура; Цена – Число; Количество – Число; Сумма – Число.

4. Для размещения процедур создадим форму документа

5. Обеспечьте заполнение поля Ответственный после выбора филиала и подразделения в документе Поступление. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

7. В окне свойств поля Подразделение воспользуйтесь событием ПриИзменении:

Процедура ПодразделениеПриИзменении(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ *

|ИЗ РегистрСведений.ОтветственныеЛица

|ГДЕ Филиал=&Филиал И

|Подразделение = &Подразделение";

Запрос.УстановитьПараметр("Филиал", ЭлементыФормы.Филиал.Значение);

Запрос.УстановитьПараметр("Подразделение", ЭлементыФормы.Подразделение.Значение);

Результат = Запрос.Выполнить().Выбрать();

Если Результат.Следующий()>0 Тогда

 ЭлементыФормы.Ответственный.Значение = Результат.Ответственный;

КонецЕсли;

КонецПроцедуры

8. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.

Задача 3. Создание периодического регистра сведений Цены.

Периодический регистр сведений обладает способностью хранить информацию в привязке ко времени.

В регистре сведений находятся и актуальные (последние) значения и все предшествующие.

Периодический регистр сведений содержит поле Период, добавляемое автоматически. Тип данных этого поля – Дата, оно предназначено для соотнесения конкретной записи с определенным периодом. Когда производится запись в регистр, автоматически осуществляется ее привязка к началу периода, в который она попадает.

Система контролирует уникальность записи в периодический регистр сведений. При этом ключом записи является совокупность значений измерений регистра и периода.

1. Создадим периодический регистр сведений Цены. ПериодичностьВ пределах секунды.

2. Перейдите на закладку Данные и создайте измерение Номенклатура (тип данных – СправочникСсылка.Номенклатура), затем создайте ресурс Цена (тип данных – Число).

3. Перейдите в режим 1С:Предприятие и внесите несколько записей. После этого вернитесь в окно конфигуратора.

4. В документе Поступление после выбора товара обеспечим автоматическую подстановку цены на указанную дату. Для этого в форме документа Поступление выполните двойной щелчок в поле Название. Перейдите к обработке события ПриИзменении и напишите текст процедуры:

Процедура ПереченьНазваниеПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

ОтборЦены = Новый Структура("Номенклатура", Товар.Название);

ЗначениеРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(Дата, ОтборЦены);

Товар.Цена = ЗначениеРесурсов.Цена;

КонецПроцедуры

5. Процедура вносит правильное значение цены на дату документа. После этого в форме документа необходимо ввести количество. При этом сумма должна рассчитываться автоматически. Для этого в поле количество оформите процедуру ПриИзменении:

Процедура ПереченьКоличествоПриИзменении(Элемент)

Товар = ЭлементыФормы.Перечень.ТекущиеДанные;

Товар.Сумма = Товар.Цена * Товар.Количество;

КонецПроцедуры

6. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. После этого вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

39543. Вибір варіанту розвитку мережі 110/35 кВ Красноармійського району в зв’язку з будівництвом тваринницького комплексу по відгодівлі свиней і підстанції АПК 8.71 MB
  В роботі на підставі аналізу режимів зроблений висновок про неможливість використання варіанту підключення ПС АПК до мережі 35 кВ, який запропонований ООО «Донецкэнергосетьпроект». Дане техніко-економічне обґрунтування варіанту приєднання нової підстанції до лінії 35 кВ, яка пов’язує ПС Новоекономічна 35 Воздвіженовка 35. Виконаний економічний аналіз проекту.
39544. Рекомендации по совершенствованию системы мотивации персонала ООО «ИнтерПроф» 21.4 MB
  Актуальность мотивации в современных условиях обусловлена тем что: 1 персонал является основным капиталом любого предприятия; 2 необходима реализация потенциала работников; 3 изменение условий производства появление новых технологий а также требований к качеству продукции требуют работников нового типа; 4 происходит изменение качественного содержания потребностей работников. Мотивация представляет собой процесс побуждения себя и других к деятельности для достижения личных целей и целей предприятия система действий работодателя по...
39545. Анализ ассортимента и качества игрушек (на примере OAO «Детский Мир-Центр») 223.5 KB
  Можно сказать что игрушки появились одновременно с появлением человека. Надо было както занимать детей в первобытном племени – и их мамы давали им всякие камушки деревяшки необычной формы – это и были первые игрушки. Игрушки и игры на всех этапах развития общества отражали в своеобразной форме материальную и духовную жизнь людей. Поэтому игрушки должны служить средством познания мира ребенком воспитывать патриотизм любовь к труду рождать мечту развивать мысль.
39546. Проектируемое предприятие общественного питания в г. Саратове 7.93 MB
  Каждый человек в среднем ежегодно тратит на быструю еду более полутора тысяч рублей. рублей в год.4 Расчет и подбор механического оборудования Наиболее характерным механическим оборудованием используемым в цехе является мясорубка и овощерезка. Фактическую продолжительность работы tфакт определяем по формуле: tфакт=Q G Коэффициент использования ηфакт определяется по формуле: ηфакт=tф Т Подбор мясорубки.
39547. Анализ состояния малого предпринимательства в нижегодской области 776 KB
  Теоретические основы и развитие государственной поддержки малого предпринимательства. Роль малого предпринимательства в экономике. Понятие и сущность малого предпринимательства. Основы государственной поддержки малого предпринимательства.
39548. Расчет и проектирование Локальной Вычислительной Сети для организации «Подольский совет ветеранов» 1.83 MB
  В связи с техническим прогрессом, и необходимости минимизации бумажного документооборота, организациям как государственным так и коммерческим, необходим более функциональный и надежный вид ведения документации, и своевременность получения необходимой информации в короткие сроки для улучшения качества выполняемой работы и достижения максимального результата. Для этого в каждой организации используется Локальная вычислительная сеть.
39549. Динамика вариабельности сердечного ритма у одних и тех же студентов, занимающихся силовыми нагрузками в тренажерном зале на протяжении двух лет (до и после учебного занятия) 245.5 KB
  Ведь именно изменения параметров ритма сердца отражают адаптивные возможности регуляторных систем организма и динамику их развития. Состояние механизмов регуляции сегодня изучают с помощью математического анализа ритма сердца [21]. Математический анализ ритма сердца является достаточно информативным методом для изучения самых разнообразных стрессовых реакций организма [4].
39550. Методические основы проектирования интерьера учебного помещения на факультете технологии и предпринимательства 1.57 MB
  Влияние цвета света формы в интерьере на психику человека. При этом визуальная среда с которой человек соприкасается каждый день представляет собой такой же экологический фактор как и упомянутые выше и имеет не меньшую степень важности для человека. определение сущности интерьера и его элементов; анализ истории развития интерьера учебных помещений; определение основных требований к организации внутреннего пространства учебных помещений; рассмотрение освещения и предпочтительных цветовых гармоний интерьера в учебном помещении; определение...
39551. Разработка компактного неодимового лазера с диодной накачкой и волоконным выходом 17.44 MB
  В рабочем теле лазера путём накачки создаётся избыточное количество атомов в верхнем энергетическом состоянии. рис1 Вынужденное испускание фотона Классическая трёхуровневая система накачки рабочей среды используется например в рубиновом лазере. Именно это делает возможным использование немонохроматического излучения в качестве накачки. Следует отметить что создать инверсию населённостей атомов хрома Cr с помощью накачки непосредственно с уровня E0 на уровень E1 нельзя.