13484

Автоматизация работы с данными

Лабораторная работа

Информатика, кибернетика и программирование

Автоматизация работы с данными Лабораторная работа Задача 1. Создание новой информационной базы. 1. Выполните Пуск Программы 1C Предприятие 8.1 Конфигуратор. 2. В появившемся окне Запуск 1С: предприятия щелкните по кнопке Добавить. 3. В появившемся окне Добавление и...

Русский

2013-05-11

591 KB

4 чел.

Автоматизация работы с данными

Лабораторная работа

Задача 1. Создание новой информационной базы.

1. Выполните Пуск|Программы|1C Предприятие 8.1|Конфигуратор.

2. В появившемся окне Запуск 1С:предприятия щелкните по кнопке Добавить.

3. В появившемся окне Добавление информационной базы/группы выберите опцию Добавление новой информационной базы и щелкните по кнопке Далее.

4. В появившемся окне Добавление информационной базы/группы выберите опцию Создание информационной базы без конфигурации и щелкните по кнопке Далее.

5. В появившемся окне Добавление информационной базы/группы в поле Укажите наименование информационной базы укажите Моя база4 и в разделе Выберите тип расположения информационной базы выберите опцию На данном компьютере или на компьютере в локальной сети и щелкните по кнопке Далее.

6. В появившемся окне Добавление информационной базы/группы в поле Каталог информационной базы укажите необходимую папку расположения и щелкните по кнопке Готово.

Задача 2. Создание перечисления ВидыЗанятий и регистра сведений Тарифы.

1. Создайте перечисление ВидыЗанятий.

2. Перейдите на закладку Данные и заполните ее по образцу:

3. Создайте независимый периодический регистр сведений Тарифы. В списке Периодичность выберите значение В пределах месяца.

4. Перейдите на закладку Данные. Укажите измерения ВидЗанятия (ПеречислениеСсылка.ВидыЗанятий) и Период, ресурс – ВеличинаТарифа (тип данных - число).

5. Перейдите в режим 1С:Предприятие т внесите в регистр сведений информацию о тарифах:

Задача 3. Создание справочников.

1. Создайте справочник Преподаватели без дополнительных реквизитов.

2. Перейдите в режим 1С:Предприятие т внесите в справочник информацию о преподавателях:

Затем вернитесь в окно конфигуратора.

3. Создайте справочник Группы с дополнительным реквизитом Количество.

4. Перейдите в режим 1С:Предприятие т внесите в справочник информацию о группах:

Затем вернитесь в окно конфигуратора.

Задача 4. Создание документа Учет.

1. Создайте документ Учет. В области шапки документа разместите дополнительный реквизит ДатаРасчета. В табличной части документа Список разместите реквизиты: Преподаватель (тип данных – СправочникСсылка.Преподаватели), Группа (тип данных – СправочникСсылка.Группы), ВидЗанятия (тип данных – ПеречислениеСсылка.ВидыЗанятий), ЧислоЧасов (тип данных – число), Тариф (тип данных - число) и Сумма (тип данных – число).

2. Создадим форму документа:

Задача 5. Создание процедур обработки событий на форме документа Учет.

1. При выборе вида занятия в поле Тариф должно автоматически проставляться значение тарифа на дату, ближайшую к дате расчета. Для этого оформите обработку события ПриИзменении для поля ВидЗанятия:

Процедура СписокВидЗанятияПриИзменении(Элемент)

ТабличнаяЧасть=ЭлементыФормы.Список.ТекущиеДанные;

СтруктураОтбора = Новый Структура;

СтруктураОтбора.Вставить("ВидЗанятия",ТабличнаяЧасть.ВидЗанятия);

Ресурс=РегистрыСведений.Тарифы.ПолучитьПоследнее(ДатаРасчета,СтруктураОтбора);

ТабличнаяЧасть.Тариф=Ресурс.ВеличинаТарифа;

КонецПроцедуры

2. После ввода количества часов необходимо осуществить расчет суммы. Для этого оформите обработку события ПриИзменении для поля ЧислоЧасов:

Процедура СписокЧислоЧасовПриИзменении(Элемент)

 ТабличнаяЧасть=ЭлементыФормы.Список.ТекущиеДанные;

 ТабличнаяЧасть.Сумма=ТабличнаяЧасть.Тариф*ТабличнаяЧасть.ЧислоЧасов;

КонецПроцедуры

3. Перейдите в режим 1С:Предприятие т внесите в справочник информацию о группах:

Затем вернитесь в окно конфигуратора.

4. При изменении даты расчета должны автоматически изменяться поля документа. Для этого оформите обработку события ПриИзменении для поля ДатаРасчета:

Процедура ДатаРасчетаПриИзменении(Элемент)

Для Каждого ТекСтрокаСписок Из Список Цикл

СтруктураОтбора = Новый Структура;

СтруктураОтбора.Вставить("ВидЗанятия",ТекСтрокаСписок.ВидЗанятия);

Ресурс=РегистрыСведений.Тарифы.ПолучитьПоследнее(ДатаРасчета,СтруктураОтбора);

ТекСтрокаСписок.Тариф=Ресурс.ВеличинаТарифа;

ТекСтрокаСписок.Сумма=ТекСтрокаСписок.Тариф*ТекСтрокаСписок.ЧислоЧасов;

КонецЦикла;

КонецПроцедуры

Задача 6. Просмотр актуальных тарифов.

1. Добавьте на форму два элемента управления – кнопку (ПоследниеТарифы) и поле списка (СрезТарифов):

2. При нажатии кнопки ПоследниеТарифы поле списка должно автоматически заполняться информацией о тарифах. Для этого оформите обработку события для кнопки ПоследниеТарифы:

Процедура ПоследниеТарифыНажатие(Элемент)

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ Срез.ВидЗанятия КАК Вид, Срез.ВеличинаТарифа КАК Величина ИЗ РегистрСведений.Тарифы.СрезПоследних(&ДатаОкончания) КАК Срез";

Запрос.УстановитьПараметр("ДатаОкончания",ЭлементыФормы.ДатаРасчета.Значение);

Результат = Запрос.Выполнить().Выбрать();

СрезТарифов.Очистить();

Пока Результат.Следующий()>0 Цикл

   СрезТарифов.Добавить(Строка(Результат.Вид)+" "+Строка(Результат.Величина)+" руб.");

КонецЦикла;

КонецПроцедуры

3. Перейдите в режим 1С:Предприятие и проверьте результаты работы:

Затем вернитесь в окно конфигуратора.

Задача 7. Создание оборотного регистра.

1. Создайте регистр накопления Начисление. Укажите Вид регистра - обороты:

2. Перейдите на закладку Данные и укажите измерение Преподаватель (тип данных – СправочникСсылка.Преподаватель) и ресурс Сумма (тип данных – число):

3. Вернитесь  в окно редактирования документа Учет и перейдите на закладку Движения. В качестве регистра накопления движений укажите Начисление.

4. Щелкните по кнопке Конструктор движений. Заполните поля по образцу и щелкните по кнопке ОК:

5. Перейдите в режим 1С:Предприятие и сформируйте несколько документов типа Учет. В результате в регистре Начисление будут сформированы соответствующие записи:

Задача 8. Создание отчета по начислению.

1. Создайте отчет ОтчетПоНачислению. На закладке Макеты воспользуйтесь конструктором выходной формы, и в качестве таблицы для построения запроса укажите Начисление.Обороты:

2. В пиктографическом меню над разделом Таблицы щелкните по пиктограмме Параметры виртуальной таблицы. В открывшемся диалоговом окне укажите параметры, определяющие начало и конец интересующего нас временного интервала:

Затем щелкните по кнопке ОК.

3. На закладке Порядок установите упорядочивание по сумме (по убыванию).

4. На закладке Отчет отключите опцию Использовать построитель отчета.

5. Перейдите на закладку Выходная форма и оформите ее по образцу:

Щелкните по кнопке ОК.

6. Перейдите в режим 1С:Предприятие. В разделе Отчеты обратитесь к нужному отчету и в открывшемся окне щелкните по кнопке Сформировать (предварительно необходимо задать интервал дат).

Задача 9. Реализация множественного выбора.

Обеспечим пользователю возможность выбора нескольких преподавателей при заполнении документа Учет. При этом все выбранные преподаватели должны добавляться в табличную часть документа.

1. Добавьте в форму документа Учет кнопку ПодборПреподавателей:

2. Перейдите на закладку Модуль и оформите текст процедуры:

Процедура ПодборПреподавателейНажатие(Элемент)

Форма = Справочники.Преподаватели.ПолучитьФормуСписка(,ЭлементыФормы.Список);

Форма.РежимВыбора=Истина;

Форма.МножественныйВыбор=Истина;

Форма.Открыть();

КонецПроцедуры

3. Откройте окно свойств табличной части Список. Щелкните по кнопке напротив события Обработка выбора и оформите текст процедуры:

Процедура СписокОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)

Для Счетчик = 0 По ВыбранноеЗначение.ВГраница() Цикл

 Строка = Список.Добавить();

 Строка.Преподаватель = ВыбранноеЗначение[Счетчик];

КонецЦикла;

КонецПроцедуры

4. Перейдите в режим 1С:Предприятие и проверьте результаты работы. Затем вернитесь в окно конфигуратора.

Задача 10. Создание сводной таблицы с использованием системы компоновки данных.

1. Создайте отчет СводнаяТаблица. С помощью кнопки Открыть схему компоновки данных перейдите к формированию схемы компоновки данных и создайте новый набор данных (Добавить набор данных – запрос):

2. Щелкните по кнопке Конструктор Запроса. В раздел Таблицы перенесите табличную часть Список документа Учет. В список полей включите поля: Преподаватель, Группа, ЧислоЧасов:

3. Перейдите на закладку Группировка и выберите поля:

Затем щелкните по кнопке ОК.

4. Перейдите на закладку Ресурсы и выберите доступный ресурс:

5. Перейдите на закладку Формы и создайте основную форму отчета.

6. В меню Таблица выберите пункт Вид и исключите режим Только просмотр.

7. Установите курсор в верхнюю левую ячейку табличного документа и в меню Таблица выберите пункт Встроенные таблицы. А затем Вставить сводную таблицу:

8. Откройте модуль формы отчета и добавьте переменную:

9. Создайте обработчик события формы отчета ПриОткрытии. Для этого в окне свойств формы щелкните по кнопке напротив события ПриОткрытии. Затем напишите текст процедуры:

Процедура ПриОткрытии()

ИнформацияПоНагрузке=Новый ИсточникДанныхСводнойТаблицыКомпоновкиДанных;

ИнформацияПоНагрузке.УстановитьСхему(СхемаКомпоновкиДанных);

ЭлементыФормы.Результат.ВстроенныеТаблицы.СводнаяТаблица1.ИсточникДанных=ИнформацияПоНагрузке;

ИнформацияПоНагрузке.УстановитьНастройки(КомпоновщикНастроек.Настройки);

КонецПроцедуры

10. Перейдите в режим 1С:Предприятие и откройте разработанный отчет:

11. Перетащите необходимые поля в области сводной таблицы. В результате будет сформирован отчет:

Задача 11. Создание сводной таблицы с использованием конструктора.

1. Создайте отчет СводнаяТаблица2.

2. Перейдите на закладку Макеты и воспользуйтесь кнопкой Конструкторы. Выберите Конструктор выходной формы.

3. В разделе База данных выберите таблицу Список документа Учет и перенесите ее в раздел Таблицы. В раздел Поля добавьте ЧислоЧасов, Преподаватель и Группа.

4. Перейдите на закладку Итоги и определите группировочное и итоговое поля:

5. Перейдите на закладку Отчет и включите опцию сводную таблицу в разделе Выводить отчет в.

Щелкните по кнопке ОК.

6. Перейдите в режим 1С:Предприятие и выберите отчет СводнаяТаблица2:

7. Щелкните по кнопке Сформировать. Затем с помощью контекстного меню перенесите поля сводной таблицы на форму:

Задача 12. Передача данных между приложениями. Использование COM-технологии

COM-технологияэто информационная модель, которая представляет собой технологию создания программ, использующих набор определенным образом взаимодействующих компонентов, которые состоят из объектов.

1. Создайте рабочую книгу MS Excel:

2. Сохраните созданную книгу с именем Преподаватели.xls.

3. Перейдите в окно конфигуратора и на форме справочника Преподаватели расположите кнопку Передать (для передачи сведений из книги в справочник).

4. Затем перейдите на закладку Модуль и оформите текст процедуры:

Процедура ПередатьНажатие(Элемент)

ConExcel = ПолучитьCOMОбъект("C:\Преподаватели.xls");

Спр = Справочники.Преподаватели;

i = 1;

Пока СтрДлина(ConExcel.Sheets(1).Cells(i,1).Value)>0 Цикл

 НовыйЭлемент = Спр.СоздатьЭлемент();

 НовыйЭлемент.Наименование = ConExcel.Sheets(1).Cells(i,1).Value;

 НовыйЭлемент.Записать();

 i = i + 1;

КонецЦикла;

КонецПроцедуры

5. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. Затем вернитесь в окно конфигуратора.

Задача 13. Передача данных между приложениями. Использование технологии OLE Automation

Пользователю предоставляется возможность работать с составными объектами, созданными в других приложениях.

Объект OLE – это объект, созданный в другом приложении, но при этом сохранивший связь с текущим приложением.

Контейнер OLE – это приложение, в котором создается документ, содержащий OLE-объект. В этом случае при необходимости работы с OLE-объектом открывается исходное приложение.

Это приложение – сервер-OLE.

1. Создайте рабочую книгу MS Excel:

2. Сохраните созданную книгу с именем Дисциплины.xls.

3. Перейдите в окно конфигуратора и создайте справочник Дисциплины. Кроме обязательных реквизитов добавьте еще два: Лекции (тип данных – число) и Практика (тип данных – число).

4. На форме справочника Дисциплины расположите кнопку Передать (для передачи сведений из справочника в книгу).

4. Затем перейдите на закладку Модуль и оформите текст процедуры:

Процедура ПередатьНажатие(Элемент)

AppExcel = Новый COMОбъект("Excel.Application");

AppExcel.Visible = Истина;

AppExcel.Workbooks.Open("C:\Дисциплины.xls");

Спр = Справочники.Дисциплины;

i = 2;

Выборка = Спр.Выбрать();

Пока Выборка.Следующий()>0 Цикл

 AppExcel.Sheets(1).Cells(i,1).Value = Выборка.Наименование;

 AppExcel.Sheets(1).Cells(i,2).Value = Выборка.Лекции;

 AppExcel.Sheets(1).Cells(i,3).Value = Выборка.Практика;

 i = i + 1;

КонецЦикла;

КонецПроцедуры

5. Перейдите в режим 1С:Предприятие и проверьте работу процедуры. Затем вернитесь в окно конфигуратора.


 

А также другие работы, которые могут Вас заинтересовать

77969. Создание и работа со списками 80 KB
  Компонент класса TListBox представляет собой стандартный для Windows список выбора с помощью которого пользователь может выбрать один или несколько элементов выбора. В компоненте предусмотрена возможность программной прорисовки элементов поэтому список может содержать не только строки но и произвольные изображения. Если MultiSelect=Flse совпадает с индексом выделенного элемента TBorderStyle: перечисл Определяет стиль рамки: bsNone нет рамки; bssingle рамка толщиной 1 пиксель Count: Integer; Содержит количество строк в компоненте...
77971. Структура программы. Идентификаторы переменных, констант 57.5 KB
  Программы в Delphi пишутся на языке Object Pscl который является развитием языка Turbo Pscl. Программы работающие в операционных системах семейства Windows называют приложениями. Комментарий во время выполнения программы игнорируется его основное назначение – пояснения к тексту программы.
77972. екстовые файлы. Диалоги для работы с файлами, настройка цвета и шрифта 53.5 KB
  Диалоги для работы с файлами настройка цвета и шрифта. Для облегчения работы с файлами в Delphi каждый отдельный файл представляет файловая переменная. Объявления файлов переменной Файловая переменная в общем виде объявляется в разделе vr примерно так...
77973. Типизированные файлы с идентичными структурами 30.5 KB
  Типизированный файл – это файл в котором записаны идентичные структуры. Например любой файл может считать файлом байтов – т.е можно читать байт за байтом, можно перейти сразу к любому байту по его номеру, можно сразу узнать сколько байт в файле, можно заменить любой байт на другой не перезаписывая файл.
77974. Условный оператор 28 KB
  Встречаются следующие формы условного оператора: Условный оператор с одной ветвью if условие then команды end При выполнении такого оператора вычисляется условие и если оно истинно то выполняются команды до ключевого слова end в противном случае выполнение программы продолжается со следующей за условным оператором команды. Условный оператор с двумя ветвями if условие then команды else команды end Здесь при истинности условия выполняются команды при ложности команды.
77976. Компоненты ввода-вывода информации 125 KB
  Свойство IsMasked: Boolean доступно только для чтения и содержит True, если строка шаблона задана. Свойство EditText: string содержит текст до наложения на него маски шаблона (т. е. то, что ввел пользователь), а свойство Text: String может (в зависимости от шаблона см. ниже) содержать либо исходный текст, либо результат наложения на него маски шаблона.
77977. Палитра компонентов 271 KB
  Для этого используется специальный редактор окно которого появляется на экране после щелчка правой кнопкой мыши на любой пиктограмме в палитре компонентов и выбора опции properties Свойства. Окно редактора палитры компонентов Данное окно позволяет добавлять или удалять компоненты с палитры компонентов или переименовывать названия вкладок: кнопка dd позволяет добавить новую вкладку палитры компонентов; кнопка Delete предназначена для удаления вкладки палитры компонентов. На нем изображены шесть наиболее важных окон Delphi: главное...