14108

Цикл с параметрами

Конспект урока

Информатика, кибернетика и программирование

9 урок Цикл с параметрами.1 урок. Общий вид цикла для: нц для i от i1 до i2 тело_цикла кц Здесь i величина типа цел она называется параметром цикла а i1 и i2 целые выражения т. е. выражения типа цел. При выполнении цикла для тело цикла выпол няется последовательно

Русский

2013-05-21

256.5 KB

2 чел.

9 урок Цикл с параметрами.-1 урок.

Общий вид цикла для:

нц для i от i1 до i2

· тело_цикла

кц

Здесь i — величина типа цел (она называется параметром цикла), а i1 и i2 — целые

выражения, т. е. выражения типа цел. При выполнении цикла для тело цикла выпол-

няется последовательно для i = i1, i = i1 + 1, . . . , i = i2. Если i1 = i2, то тело цикла

выполнится один раз для i = i1. Если же i1 > i2, то тело цикла не выполнится ни разу.

Общий вид цикла для с шагом:

нц для i от i1 до i2 шаг i3

· тело_цикла

кц

Если шаг i3 (который также должен быть целым выражением) равен положительному

числу d, то тело цикла будет выполняться последовательно для i = i1, i = i1 + d, i =

i1 + 2d, . . . до тех пор, пока значение i удовлетворяет условию i · i2.

Если же шаг i3 отрицателен и равен −d, то тело цикла будет выполняется последова-

тельно для i = i1, i = i1 − d, i = i1 − 2d, . . . до тех пор, пока значение i удовлетворяет

условию i . i1.

  1.  Получит  10  раз  слово  «привет»

Программа                                                       Выполнение

 

  1.  Вывести  на  экран  сумму  квадратов  чисел  от 1  до 10

    

  1.  Вывести  на  экран  все  нечетные  числа  от 1  до 20

Программа                                                            Выполнение

  1.  Найти  сумму  чисел  от 1  до  10

          Программа                                                       Выполнение

     

  1.   Напечатать  таблицу  умножения  на 7

7х1=7

7х2=14

…….

7х9=63

Программа                                                    Результат

             

    

  1.   Напечатать  столбцом  значения  синусов  углов  от  а  до  б (а, б вводятся  с  клавиатуры)

              Программа                                                            Результат

                              

Для  самостоятельного  решения

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  


 

А также другие работы, которые могут Вас заинтересовать

63538. Налоги в экономической системе общества 98.5 KB
  Налог является таким образом не только финансовой категорией но и правовой признаки налога смотреть в практике. Таким образом в налогах выражается весь спектр экономических политических и социальных интересов государства и общества.
63539. Древнейшие цивилизации на территории нашей страны 1.14 MB
  Однако целых три столетия до этого имя хазар не сходило со страниц летописей разных народов и не случайно поскольку именно их держава каганат до возвышения Руси доминировала в Восточной Европе.
63540. ЭКОНОМИЧЕСКАЯ ТЕОРИЯ 98.5 KB
  Основы экономики общества и ее структура. Роль экономики в развитии общества. Цикличность рыночной экономики. Необходимость практика и перспективы экономических реформ преобразования командной экономики.
63541. ПЛАТЕЖНАЯ СИСТЕМА БАНКА РОССИИ 83 KB
  Издаваемые в форме указаний о внесении изменений и дополнений в действующие правила положения Банка России принимаемые нововведения в большинстве случаев касаются отдельных вопросов правил и не изменяют базовых принципов положенных в их основу включая подходы к терминологии структуре содержания и форме изложения.
63543. Правонарушения и юридическая ответственность 71.5 KB
  Социально-правовая активность определяется главным образом высоким уровнем правосознания сформировавшегося на основе идейной убежденности и в общественной пользе поступка осознания долга перед обществом знания прав и обязанностей профессионального чувства ответственности.