14108

Цикл с параметрами

Конспект урока

Информатика, кибернетика и программирование

9 урок Цикл с параметрами.1 урок. Общий вид цикла для: нц для i от i1 до i2 тело_цикла кц Здесь i величина типа цел она называется параметром цикла а i1 и i2 целые выражения т. е. выражения типа цел. При выполнении цикла для тело цикла выпол няется последовательно

Русский

2013-05-21

256.5 KB

2 чел.

9 урок Цикл с параметрами.-1 урок.

Общий вид цикла для:

нц для i от i1 до i2

· тело_цикла

кц

Здесь i — величина типа цел (она называется параметром цикла), а i1 и i2 — целые

выражения, т. е. выражения типа цел. При выполнении цикла для тело цикла выпол-

няется последовательно для i = i1, i = i1 + 1, . . . , i = i2. Если i1 = i2, то тело цикла

выполнится один раз для i = i1. Если же i1 > i2, то тело цикла не выполнится ни разу.

Общий вид цикла для с шагом:

нц для i от i1 до i2 шаг i3

· тело_цикла

кц

Если шаг i3 (который также должен быть целым выражением) равен положительному

числу d, то тело цикла будет выполняться последовательно для i = i1, i = i1 + d, i =

i1 + 2d, . . . до тех пор, пока значение i удовлетворяет условию i · i2.

Если же шаг i3 отрицателен и равен −d, то тело цикла будет выполняется последова-

тельно для i = i1, i = i1 − d, i = i1 − 2d, . . . до тех пор, пока значение i удовлетворяет

условию i . i1.

  1.  Получит  10  раз  слово  «привет»

Программа                                                       Выполнение

 

  1.  Вывести  на  экран  сумму  квадратов  чисел  от 1  до 10

    

  1.  Вывести  на  экран  все  нечетные  числа  от 1  до 20

Программа                                                            Выполнение

  1.  Найти  сумму  чисел  от 1  до  10

          Программа                                                       Выполнение

     

  1.   Напечатать  таблицу  умножения  на 7

7х1=7

7х2=14

…….

7х9=63

Программа                                                    Результат

             

    

  1.   Напечатать  столбцом  значения  синусов  углов  от  а  до  б (а, б вводятся  с  клавиатуры)

              Программа                                                            Результат

                              

Для  самостоятельного  решения

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  

  1.  


 

А также другие работы, которые могут Вас заинтересовать

8270. Конституційне право. Характеристика Конституції України 57.5 KB
  Конституційне право. Характеристика Конституції України. Мета: сформувати поняття «джерела конституційного права», розкрити процес прийняття Конституції України, розвивати вміння працювати з юридичними документами, складати таблиці, аналізуват...
8271. Загальна характеристика держави та державної влади 63.5 KB
  Тема: Загальна характеристика держави та державної влади. Мета: Навчити ліцеїстів основних поняттям теорії держави та влади розвивати вміння висловлювати власне ставлення до проблеми виховувати почуття правової свідомості. Обладнання: Дошка, підру...
8272. Поняття і структура правової системи 38.5 KB
  Поняття і структура правової системи. Мета: Актуалізувати знання учнів зі питань поняття і структура правової системи , поглибити їх з урахуванням вікових та індивідуальних особливостей учнів розвивати вміння аналізувати зміст понять, висловлювати ...
8273. Вступ до Основ правознавства. Історичний аспект виникнення держави 57 KB
  Тема уроку: Вступ до Основ правознавства. Історичний аспект виникнення держави. Мета уроку: Ознайомлення учнів з основними аспектами теорії держави та права. Формування правових знань в учнів: загальне розуміння правових понять, термінів здатність ...
8274. Поняття і загальна характеристика права 59.5 KB
  Тема уроку. Поняття і загальна характеристика права. Мета: Актуалізувати знання учнів зі питань загальної характеристики соціальних норм, моралі, права, поглибити їх з урахуванням вікових та індивідуальних особливостей учнів розвивати вміння аналіз...