16388

Функции в Ms Excel

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторная работа №2 Функции в Ms Excel В целом Microsoft Excel содержит около 1000 функций рабочего листа встроенных функций обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп: матема...

Русский

2013-06-20

49 KB

29 чел.

Лабораторная работа №2

Функции в Ms Excel

В целом Microsoft Excel содержит около 1000 функций рабочего листа (встроенных функций), обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп:

  1.  математические функции;
  2.  текстовые функции;
  3.  логические функции;
  4.  информационные функции;
  5.  функции ссылки и автоподстановки;
  6.  функции даты и времени;
  7.  финансовые функции;
  8.  инженерные функции;
  9.  статистические функции;
  10.  функции проверки свойств и значений;
  11.  функции DDE и внешние функции;
  12.  функции для работы со списками.

Обращение к каждой функции производится указанием её имени и следующего за ним в круглых скобках списка аргументов (параметров). Наличие круглых скобок обязательно, именно они служат признаком того, что используемое имя является именем функции. Аргументы списка разделяются точкой с запятой. Их количество не должно превышать 30, а длина формулы, содержащей сколько угодно обращений к функциям, не может превышать 1024 символов. В качестве аргументов могут использоваться константы, адреса ячеек, интервалы, выражения. Например: =СУММ(2,71; A1; B2:D10; 2*SIN($A$3))

Наличие знака равенства (=) перед формулой обязательно, иначе Excel поймет выражение не как формулу, а как текст. Большинство имён функций образовано буквами русского алфавита и имеет определённую смысловую нагрузку, понятную всем (=СУММ() – возвращает сумму своих аргументов).

Все функции вы можете посмотреть в меню Вставка – функция или нажать на кнопку Вставка функции  в начале строки формул. Рассмотрим краткое описание некоторых математических и логических функций.

Математические функции

  1.  ABS(число) – возвращает модуль (абсолютную величину) числа.
  2.  COS(число) – возвращает косинус заданного угла.
  3.  LN(число) – возвращает натуральный логарифм числа. Натуральный логарифм – это логарифм по основанию e (2,71828182845904).
  4.  LOG(число; основание) – возвращает логарифм числа по заданному основанию.
  5.  SIN(число) – возвращает синус заданного угла.
  6.  TAN(число) – возвращает тангенс заданного угла.
  7.  КОРЕНЬ(число) – возвращает положительное значение квадратного корня.
  8.  ОКРУГЛ(число; число_разрядов) – округляет число до указанного количества десятичных разрядов.
  9.  ОТБР(число; число_разрядов) – усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.
  10.  ПРОИЗВЕД(число1; число2; ...) – перемножает числа, заданные в качестве аргументов, и возвращает их произведение.
  11.  СЛЧИС( ) – возвращает равномерно распределенное случайное число, большее либо равное 0 и меньшее 1. Новое случайное число возвращается каждый раз, когда рабочий лист перевычисляется.
  12.  СТЕПЕНЬ(число; степень) – возвращает результат возведения в степень.
  13.  СУММ(число1; число2; ...) – суммирует все числа в интервале ячеек.
  14.  СУММКВ(число1; число2; ...) – возвращает сумму квадратов аргументов.
  15.  СУММПРОИЗВ(массив1; массив2; массив3; ...) – перемножает соответствующие элементы заданных массивов и возвращает сумму произведений.
  16.  СЧЁТ(значение1; значение2;…) – подсчитывает количество чисел в списке аргументов.

Логические функции

  1.  И(логическое_значение1; логическое_значение2; ...) – возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.
  2.  ИЛИ(логическое_значение1; логическое_значение2; ...) – возвращает ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА; возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.
  3.  НЕ(логическое_значение) – меняет на противоположное логическое значение своего аргумента. Функция НЕ используется в тех случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.
  4.  ЕСЛИ(лог_выражение; значение_если_истина; значение_если_ложь) – возвращает значение_если_истина, если заданное условие при вычислении дает значение ИСТИНА, и значение_если_ложь в противном случае.

Задание. Записать формулы в ЭТ для математических выражений:

Вставка – Функция - Математическая

75х; Sin(x); x3; 3Cos(x2); 4Sin2 (x); ; ; Log23x

Пример1: Заполнить массив случайными числами, округлить их до десятичных чисел. Выбрать максимальный и минимальный элемент массива, найти среднее значение всех величин и их сумму.

Решение: Для заполнения и округления используем функции =ОТБР(СЛЧИС()*3+1;1). Умножаем на 3 и прибавляем 1 для того чтобы числа были больше 1. Соответствующие ячейки подписываем и вставляем нужные нам функции, выделяя при этом весь массив.

 Пример2: У трех студентов за семестр набрано 45, 75 и 90 баллов по рейтинговой системе оценок. Максимальное количество баллов, которое они могли набрать в течение семестра 90 баллов. Подсчитать рейтинг каждого студента в процентах и определить можно ли им поставить зачет. Зачет ставится если рейтинг больше 60%.

Решение: Заполняем таблицу известными данными. Подсчитать рейтинг каждого студента в процентах по формуле(кол-во_баллов/макс_балл * 100) Затем используем функцию ЕСЛИ.

Задача 1: Известны оценки по информатике каждого из 15 студентов. Определить количество пятерок. Дана таблица успеваемости по информатике. Для решения этой задачи используйте функцию СЧЁТЕСЛИ. Она подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию.

Задача 2: Определить в какой день недели началась Великая Отечественная война. Используйте функцию ДАТА и ВРЕМЯ – ДЕНЬНЕД. У этой функции 2 аргумента: Дата_в_числовом_формате и Тип. В первое поле занесите дату начала ВОВ, т.е. номер ячейки, где она прописана. Во второе поле – тип. Укажите тип номер 2.

Задача 3: Определить сколько дней продолжалась Великая Отечественная война.

Используйте функцию ДАТА и ВРЕМЯ - ДАТА360. У этой функции 3 аргумента: Нач_дата, Кон_дата, Метод. Вам нужно заполнить только 1 и 2 поле. Поле метод не заполнять.

 Задача 4: Дана таблица целых чисел (6х6). Определить, сколько из них оканчиваются нулем. Для начала определим для каждого из чисел оканчивается оно на 0 или нет, записав формулу: =ЕСЛИ(ОСТАТ(ячейка;10)=0;”да”;”нет”). Растягиваем эту формулу на все ячейки. Затем для определения количества чисел, оканчивающихся на 0, в ячейку вписываем формулу: =СЧЁТЕСЛИ(блок ячеек;”да”).


 

А также другие работы, которые могут Вас заинтересовать

48259. Ідейно-теоретичні концепції свободи преси 892.5 KB
  Основні принципи авторитаризму – контроль регламентація та використання засобів масової комунікації. У цих рисах німецька нацистська журналістика дуже схожа з радянською тоталітарною системою масової комунікації тому її можна визначити як перехідну модель журналістики між авторитарною та тоталітарною системами журналістики. Саме суди визначають межі втручання влади у сферу масової комунікації. Тут не вистачає специфіки комунікації як творчого процесу бо з одного боку визначення надто широке телевізор телефон наприклад теж можна...
48260. Феномен університетської освіти у історичному вимірі 945.5 KB
  В XI столітті XII столітті були засновані: Болонський університет 1088 Болонський університет найстаріший університет Європи в місті Болонья Північна Італія заснований в 1088 році як юридичний навчальний заклад. Заснований Університет Історія 9 століття Салерно Італія Медичний факультет; статус університету під сумнівом кінець 11 століття Болонья Італія Точна дата заснування не відома; офіційний рік заснування 1088; В кінці 11 століття існувала школа права; поступовий розвиток в університет 13 століття Заснований Університет...
48261. Літературознавство як наука 224 KB
  Автор будьякого художнього твору завжди репрезентує певний культурний прошарок своєї доби спостерігаючи яку беручи участь в її житті він водночас представляє певний ідеологічний або політичний напрям. Щоб розібратися в задумі письменника в політичній спрямованості його твору чи творчості треба знати основні факти біографії митця його зв'язки з іншими людьми участь у політичному і громадському житті. Вужчим за науковим обсягом вважаються так звані допоміжні галузі літературознавства – бібліографія археологія текстологія методика...
48262. Уголовно-процессуальное право 108.76 KB
  Структурно уголовно-процессуальное право распадается на части; Общую и Особенную. Деление это носит двойственный характер. С одной стороны, оно отражает специфику структуры Уголовно-процессуального кодекса, что уже понятия уголовно-процессуального права. С другой стороны, такая дифференциация оправдана методологически.
48264. ПРЕДМЕТ І ЗАВДАННЯ ЕПІЗООТОЛОГІЇ 4.42 MB
  Епізоотологія наука яка вивчає об'єктивні закономірності процесів виникнення розвитку поширення і згасання інфекційних хвороб тварин та на основі пізнання загальних закономірностей а також сучасних даних суміжних наук розробляє раціональні заходи профілактики і ліквідації епізоотій. Назва науки Епізоотологія як вчення про заразні захворювання сільськогосподарських і диких тварин птахів риб бджіл складається з трьох грецьких слів: ері на zoon тварина і logos вчення. Тобто мова йде про значне ураження тварин...
48265. Редагування як вид професійної діяльності і складова редакційно-видавничого процесу 256 KB
  Редагування як вид професійної діяльності і складова редакційновидавничого процесу. План Предмет і завдання курсу Загальне редагування. Зміст поняття редагування.
48266. ЕКОНОМІЧНА ІНФОРМАЦІЯ І ЗАСОБИ ЇЇ ФОРМАЛІЗОВАНОГО ОПИСУ 186 KB
  ЕКОНОМІЧНА ІНФОРМАЦІЯ І ЗАСОБИ ЇЇ ФОРМАЛІЗОВАНОГО ОПИСУ Економiчна інформація ЕКІ – це послiдовнiсть повiдомлень економiчного змiсту що можуть бути введенi вiдображенi збереженi обробленi переданi та загалом використанi для прийняття управлiнських рiшень на рiвнi окремих установ чи структурних одиниць так i економiки в цiлому. Економiчна інформація ЕКІ один з найбiльш масових рiзновидiв iнформацiї що вiдображає процеси виробництва розподiлу обмiну i споживання матерiальних благ та послуг. Види ЕКІ Вiдповiдно до виконуваних...
48267. Бюджетний механізм, його призначення та структура, роль в регулюванні соціально-економічних процесів у державі 45 KB
  Бюджетний механізм його призначення та структура роль в регулюванні соціальноекономічних процесів у державі. Бюджетний механізм може бути охарактеризований як комплекс спеціально розроблених і законодавчо закріплених у державі форм і методів створення і використання фінансових ресурсів для регулювання економічних і соціальних процесів. В економічній літературі відсутня єдина думка щодо визначення поняття фінансовий механізм . У працях провідних західних учених фінансовий механізм не вивчається як окремий об'єкт але всебічно досліджуються...