16388

Функции в Ms Excel

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторная работа №2 Функции в Ms Excel В целом Microsoft Excel содержит около 1000 функций рабочего листа встроенных функций обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп: матема...

Русский

2013-06-20

49 KB

27 чел.

Лабораторная работа №2

Функции в Ms Excel

В целом Microsoft Excel содержит около 1000 функций рабочего листа (встроенных функций), обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп:

  1.  математические функции;
  2.  текстовые функции;
  3.  логические функции;
  4.  информационные функции;
  5.  функции ссылки и автоподстановки;
  6.  функции даты и времени;
  7.  финансовые функции;
  8.  инженерные функции;
  9.  статистические функции;
  10.  функции проверки свойств и значений;
  11.  функции DDE и внешние функции;
  12.  функции для работы со списками.

Обращение к каждой функции производится указанием её имени и следующего за ним в круглых скобках списка аргументов (параметров). Наличие круглых скобок обязательно, именно они служат признаком того, что используемое имя является именем функции. Аргументы списка разделяются точкой с запятой. Их количество не должно превышать 30, а длина формулы, содержащей сколько угодно обращений к функциям, не может превышать 1024 символов. В качестве аргументов могут использоваться константы, адреса ячеек, интервалы, выражения. Например: =СУММ(2,71; A1; B2:D10; 2*SIN($A$3))

Наличие знака равенства (=) перед формулой обязательно, иначе Excel поймет выражение не как формулу, а как текст. Большинство имён функций образовано буквами русского алфавита и имеет определённую смысловую нагрузку, понятную всем (=СУММ() – возвращает сумму своих аргументов).

Все функции вы можете посмотреть в меню Вставка – функция или нажать на кнопку Вставка функции  в начале строки формул. Рассмотрим краткое описание некоторых математических и логических функций.

Математические функции

  1.  ABS(число) – возвращает модуль (абсолютную величину) числа.
  2.  COS(число) – возвращает косинус заданного угла.
  3.  LN(число) – возвращает натуральный логарифм числа. Натуральный логарифм – это логарифм по основанию e (2,71828182845904).
  4.  LOG(число; основание) – возвращает логарифм числа по заданному основанию.
  5.  SIN(число) – возвращает синус заданного угла.
  6.  TAN(число) – возвращает тангенс заданного угла.
  7.  КОРЕНЬ(число) – возвращает положительное значение квадратного корня.
  8.  ОКРУГЛ(число; число_разрядов) – округляет число до указанного количества десятичных разрядов.
  9.  ОТБР(число; число_разрядов) – усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.
  10.  ПРОИЗВЕД(число1; число2; ...) – перемножает числа, заданные в качестве аргументов, и возвращает их произведение.
  11.  СЛЧИС( ) – возвращает равномерно распределенное случайное число, большее либо равное 0 и меньшее 1. Новое случайное число возвращается каждый раз, когда рабочий лист перевычисляется.
  12.  СТЕПЕНЬ(число; степень) – возвращает результат возведения в степень.
  13.  СУММ(число1; число2; ...) – суммирует все числа в интервале ячеек.
  14.  СУММКВ(число1; число2; ...) – возвращает сумму квадратов аргументов.
  15.  СУММПРОИЗВ(массив1; массив2; массив3; ...) – перемножает соответствующие элементы заданных массивов и возвращает сумму произведений.
  16.  СЧЁТ(значение1; значение2;…) – подсчитывает количество чисел в списке аргументов.

Логические функции

  1.  И(логическое_значение1; логическое_значение2; ...) – возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.
  2.  ИЛИ(логическое_значение1; логическое_значение2; ...) – возвращает ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА; возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.
  3.  НЕ(логическое_значение) – меняет на противоположное логическое значение своего аргумента. Функция НЕ используется в тех случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.
  4.  ЕСЛИ(лог_выражение; значение_если_истина; значение_если_ложь) – возвращает значение_если_истина, если заданное условие при вычислении дает значение ИСТИНА, и значение_если_ложь в противном случае.

Задание. Записать формулы в ЭТ для математических выражений:

Вставка – Функция - Математическая

75х; Sin(x); x3; 3Cos(x2); 4Sin2 (x); ; ; Log23x

Пример1: Заполнить массив случайными числами, округлить их до десятичных чисел. Выбрать максимальный и минимальный элемент массива, найти среднее значение всех величин и их сумму.

Решение: Для заполнения и округления используем функции =ОТБР(СЛЧИС()*3+1;1). Умножаем на 3 и прибавляем 1 для того чтобы числа были больше 1. Соответствующие ячейки подписываем и вставляем нужные нам функции, выделяя при этом весь массив.

 Пример2: У трех студентов за семестр набрано 45, 75 и 90 баллов по рейтинговой системе оценок. Максимальное количество баллов, которое они могли набрать в течение семестра 90 баллов. Подсчитать рейтинг каждого студента в процентах и определить можно ли им поставить зачет. Зачет ставится если рейтинг больше 60%.

Решение: Заполняем таблицу известными данными. Подсчитать рейтинг каждого студента в процентах по формуле(кол-во_баллов/макс_балл * 100) Затем используем функцию ЕСЛИ.

Задача 1: Известны оценки по информатике каждого из 15 студентов. Определить количество пятерок. Дана таблица успеваемости по информатике. Для решения этой задачи используйте функцию СЧЁТЕСЛИ. Она подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию.

Задача 2: Определить в какой день недели началась Великая Отечественная война. Используйте функцию ДАТА и ВРЕМЯ – ДЕНЬНЕД. У этой функции 2 аргумента: Дата_в_числовом_формате и Тип. В первое поле занесите дату начала ВОВ, т.е. номер ячейки, где она прописана. Во второе поле – тип. Укажите тип номер 2.

Задача 3: Определить сколько дней продолжалась Великая Отечественная война.

Используйте функцию ДАТА и ВРЕМЯ - ДАТА360. У этой функции 3 аргумента: Нач_дата, Кон_дата, Метод. Вам нужно заполнить только 1 и 2 поле. Поле метод не заполнять.

 Задача 4: Дана таблица целых чисел (6х6). Определить, сколько из них оканчиваются нулем. Для начала определим для каждого из чисел оканчивается оно на 0 или нет, записав формулу: =ЕСЛИ(ОСТАТ(ячейка;10)=0;”да”;”нет”). Растягиваем эту формулу на все ячейки. Затем для определения количества чисел, оканчивающихся на 0, в ячейку вписываем формулу: =СЧЁТЕСЛИ(блок ячеек;”да”).


 

А также другие работы, которые могут Вас заинтересовать

20065. Изготовление пробных стекол. Изготовление шкал и сеток 393 KB
  Для получения точных плоских поверхностей принимают одно стекло например 1 на рис.31 б в Рис. При наложении стекол 2 и 3 друг на друга общий €œбугор€ составит 2 полосы рис 4. Эллиптические зеркала большого диаметра изготавливают за несколько переходов с промежуточным отжигом из тонкого латунного листа 1 выдавливанием на токарном станке с помощью приспособления 2 имеющего выпуклую форму с наружной асферической поверхностью рис.
20066. Способы формообразования сферических и плоских поверхностей. Шлифование стекла свободным абразивом. Полирование стекла 39 KB
  Шлифование стекла свободным абразивом. Шлифование используется для придания необходимых форм размеров и образования поверхностей с тонкой структурой. Для формообразования поверхности с постепенным снижением шероховатости производят последовательно грубое среднее и тонкое шлифование. Грубое шлифование плоских поверхностей выполняют алмазными кругами на спец фрезерных или плоскошлифовальных станках.
20067. Влияние основных технологических факторов на процессы шлифования и полирования стекла. Обработка деталей на станках с жестко устанавливаемым инструментом. Способ свободной притирки 28.5 KB
  Обработка деталей на станках с жестко устанавливаемым инструментом. Обработка деталей на станках с жестко устанавливаемым инструментом. Для обработки оптических деталей способом свободного притира используются шлифовальнополировальные станки.
20068. Инструмент и приспособления для механического креплением заготовок. Блокировка оптических деталей 77.5 KB
  Приспособления с механическим креплением заготовок применяют на операциях обработки граней призм кругления дисков и т. Приспособления для обработки 3х граней призм плоскошлифовальном станкерис. Грани призм обрабатывают последовательно устанавливая приспособление на столе ст. Гипсованиерис крепят призмы с невысокими требованиями точности изготовления углов 3’ а также пластины.
20069. Классификация и технологичность конструкции. Заготовки и способы закрепления. Основные варианты изготовления осей и валов. Обработка многоступенчатых валов на многорезцовых токарных полуавтоматах 158.5 KB
  Основные варианты изготовления осей и валов. Обработка многоступенчатых валов на многорезцовых токарных полуавтоматах. При изготовлении валов исходные заготовки получают либо путем пластической деформации либо путем резки сортового или калиброванного проката.95 для единичного и мелкосерийного при изготовлении валов с небольшим перепадом диаметров используют горячекатаный нормальный прокат который разрезают на штучные заготовки.
20070. Структурные схемы приборов. Схема с последовательным соединением звеньев. Чувствительность. Погрешность 253.5 KB
  Структурной схемой называют схему содержащую предельно упрощенное обозначение функциональных узлов прибора или устройства а также логические связи этих узлов друг с другом. При эксплуатации прибора на его вход воздействует информативный параметр х измеряемая величина а также неинформативные параметры g1 g2 gn. При прохождении сигнала по компонентам прибора на подсистемы подузлы прибора воздействуют внутренние дестабилизирующие факторы q1 q2 qm которые так или иначе влияют на работоспособность этих узлов а следовательно и на...
20071. Дифференциальная схема соединения звеньев 55 KB
  Дифференциальной называется схема содержащая два канала с последовательным соединением преобразователей причем выходные величины каждого из каналов подаются на два входа вычитающего преобразователя. Вычитающий преобразователь это преобразователь с двумя входами выходная величина которого: у=у1у2 Оба канала дифференциальной схемы одинаковы и находятся в одинаковых условиях. В схеме первого типа измеряемая величина воздействует на вход одного канала а на вход другого канала подается величина той же физ. В схеме второго типа измеряемая...
20072. Схемы включения резистивных преобразователей. 86 KB
  I=E RxRИПRлсRE При изменении сопротивления резистивного преобразователя Rx изменяется ток Iр в цепи и следовательно показания прибора ИП. достоинства: простота Делитель напряжения E= IR1 Rx UХ= I Rx= E Rx Rx R1 Потенциометрическая схема включения резистивных преобразователей напряжение от источника питания E подается на крайние выходы резистивного преобразователя Rx. При этом напряжение нагрузки пропорционально перемещению движка при линейной функции...
20073. Мостовая схема включения резистивных преобразователей. Балансировка 79.5 KB
  Ветви с сопротивлениями R1 R2 R3 и R4 называются плечами моста. Ветви включающие измерительный прибор и источник питания называются диагоналями моста. Резистивные преобразователи могут включаться в 1 2 или все четыре плеча моста режим х. то выходное напряжение моста: ; где Uпит = Е напряжение питания.