16388

Функции в Ms Excel

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторная работа №2 Функции в Ms Excel В целом Microsoft Excel содержит около 1000 функций рабочего листа встроенных функций обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп: матема...

Русский

2013-06-20

49 KB

27 чел.

Лабораторная работа №2

Функции в Ms Excel

В целом Microsoft Excel содержит около 1000 функций рабочего листа (встроенных функций), обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп:

  1.  математические функции;
  2.  текстовые функции;
  3.  логические функции;
  4.  информационные функции;
  5.  функции ссылки и автоподстановки;
  6.  функции даты и времени;
  7.  финансовые функции;
  8.  инженерные функции;
  9.  статистические функции;
  10.  функции проверки свойств и значений;
  11.  функции DDE и внешние функции;
  12.  функции для работы со списками.

Обращение к каждой функции производится указанием её имени и следующего за ним в круглых скобках списка аргументов (параметров). Наличие круглых скобок обязательно, именно они служат признаком того, что используемое имя является именем функции. Аргументы списка разделяются точкой с запятой. Их количество не должно превышать 30, а длина формулы, содержащей сколько угодно обращений к функциям, не может превышать 1024 символов. В качестве аргументов могут использоваться константы, адреса ячеек, интервалы, выражения. Например: =СУММ(2,71; A1; B2:D10; 2*SIN($A$3))

Наличие знака равенства (=) перед формулой обязательно, иначе Excel поймет выражение не как формулу, а как текст. Большинство имён функций образовано буквами русского алфавита и имеет определённую смысловую нагрузку, понятную всем (=СУММ() – возвращает сумму своих аргументов).

Все функции вы можете посмотреть в меню Вставка – функция или нажать на кнопку Вставка функции  в начале строки формул. Рассмотрим краткое описание некоторых математических и логических функций.

Математические функции

  1.  ABS(число) – возвращает модуль (абсолютную величину) числа.
  2.  COS(число) – возвращает косинус заданного угла.
  3.  LN(число) – возвращает натуральный логарифм числа. Натуральный логарифм – это логарифм по основанию e (2,71828182845904).
  4.  LOG(число; основание) – возвращает логарифм числа по заданному основанию.
  5.  SIN(число) – возвращает синус заданного угла.
  6.  TAN(число) – возвращает тангенс заданного угла.
  7.  КОРЕНЬ(число) – возвращает положительное значение квадратного корня.
  8.  ОКРУГЛ(число; число_разрядов) – округляет число до указанного количества десятичных разрядов.
  9.  ОТБР(число; число_разрядов) – усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.
  10.  ПРОИЗВЕД(число1; число2; ...) – перемножает числа, заданные в качестве аргументов, и возвращает их произведение.
  11.  СЛЧИС( ) – возвращает равномерно распределенное случайное число, большее либо равное 0 и меньшее 1. Новое случайное число возвращается каждый раз, когда рабочий лист перевычисляется.
  12.  СТЕПЕНЬ(число; степень) – возвращает результат возведения в степень.
  13.  СУММ(число1; число2; ...) – суммирует все числа в интервале ячеек.
  14.  СУММКВ(число1; число2; ...) – возвращает сумму квадратов аргументов.
  15.  СУММПРОИЗВ(массив1; массив2; массив3; ...) – перемножает соответствующие элементы заданных массивов и возвращает сумму произведений.
  16.  СЧЁТ(значение1; значение2;…) – подсчитывает количество чисел в списке аргументов.

Логические функции

  1.  И(логическое_значение1; логическое_значение2; ...) – возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.
  2.  ИЛИ(логическое_значение1; логическое_значение2; ...) – возвращает ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА; возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.
  3.  НЕ(логическое_значение) – меняет на противоположное логическое значение своего аргумента. Функция НЕ используется в тех случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.
  4.  ЕСЛИ(лог_выражение; значение_если_истина; значение_если_ложь) – возвращает значение_если_истина, если заданное условие при вычислении дает значение ИСТИНА, и значение_если_ложь в противном случае.

Задание. Записать формулы в ЭТ для математических выражений:

Вставка – Функция - Математическая

75х; Sin(x); x3; 3Cos(x2); 4Sin2 (x); ; ; Log23x

Пример1: Заполнить массив случайными числами, округлить их до десятичных чисел. Выбрать максимальный и минимальный элемент массива, найти среднее значение всех величин и их сумму.

Решение: Для заполнения и округления используем функции =ОТБР(СЛЧИС()*3+1;1). Умножаем на 3 и прибавляем 1 для того чтобы числа были больше 1. Соответствующие ячейки подписываем и вставляем нужные нам функции, выделяя при этом весь массив.

 Пример2: У трех студентов за семестр набрано 45, 75 и 90 баллов по рейтинговой системе оценок. Максимальное количество баллов, которое они могли набрать в течение семестра 90 баллов. Подсчитать рейтинг каждого студента в процентах и определить можно ли им поставить зачет. Зачет ставится если рейтинг больше 60%.

Решение: Заполняем таблицу известными данными. Подсчитать рейтинг каждого студента в процентах по формуле(кол-во_баллов/макс_балл * 100) Затем используем функцию ЕСЛИ.

Задача 1: Известны оценки по информатике каждого из 15 студентов. Определить количество пятерок. Дана таблица успеваемости по информатике. Для решения этой задачи используйте функцию СЧЁТЕСЛИ. Она подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию.

Задача 2: Определить в какой день недели началась Великая Отечественная война. Используйте функцию ДАТА и ВРЕМЯ – ДЕНЬНЕД. У этой функции 2 аргумента: Дата_в_числовом_формате и Тип. В первое поле занесите дату начала ВОВ, т.е. номер ячейки, где она прописана. Во второе поле – тип. Укажите тип номер 2.

Задача 3: Определить сколько дней продолжалась Великая Отечественная война.

Используйте функцию ДАТА и ВРЕМЯ - ДАТА360. У этой функции 3 аргумента: Нач_дата, Кон_дата, Метод. Вам нужно заполнить только 1 и 2 поле. Поле метод не заполнять.

 Задача 4: Дана таблица целых чисел (6х6). Определить, сколько из них оканчиваются нулем. Для начала определим для каждого из чисел оканчивается оно на 0 или нет, записав формулу: =ЕСЛИ(ОСТАТ(ячейка;10)=0;”да”;”нет”). Растягиваем эту формулу на все ячейки. Затем для определения количества чисел, оканчивающихся на 0, в ячейку вписываем формулу: =СЧЁТЕСЛИ(блок ячеек;”да”).


 

А также другие работы, которые могут Вас заинтересовать

21253. СТІЙКІСТЬ РОБОТИ ПРОМИСЛОВИХ ОБ’ЄКТІВ У НАДЗВИЧАЙНИХ СИТУАЦІЯХ 152 KB
  Основи стійкості роботи промислових підприємств Під стійкістю роботи промислових підприємств об’єктів розуміють їх можливість в умовах надзвичайних ситуацій мирного і воєнного часу виробляти продукцію в запланованому обсязі і номенклатурі а при слабких пошкодженнях відновлювати виробництво в мінімальні терміни. Стійкість роботи промислового підприємства складається із : стійкості інженернотехнічного комплексу будівель споруд систем енерго газо водозабезпечення технологічного обладнання і т. до дії зовнішніх факторів при аваріях...
21254. Підготовка населення по цивільній обороні 82 KB
  Організація навчання населення з цивільної оборони Одним із основних завдань цивільної оборони що визначені Законом України Про Цивільну оборону України є підготовка і передпідготовка керівного складу Цивільної оборони її органів управління та сил навчання населення вмінню застосувати засоби індивідуального захисту та дій у надзвичайних ситуаціях. Підготовка керівного складу Метою навчання цієї категорії є підготовка до управління силами ЦО своїх об’єктів у випадку стихійного лиха або аварії. Підготовка проводиться на курсах ЦО в...
21255. Облік витрат та калькулювання собівартості продукції тваринництва 250 KB
  Собівартість окремих видів сільськогосподарської продукції визначається виходячи з витрат віднесених на відповідний вид групу тварин. Розрахунок собівартості продукції у тваринництві здійснюється в такій послідовності: розподіляють між окремими об'єктами обліку витрати на утриманняосновних засобів визначають собівартість робіт та послуг допоміжних виробництв та списують калькуляційні різниці між фактичною та плановою їх собівартістю списують частину витрат бджільництва на сільськогосподарські культури що запилюються списують з витрат...
21256. Облік інших операцій на сільськогосподарських підприємствах 279.5 KB
  За дебетом субрахунку 234 обліковуються всі витрати по виконанню робіт та послугу розрізі типової номенклатури статей. За дебетом рахунку відображаються прямі матеріальні трудові та інші прямі витрати а також загально виробничі витрати за кредитом – списання собівартості виготовлених виробів вартість послуг на ремонти техогляди та ін. Усі витрати по капітальному та поточному ремонтах основних засобів по виготовленню запасних частин та інших роботах що виконують майстерні обліковуються за статтями: 1 витрати на оплату праці 2 паливо і...
21257. Загальна характеристика автотранспортних підприємств. Облік рухомого складу транспортних засобів 486.5 KB
  Послуги пасажирського автомобільного транспорту поділяють на послуги з перевезення пасажирів автобусами в таксі та легкових автомобілях на замовлення. Таксі – легковий автомобіль обладнаний розпізнавальним ліхтарем оранжевого кольору який встановлюється на даху автомобіля діючим таксометром сигнальним ліхтарем із зеленим та червоним світлом розташованим у верхньому правому кутку лобового скла і який має нанесені композиції з квадратів розташованих у шаховому порядку на дверцятах автомобіля з лівого та правого боків призначений для...
21258. Облік запасів в автотранспортних підприємствах 245.5 KB
  Облік паливномастильних матеріалів Облік наявності й руху палива яке купується для експлуатації транспортних засобів ведеться на субрахунку 203 Паливо рахунку 20 Виробничі запаси . Відображення в обліку операцій з придбання паливномастильних матеріалів залежить від способу їх придбання. Підприємства отримують паливномастильні матеріали за укладеними договорами з автозаправними станціями АЗС за безготівковим розрахунком та за готівку зі складів або на АЗС. Облік паливномастильних матеріалів проводиться працівниками комірниками з...
21259. Облік реалізації послуг в автотранспортних підприємствах 357 KB
  Облік реалізації послуг в автотранспортних підприємствах 11. Облік надання послуг з вантажних перевезень Порядок перевезення вантажів автотранспортом в Україні регламентується Законом Про автотранспорт та Правилами перевезення вантажів автомобільним транспортом в Україні затвердженими наказом Міністерства транспорту України від 14. Третій примірник що є підставою для розрахунків за виконання транспортних послуг перевізник надсилає замовнику автотранспорту для оплати за перевезення; четвертий примірник додається до подорожнього листа і є...
21260. Основи побудови обліку у будівельних підприємствах 191.5 KB
  З економічної точки зору для галузі будівництва можна виділити ряд особливостей які вливають на організацію аналітичного й синтетичного обліку: термін операційного циклу період будівництва може продовжуватися декілька звітних періодів; індивідуальний характер кожного об'єкта будівництва; мають місце великі залишки незавершеного виробництва зза довгого робочого періоду й одночасного ведення робіт на великій кількості об'єктів; об’єкт будівництва знаходиться не за місцем розташування виконавця будівельномонтажних робіт БМР а на окремій...
21261. Облік у підрядчика. Облік у забудовника 597 KB
  Відображено витрати на транспортування у складі первісної вартості запасів 1000 20 22 631 685 4. Відображено витрати на транспортування у складі первісної вартості запасів 1000 20 22 631 685 8. Списано на загальновиробничі витрати нестачу запасів у межах норм природного збитку 7230 23 201 5. Списано на фінансові результати витрати 3259751195210 959 793 947 13.