16388

Функции в Ms Excel

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторная работа №2 Функции в Ms Excel В целом Microsoft Excel содержит около 1000 функций рабочего листа встроенных функций обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп: матема...

Русский

2013-06-20

49 KB

36 чел.

Лабораторная работа №2

Функции в Ms Excel

В целом Microsoft Excel содержит около 1000 функций рабочего листа (встроенных функций), обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп:

  1.  математические функции;
  2.  текстовые функции;
  3.  логические функции;
  4.  информационные функции;
  5.  функции ссылки и автоподстановки;
  6.  функции даты и времени;
  7.  финансовые функции;
  8.  инженерные функции;
  9.  статистические функции;
  10.  функции проверки свойств и значений;
  11.  функции DDE и внешние функции;
  12.  функции для работы со списками.

Обращение к каждой функции производится указанием её имени и следующего за ним в круглых скобках списка аргументов (параметров). Наличие круглых скобок обязательно, именно они служат признаком того, что используемое имя является именем функции. Аргументы списка разделяются точкой с запятой. Их количество не должно превышать 30, а длина формулы, содержащей сколько угодно обращений к функциям, не может превышать 1024 символов. В качестве аргументов могут использоваться константы, адреса ячеек, интервалы, выражения. Например: =СУММ(2,71; A1; B2:D10; 2*SIN($A$3))

Наличие знака равенства (=) перед формулой обязательно, иначе Excel поймет выражение не как формулу, а как текст. Большинство имён функций образовано буквами русского алфавита и имеет определённую смысловую нагрузку, понятную всем (=СУММ() – возвращает сумму своих аргументов).

Все функции вы можете посмотреть в меню Вставка – функция или нажать на кнопку Вставка функции  в начале строки формул. Рассмотрим краткое описание некоторых математических и логических функций.

Математические функции

  1.  ABS(число) – возвращает модуль (абсолютную величину) числа.
  2.  COS(число) – возвращает косинус заданного угла.
  3.  LN(число) – возвращает натуральный логарифм числа. Натуральный логарифм – это логарифм по основанию e (2,71828182845904).
  4.  LOG(число; основание) – возвращает логарифм числа по заданному основанию.
  5.  SIN(число) – возвращает синус заданного угла.
  6.  TAN(число) – возвращает тангенс заданного угла.
  7.  КОРЕНЬ(число) – возвращает положительное значение квадратного корня.
  8.  ОКРУГЛ(число; число_разрядов) – округляет число до указанного количества десятичных разрядов.
  9.  ОТБР(число; число_разрядов) – усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.
  10.  ПРОИЗВЕД(число1; число2; ...) – перемножает числа, заданные в качестве аргументов, и возвращает их произведение.
  11.  СЛЧИС( ) – возвращает равномерно распределенное случайное число, большее либо равное 0 и меньшее 1. Новое случайное число возвращается каждый раз, когда рабочий лист перевычисляется.
  12.  СТЕПЕНЬ(число; степень) – возвращает результат возведения в степень.
  13.  СУММ(число1; число2; ...) – суммирует все числа в интервале ячеек.
  14.  СУММКВ(число1; число2; ...) – возвращает сумму квадратов аргументов.
  15.  СУММПРОИЗВ(массив1; массив2; массив3; ...) – перемножает соответствующие элементы заданных массивов и возвращает сумму произведений.
  16.  СЧЁТ(значение1; значение2;…) – подсчитывает количество чисел в списке аргументов.

Логические функции

  1.  И(логическое_значение1; логическое_значение2; ...) – возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.
  2.  ИЛИ(логическое_значение1; логическое_значение2; ...) – возвращает ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА; возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.
  3.  НЕ(логическое_значение) – меняет на противоположное логическое значение своего аргумента. Функция НЕ используется в тех случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.
  4.  ЕСЛИ(лог_выражение; значение_если_истина; значение_если_ложь) – возвращает значение_если_истина, если заданное условие при вычислении дает значение ИСТИНА, и значение_если_ложь в противном случае.

Задание. Записать формулы в ЭТ для математических выражений:

Вставка – Функция - Математическая

75х; Sin(x); x3; 3Cos(x2); 4Sin2 (x); ; ; Log23x

Пример1: Заполнить массив случайными числами, округлить их до десятичных чисел. Выбрать максимальный и минимальный элемент массива, найти среднее значение всех величин и их сумму.

Решение: Для заполнения и округления используем функции =ОТБР(СЛЧИС()*3+1;1). Умножаем на 3 и прибавляем 1 для того чтобы числа были больше 1. Соответствующие ячейки подписываем и вставляем нужные нам функции, выделяя при этом весь массив.

 Пример2: У трех студентов за семестр набрано 45, 75 и 90 баллов по рейтинговой системе оценок. Максимальное количество баллов, которое они могли набрать в течение семестра 90 баллов. Подсчитать рейтинг каждого студента в процентах и определить можно ли им поставить зачет. Зачет ставится если рейтинг больше 60%.

Решение: Заполняем таблицу известными данными. Подсчитать рейтинг каждого студента в процентах по формуле(кол-во_баллов/макс_балл * 100) Затем используем функцию ЕСЛИ.

Задача 1: Известны оценки по информатике каждого из 15 студентов. Определить количество пятерок. Дана таблица успеваемости по информатике. Для решения этой задачи используйте функцию СЧЁТЕСЛИ. Она подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию.

Задача 2: Определить в какой день недели началась Великая Отечественная война. Используйте функцию ДАТА и ВРЕМЯ – ДЕНЬНЕД. У этой функции 2 аргумента: Дата_в_числовом_формате и Тип. В первое поле занесите дату начала ВОВ, т.е. номер ячейки, где она прописана. Во второе поле – тип. Укажите тип номер 2.

Задача 3: Определить сколько дней продолжалась Великая Отечественная война.

Используйте функцию ДАТА и ВРЕМЯ - ДАТА360. У этой функции 3 аргумента: Нач_дата, Кон_дата, Метод. Вам нужно заполнить только 1 и 2 поле. Поле метод не заполнять.

 Задача 4: Дана таблица целых чисел (6х6). Определить, сколько из них оканчиваются нулем. Для начала определим для каждого из чисел оканчивается оно на 0 или нет, записав формулу: =ЕСЛИ(ОСТАТ(ячейка;10)=0;”да”;”нет”). Растягиваем эту формулу на все ячейки. Затем для определения количества чисел, оканчивающихся на 0, в ячейку вписываем формулу: =СЧЁТЕСЛИ(блок ячеек;”да”).


 

А также другие работы, которые могут Вас заинтересовать

72032. Підвищення якості електричної енергії в системах електропостачання об’єктів будівництва фільтрами струмів нульової послідовності 2.02 MB
  В даній роботі розглянуті питання повязані з використанням саме автотрансформаторних ФСНП в СЕ обєктів будівництва. Необхідність використання ФСНП в СЕ обєктів будівництва повязана з тим що в таких системах зявилась велика кількість однофазних електроприймачів з нелінійним...
72033. Діагностика та прогноз перебігу рака молочної залози: імуноморфологічні аспекти 199 KB
  Визначено що по відношенню до прогнозу перебігу РМЗ виняток склала експресія маркерів ER та PgR в віковій групі до 35 років ER у віковій групі 3550 років. Інвазивна протокова карцинома яку ми виявили в групі з попереднім діагнозом МГА завдяки підвищеній реакції з Кі67 та р53 мала унікальний фенотип....
72034. ФОРМУВАННЯ ЕКОНОМІЧНОЇ КУЛЬТУРИ УЧНІВ ОСНОВНОЇ ТА СТАРШОЇ ШКОЛИ 1.22 MB
  Сьогодні виявлено протиріччя між динамікою економічного розвитку країни які висуває вимоги до системної організації процесу економічного навчання та виховання підростаючого покоління і сформованою практикою економічної освіти; між реальним рівнем...
72035. УДОСКОНАЛЕННЯ ЗАСОБІВ ОЧИЩЕННЯ ПРОМИВНИХ ВОД ТА УТИЛІЗАЦІЇ ОСАДУ ВОДОПРОВІДНИХ ФІЛЬТРУВАЛЬНИХ СТАНЦІЙ 225 KB
  У багатьох частинах світу спостерігається дефіцит поступове вичерпання і зростаюче забруднення джерел прісної води. Питне водопостачання здійснюється як з поверхневих близько 70 всієї води так і з підземних джерел. В процесі очищення води тільки поверхневих джерел на спорудах поліпшення її якості щорічно утворюється близько 100 млн.
72036. СТАБІЛЬНИЙ РАНГ ТА ПОВ’ЯЗАНІ З НИМ ЗАДАЧІ ТЕОРІЇ КІЛЕЦЬ І МОДУЛІВ 405.5 KB
  У дисертаційній роботі встановлюються принципові зв’язки методів теорії матриць над кільцями з сучасними досягненнями алгебраїчної К-теорії. При дослідженні проблем алгебри матриць над кільцями неможливо обійтись без застосування результатів К-теорії.
72037. ПРОФІЛАКТИКА, ДІАГНОСТИКА І ЛІКУВАННЯ ПОРУШЕНЬ МЕНСТРУАЛЬНОГО ЦИКЛУ У ДІВЧАТ-ПІДЛІТКІВ З НЕРВОВОЮ АНОРЕКСІЄЮ 290.5 KB
  На сучасному етапі однією з важливих проблем дитячої та підліткової гінекології є профілактика та лікування порушень функції репродуктивної системи у дівчатпідлітків з психоемоційними розладами В. Відомо що порушення менструальної функції в підлітковому віці у дівчат негативно впливають на стан репродуктивної системи...
72038. ОСОБЛИВОСТІ КЛІНІЧНОГО ПЕРЕБІГУ ПОРОЖНИННИХ УТВОРЕНЬ ПІДШЛУНКОВОЇ ЗАЛОЗИ ТА ЇХ ХІРУРГІЧНЕ ЛІКУВАННЯ 174 KB
  Метою роботи було поліпшення результатів хірургічного лікування хворих на порожнинні утворення підшлункової залози при панкреатиті шляхом диференційованого вибору операційних технологій з урахуванням особливостей клінічного перебігу та прогнозування розвитку їх ускладнень.
72039. ПЕДАГОГІЧНІ УМОВИ ФІЗИЧНОГО ВИХОВАННЯ ДІТЕЙ СТАРШОГО ДОШКІЛЬНОГО ВІКУ У ВЗАЄМОДІЇ ДОШКІЛЬНОГО НАВЧАЛЬНОГО ЗАКЛАДУ І СІМ’Ї 202 KB
  Трансформаційні процеси у сучасному суспільстві висувають нові вимоги до системи освіти загалом та фізичного виховання дітей зокрема. Економічні й політичні реформи в Україні здійснюються на тлі загострення проблеми захворюваності дітей яка зросла за багатьма показниками: лише третина сучасних...
72040. КРИМСЬКОТАТАРСЬКИЙ НАЦІОНАЛЬНИЙ РУХ ЯК СУБ’ЄКТ ПОЛІТИЧНОГО ПРОЦЕСУ В КРИМУ 163 KB
  В останні два десятиліття проблема повернення та облаштування кримських татар питання політикоправового статусу кримсько-татарського народу виступають найважливішими чинниками етнополітичної ситуації на півострові визначаючи діяльність кримсько-татарського національного...