16388

Функции в Ms Excel

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторная работа №2 Функции в Ms Excel В целом Microsoft Excel содержит около 1000 функций рабочего листа встроенных функций обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп: матема...

Русский

2013-06-20

49 KB

23 чел.

Лабораторная работа №2

Функции в Ms Excel

В целом Microsoft Excel содержит около 1000 функций рабочего листа (встроенных функций), обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп:

  1.  математические функции;
  2.  текстовые функции;
  3.  логические функции;
  4.  информационные функции;
  5.  функции ссылки и автоподстановки;
  6.  функции даты и времени;
  7.  финансовые функции;
  8.  инженерные функции;
  9.  статистические функции;
  10.  функции проверки свойств и значений;
  11.  функции DDE и внешние функции;
  12.  функции для работы со списками.

Обращение к каждой функции производится указанием её имени и следующего за ним в круглых скобках списка аргументов (параметров). Наличие круглых скобок обязательно, именно они служат признаком того, что используемое имя является именем функции. Аргументы списка разделяются точкой с запятой. Их количество не должно превышать 30, а длина формулы, содержащей сколько угодно обращений к функциям, не может превышать 1024 символов. В качестве аргументов могут использоваться константы, адреса ячеек, интервалы, выражения. Например: =СУММ(2,71; A1; B2:D10; 2*SIN($A$3))

Наличие знака равенства (=) перед формулой обязательно, иначе Excel поймет выражение не как формулу, а как текст. Большинство имён функций образовано буквами русского алфавита и имеет определённую смысловую нагрузку, понятную всем (=СУММ() – возвращает сумму своих аргументов).

Все функции вы можете посмотреть в меню Вставка – функция или нажать на кнопку Вставка функции  в начале строки формул. Рассмотрим краткое описание некоторых математических и логических функций.

Математические функции

  1.  ABS(число) – возвращает модуль (абсолютную величину) числа.
  2.  COS(число) – возвращает косинус заданного угла.
  3.  LN(число) – возвращает натуральный логарифм числа. Натуральный логарифм – это логарифм по основанию e (2,71828182845904).
  4.  LOG(число; основание) – возвращает логарифм числа по заданному основанию.
  5.  SIN(число) – возвращает синус заданного угла.
  6.  TAN(число) – возвращает тангенс заданного угла.
  7.  КОРЕНЬ(число) – возвращает положительное значение квадратного корня.
  8.  ОКРУГЛ(число; число_разрядов) – округляет число до указанного количества десятичных разрядов.
  9.  ОТБР(число; число_разрядов) – усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.
  10.  ПРОИЗВЕД(число1; число2; ...) – перемножает числа, заданные в качестве аргументов, и возвращает их произведение.
  11.  СЛЧИС( ) – возвращает равномерно распределенное случайное число, большее либо равное 0 и меньшее 1. Новое случайное число возвращается каждый раз, когда рабочий лист перевычисляется.
  12.  СТЕПЕНЬ(число; степень) – возвращает результат возведения в степень.
  13.  СУММ(число1; число2; ...) – суммирует все числа в интервале ячеек.
  14.  СУММКВ(число1; число2; ...) – возвращает сумму квадратов аргументов.
  15.  СУММПРОИЗВ(массив1; массив2; массив3; ...) – перемножает соответствующие элементы заданных массивов и возвращает сумму произведений.
  16.  СЧЁТ(значение1; значение2;…) – подсчитывает количество чисел в списке аргументов.

Логические функции

  1.  И(логическое_значение1; логическое_значение2; ...) – возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.
  2.  ИЛИ(логическое_значение1; логическое_значение2; ...) – возвращает ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА; возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.
  3.  НЕ(логическое_значение) – меняет на противоположное логическое значение своего аргумента. Функция НЕ используется в тех случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.
  4.  ЕСЛИ(лог_выражение; значение_если_истина; значение_если_ложь) – возвращает значение_если_истина, если заданное условие при вычислении дает значение ИСТИНА, и значение_если_ложь в противном случае.

Задание. Записать формулы в ЭТ для математических выражений:

Вставка – Функция - Математическая

75х; Sin(x); x3; 3Cos(x2); 4Sin2 (x); ; ; Log23x

Пример1: Заполнить массив случайными числами, округлить их до десятичных чисел. Выбрать максимальный и минимальный элемент массива, найти среднее значение всех величин и их сумму.

Решение: Для заполнения и округления используем функции =ОТБР(СЛЧИС()*3+1;1). Умножаем на 3 и прибавляем 1 для того чтобы числа были больше 1. Соответствующие ячейки подписываем и вставляем нужные нам функции, выделяя при этом весь массив.

 Пример2: У трех студентов за семестр набрано 45, 75 и 90 баллов по рейтинговой системе оценок. Максимальное количество баллов, которое они могли набрать в течение семестра 90 баллов. Подсчитать рейтинг каждого студента в процентах и определить можно ли им поставить зачет. Зачет ставится если рейтинг больше 60%.

Решение: Заполняем таблицу известными данными. Подсчитать рейтинг каждого студента в процентах по формуле(кол-во_баллов/макс_балл * 100) Затем используем функцию ЕСЛИ.

Задача 1: Известны оценки по информатике каждого из 15 студентов. Определить количество пятерок. Дана таблица успеваемости по информатике. Для решения этой задачи используйте функцию СЧЁТЕСЛИ. Она подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию.

Задача 2: Определить в какой день недели началась Великая Отечественная война. Используйте функцию ДАТА и ВРЕМЯ – ДЕНЬНЕД. У этой функции 2 аргумента: Дата_в_числовом_формате и Тип. В первое поле занесите дату начала ВОВ, т.е. номер ячейки, где она прописана. Во второе поле – тип. Укажите тип номер 2.

Задача 3: Определить сколько дней продолжалась Великая Отечественная война.

Используйте функцию ДАТА и ВРЕМЯ - ДАТА360. У этой функции 3 аргумента: Нач_дата, Кон_дата, Метод. Вам нужно заполнить только 1 и 2 поле. Поле метод не заполнять.

 Задача 4: Дана таблица целых чисел (6х6). Определить, сколько из них оканчиваются нулем. Для начала определим для каждого из чисел оканчивается оно на 0 или нет, записав формулу: =ЕСЛИ(ОСТАТ(ячейка;10)=0;”да”;”нет”). Растягиваем эту формулу на все ячейки. Затем для определения количества чисел, оканчивающихся на 0, в ячейку вписываем формулу: =СЧЁТЕСЛИ(блок ячеек;”да”).


 

А также другие работы, которые могут Вас заинтересовать

79377. Автономное существование человека в условиях природной среды 57 KB
  Способствующие: хорошее здоровье, высокие морально-волевые качества, психофизиологическая устойчивость организма, наличие средств для жизнедеятельности в экстремальных условиях (одежда, снаряжение водно-пищевой запас), подготовленность к действиям в экстремальных условиях.
79378. Комп’ютери бувають різні 66.5 KB
  Мета: сформувати уявлення про види комп’ютерів; розглянути види комп’ютерів та сфери їх застосування; повторити правила безпечної роботи та поведінки в комп’ютерному класі правила вибору переміщення об’єктів; вчити робити висновки узагальнення доводити власну думку...
79379. ПРАВИЛА БЕЗОПАСНОГО ПОВЕДЕНИЯ В СИТУАЦИЯХ КРИМИНОГЕННОГО ХАРАКТЕРА 36.5 KB
  Не держите деньги в карманах в которые легко проникнуть вору. Ключи и кошелек храните во внутренних карманах При выходе из дома в темное время суток избегайте малолюдных и плохо освещенных мест пустынных парков и скверов; на улице держитесь подальше от стен домов.
79380. Относительное позиционирование 85.5 KB
  Смещение в этом случае будет происходить не относительно «родительского» элемента (как при абсолютном позиционировании), а относительно самого блока в нормальном потоке. Это будет понятнее на примере. Пусть у нас есть html-страница с тремя div-ами...
79381. УГОЛОВНАЯ ОТВЕСТВЕННОСТЬ НЕСОВЕРШЕННОЛЕТНИХ. ПОНЯТИЕ ПРСТУПЛЕНИЯ. ОСОБЕННОСТИ УГОЛОВНОЙ ОТВЕТСТВЕННОСТИ НЕСОВЕРШЕННОЛЕТНИХ 16.78 KB
  Лишение свободы на определенный срок в возрасте до 16 лет на срок до 6 лет. Если за особо тяжкое преступления с санкцией до 10 лет несовершеннолетним назначается отбытие в воспитательных колониях. М.Б. наказание в виде лишения свободы и за небольшой и средней тяжести преступления, есл преступления совершены впервые.
79382. УГОЛОВНАЯ ОТВЕСТВЕННОСТЬ ЗА ХУЛИГАНСТВО, ВАНДАЛИЗМ, НАДРУГАТЕЛЬСТВО, ЗА ПРИВЕДЕНИЕ В НЕГОДНОСТЬ ТРАНСПОРТНЫХ СРЕДСТВ 19.16 KB
  Грубое нарушение общественного порядка: действия причинившие существенный ущерб личным или общественным интересам либо выразившееся в злостном нарушении общественной нравственности Примеры: срыв общественного мероприятия нарушение покоя и отдыха граждан в ночное время распитие спиртных...
79383. ПРАВИЛА ПОВЕДЕНИЯ В УСЛОВИЯХ ЧС ПРИРОДНОГО И ТЕХНОГЕННОГО ХАРАКТЕРА 55 KB
  Способы оповещения и управления эвакуацией людей при пожаре: подачей звуковых и или световых сигналов во все помещения здания с постоянным или временным пребыванием людей; трансляцией текстов директор школы зам. директора о необходимости эвакуации путях эвакуации направлении...
79385. ПРЕДНАЗНАЧЕНИЕ И ЗАДАЧИ ГО. СТРУКТУРА И ОРГАНЫ УПРАВЛЕНИЯ. КЧС И ПБ 60 KB
  Определяет: задачи и правовые основы их осуществления; правовое регулирование в области гражданской обороны; принципы организации и ведения гражданской обороны; полномочия органов государственной власти Российской Федерации органов исполнительной власти субъектов Российской Федерации...