16388

Функции в Ms Excel

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторная работа №2 Функции в Ms Excel В целом Microsoft Excel содержит около 1000 функций рабочего листа встроенных функций обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп: матема...

Русский

2013-06-20

49 KB

24 чел.

Лабораторная работа №2

Функции в Ms Excel

В целом Microsoft Excel содержит около 1000 функций рабочего листа (встроенных функций), обеспечивающих возможность выполнения самых разнообразных вычислений. Все они в соответствии с характером вычислений делятся на 12 групп:

  1.  математические функции;
  2.  текстовые функции;
  3.  логические функции;
  4.  информационные функции;
  5.  функции ссылки и автоподстановки;
  6.  функции даты и времени;
  7.  финансовые функции;
  8.  инженерные функции;
  9.  статистические функции;
  10.  функции проверки свойств и значений;
  11.  функции DDE и внешние функции;
  12.  функции для работы со списками.

Обращение к каждой функции производится указанием её имени и следующего за ним в круглых скобках списка аргументов (параметров). Наличие круглых скобок обязательно, именно они служат признаком того, что используемое имя является именем функции. Аргументы списка разделяются точкой с запятой. Их количество не должно превышать 30, а длина формулы, содержащей сколько угодно обращений к функциям, не может превышать 1024 символов. В качестве аргументов могут использоваться константы, адреса ячеек, интервалы, выражения. Например: =СУММ(2,71; A1; B2:D10; 2*SIN($A$3))

Наличие знака равенства (=) перед формулой обязательно, иначе Excel поймет выражение не как формулу, а как текст. Большинство имён функций образовано буквами русского алфавита и имеет определённую смысловую нагрузку, понятную всем (=СУММ() – возвращает сумму своих аргументов).

Все функции вы можете посмотреть в меню Вставка – функция или нажать на кнопку Вставка функции  в начале строки формул. Рассмотрим краткое описание некоторых математических и логических функций.

Математические функции

  1.  ABS(число) – возвращает модуль (абсолютную величину) числа.
  2.  COS(число) – возвращает косинус заданного угла.
  3.  LN(число) – возвращает натуральный логарифм числа. Натуральный логарифм – это логарифм по основанию e (2,71828182845904).
  4.  LOG(число; основание) – возвращает логарифм числа по заданному основанию.
  5.  SIN(число) – возвращает синус заданного угла.
  6.  TAN(число) – возвращает тангенс заданного угла.
  7.  КОРЕНЬ(число) – возвращает положительное значение квадратного корня.
  8.  ОКРУГЛ(число; число_разрядов) – округляет число до указанного количества десятичных разрядов.
  9.  ОТБР(число; число_разрядов) – усекает число до целого, отбрасывая дробную часть числа, так что остается целое число.
  10.  ПРОИЗВЕД(число1; число2; ...) – перемножает числа, заданные в качестве аргументов, и возвращает их произведение.
  11.  СЛЧИС( ) – возвращает равномерно распределенное случайное число, большее либо равное 0 и меньшее 1. Новое случайное число возвращается каждый раз, когда рабочий лист перевычисляется.
  12.  СТЕПЕНЬ(число; степень) – возвращает результат возведения в степень.
  13.  СУММ(число1; число2; ...) – суммирует все числа в интервале ячеек.
  14.  СУММКВ(число1; число2; ...) – возвращает сумму квадратов аргументов.
  15.  СУММПРОИЗВ(массив1; массив2; массив3; ...) – перемножает соответствующие элементы заданных массивов и возвращает сумму произведений.
  16.  СЧЁТ(значение1; значение2;…) – подсчитывает количество чисел в списке аргументов.

Логические функции

  1.  И(логическое_значение1; логическое_значение2; ...) – возвращает значение ИСТИНА, если все аргументы имеют значение ИСТИНА; возвращает значение ЛОЖЬ, если хотя бы один аргумент имеет значение ЛОЖЬ.
  2.  ИЛИ(логическое_значение1; логическое_значение2; ...) – возвращает ИСТИНА, если хотя бы один из аргументов имеет значение ИСТИНА; возвращает ЛОЖЬ, если все аргументы имеют значение ЛОЖЬ.
  3.  НЕ(логическое_значение) – меняет на противоположное логическое значение своего аргумента. Функция НЕ используется в тех случаях, когда необходимо быть уверенным в том, что значение не равно некоторой конкретной величине.
  4.  ЕСЛИ(лог_выражение; значение_если_истина; значение_если_ложь) – возвращает значение_если_истина, если заданное условие при вычислении дает значение ИСТИНА, и значение_если_ложь в противном случае.

Задание. Записать формулы в ЭТ для математических выражений:

Вставка – Функция - Математическая

75х; Sin(x); x3; 3Cos(x2); 4Sin2 (x); ; ; Log23x

Пример1: Заполнить массив случайными числами, округлить их до десятичных чисел. Выбрать максимальный и минимальный элемент массива, найти среднее значение всех величин и их сумму.

Решение: Для заполнения и округления используем функции =ОТБР(СЛЧИС()*3+1;1). Умножаем на 3 и прибавляем 1 для того чтобы числа были больше 1. Соответствующие ячейки подписываем и вставляем нужные нам функции, выделяя при этом весь массив.

 Пример2: У трех студентов за семестр набрано 45, 75 и 90 баллов по рейтинговой системе оценок. Максимальное количество баллов, которое они могли набрать в течение семестра 90 баллов. Подсчитать рейтинг каждого студента в процентах и определить можно ли им поставить зачет. Зачет ставится если рейтинг больше 60%.

Решение: Заполняем таблицу известными данными. Подсчитать рейтинг каждого студента в процентах по формуле(кол-во_баллов/макс_балл * 100) Затем используем функцию ЕСЛИ.

Задача 1: Известны оценки по информатике каждого из 15 студентов. Определить количество пятерок. Дана таблица успеваемости по информатике. Для решения этой задачи используйте функцию СЧЁТЕСЛИ. Она подсчитывает количество ячеек внутри диапазона, удовлетворяющих заданному критерию.

Задача 2: Определить в какой день недели началась Великая Отечественная война. Используйте функцию ДАТА и ВРЕМЯ – ДЕНЬНЕД. У этой функции 2 аргумента: Дата_в_числовом_формате и Тип. В первое поле занесите дату начала ВОВ, т.е. номер ячейки, где она прописана. Во второе поле – тип. Укажите тип номер 2.

Задача 3: Определить сколько дней продолжалась Великая Отечественная война.

Используйте функцию ДАТА и ВРЕМЯ - ДАТА360. У этой функции 3 аргумента: Нач_дата, Кон_дата, Метод. Вам нужно заполнить только 1 и 2 поле. Поле метод не заполнять.

 Задача 4: Дана таблица целых чисел (6х6). Определить, сколько из них оканчиваются нулем. Для начала определим для каждого из чисел оканчивается оно на 0 или нет, записав формулу: =ЕСЛИ(ОСТАТ(ячейка;10)=0;”да”;”нет”). Растягиваем эту формулу на все ячейки. Затем для определения количества чисел, оканчивающихся на 0, в ячейку вписываем формулу: =СЧЁТЕСЛИ(блок ячеек;”да”).


 

А также другие работы, которые могут Вас заинтересовать

76806. Большие слюнные железы 183.29 KB
  Обе железы входят в группу больших слюнных желез располагающихся в нижней стенке полости рта. Кроме них в полости рта находятся и малые слюнные железы: губные щечные язычные небные тоже вырабатывающие смешанный секрет но в небольшом количестве. Все слюнные железы обладают и малой эндокринной функцией выделяя калликреин инсулин факторы роста нервов и эпителия и др.
76807. Околоушная слюнная железа 179.92 KB
  От капсулы внутрь железы отходят перегородки которые отграничивают железистые дольки состоящие из альвеол. Он выходит из переднего и верхнего отростков железы располагается на щечной и жевательной мышцах параллельно скуловой кости прободает щечную мышцу и открывается на слизистой щеки в верхнем своде преддверия рта на уровне 2го верхнего коренного зуба. В толще поверхностной части железы находится сплетение двигательных ветвей лицевого нерва направляющихся к мимическим мышцам.
76808. Глотка, ее строение, кровоснабжение, иннервация, региональные лимфатические узлы. Лимфоидное кольцо глотки 186.13 KB
  Лимфоидное кольцо глотки. Нижний – гортанный или гортаноглотка где в передней стенке находится отверстие входа в гортань а книзу от него выступ гортани по бокам от которого и выше лежат грушевидные карманы глотки по которым продвигается пища. Послойное строение стенки глотки изнутри кнаружи: слизистая оболочка покрытая в носоглотке мерцательным эпителием а в остальных отделах многослойным плоским содержит много слизистых желез; подслизистая основа представленная в носоглотке плотной глоточнобазилярной фасцией а в нижних...
76809. Пищевод и его строение 182.54 KB
  Все три части пищевода плавно повторяют фронтальные изгибы позвоночника вдоль которого проходит орган. Однако пищевод имеет небольшие отклонения и в сагиттальной плоскости. Шейная часть пищевода лежит на уровне тел VI шейного – II грудного позвонков имеет длину в 58 см немного отклоняется от срединной линии влево.
76810. Желудок: строение, топография. Рентгеновское изображение. Кровоснабжение, иннервация, региональные лимфатические узлы 185.8 KB
  Анатомическое строение желудка Две стенки передняя и задняя которые переходят одна в другую образуя на краях малую и большую кривизну. Кардиальное отверстие место впадения пищевода в желудок пилорическое отверстие место перехода желудка в 12ти перстную кишку. Кардиальная часть желудка состоит из дна свода и тела и выполняет пищеприемную и перерабатывающую функции задерживая перемешивая обезвреживая и гидролизуя продукты питания. Анатомическая граница между пищеприемным кардиальным отделом и эвакуаторным пилорическим каналом...
76811. Тонкая кишка 186.47 KB
  Начало тонкой кишки лежит у правого края ХII грудного или I поясничного позвонков конец в правой подвздошной яме большого таза. Отделы тонкой кишки: 12перстная duodenum тощая jejunum подвздошная ileum последовательно переходят один в другой. Общая длина всей тонкой кишки 2244 м поперечник у начала т. Просвет кишки плавно сужается от ее начала и до конца что способствует более длительному пребыванию пищевой кашицы в ее полости.
76812. Двенадцатиперстная кишка 181.15 KB
  Голотопическая проекция кишки приходится на эпигастральную и околопупочную области. Строение стенки Слизистая оболочка с подслизистой основой образует циркулярные складки во всех отделах кишки. Топография кишки Двенадцатиперстная кишка располагается большей своей частью забрюшинно у задней брюшной стенки на уровне ХII грудного III поясничного позвонков проецируется на эпигастральную и околопупочную области.
76813. Брыжеечная часть тонкой кишки (тощая и подвздошная), строение, стенки, кровоснабжение, иннервация 185.11 KB
  Брыжеечная часть называется по наличию у тощей и подвздошной кишки брыжейки которая представляет собой двойной листок брюшины косо прикрепляющийся к задней брюшной стенке по линии слева направо от второго поясничного позвонка к правому...
76814. Толстая кишка 189.72 KB
  Железы кишки выделяют мало ферментов всасывание ограничивается изза отсутствия кишечных ворсинок. Отличительные анатомические признаки: продольные ленты – tenie coli: брыжеечная сальниковая свободная tenie mesocilic tenie omentlis tenie liber сформированные длинными гладкомышечными пучками; гаустры hustre coli поперечные вздутия с поперечными бороздами между ними образованные за счет перераспределения продольных и круговых мышц; сальниковые отростки ppendicis epiploice до 45 см длиной в виде пальцевидных выростов...