16421

Функции в Excel

Доклад

Информатика, кибернетика и программирование

Функции в Excel Использование стандартных функций значительно облегчает проведение вычислений в ЭТ После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ. В поставку EXCEL 2007 входит более 400 функций. Используя VBA м

Русский

2013-06-22

23.88 KB

5 чел.

Функции в Excel

Использование стандартных функций значительно облегчает проведение вычислений в ЭТ

После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ.

В поставку EXCEL 2007 входит более 400 функций. Используя VBA можно создавать свои функции.

1.         Формат стандартной функции:

Имя_Функции (Аргумент)

2.          Аргумент функции

Аргументом может быть:

1. Пустой аргумент () - СЕГОДНЯ().

2. Константа - КОРЕНЬ(124).

3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4).

4. Диапазон - СУММ(А3:А8).

5. Несколько аргументов -

а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46.

б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125).

6. Выражения - КОРЕНЬ(A1^2+A2^2).

7. Другие функции - SIN(РАДИАНЫ(В2)).

3.            Ввод функций

Функции могут использоваться самостоятельно и в составе выражений. Порядок ввода функций одинаковый.

1. Выделить ячейку, в которую вставляем функцию

2. Вставка  Функция или <fx> или <Shift + F3>

3. В поле Категория выбрать нужную категорию.

4. В поле Функция -функцию. ОК

Внизу диалогового окна появиться краткое описание этой функции. Если необходимо узнать подробнее, то вызвать справку (слева внизу).

5. В появившемся диалоговом окне ввести аргументы.

6. После выбора аргументов в нижней части диалогового окна будет виден результат. Если он правильный, то <ОК>.

7. Если аргументом функции должна быть другая функция, то щелкнуть в поле ввода аргумента и выбрать нужную функцию из списка.

4.            Основные функции

Название

Назначение

Действие

1. Математические – 50 штук

1. ЦЕЛОЕ

Определяет целую часть числа

=ЦЕЛОЕ(412,98)             –412

2. СЛЧИС

Определяет случайное число из [0,1)

=ЦЕЛОЕ(6*СЛЧИС()+1) –

опр. случайное число от 1 до 6

3. РИМСКОЕ

Преобразует число римское

=РИМСКОЕ(1998) –MCMXCVIII

4. ОКРУГЛ

Округляет значение до указанного количества десятичных разрядов

=ОКРУГЛ(123,456; 2)    – 123,46

=ОКРУГЛ(123,456; 1)    – 123,50

=ОКРУГЛ(123,456; -2)   – 100,00

5. ПИ

Число  – 14 знаков

6.SIN

Sin угла в радианах

7. КОРЕНЬ

Квадратный корень

Кубический корень – ^1/3

=КОРЕНЬ (А4+В4)

8.СУММ

Вычисляет сумму – до 30 аргументов кнопка <>

=СУММ(А1:А7; В1:В7; Е7; С12)


2. Статистические – 80 шт.

1. СРЗНАЧ

Определяет среднее значение

=СРЗНАЧ(А1:А12; С1:С12)

2. МИН

Определяет наименьшее знач.

=МИН(А3:С3; А8:С8)

3. МАКС

Определяет наибольшее знач.

=МАКС(А3:С3; А8:С8)

3. Текстовые – 23 шт.

1. ПРОПНАЧ

В словах первую букву делает прописной, а остальные – строчными.

=ПРОПНАЧ(ИВАНОВ И.И.)  

               Иванов И.И.

2. СИМВОЛ

Преобразует ANSI код в символ

=СИМВОЛ(169)                 –©

4. Дата и время – 14 шт.

1. СЕГОДНЯ

Вставляет сегодняшнюю дату

=СЕГОДНЯ()

2. ДЕНЬНЕД

Определяет день недели указанной даты

=ДЕНЬНЕД(Дата; код)

=ДЕНЬНЕД (СЕГОДНЯ();1)

3. ДЕНЬ

Выделяет день месяца из указанной даты

=ДЕНЬ(12.09.2006) – 12

=ДЕНЬ(СЕГОДНЯ())

3. МЕСЯЦ

Выделяет месяц

=МЕСЯЦ(12.09.2002) –9

3. ГОД

Выделяет год

=год(12.05.2006) – 2006

Значение второго параметра для функции ДЕНЬНЕД:

Тип

Возвращаемое число

1 или опущен

Число от 1 (воскресенье) до 7 (суббота).

2

Число от 1 (понедельник) до 7 (воскресенье)

3

Число от 0 (понедельник) до 6 (воскресенье)

5.             Пример использования функций ГОД и СЕГОДНЯ

Эти функции позволяют вычислять в таблице такие данные, как возраст человека по дате его рождения или стаж по дате поступления на работу.

Заполним такую таблицу:

А

В

С

ФИО

Дата

рождения

Возраст

1

Иванов И.И.

11.01.1980

28

2

Петров П.П.

20.05.1995

13

3

Сидоров С.С.

05.12.1999

8

В столбцы ФИО и Дата рождения вносим произвольные данные. Для вычисления возраста используется формула:

=(ГОД(СЕГОДНЯ()-B2)-1900)

Эта формула будет вычислять всегда правильное количество полных лет человека, т.к. для вычисления используется функция СЕГОДНЯ, которая в каждый конкретный момент времени использует текущую дату. (Таблица была составлена 25.08.08, при использовании этого примера позже 5.12.08 будут другие данные в столбце С)

Очень важным достоинством ЭТ является то, что при изменении значения в ячейке, которая участвует в формуле, автоматически это формула пересчитывается и в таблице появляется новый результат.

6.            Ошибки в формулах.

Значение

Описание

########

Получилось слишком длинное число – нужно увеличить ширину столбца или изменить формат ячейки

#ДЕЛ/0

Попытка деления на ноль

#ИМЯ?

В формуле используется несуществующее имя

#ЗНАЧ!

Введено арифметическое выражение, содержащее адрес ячейки с текстом

#ССЫЛКА!

Отсутствуют ячейки, адреса которых используются в формуле

#Н/Д

Нет данных для вычислений. Удобно использовать для резервирования данных под ожидаемые данные. Формула, содержащая адрес ячейки со значением #Н/Д, возвращает результат #Н/Д

#число!

Задан неправильный аргумент функции

#пусто!

В формуле используется пересечение диапазонов, не имеющих общих ячеек


 

А также другие работы, которые могут Вас заинтересовать

32988. ПРИРОДА И СУЩНОСТЬ НАУЧНЫХ РЕВОЛЮЦИЙ 23.48 KB
  Макс Планк старое поколение ученых не приживается к новым идеям однако они отходят от науки и умирают. компонентов науки. Есть микрореволюции в рамках той или иной науки физика биология экология; глобальные революции появление науки религии. философии проблема роста развития знания является центральной в философии науки.
32989. Общественное сознание и его структура 17.1 KB
  Конец формы Общественное сознание и его структура. Если сознание есть во многом продут социальный есть порождение общественных отношений то что такое общественные отношения общественное сознание Какова их структура Механизм работы И здесь наблюдаются определенные отличия индивидуального сознания и общественного сознания. Вопервых индивидуальное сознание имеет границы жизни обусловленные жизнью конкретного человека. Общественное же сознание может охватывать жизнь множества поколений.
32990. Структура общественного сознания и его основные формы 15.45 KB
  Обыденное и теоретическое сознание.Общественное сознание это совокупность идей взглядов и оценок свойственных данному обществу в осознании им собственного бытия.Индивидуальное сознание это совокупность идей взглядов чувств свойственных конкретному человеку.ОБЩЕСТВЕННОЕ СОЗНАНИЕ складывается на основе сознаний отдельных людей но не является их простой суммой.
32991. Философия истории 29.45 KB
  заключается ли он в самой ткани исторического события или он следствие нашей позднейшей его интерпретации Имеет ли история направление Кто является творцом истории Как возможно историческое событие Важнейшее отличие философии истории от истории состоит в том что если историю интересует причины определенных конкретных событий то философия истории анализирует общие закономерности исторического процесса в целом. в таких работах как “Экономическофилософские рукописи 1844 года†“Святое семействНемецкая идеология†а в...
32992. Марксистская концепция общественного развития 22.24 KB
  Подобно Гегелю марксисты рассматривают мировую историю как единый закономерный процесс а исторический материализм призван изучать наиболее общие законы развития человеческого общества. Естественно что вначале эти идеи выступали как гипотезы а затем по мере развития социальной науки сами основоположники и их последователи в первую очередь советские обществоведы превратили ее в хорошо структурированную и аргументированную социальную теорию. В своем основном труде Капитал Маркс осуществил детальный анализ капиталистического общества...
32993. Как выглядит цивилизационная модель философии истории Освальда Шпенглера 16.52 KB
  Ожидается как он полагал появление русскосибирской культуры. В основе каждой культуры лежит душа а культура это символическое тело жизненное воплощение этой души. Так непредсказуемое неспланированное рождение конкретной культуры он связывает с хаотическим проявлением таинственности душевной жизни. Зато поэтапное становление культуры проходящей как и человек свои возрастные ступени Шпенглер склонен связывать со спиралью.
32994. ТИПЫ СОЦИАЛЬНОЙ ДИНАМИКИ 41.62 KB
  Конт который и ввел этот термин в научный оборот подразумевал под ним однонаправленные поступательные процессы общественного развития исключающие скачки и перерывы. Между тем понятие социальная динамика отражает определенную и весьма существенную сторону общественного развития в целом. ЦИКЛИЧЕСКИЙ ТИП СОЦИАЛЬНОЙ ДИНАМИКИ В общественной жизни широко распространены циклические процессы имеющие собственную логику развития и специфические формы реализации. Они не могут быть сведены к случайным и кратковременным явлениям в наступательном...
32996. Интерфейс для офисного служащего 276.5 KB
  Выводится критерий для оценки качества интерфейса. Создается прототип интерфейса с шаблонами основных частозаполняемых документов для офисного служащего, удовлетворяющий полученному критерию. Проводится пилотный эксперимент для оценки работоспособности интерфейса.