16421

Функции в Excel

Доклад

Информатика, кибернетика и программирование

Функции в Excel Использование стандартных функций значительно облегчает проведение вычислений в ЭТ После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ. В поставку EXCEL 2007 входит более 400 функций. Используя VBA м

Русский

2013-06-22

23.88 KB

4 чел.

Функции в Excel

Использование стандартных функций значительно облегчает проведение вычислений в ЭТ

После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ.

В поставку EXCEL 2007 входит более 400 функций. Используя VBA можно создавать свои функции.

1.         Формат стандартной функции:

Имя_Функции (Аргумент)

2.          Аргумент функции

Аргументом может быть:

1. Пустой аргумент () - СЕГОДНЯ().

2. Константа - КОРЕНЬ(124).

3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4).

4. Диапазон - СУММ(А3:А8).

5. Несколько аргументов -

а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46.

б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125).

6. Выражения - КОРЕНЬ(A1^2+A2^2).

7. Другие функции - SIN(РАДИАНЫ(В2)).

3.            Ввод функций

Функции могут использоваться самостоятельно и в составе выражений. Порядок ввода функций одинаковый.

1. Выделить ячейку, в которую вставляем функцию

2. Вставка  Функция или <fx> или <Shift + F3>

3. В поле Категория выбрать нужную категорию.

4. В поле Функция -функцию. ОК

Внизу диалогового окна появиться краткое описание этой функции. Если необходимо узнать подробнее, то вызвать справку (слева внизу).

5. В появившемся диалоговом окне ввести аргументы.

6. После выбора аргументов в нижней части диалогового окна будет виден результат. Если он правильный, то <ОК>.

7. Если аргументом функции должна быть другая функция, то щелкнуть в поле ввода аргумента и выбрать нужную функцию из списка.

4.            Основные функции

Название

Назначение

Действие

1. Математические – 50 штук

1. ЦЕЛОЕ

Определяет целую часть числа

=ЦЕЛОЕ(412,98)             –412

2. СЛЧИС

Определяет случайное число из [0,1)

=ЦЕЛОЕ(6*СЛЧИС()+1) –

опр. случайное число от 1 до 6

3. РИМСКОЕ

Преобразует число римское

=РИМСКОЕ(1998) –MCMXCVIII

4. ОКРУГЛ

Округляет значение до указанного количества десятичных разрядов

=ОКРУГЛ(123,456; 2)    – 123,46

=ОКРУГЛ(123,456; 1)    – 123,50

=ОКРУГЛ(123,456; -2)   – 100,00

5. ПИ

Число  – 14 знаков

6.SIN

Sin угла в радианах

7. КОРЕНЬ

Квадратный корень

Кубический корень – ^1/3

=КОРЕНЬ (А4+В4)

8.СУММ

Вычисляет сумму – до 30 аргументов кнопка <>

=СУММ(А1:А7; В1:В7; Е7; С12)


2. Статистические – 80 шт.

1. СРЗНАЧ

Определяет среднее значение

=СРЗНАЧ(А1:А12; С1:С12)

2. МИН

Определяет наименьшее знач.

=МИН(А3:С3; А8:С8)

3. МАКС

Определяет наибольшее знач.

=МАКС(А3:С3; А8:С8)

3. Текстовые – 23 шт.

1. ПРОПНАЧ

В словах первую букву делает прописной, а остальные – строчными.

=ПРОПНАЧ(ИВАНОВ И.И.)  

               Иванов И.И.

2. СИМВОЛ

Преобразует ANSI код в символ

=СИМВОЛ(169)                 –©

4. Дата и время – 14 шт.

1. СЕГОДНЯ

Вставляет сегодняшнюю дату

=СЕГОДНЯ()

2. ДЕНЬНЕД

Определяет день недели указанной даты

=ДЕНЬНЕД(Дата; код)

=ДЕНЬНЕД (СЕГОДНЯ();1)

3. ДЕНЬ

Выделяет день месяца из указанной даты

=ДЕНЬ(12.09.2006) – 12

=ДЕНЬ(СЕГОДНЯ())

3. МЕСЯЦ

Выделяет месяц

=МЕСЯЦ(12.09.2002) –9

3. ГОД

Выделяет год

=год(12.05.2006) – 2006

Значение второго параметра для функции ДЕНЬНЕД:

Тип

Возвращаемое число

1 или опущен

Число от 1 (воскресенье) до 7 (суббота).

2

Число от 1 (понедельник) до 7 (воскресенье)

3

Число от 0 (понедельник) до 6 (воскресенье)

5.             Пример использования функций ГОД и СЕГОДНЯ

Эти функции позволяют вычислять в таблице такие данные, как возраст человека по дате его рождения или стаж по дате поступления на работу.

Заполним такую таблицу:

А

В

С

ФИО

Дата

рождения

Возраст

1

Иванов И.И.

11.01.1980

28

2

Петров П.П.

20.05.1995

13

3

Сидоров С.С.

05.12.1999

8

В столбцы ФИО и Дата рождения вносим произвольные данные. Для вычисления возраста используется формула:

=(ГОД(СЕГОДНЯ()-B2)-1900)

Эта формула будет вычислять всегда правильное количество полных лет человека, т.к. для вычисления используется функция СЕГОДНЯ, которая в каждый конкретный момент времени использует текущую дату. (Таблица была составлена 25.08.08, при использовании этого примера позже 5.12.08 будут другие данные в столбце С)

Очень важным достоинством ЭТ является то, что при изменении значения в ячейке, которая участвует в формуле, автоматически это формула пересчитывается и в таблице появляется новый результат.

6.            Ошибки в формулах.

Значение

Описание

########

Получилось слишком длинное число – нужно увеличить ширину столбца или изменить формат ячейки

#ДЕЛ/0

Попытка деления на ноль

#ИМЯ?

В формуле используется несуществующее имя

#ЗНАЧ!

Введено арифметическое выражение, содержащее адрес ячейки с текстом

#ССЫЛКА!

Отсутствуют ячейки, адреса которых используются в формуле

#Н/Д

Нет данных для вычислений. Удобно использовать для резервирования данных под ожидаемые данные. Формула, содержащая адрес ячейки со значением #Н/Д, возвращает результат #Н/Д

#число!

Задан неправильный аргумент функции

#пусто!

В формуле используется пересечение диапазонов, не имеющих общих ячеек


 

А также другие работы, которые могут Вас заинтересовать

40586. Методология функционального моделирования SADT. Состав и функции моделей SADT 61.84 KB
  Состав и функции моделей SDT. Взаимодействие блоков друг с другом описываются посредством интерфейсных дуг выражающих ограничения которые в свою очередь определяют когда и каким образом функции выполняются и управляются; строгость и точность. отделение организации от функции т. Методология SDT может использоваться для моделирования широкого круга систем и определения требований и функций а затем для разработки системы которая удовлетворяет этим требованиям и реализует эти функции.
40587. Методология функционального моделирования SADT. Состав и функции моделей SADT. Типы связей 40.5 KB
  Вендрова Проектирование ПО Ход урока Организационный момент 24 мин: Приветствие оформление документов к занятию Повторение пройденного материала применяемая методика выводы1520 минзанятие 22 п.5 Сообщение темы урока постановка цели и задачи:13 мин: Методология функционального моделирования SDT; Состав и функции моделей SDT. Изложение нового материала применяемая методика: 5060 мин. лекция: Состав функциональной модели Иерархия диаграмм Типы связей между функциями Моделирование потоков данных процессов...
40588. Психологические особенности профессионального общения сотрудников ОВД 92 KB
  Чтобы профессиональное общение сотрудника ОВД было эффективным и успешным, он обязан разбираться в психологии общения, обладать умением делать выводы на основании фактов и собственных наблюдений.
40589. Создание SADT-диаграмм по произвольным проектам 48 KB
  Организационный момент 23 мин: Приветствие фиксация отсутствующих проверка санитарного состояния аудитории заполнение журнала рапортички проверка подготовленности студентов к занятию. Напоминание правил техники безопасности при работе с ПК; 2. Сообщение темы цели и задач практикума 23 мин: Цели: Приобретение навыков создания SDT моделей по методологии IDEF0. Актуализация опорных знаний и умений студентов 1015 мин: устный опрос занятие 24 п.
40590. Метод моделирования IDEF1 35.48 KB
  Сущность в методологии IDEF1X является независимой от идентификаторов или просто независимой если каждый экземпляр сущности может быть однозначно идентифицирован без определения его отношений с другими сущностями. Сущность называется зависимой от идентификаторов или просто зависимой если однозначная идентификация экземпляра сущности зависит от его отношения к другой сущности рисунок 1. Сущности Каждой сущности присваивается уникальное имя и номер разделяемые косой чертой и помещаемые над блоком. Связь может дополнительно определяться с...
40591. Создание ERD диаграмм методом IDEF I 48.5 KB
  Организационный момент 23 мин: Приветствие фиксация отсутствующих проверка санитарного состояния аудитории заполнение журнала рапортички проверка подготовленности студентов к занятию. Напоминание правил техники безопасности при работе с ПК; 2. Сообщение темы цели и задач практикума 23 мин: Цели: Приобретение навыков создания SDT моделей по методологии IDEF0. Актуализация опорных знаний и умений студентов 1015 мин: устный опрос занятие 27 п.
40592. Сущность объектно-ориентированного подхода 16.76 KB
  Объектноориентированный подход использует объектную декомпозицию при этом статическая структура системы описывается в терминах объектов и связей между ними а поведение системы описывается в терминах обмена сообщениями между объектами. Каждый объект системы обладает своим собственным поведением моделирующим поведение объекта реального мира. Абстрагирование это выделение существенных характеристик некоторого объекта которые отличают его от всех других видов объектов и таким образом четко определяют его концептуальные границы...
40593. Унифицированный язык UML 17.75 KB
  Например нотация диаграммы классов определяет каким образом представляются такие элементы и понятия как класс ассоциация и множественность. Определение классов и объектов одна из самых сложных задач объектноориентированного проектирования. Наследование означает построение новых классов на основе существующих с возможностью добавления или переопределения данных и методов. Наследование и полиморфизм обеспечивают возможность определения новой функциональности классов с помощью создания производных классов потомков базовых классов.
40594. Диаграммы вариантов использования 52.06 KB
  Суть диаграммы вариантов использования состоит в следующем. Проектируемая система представляется в виде множества сущностей или актеров взаимодействующих с системой с помощью вариантов использования. Вариант использования служит для описания сервисов которые система предоставляет актеру.