16421

Функции в Excel

Доклад

Информатика, кибернетика и программирование

Функции в Excel Использование стандартных функций значительно облегчает проведение вычислений в ЭТ После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ. В поставку EXCEL 2007 входит более 400 функций. Используя VBA м

Русский

2013-06-22

23.88 KB

5 чел.

Функции в Excel

Использование стандартных функций значительно облегчает проведение вычислений в ЭТ

После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ.

В поставку EXCEL 2007 входит более 400 функций. Используя VBA можно создавать свои функции.

1.         Формат стандартной функции:

Имя_Функции (Аргумент)

2.          Аргумент функции

Аргументом может быть:

1. Пустой аргумент () - СЕГОДНЯ().

2. Константа - КОРЕНЬ(124).

3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4).

4. Диапазон - СУММ(А3:А8).

5. Несколько аргументов -

а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46.

б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125).

6. Выражения - КОРЕНЬ(A1^2+A2^2).

7. Другие функции - SIN(РАДИАНЫ(В2)).

3.            Ввод функций

Функции могут использоваться самостоятельно и в составе выражений. Порядок ввода функций одинаковый.

1. Выделить ячейку, в которую вставляем функцию

2. Вставка  Функция или <fx> или <Shift + F3>

3. В поле Категория выбрать нужную категорию.

4. В поле Функция -функцию. ОК

Внизу диалогового окна появиться краткое описание этой функции. Если необходимо узнать подробнее, то вызвать справку (слева внизу).

5. В появившемся диалоговом окне ввести аргументы.

6. После выбора аргументов в нижней части диалогового окна будет виден результат. Если он правильный, то <ОК>.

7. Если аргументом функции должна быть другая функция, то щелкнуть в поле ввода аргумента и выбрать нужную функцию из списка.

4.            Основные функции

Название

Назначение

Действие

1. Математические – 50 штук

1. ЦЕЛОЕ

Определяет целую часть числа

=ЦЕЛОЕ(412,98)             –412

2. СЛЧИС

Определяет случайное число из [0,1)

=ЦЕЛОЕ(6*СЛЧИС()+1) –

опр. случайное число от 1 до 6

3. РИМСКОЕ

Преобразует число римское

=РИМСКОЕ(1998) –MCMXCVIII

4. ОКРУГЛ

Округляет значение до указанного количества десятичных разрядов

=ОКРУГЛ(123,456; 2)    – 123,46

=ОКРУГЛ(123,456; 1)    – 123,50

=ОКРУГЛ(123,456; -2)   – 100,00

5. ПИ

Число  – 14 знаков

6.SIN

Sin угла в радианах

7. КОРЕНЬ

Квадратный корень

Кубический корень – ^1/3

=КОРЕНЬ (А4+В4)

8.СУММ

Вычисляет сумму – до 30 аргументов кнопка <>

=СУММ(А1:А7; В1:В7; Е7; С12)


2. Статистические – 80 шт.

1. СРЗНАЧ

Определяет среднее значение

=СРЗНАЧ(А1:А12; С1:С12)

2. МИН

Определяет наименьшее знач.

=МИН(А3:С3; А8:С8)

3. МАКС

Определяет наибольшее знач.

=МАКС(А3:С3; А8:С8)

3. Текстовые – 23 шт.

1. ПРОПНАЧ

В словах первую букву делает прописной, а остальные – строчными.

=ПРОПНАЧ(ИВАНОВ И.И.)  

               Иванов И.И.

2. СИМВОЛ

Преобразует ANSI код в символ

=СИМВОЛ(169)                 –©

4. Дата и время – 14 шт.

1. СЕГОДНЯ

Вставляет сегодняшнюю дату

=СЕГОДНЯ()

2. ДЕНЬНЕД

Определяет день недели указанной даты

=ДЕНЬНЕД(Дата; код)

=ДЕНЬНЕД (СЕГОДНЯ();1)

3. ДЕНЬ

Выделяет день месяца из указанной даты

=ДЕНЬ(12.09.2006) – 12

=ДЕНЬ(СЕГОДНЯ())

3. МЕСЯЦ

Выделяет месяц

=МЕСЯЦ(12.09.2002) –9

3. ГОД

Выделяет год

=год(12.05.2006) – 2006

Значение второго параметра для функции ДЕНЬНЕД:

Тип

Возвращаемое число

1 или опущен

Число от 1 (воскресенье) до 7 (суббота).

2

Число от 1 (понедельник) до 7 (воскресенье)

3

Число от 0 (понедельник) до 6 (воскресенье)

5.             Пример использования функций ГОД и СЕГОДНЯ

Эти функции позволяют вычислять в таблице такие данные, как возраст человека по дате его рождения или стаж по дате поступления на работу.

Заполним такую таблицу:

А

В

С

ФИО

Дата

рождения

Возраст

1

Иванов И.И.

11.01.1980

28

2

Петров П.П.

20.05.1995

13

3

Сидоров С.С.

05.12.1999

8

В столбцы ФИО и Дата рождения вносим произвольные данные. Для вычисления возраста используется формула:

=(ГОД(СЕГОДНЯ()-B2)-1900)

Эта формула будет вычислять всегда правильное количество полных лет человека, т.к. для вычисления используется функция СЕГОДНЯ, которая в каждый конкретный момент времени использует текущую дату. (Таблица была составлена 25.08.08, при использовании этого примера позже 5.12.08 будут другие данные в столбце С)

Очень важным достоинством ЭТ является то, что при изменении значения в ячейке, которая участвует в формуле, автоматически это формула пересчитывается и в таблице появляется новый результат.

6.            Ошибки в формулах.

Значение

Описание

########

Получилось слишком длинное число – нужно увеличить ширину столбца или изменить формат ячейки

#ДЕЛ/0

Попытка деления на ноль

#ИМЯ?

В формуле используется несуществующее имя

#ЗНАЧ!

Введено арифметическое выражение, содержащее адрес ячейки с текстом

#ССЫЛКА!

Отсутствуют ячейки, адреса которых используются в формуле

#Н/Д

Нет данных для вычислений. Удобно использовать для резервирования данных под ожидаемые данные. Формула, содержащая адрес ячейки со значением #Н/Д, возвращает результат #Н/Д

#число!

Задан неправильный аргумент функции

#пусто!

В формуле используется пересечение диапазонов, не имеющих общих ячеек


 

А также другие работы, которые могут Вас заинтересовать

19891. Судовий розгляд кримінальної справи 49.77 KB
  ТЕМА 17: Судовий розгляд кримінальної справи 1. Загальні положення судового розгляду. 2. Підготовча частина судового засідання. 3. Судове слідство 4. Судові дебати та останнє слово підсудного. 5. Постановлення вироку. 1. Загальні положення судового розгляду Судови...
19892. Провадження справ у апеляційній інстанції 48.86 KB
  ТЕМА 18: Провадження справ у апеляційній інстанції План 1. Суть завдання та основні риси апеляційного провадження. 2. Суб'єкти процесуальний порядок і строки розгляду в суді кримінальних справ у апеляційному провадженні. 3. Скасування зміна вироку ухвали постанови ...
19893. Застосування примусових заходів медичного характеру 28.32 KB
  ТЕМА 19: Застосування примусових заходів медичного характеру План 1. Поняття примусових заходів медичного характеру та їх види 2. Процесуальний порядок провадження досудового слідства в справах про діяння неосудних або обмежено осудних осіб 3. Особливості судового
19894. Протокольна форма досудової підготовки матеріалів 27.85 KB
  ТЕМА 20: Протокольна форма досудової підготовки матеріалів План 1. Сутність протокольної форми досудової підготовки матеріалів. 2. Порядок оформлення протокольної форми досудової підготовки матеріалів органами внутрішніх справ. 3. Процесуальний порядок провадження...
19895. Провадження у справах про злочини неповнолітніх 41.7 KB
  ТЕМА 21: Провадження у справах про злочини неповнолітніх План 1. Особливості провадження у кримінальних справах про злочини неповнолітніх. 2. Предмет доказування у справах про злочини неповнолітніх. 3. Особливості провадження досудового і судового слідства у справах ...
19896. Поняття і система інвестиційного права 78 KB
  Лекція № 1. Тема : Поняття і система інвестиційного права. Мета: Ознайомлення студентів з поняттям функціями та системою інвестиційного права місцем інвестиційного права в системі права України. План 1. Місце інвестиційного права в системі права України. 2. По...
19897. Поняття інвестиційної діяльності 104.5 KB
  Лекція № 2. Тема 2: Поняття інвестиційної діяльності Мета: ознайомлення студентів з основами інвестиційної діяльності структурою інвестиційної діяльності поняттям інвестиційного клімату держави План 1. Поняття та класифікація інвестицій. Поняття інвестицій
19898. Правове регулювання фінансових інвестицій 97 KB
  Лекція № 3. Тема : Правове регулювання фінансових інвестицій. Мета: ознайомлення студентів з поняттям фінансові інвестиції основними цінними паперами основами управління інвестиційним портфелем План 1. Загальна характеристика фондового ринку в Україні. 2. Пра
19899. Субєкти інвестиційної діяльності 99 KB
  Лекція № 4. Тема 4: Суб'єкти інвестиційної діяльності. Мета: вивчення кола субєктів інвестиційної діяльності форми діяльності суб'єктів інвестиційної діяльності. План 1. Держава як суб'єкт інвестиційної діяльності. 2. Інвестиційний фонд компанія та довірчі то