16421

Функции в Excel

Доклад

Информатика, кибернетика и программирование

Функции в Excel Использование стандартных функций значительно облегчает проведение вычислений в ЭТ После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ. В поставку EXCEL 2007 входит более 400 функций. Используя VBA м

Русский

2013-06-22

23.88 KB

5 чел.

Функции в Excel

Использование стандартных функций значительно облегчает проведение вычислений в ЭТ

После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ.

В поставку EXCEL 2007 входит более 400 функций. Используя VBA можно создавать свои функции.

1.         Формат стандартной функции:

Имя_Функции (Аргумент)

2.          Аргумент функции

Аргументом может быть:

1. Пустой аргумент () - СЕГОДНЯ().

2. Константа - КОРЕНЬ(124).

3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4).

4. Диапазон - СУММ(А3:А8).

5. Несколько аргументов -

а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46.

б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125).

6. Выражения - КОРЕНЬ(A1^2+A2^2).

7. Другие функции - SIN(РАДИАНЫ(В2)).

3.            Ввод функций

Функции могут использоваться самостоятельно и в составе выражений. Порядок ввода функций одинаковый.

1. Выделить ячейку, в которую вставляем функцию

2. Вставка  Функция или <fx> или <Shift + F3>

3. В поле Категория выбрать нужную категорию.

4. В поле Функция -функцию. ОК

Внизу диалогового окна появиться краткое описание этой функции. Если необходимо узнать подробнее, то вызвать справку (слева внизу).

5. В появившемся диалоговом окне ввести аргументы.

6. После выбора аргументов в нижней части диалогового окна будет виден результат. Если он правильный, то <ОК>.

7. Если аргументом функции должна быть другая функция, то щелкнуть в поле ввода аргумента и выбрать нужную функцию из списка.

4.            Основные функции

Название

Назначение

Действие

1. Математические – 50 штук

1. ЦЕЛОЕ

Определяет целую часть числа

=ЦЕЛОЕ(412,98)             –412

2. СЛЧИС

Определяет случайное число из [0,1)

=ЦЕЛОЕ(6*СЛЧИС()+1) –

опр. случайное число от 1 до 6

3. РИМСКОЕ

Преобразует число римское

=РИМСКОЕ(1998) –MCMXCVIII

4. ОКРУГЛ

Округляет значение до указанного количества десятичных разрядов

=ОКРУГЛ(123,456; 2)    – 123,46

=ОКРУГЛ(123,456; 1)    – 123,50

=ОКРУГЛ(123,456; -2)   – 100,00

5. ПИ

Число  – 14 знаков

6.SIN

Sin угла в радианах

7. КОРЕНЬ

Квадратный корень

Кубический корень – ^1/3

=КОРЕНЬ (А4+В4)

8.СУММ

Вычисляет сумму – до 30 аргументов кнопка <>

=СУММ(А1:А7; В1:В7; Е7; С12)


2. Статистические – 80 шт.

1. СРЗНАЧ

Определяет среднее значение

=СРЗНАЧ(А1:А12; С1:С12)

2. МИН

Определяет наименьшее знач.

=МИН(А3:С3; А8:С8)

3. МАКС

Определяет наибольшее знач.

=МАКС(А3:С3; А8:С8)

3. Текстовые – 23 шт.

1. ПРОПНАЧ

В словах первую букву делает прописной, а остальные – строчными.

=ПРОПНАЧ(ИВАНОВ И.И.)  

               Иванов И.И.

2. СИМВОЛ

Преобразует ANSI код в символ

=СИМВОЛ(169)                 –©

4. Дата и время – 14 шт.

1. СЕГОДНЯ

Вставляет сегодняшнюю дату

=СЕГОДНЯ()

2. ДЕНЬНЕД

Определяет день недели указанной даты

=ДЕНЬНЕД(Дата; код)

=ДЕНЬНЕД (СЕГОДНЯ();1)

3. ДЕНЬ

Выделяет день месяца из указанной даты

=ДЕНЬ(12.09.2006) – 12

=ДЕНЬ(СЕГОДНЯ())

3. МЕСЯЦ

Выделяет месяц

=МЕСЯЦ(12.09.2002) –9

3. ГОД

Выделяет год

=год(12.05.2006) – 2006

Значение второго параметра для функции ДЕНЬНЕД:

Тип

Возвращаемое число

1 или опущен

Число от 1 (воскресенье) до 7 (суббота).

2

Число от 1 (понедельник) до 7 (воскресенье)

3

Число от 0 (понедельник) до 6 (воскресенье)

5.             Пример использования функций ГОД и СЕГОДНЯ

Эти функции позволяют вычислять в таблице такие данные, как возраст человека по дате его рождения или стаж по дате поступления на работу.

Заполним такую таблицу:

А

В

С

ФИО

Дата

рождения

Возраст

1

Иванов И.И.

11.01.1980

28

2

Петров П.П.

20.05.1995

13

3

Сидоров С.С.

05.12.1999

8

В столбцы ФИО и Дата рождения вносим произвольные данные. Для вычисления возраста используется формула:

=(ГОД(СЕГОДНЯ()-B2)-1900)

Эта формула будет вычислять всегда правильное количество полных лет человека, т.к. для вычисления используется функция СЕГОДНЯ, которая в каждый конкретный момент времени использует текущую дату. (Таблица была составлена 25.08.08, при использовании этого примера позже 5.12.08 будут другие данные в столбце С)

Очень важным достоинством ЭТ является то, что при изменении значения в ячейке, которая участвует в формуле, автоматически это формула пересчитывается и в таблице появляется новый результат.

6.            Ошибки в формулах.

Значение

Описание

########

Получилось слишком длинное число – нужно увеличить ширину столбца или изменить формат ячейки

#ДЕЛ/0

Попытка деления на ноль

#ИМЯ?

В формуле используется несуществующее имя

#ЗНАЧ!

Введено арифметическое выражение, содержащее адрес ячейки с текстом

#ССЫЛКА!

Отсутствуют ячейки, адреса которых используются в формуле

#Н/Д

Нет данных для вычислений. Удобно использовать для резервирования данных под ожидаемые данные. Формула, содержащая адрес ячейки со значением #Н/Д, возвращает результат #Н/Д

#число!

Задан неправильный аргумент функции

#пусто!

В формуле используется пересечение диапазонов, не имеющих общих ячеек


 

А также другие работы, которые могут Вас заинтересовать

83994. Прислівник. Узагальнення знань і вмінь з вивченої теми 64.5 KB
  Вчити правильно вживати у мовленні використовувати прислівники у самостійно складених текстах. Прислівники у реченні повязані з: А Іменниками; Б Прикметниками; В Дієсловами. У реченні прислівники виконують роль: А Головних членів; Б Другорядних членів.
83995. Форми давального і місцевого відмінків прикметників жіночого роду 45.5 KB
  Мета. Вчити дітей розрізняти в реченнях форми прикметників жіночого роду в давальному і місцевому відмінках правильно вимовляти і писати ці форми користуючись правилом; розвивати звязне висловлювання учнів; виховувати любов до рідної землі шанобливе ставлення до української мови.
83996. Власні і загальні іменники. Велика буква у власних іменниках 47.5 KB
  Мета: навчити дітей записувати географічні назви з великої літери; ознайомити учнів шляхом уявної подорожі з деякими країнами; розвивати навички правильного каліграфічного письма уміння складати повні відповіді на запитання; виховати бажання дізнаватись про щось нове...
83997. Закріплення і систематизація знань про граматичні ознаки дієслова 61.5 KB
  Удосконалювати вміння розпізнавати часові форми дієслова. Виробляти навички правопису особових закінчень дієслова. Що таке дієслово Як змінюється дієслово Які часи мають дієслова Як змінюються дієслова минулого часу Яким членом речення найчастіше дієслово виступає в реченні...
83998. Закріплення вивченого матеріалу про частини мови 57 KB
  Мета: Систематизувати і закріпити знання дітей про частини мови. Виховувати почуття любові до рідного краю до української мови. Тож і ми часу не гаймо Урок мови починаймо Девіз уроку: Мову рідну я вивчаю Її люблю не забуваю.
83999. Розвиток зв’язного мовлення. Твір-розповідь з елементами опису. Опис калини 105 KB
  Мета: формування в учнів навички вільного володіння рідною мовою, сприяти розширенню їх словникового запасу; розвивати зв’язне мовлення учнів, уміння порівнювати і зіставляти; розширити знання дітей про калину, як рослину-символ України;виховувати любов до рідного слова...
84000. Узагальнення вивченого про прислівник 44 KB
  Мета: вдосконалювати вміння розпізнавати прислівники в усному і писемному мовленні. Розвивати вміння використовувати прислівники у текстах визначати їх роль; розвивати здатність учнів до взаємодії мовне чуття мислення увагу пам’ять; виховувати самостійність старанність наполегливість...
84001. Колективне складання текстів різного типу про осінь 207 KB
  Учитель читає вірш: Лоскоче душу промінь золотавий Убравши пишно парки і ліси Йде краєм осінь Туман ранковий стелиться над ставом І лине сум прощальної краси. звучить тиха мелодія і на дошці розміщені ілюстрації осені в природі Скажіть хто створює цю красу Так осінь.
84002. Вживання прикметників у прямому і переносному значенні 39.5 KB
  Мета: Формувати вміння розрізняти прикметники вжиті в прямому і переносному значенні; закріплювати знання про прикметники Їхню роль у тексті; розвивати інтерес до усної народної творчості; збагачувати словниковий запас учнів; виховувати любов до рідної мови.