16421

Функции в Excel

Доклад

Информатика, кибернетика и программирование

Функции в Excel Использование стандартных функций значительно облегчает проведение вычислений в ЭТ После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ. В поставку EXCEL 2007 входит более 400 функций. Используя VBA м

Русский

2013-06-22

23.88 KB

5 чел.

Функции в Excel

Использование стандартных функций значительно облегчает проведение вычислений в ЭТ

После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ.

В поставку EXCEL 2007 входит более 400 функций. Используя VBA можно создавать свои функции.

1.         Формат стандартной функции:

Имя_Функции (Аргумент)

2.          Аргумент функции

Аргументом может быть:

1. Пустой аргумент () - СЕГОДНЯ().

2. Константа - КОРЕНЬ(124).

3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4).

4. Диапазон - СУММ(А3:А8).

5. Несколько аргументов -

а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46.

б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125).

6. Выражения - КОРЕНЬ(A1^2+A2^2).

7. Другие функции - SIN(РАДИАНЫ(В2)).

3.            Ввод функций

Функции могут использоваться самостоятельно и в составе выражений. Порядок ввода функций одинаковый.

1. Выделить ячейку, в которую вставляем функцию

2. Вставка  Функция или <fx> или <Shift + F3>

3. В поле Категория выбрать нужную категорию.

4. В поле Функция -функцию. ОК

Внизу диалогового окна появиться краткое описание этой функции. Если необходимо узнать подробнее, то вызвать справку (слева внизу).

5. В появившемся диалоговом окне ввести аргументы.

6. После выбора аргументов в нижней части диалогового окна будет виден результат. Если он правильный, то <ОК>.

7. Если аргументом функции должна быть другая функция, то щелкнуть в поле ввода аргумента и выбрать нужную функцию из списка.

4.            Основные функции

Название

Назначение

Действие

1. Математические – 50 штук

1. ЦЕЛОЕ

Определяет целую часть числа

=ЦЕЛОЕ(412,98)             –412

2. СЛЧИС

Определяет случайное число из [0,1)

=ЦЕЛОЕ(6*СЛЧИС()+1) –

опр. случайное число от 1 до 6

3. РИМСКОЕ

Преобразует число римское

=РИМСКОЕ(1998) –MCMXCVIII

4. ОКРУГЛ

Округляет значение до указанного количества десятичных разрядов

=ОКРУГЛ(123,456; 2)    – 123,46

=ОКРУГЛ(123,456; 1)    – 123,50

=ОКРУГЛ(123,456; -2)   – 100,00

5. ПИ

Число  – 14 знаков

6.SIN

Sin угла в радианах

7. КОРЕНЬ

Квадратный корень

Кубический корень – ^1/3

=КОРЕНЬ (А4+В4)

8.СУММ

Вычисляет сумму – до 30 аргументов кнопка <>

=СУММ(А1:А7; В1:В7; Е7; С12)


2. Статистические – 80 шт.

1. СРЗНАЧ

Определяет среднее значение

=СРЗНАЧ(А1:А12; С1:С12)

2. МИН

Определяет наименьшее знач.

=МИН(А3:С3; А8:С8)

3. МАКС

Определяет наибольшее знач.

=МАКС(А3:С3; А8:С8)

3. Текстовые – 23 шт.

1. ПРОПНАЧ

В словах первую букву делает прописной, а остальные – строчными.

=ПРОПНАЧ(ИВАНОВ И.И.)  

               Иванов И.И.

2. СИМВОЛ

Преобразует ANSI код в символ

=СИМВОЛ(169)                 –©

4. Дата и время – 14 шт.

1. СЕГОДНЯ

Вставляет сегодняшнюю дату

=СЕГОДНЯ()

2. ДЕНЬНЕД

Определяет день недели указанной даты

=ДЕНЬНЕД(Дата; код)

=ДЕНЬНЕД (СЕГОДНЯ();1)

3. ДЕНЬ

Выделяет день месяца из указанной даты

=ДЕНЬ(12.09.2006) – 12

=ДЕНЬ(СЕГОДНЯ())

3. МЕСЯЦ

Выделяет месяц

=МЕСЯЦ(12.09.2002) –9

3. ГОД

Выделяет год

=год(12.05.2006) – 2006

Значение второго параметра для функции ДЕНЬНЕД:

Тип

Возвращаемое число

1 или опущен

Число от 1 (воскресенье) до 7 (суббота).

2

Число от 1 (понедельник) до 7 (воскресенье)

3

Число от 0 (понедельник) до 6 (воскресенье)

5.             Пример использования функций ГОД и СЕГОДНЯ

Эти функции позволяют вычислять в таблице такие данные, как возраст человека по дате его рождения или стаж по дате поступления на работу.

Заполним такую таблицу:

А

В

С

ФИО

Дата

рождения

Возраст

1

Иванов И.И.

11.01.1980

28

2

Петров П.П.

20.05.1995

13

3

Сидоров С.С.

05.12.1999

8

В столбцы ФИО и Дата рождения вносим произвольные данные. Для вычисления возраста используется формула:

=(ГОД(СЕГОДНЯ()-B2)-1900)

Эта формула будет вычислять всегда правильное количество полных лет человека, т.к. для вычисления используется функция СЕГОДНЯ, которая в каждый конкретный момент времени использует текущую дату. (Таблица была составлена 25.08.08, при использовании этого примера позже 5.12.08 будут другие данные в столбце С)

Очень важным достоинством ЭТ является то, что при изменении значения в ячейке, которая участвует в формуле, автоматически это формула пересчитывается и в таблице появляется новый результат.

6.            Ошибки в формулах.

Значение

Описание

########

Получилось слишком длинное число – нужно увеличить ширину столбца или изменить формат ячейки

#ДЕЛ/0

Попытка деления на ноль

#ИМЯ?

В формуле используется несуществующее имя

#ЗНАЧ!

Введено арифметическое выражение, содержащее адрес ячейки с текстом

#ССЫЛКА!

Отсутствуют ячейки, адреса которых используются в формуле

#Н/Д

Нет данных для вычислений. Удобно использовать для резервирования данных под ожидаемые данные. Формула, содержащая адрес ячейки со значением #Н/Д, возвращает результат #Н/Д

#число!

Задан неправильный аргумент функции

#пусто!

В формуле используется пересечение диапазонов, не имеющих общих ячеек


 

А также другие работы, которые могут Вас заинтересовать

14177. Маркетинг предприятий розничной торговли ТОО «Капан» ВКО г. Аягоза 273.5 KB
  Дипломная работа на тему: Маркетинг предприятий розничной торговли ТОО Капан ВКО г. Аягоза Студент: Капанов Б. К. Научный руководитель: Темиргалиева Ф. Э. Содержание Введение Глава 1. Маркетинговый анализ лекарственных препаратов на фармацевтическ...
14178. Анализ методики и организации учета и анализа товарооборота в розничной торговле на примере ООО Торгового дома «Агат» 578.5 KB
  Целью данной дипломной работы является изучение существующей методики и организации учета и анализа товарооборота в розничной торговле на примере ООО Торгового дома «Агат».
14179. Обзор рынка страхования в Российской Федерации на современном этапе, агрострахование 674.5 KB
  Содержание Введение 1. ТЕОРЕТИЧЕСКИЕ ОСНОВЫ СТРАХОВАНИЯ 1.1 Сущность и функции страхования 1.2 Обзор рынка страхования в Российской Федерации на современном этапе 1.3 Правовое регулирование в сфере страхования 2. Организационноэкономическая характеристика хозя...
14180. ОБЩИЕ ТРЕБОВАНИЯ К РЕКЛАМЕ 114.96 KB
  ОБЩИЕ ТРЕБОВАНИЯ К РЕКЛАМЕ ОГЛАВЛЕНИЕ Ведение Глава 1. Основные требования к рекламе. Ненадлежащая реклама 1.1. Понятие рекламы как объекта информационных правоотношений 1.2. Перечень общих требований к рекламе 1.3. Недобросовестная и недостоверная реклама 1.4. О...
14181. Особенности, формы и предпосылки развития государственного предпринимательства Таймырский округ 522.5 KB
  Особенности развития предпринимательской деятельности Администрации муниципального образования (на примере Таймырского Долгано-Ненецкого муниципального района). Анализ предпринимательской деятельности Администрации Таймырского Долгано-Ненецкого муниципального района
14182. Оценка предпринимательских рисков и методы их снижения на примере ООО «ТД «Евронорд» 460 KB
  Оценка предпринимательских рисков и методы их снижения на примере ООО ТД Евронорд Содержание Введение 1 Институциальные аспекты управления риском 1.1 Сущность содержание и виды рисков 1.2 Приемы и методы управления риском 1.3 Процесс управления рисками на п...
14183. Предоставление земельного участка для строительства в населенных пунктах 279.5 KB
  Оглавление [1] Введение [2] Глава 1. Теоретические и правовые основы регулирования отношений по предоставлению земельного участка в аренду [2.1] 1. Общая характеристика объекта земельных правоотношений по предоставлению земельных у
14184. Принципы гражданского процессуального права 399.5 KB
  Объектом исследования выступают принципы гражданско-процессуального права. Предметом работы выступают нормы гражданско-процессуального законодательства. Цель работы выступает анализ принципов гражданско-процессуального права
14185. Пути и методы снижения рисков в предпринимательской деятельности на примере транспортного предприятия 957 KB
  Реферат Объём пояснительной записки 104 стр. рис.30 табл.34 источников 42. Тема: Пути и методы снижения рисков в предпринимательской деятельности на примере ТПЧУП СифудСеврис Ключевые слова: риск управление рисками минимизация рисков финан