16421

Функции в Excel

Доклад

Информатика, кибернетика и программирование

Функции в Excel Использование стандартных функций значительно облегчает проведение вычислений в ЭТ После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ. В поставку EXCEL 2007 входит более 400 функций. Используя VBA м

Русский

2013-06-22

23.88 KB

5 чел.

Функции в Excel

Использование стандартных функций значительно облегчает проведение вычислений в ЭТ

После этого урока вы сможете использовать стандартные функции для проведения более сложных вычислений в ЭТ.

В поставку EXCEL 2007 входит более 400 функций. Используя VBA можно создавать свои функции.

1.         Формат стандартной функции:

Имя_Функции (Аргумент)

2.          Аргумент функции

Аргументом может быть:

1. Пустой аргумент () - СЕГОДНЯ().

2. Константа - КОРЕНЬ(124).

3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4).

4. Диапазон - СУММ(А3:А8).

5. Несколько аргументов -

а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46.

б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125).

6. Выражения - КОРЕНЬ(A1^2+A2^2).

7. Другие функции - SIN(РАДИАНЫ(В2)).

3.            Ввод функций

Функции могут использоваться самостоятельно и в составе выражений. Порядок ввода функций одинаковый.

1. Выделить ячейку, в которую вставляем функцию

2. Вставка  Функция или <fx> или <Shift + F3>

3. В поле Категория выбрать нужную категорию.

4. В поле Функция -функцию. ОК

Внизу диалогового окна появиться краткое описание этой функции. Если необходимо узнать подробнее, то вызвать справку (слева внизу).

5. В появившемся диалоговом окне ввести аргументы.

6. После выбора аргументов в нижней части диалогового окна будет виден результат. Если он правильный, то <ОК>.

7. Если аргументом функции должна быть другая функция, то щелкнуть в поле ввода аргумента и выбрать нужную функцию из списка.

4.            Основные функции

Название

Назначение

Действие

1. Математические – 50 штук

1. ЦЕЛОЕ

Определяет целую часть числа

=ЦЕЛОЕ(412,98)             –412

2. СЛЧИС

Определяет случайное число из [0,1)

=ЦЕЛОЕ(6*СЛЧИС()+1) –

опр. случайное число от 1 до 6

3. РИМСКОЕ

Преобразует число римское

=РИМСКОЕ(1998) –MCMXCVIII

4. ОКРУГЛ

Округляет значение до указанного количества десятичных разрядов

=ОКРУГЛ(123,456; 2)    – 123,46

=ОКРУГЛ(123,456; 1)    – 123,50

=ОКРУГЛ(123,456; -2)   – 100,00

5. ПИ

Число  – 14 знаков

6.SIN

Sin угла в радианах

7. КОРЕНЬ

Квадратный корень

Кубический корень – ^1/3

=КОРЕНЬ (А4+В4)

8.СУММ

Вычисляет сумму – до 30 аргументов кнопка <>

=СУММ(А1:А7; В1:В7; Е7; С12)


2. Статистические – 80 шт.

1. СРЗНАЧ

Определяет среднее значение

=СРЗНАЧ(А1:А12; С1:С12)

2. МИН

Определяет наименьшее знач.

=МИН(А3:С3; А8:С8)

3. МАКС

Определяет наибольшее знач.

=МАКС(А3:С3; А8:С8)

3. Текстовые – 23 шт.

1. ПРОПНАЧ

В словах первую букву делает прописной, а остальные – строчными.

=ПРОПНАЧ(ИВАНОВ И.И.)  

               Иванов И.И.

2. СИМВОЛ

Преобразует ANSI код в символ

=СИМВОЛ(169)                 –©

4. Дата и время – 14 шт.

1. СЕГОДНЯ

Вставляет сегодняшнюю дату

=СЕГОДНЯ()

2. ДЕНЬНЕД

Определяет день недели указанной даты

=ДЕНЬНЕД(Дата; код)

=ДЕНЬНЕД (СЕГОДНЯ();1)

3. ДЕНЬ

Выделяет день месяца из указанной даты

=ДЕНЬ(12.09.2006) – 12

=ДЕНЬ(СЕГОДНЯ())

3. МЕСЯЦ

Выделяет месяц

=МЕСЯЦ(12.09.2002) –9

3. ГОД

Выделяет год

=год(12.05.2006) – 2006

Значение второго параметра для функции ДЕНЬНЕД:

Тип

Возвращаемое число

1 или опущен

Число от 1 (воскресенье) до 7 (суббота).

2

Число от 1 (понедельник) до 7 (воскресенье)

3

Число от 0 (понедельник) до 6 (воскресенье)

5.             Пример использования функций ГОД и СЕГОДНЯ

Эти функции позволяют вычислять в таблице такие данные, как возраст человека по дате его рождения или стаж по дате поступления на работу.

Заполним такую таблицу:

А

В

С

ФИО

Дата

рождения

Возраст

1

Иванов И.И.

11.01.1980

28

2

Петров П.П.

20.05.1995

13

3

Сидоров С.С.

05.12.1999

8

В столбцы ФИО и Дата рождения вносим произвольные данные. Для вычисления возраста используется формула:

=(ГОД(СЕГОДНЯ()-B2)-1900)

Эта формула будет вычислять всегда правильное количество полных лет человека, т.к. для вычисления используется функция СЕГОДНЯ, которая в каждый конкретный момент времени использует текущую дату. (Таблица была составлена 25.08.08, при использовании этого примера позже 5.12.08 будут другие данные в столбце С)

Очень важным достоинством ЭТ является то, что при изменении значения в ячейке, которая участвует в формуле, автоматически это формула пересчитывается и в таблице появляется новый результат.

6.            Ошибки в формулах.

Значение

Описание

########

Получилось слишком длинное число – нужно увеличить ширину столбца или изменить формат ячейки

#ДЕЛ/0

Попытка деления на ноль

#ИМЯ?

В формуле используется несуществующее имя

#ЗНАЧ!

Введено арифметическое выражение, содержащее адрес ячейки с текстом

#ССЫЛКА!

Отсутствуют ячейки, адреса которых используются в формуле

#Н/Д

Нет данных для вычислений. Удобно использовать для резервирования данных под ожидаемые данные. Формула, содержащая адрес ячейки со значением #Н/Д, возвращает результат #Н/Д

#число!

Задан неправильный аргумент функции

#пусто!

В формуле используется пересечение диапазонов, не имеющих общих ячеек


 

А также другие работы, которые могут Вас заинтересовать

84356. Нации и межнациональные отношения 75 KB
  Тип урока комбинированный Используемые технологии: личностно-ориентированного обучения и воспитания развитие ключевых компетентностей учащихся; проблемного обученияпроблемный вопрос: стихотворение Кострова; дебаты Этническое многообразие богатство или беда России...
84357. Правоохранительные органы 50.5 KB
  Цели урока: Образовательная: познакомить учащихся с правоохранительными органами их функциями; учить пользоваться правовой терминологией а также различать в какую структуру должен обратиться гражданин для защиты своих прав; Развивающая: продолжить формирование умения вести дискуссию аргументировать...
84358. Деление двузначного числа на однозначное 25.31 KB
  Цели урока: содействовать закреплению знаний по теме Деление суммы на число, развивать умение применять эти знания при решении примеров и задач; совершенствовать вычислительные навыки; умение осуществлять перенос ранее усвоенных знаний в новые условия...
84359. Глобальная компьютерная сеть Интернет 746.5 KB
  Цели и задачи: Общеобразовательные учащиеся должны освоить основные базовые понятия информатики: Интернет, браузер, поисковые системы, общение в сети Интернет, усвоить виды браузеров и их назначение, усвоить примеры поисковых систем и их назначение.
84360. Осевая симметрия 39.94 KB
  Цели: Образовательные Закрепить понятия о симметричных предметах и геометрических фигурах. Дать понятие о предметах и геометрических фигурах, симметрично расположенных относительно оси симметрии. Коррекционные Развивать предметно – практическую деятельность.
84361. Здоровье всему голова 23.25 KB
  Цель мероприятия: ознакомить детей с новыми понятиями качество товара потребитель срок годности товара; учить детей правильно совершать покупки; способствовать воспитанию в детях чувства гордости за кубанскую продукцию.
84362. Страна изучаемого языка и моя страна 54 KB
  Цель урока: Формирование навыков устно-речевого общения речевой деятельности через речевые ситуации связанные со страной изучаемого языка и родной страной. Цель которую ставит учитель: ориентировать учащихся на речевую деятельность создать атмосферу иноязычного общения через речевую ситуацию знакомство...
84363. Материк Австралия, урок 34.42 KB
  Коррекционно образовательные Закрепить понятия: о географическом положении материка Австралии океанах и морях омывающих данный материк. Покажите на карте материк Австралии. Назовите какими океанами омывается Австралия Скажите какие материки расположены ближе к Австралии. Определите где шаблон Австралии.
84364. Текст-повествование. Изложение по рассказу В. Бианки «Купание медвежат» 41 KB
  Цели урока: познакомить со структурой повествовательного текста; обучать учащихся письменной передаче текста; развивать устную и письменную речь учащихся; использовать в речи точный образный язык; развивать эмоциональную сферу детей их чувства эстетический вкус; воспитывать любовь к природе.