17107

Циклічні алгоритми

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторна робота № 3 Тема: Циклічні алгоритми. Мета: навчитися складати схеми циклічних алгоритмів. Обладнання: інструкція до практичної роботи олівець лінійка. Хід роботи. Правила Т/Б в кабінеті комп'ютерної техніки. Методичні вказівки. Базова ст...

Украинкский

2013-06-29

61.5 KB

3 чел.

Лабораторна робота № 3

Тема: Циклічні алгоритми.

Мета: навчитися складати схеми циклічних алгоритмів.

Обладнання: інструкція до практичної роботи, олівець лінійка.

Хід роботи.

  1.  Правила Т/Б в кабінеті комп'ютерної техніки.
  2.  Методичні вказівки.

Базова структура „цикл". Забезпечує багаторазове виконання деякої сукупності дій, яка називається тілом циклу. Основні різновиди циклів приведені в таблиці:

алгоритмічна мова

мова блок-схем

Цикл типу ПОКА.

Наказує виконувати тіло циклу до тих пір, поки виконується умова, записана після слова пока

нц пока условие

тело цикла (последовательность действий )

Цикл типу ДЛЯ.

Наказує виконувати тіло циклу для всіх значень деякої змінної (параметра циклу) в заданому

діапазоні

нц для і от і 1 до І2

тело цикла

(последовательность действий)

кц

Примеры структури ЦИКЛ

Алгоритмічний язик

Мова блок-схем

нц пока і<=5

S:=S+A[i]

i:=i+1

кц

нц для і от 1 до 5

Х[і]:=i*і*і

Y[i]:=X[i]/2

кц

3.   Скласти алгоритм ітераційного циклу.

Скласти алгоритм обчислення нескінченної суми з

заданою точністю є (для даної нескінченої суми, що знакочергується, потрібна точність буде досягнута, коли черговий доданок буде за абсолютною величиною менше є).

Обчислення сум - типова циклічна задача. Особливістю ж нашої конкретної задачі є те,

що число доданків заздалегідь невідомо. Тому виконання циклу повинне завершитися в

момент потрібної точності.

При складанні алгоритму потрібно врахувати, що знаки доданків чергуються і ступінь

числах в чисельниках доданків зростає.

Розв'язуючи задачу „в лоб" шляхом обчислення на кожному i-му кроці часткової суми

S := S + ((-1)**(/-1))*(х**/)//,   ми   отримаємо   дуже   неефективний   алгоритм,   що

потребує виконання великого числа операцій. Набагато краще організувати обчислення

наступним чином: якщо позначити чисельник якого-небудь доданку буквою р, то у

наступного доданку чисельник буде дорівнювати -/?*х (знак мінус забезпечує чергування

знаків доданків), а сам доданок т буде дорівнювати р/і, де i - номер доданку.

алгоритмічна мова

блок схема

алг Сумма (арг вещ х, Eps, рез вещ S)

дано [ 0<х<1

надо | S=x-x**2/2+x**3/3-...

нач цел і, вещ m, p

ввод х, Eps

S:=0; i:=l    | Начальные значення

m:=1; р:= -1

нц пока abs(m)>Eps

р:= -р*х | р - числитель очередного слагаемого

m:= р/і    | m - очередное слагаемое

S:-S+m   | S - частична сумма

і:= і+1     | і - номер очередного слагаемого

кц

вывод S

кон

Алгоритм у склад якого входить ітераційний цикл, називається ітераційним алгоритмом. Ітераційні алгоритми застосовують при реалізації ітераційних чисельних методів.

4.   Індивідуальне завдання. Скласти схему алгоритму. Варіанти.

  1.  Знайдіть значення виразу (для натуральних-m і п, т<п): S=l+2+...+n
  2.  Знайдіть значення виразу (для натуральних т і п, т<п): F= 1 *2*...*п
  3.  Знайдіть значення виразу (для натуральних т і п, т<п): A=m+(m+l)+...+(m+n)
  4.  Знайдіть значення виразу (для натуральних т і п, т<п): B=m*(m+l)*...*(m+n)

5.   Знайдіть значення виразу (для натуральних т і п, т<п):

6.   Знайдіть значення виразу (для натуральних m i n,  m<=n):

S=1+1*2+1*2*3+1*2*3*4+…+1*2*3*…n

7.   Знайдіть значення виразу (для натуральних т і п, т<п):

8.   Знайдіть суму S і добуток Р парних чисел від 1 до п.

9.   Знайдіть суму S і добуток Р непарних чисел від 1 до п.

10.  Знайдіть суму S і добуток Р чисел кратних 3, від 1 до п.

11.  Знайдіть суму квадратів перших п натуральних чисел.

12.  Знайдіть суму кубів перших п натуральних чисел.

13.   Знайдіть суму квадратів парних чисел з перших п натуральних чисел.

14.  Знайдіть суму кубів парних чисел з перших п натуральних чисел.

15.  Для послідовності a(n)=nsinn знайдіть суму і добуток п перших членів.

5.   Контрольні питання

  1.  Накреслити схему простого циклу.
  2.  Що таке тіло циклу?
  3.  Для чого потрібна змінна циклу.

6. Захист роботи.


i=i1,i2

Тело цикла

i<=5

S:=S+A[i]     i:=ш+1

i=1,5

X[i]:=i3   Y[i]:=X[i]/2

початок

x,e

S:=0; i:=1;  m:=1;  p:=-1

|m|>e

P:=-p*x; m:=p/I; S:=S+m; i:=i+1

S

кінець


 

А также другие работы, которые могут Вас заинтересовать

60169. Жінки в долі та творчості Т.Шевченка 104.5 KB
  Щось до лона пригортає і з туманом розмовляє: Виходить Ганна з дитиною на руках: Ой тумане тумане Мій латаний талане Чому мене не сховаєш Отут серед лану Чому мене не задавиш У землю не вдавиш...
60170. Пожежонебезпечні і вибухонебезпечні речовини та матеріали 141 KB
  Міні-вистава Небазпечні іграшки Дійові особи: Хлопчики : Миколка Василько Андрійко Бабуся Марина Дівчинка Настя Два лікарі Міліціонер Скверик.
60171. Круглий стіл: «Попередження насильства в сімї» 148.5 KB
  Мета: сформулювати уявлення про насильство та розвинути знання про методи захисту від насильства, вміти протистояти насильству; висловлювати своє відношення до можливих випадків насильства.
60172. Позакласний захід “Свято казки” 186.5 KB
  Дітей люблю і поважаю Завжди учу добро робити Всіх цінувати і любити. Всі мене мабуть впізнали Я Сніжинкою зовусь. Пеппі Де море берег омиває І сяйво півночі сіяє Країна Швеція лежить А в ній повільно час біжить Десь на околиці містечка...
60173. We love English 193.5 KB
  Pupils are divided into two groups. Senior pupils make up the jury of the competition. Each team has a name. One team is called “Mickey Mouse”, the other – “Minney Mouse”. The teams have emblems and greet each other.
60174. Інтелектуальна гра «Мовознавці» 376.5 KB
  Мета заходу: поглибити знання учнів про історію українського та англійського народів; формувати загально-пізнавальні вміння; порівнювати та зіставляти вивчене в українській та англійській мовах; розвивати творчі можливості учнів...
60175. Внеклассное мероприятие для начальной школы. Хлеб - всему голова 536.84 KB
  Цель: показать значимость и ценность хлеба в жизни человека; познакомить детей с тем, как выращивают хлеб; воспитывать у детей уважение к хлеборобам, бережное отношение к хлебу.
60176. ПОДОРОЖ У ЧАРІВНИЙ СВІТ ХІМІЇ 691.54 KB
  Мета: закріпити й узагальнити знання з хімії та біології за курс основної школи; розвивати уміння і навики проведення хімічного досліду з дотриманням правил техніки безпеки; стимулювати пізнавальну діяльність, активізувати творчі можливості студентів; розвивати логічне мислення
60177. Вверх по лестнице-чудеснице 165 KB
  Оборудование: карточки с заданиями для работы в парах таблицы с ребусами геометрические фигуры для работы в парах картинка Буратино таблички с названиями ступенек ступеньками расположены на доске.