17107

Циклічні алгоритми

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторна робота № 3 Тема: Циклічні алгоритми. Мета: навчитися складати схеми циклічних алгоритмів. Обладнання: інструкція до практичної роботи олівець лінійка. Хід роботи. Правила Т/Б в кабінеті комп'ютерної техніки. Методичні вказівки. Базова ст...

Украинкский

2013-06-29

61.5 KB

3 чел.

Лабораторна робота № 3

Тема: Циклічні алгоритми.

Мета: навчитися складати схеми циклічних алгоритмів.

Обладнання: інструкція до практичної роботи, олівець лінійка.

Хід роботи.

  1.  Правила Т/Б в кабінеті комп'ютерної техніки.
  2.  Методичні вказівки.

Базова структура „цикл". Забезпечує багаторазове виконання деякої сукупності дій, яка називається тілом циклу. Основні різновиди циклів приведені в таблиці:

алгоритмічна мова

мова блок-схем

Цикл типу ПОКА.

Наказує виконувати тіло циклу до тих пір, поки виконується умова, записана після слова пока

нц пока условие

тело цикла (последовательность действий )

Цикл типу ДЛЯ.

Наказує виконувати тіло циклу для всіх значень деякої змінної (параметра циклу) в заданому

діапазоні

нц для і от і 1 до І2

тело цикла

(последовательность действий)

кц

Примеры структури ЦИКЛ

Алгоритмічний язик

Мова блок-схем

нц пока і<=5

S:=S+A[i]

i:=i+1

кц

нц для і от 1 до 5

Х[і]:=i*і*і

Y[i]:=X[i]/2

кц

3.   Скласти алгоритм ітераційного циклу.

Скласти алгоритм обчислення нескінченної суми з

заданою точністю є (для даної нескінченої суми, що знакочергується, потрібна точність буде досягнута, коли черговий доданок буде за абсолютною величиною менше є).

Обчислення сум - типова циклічна задача. Особливістю ж нашої конкретної задачі є те,

що число доданків заздалегідь невідомо. Тому виконання циклу повинне завершитися в

момент потрібної точності.

При складанні алгоритму потрібно врахувати, що знаки доданків чергуються і ступінь

числах в чисельниках доданків зростає.

Розв'язуючи задачу „в лоб" шляхом обчислення на кожному i-му кроці часткової суми

S := S + ((-1)**(/-1))*(х**/)//,   ми   отримаємо   дуже   неефективний   алгоритм,   що

потребує виконання великого числа операцій. Набагато краще організувати обчислення

наступним чином: якщо позначити чисельник якого-небудь доданку буквою р, то у

наступного доданку чисельник буде дорівнювати -/?*х (знак мінус забезпечує чергування

знаків доданків), а сам доданок т буде дорівнювати р/і, де i - номер доданку.

алгоритмічна мова

блок схема

алг Сумма (арг вещ х, Eps, рез вещ S)

дано [ 0<х<1

надо | S=x-x**2/2+x**3/3-...

нач цел і, вещ m, p

ввод х, Eps

S:=0; i:=l    | Начальные значення

m:=1; р:= -1

нц пока abs(m)>Eps

р:= -р*х | р - числитель очередного слагаемого

m:= р/і    | m - очередное слагаемое

S:-S+m   | S - частична сумма

і:= і+1     | і - номер очередного слагаемого

кц

вывод S

кон

Алгоритм у склад якого входить ітераційний цикл, називається ітераційним алгоритмом. Ітераційні алгоритми застосовують при реалізації ітераційних чисельних методів.

4.   Індивідуальне завдання. Скласти схему алгоритму. Варіанти.

  1.  Знайдіть значення виразу (для натуральних-m і п, т<п): S=l+2+...+n
  2.  Знайдіть значення виразу (для натуральних т і п, т<п): F= 1 *2*...*п
  3.  Знайдіть значення виразу (для натуральних т і п, т<п): A=m+(m+l)+...+(m+n)
  4.  Знайдіть значення виразу (для натуральних т і п, т<п): B=m*(m+l)*...*(m+n)

5.   Знайдіть значення виразу (для натуральних т і п, т<п):

6.   Знайдіть значення виразу (для натуральних m i n,  m<=n):

S=1+1*2+1*2*3+1*2*3*4+…+1*2*3*…n

7.   Знайдіть значення виразу (для натуральних т і п, т<п):

8.   Знайдіть суму S і добуток Р парних чисел від 1 до п.

9.   Знайдіть суму S і добуток Р непарних чисел від 1 до п.

10.  Знайдіть суму S і добуток Р чисел кратних 3, від 1 до п.

11.  Знайдіть суму квадратів перших п натуральних чисел.

12.  Знайдіть суму кубів перших п натуральних чисел.

13.   Знайдіть суму квадратів парних чисел з перших п натуральних чисел.

14.  Знайдіть суму кубів парних чисел з перших п натуральних чисел.

15.  Для послідовності a(n)=nsinn знайдіть суму і добуток п перших членів.

5.   Контрольні питання

  1.  Накреслити схему простого циклу.
  2.  Що таке тіло циклу?
  3.  Для чого потрібна змінна циклу.

6. Захист роботи.


i=i1,i2

Тело цикла

i<=5

S:=S+A[i]     i:=ш+1

i=1,5

X[i]:=i3   Y[i]:=X[i]/2

початок

x,e

S:=0; i:=1;  m:=1;  p:=-1

|m|>e

P:=-p*x; m:=p/I; S:=S+m; i:=i+1

S

кінець


 

А также другие работы, которые могут Вас заинтересовать

8817. Банківські ресурси як основа функціонування банку Тестові завдання 26.05 KB
  Банківські ресурси як основа функціонування банку. Тестові завдання. Мінімальний розмір статутного капіталу банку, створеного за участю іноземного капіталу, частка якого у статутному капіталі банку становить до....
8819. История. Назначение. Системные вызовы. Структура операционных систем. 153 KB
  История. Назначение. Системные вызовы. Структура операционных систем. 1.1 История ОС Первые (1945-1955г.г.) компьютеры работали без операционных систем, как правило, на них работала одна программа. Когда скорость выполнения программ и их количество ...
8820. Процессы и потоки (нити) 130 KB
  Процессы и потоки (нити). 2.1 Процессы 2.1.1 Понятие процесса Процесс (задача) - программа, находящаяся в режиме выполнения. С каждым процессом связывается его адресное пространство, из которого он может читать и в которое он может писать данн...
8821. Взаимодействие между процессами 164.5 KB
  Взаимодействие между процессами. 3.1 Взаимодействие между процессами Ситуации, когда приходится процессам взаимодействовать: Передача информации от одного процесса другому Контроль над деятельностью процессов (например: когда они борются...
8822. Планирование процессов в информатике 144 KB
  Планирование процессов. Основные понятия планирования процессов Планирование - обеспечение поочередного доступа процессов к одному процессору. Планировщик - отвечающая за это часть операционной системы. Алгоритм планирования - используемый алгори...
8823. Взаимоблокировка процессов 181.5 KB
  Взаимоблокировка процессов Взаимоблокировка процессов  может происходить, когда несколько процессов борются за один ресурс. Ресурсы бывают выгружаемые и невыгружаемые, аппаратные и программные. Выгружаемый ресурс - это...
8824. Управление памятью. Страничная организация 128.5 KB
  Управление памятью. Страничная организация 6.1 Основные понятия Менеджер памяти - часть операционной системы, отвечающая за управление памятью. Основные методы распределения памяти: Без использования внешней памяти С использованием внешн...
8825. Алгоритмы замещения страниц 116 KB
  Алгоритмы замещения страниц 7.1 Алгоритмы замещения страниц Идеальный алгоритм заключается в том, что бы выгружать ту страницу, которая будет запрошена позже всех. Но этот алгоритм не осуществим, т.к. нельзя знать какую страницу, когда запросят. Мож...