17108

Вкладені цикли

Лабораторная работа

Информатика, кибернетика и программирование

Лабораторна робота № 4 Тема: Вкладені цикли. Мета: навчитися складати алгоритми з вкладеними циклами. Обладнання: інструкція до практичної роботи олівець лінійка. Хід роботи Правила Т/Б в кабінеті комп'ютерної техніки. Методичні вказівки. Можливі в

Украинкский

2013-06-29

58 KB

5 чел.

Лабораторна робота № 4

Тема: Вкладені цикли.

Мета: навчитися складати алгоритми з вкладеними циклами.

Обладнання: інструкція до практичної роботи, олівець лінійка.

Хід роботи,

  1.  Правила Т/Б в кабінеті комп'ютерної техніки.
  2.  Методичні вказівки.

Можливі випадки, коли усередині тіла циклу необхідно повторювати деяку послідовність операторів, тобто організувати внутрішній цикл. Така структура одержала назву циклу в циклі чи вкладених циклів. Глибина вкладення циклів (тобто кількість вкладених друг у друга циклів) може бути різною.

При використанні такої структури для економії машинного часу необхідно виносити з внутрішнього циклу в зовнішній всі оператори, що. не залежать від параметра внутрішнього циклу.

3.   Скласти алгоритм:

Обчислити суму елементів заданої матриці А(5,3)

Матриця А

1

2

3

1

2

3

4

5

                                                                                                                               S:=0;

   нц для I от 1до 5

    нц для gот 1 до 3

        S:=S+A[I,g]

     кц

кц    
Обчислити   добуток   тих   елементів   заданої  матриці   А( 10,10),   які   розташовані   на перетинанні парних рядків і парних стовпців.

 і:=2; Р:=1 нц пока 

 і<=10 j:=2

 нц

                                                                                                                                  покаі<=10

                                                                                                                                                  P:=P*A[i,j]

                                                                                                           J-J+2 кц

                                                                                                              кц

4.  Індивідуальні завдання

Скласти алгоритм. Визначити які блоки складають тіло циклу, що є зміною циклу,

зовнішнього та внутрішнього.

Обчислити суму елементів таблиці з

№п/п

Розмірність таблиці

1

3 рядків 4 стовпців

2

4 рядків 2 стовпців

3

5 рядків 5 стовпців

4

4 рядків 5 стовпців

5

6 рядків 6 стовпців

6

6 рядків 7 стовпців

7

7 рядків 3 стовпців

8

4 рядків 6 стовпців

9

10 рядків 10 стовпців

10

9 рядків 8 стовпців

5.   Контрольні питання.

  1.  Накреслити схему вкладеного циклу.
  2.  Поясніть призначення кожного блоку

6.   Захист роботи.


К.ц.

3                       Блок зміни змінних

S:=0

I=1,5

I=1,3

S:=S+aig

КЦ

3             Бзз внут. цикл

2              А.б. внут. цикл

1               Бпз внут. цикл

2                 

ариф

мети

чний

блок

1         Блок підготовки даних зовнішнього циклу

i=i+2

j=j+2

P:=P*aij

j<=10

j=2

i<=10

i=2; P:=1