17138

Майстер функцій. Функції логіки. Математичні функції

Лекция

Информатика, кибернетика и программирование

Лекція №14 Тема: Майстер функцій. Функції логіки. Математичні функції. План Майстер функцій. Функції логіки. Математичні функції. Функції Функції наперед певні формули які виконують обчислення по заданих величинах званих аргументами і у вк...

Украинкский

2013-06-29

122 KB

4 чел.

Лекція №14

Тема: Майстер функцій. Функції логіки. Математичні функції.  

План

  1.  Майстер функцій.
  2.  Функції логіки.
  3.  Математичні функції.

Функції

Функції  — наперед певні формули, які виконують обчислення по заданих величинах, званих аргументами, і у вказаному порядку. Ці функції дозволяють виконувати як прості, так і складні обчислення.

Структура функції

Структура функції починається із знаку рівності (=), за ним слідує ім'я функції, відкриваюча дужка, список аргументів, розділених комами, закриваюча дужка.

Ім'я функції. Для появи списку доступних функцій клацніть осередок і натисніть клавіші SHIFT+F3.

Аргументи. Існують різні типи аргументів: число, текст, логічне значення (ІСТИНА і БРЕХНЯ), масиви, значення помилки (наприклад #Н/Д), або посилання на осередок. Як аргументи використовуються константи, формули, або функції. У кожному конкретному випадку необхідно використовувати відповідний тип аргументу.

  Спливаюча підказка аргументу. Спливаюча підказка з синтаксисом і аргументами з'являється після введення функції. Наприклад, спливаюча підказка з'явиться після введення =ОКРУГЛ(). Спливаючі підказки з'являються тільки для вбудованих функцій.

Введення формул. 

   Діалогове вікно Майстер функцій полегшує введення функцій при створенні формул, що містять функції. При введенні функції у формулу діалогове вікно Майстер функцій відображає ім'я функції, всі її аргументи, опис функції і кожного аргументу, поточний результат функції і всієї формули.

В деяких випадках може потрібно використовування функції як одного з аргументів іншої функції. Наприклад, в наступній формулі функція СРЗНАЧ вкладена у функцію ЕСЛИ для порівняння середнього значення декількох значень з числом 50.

Допустимі типи обчислюваних значень.

     Вкладена функція, використовувана як аргумент, повинна обчислювати відповідний цьому аргументу тип даних. Наприклад, якщо аргумент повинен бути логічним, тобто мати значення або ІСТИНА, або БРЕХНЯ, то вкладена функція в результаті обчислень теж повинна давати логічне значення або ІСТИНА, або БРЕХНЯ. Інакше з'явиться повідомлення про помилку «#ЗНАЧ!».

Обмеження кількості рівнів вкладення функцій.

     У формулах можна використовувати до семи рівнів вкладення функцій. Коли функція б є аргументом функції А, функція б знаходиться на другому рівні вкладеності. Наприклад, функції СРЗНАЧ і СУМ вважаються функціями другого рівня, тому що обидва вони є аргументами функції ЕСЛИ. Функція, вкладена як аргумент у функцію СРЗНАЧ, буде функцією третього рівня і так далі.

Створення умовних формул з використанням функції ЕСЛИ

Приклад 1

А

 1

Дані

 2

15

 3

9

 4

8

Формула

Опис (результат)

=И(A2>A3; A2<A4)

15 більше 9 і менше 8? (БРЕХНЯ)

=ИЛИ(A2>A3; A2<A4)

15 більше 9 або менше 8? (ІСТИНА)

=НЕ(A2+A3=24)

15 плюс 9 не рівно 24? (БРЕХНЯ)

Опис функцій

И

Повертає значення ІСТИНА, якщо всі аргументи мають значення ІСТИНА; повертає значення БРЕХНЯ, якщо хоча б один аргумент має значення БРЕХНЯ.

Синтаксис

И (логическое_значение1; логическое_значение2; ...)

Логическое_значение1, логическое_значение2, ...       — це від 1 до 30 умов, що перевіряються, які можуть мати значення або ІСТИНА, або БРЕХНЯ.

Замітки

  •  Аргументи повинні бути логічними значеннями (такими, як ІСТИНА або БРЕХНЯ), масивами або посиланнями, що містять логічні значення.
  •  Якщо аргумент, який є посиланням або масивом, містить текст або порожні осередки, то такі значення ігноруються.
  •  Якщо вказаний інтервал не містить логічних значень, то І повертає значення помилки #ЗНАЧ!.

А

B

1

Формула

Опис (результат)

2

=И (ІСТИНА; ІСТИНА)

Всі аргументи — ІСТИНА (ІСТИНА)

3

=И (ІСТИНА; БРЕХНЯ)

Один аргумент — БРЕХНЯ (БРЕХНЯ)

4

=И(2+2=4; 2+3=5)

Всі аргументи розцінюються як ІСТИНА(ІСТИНА)

Приклад 2

А

 1

Дані

 2

50

 3

104

Формула

Опис (результат)

=И(1<A2; A2<100)

Оскільки 50 більше 1 і менше 100 (ІСТИНА)

=ЕСЛИ(І(1<A3; A3<100); A3; "Значення поза інтервалом.")

Показує друге число з приведених вище (якщо воно більше 1 і менше 100) або повідомлення (Значення поза інтервалом.)

=ЕСЛИ(І(1<A2; A2<100); A2; "Значення поза інтервалом.")

Показує перше число з приведених вище (якщо воно більше 1 і менше 100) або повідомлення (50)

ИЛИ

Повертає ІСТИНА, якщо хоча б один з аргументів має значення ІСТИНА; повертає БРЕХНЮ, якщо всі аргументи мають значення БРЕХНЯ.

Синтаксис

ИЛИ (логическое_значение1;логическое_значение2; ...)

Логическое_значение1, логическое_значение2,...        — від 1 до 30 умов, що перевіряються, які можуть мати значення або ІСТИНА, або БРЕХНЯ.

 

А

B

Формула

Опис (результат)

=ИЛИ(ІСТИНА)

Один аргумент має значення ІСТИНА (ІСТИНА)

=ИЛИ(1+1=1;2+2=5)

Всі аргументи приймають значення БРЕХНЯ (БРЕХНЯ)

=ИЛИ(ІСТИНА;ЛОЖЬ;ИСТИНА)

Принаймні один аргумент має значення ІСТИНА (ІСТИНА)

НЕ

Міняє на протилежне логічне значення свого аргументу. Функція не використовується в тих випадках, коли необхідно бути упевненим у тому, що значення не рівне деякій конкретній величині.

Синтаксис

НЕ(логическое_значение)

Логическое_значение        — величина або вираз, які можуть приймати два значення: ІСТИНА або БРЕХНЯ.

Замітки

Якщо логическое_значение має значення БРЕХНЯ, то функція не повертає значення ІСТИНА; якщо логическое_значение має значення ІСТИНА, то функція не повертає значення БРЕХНЯ.

А

B

Формула

Опис (результат)

=НЕ(БРЕХНЯ)

Міняє на протилежне значення БРЕХНЮ (ІСТИНА)

=НЕ(1+1=2)

Міняє значення ІСТИНА, якому рівний логічний вираз, на протилежне (БРЕХНЯ)

ЕСЛИ

Повертає одне значення, якщо задана умова при обчисленні дає значення ІСТИНА, і інше значення, якщо БРЕХНЯ.

Функція ЕСЛИ використовується при перевірці умов для значень і формул.

Синтаксис

ЕСЛИ(лог_выражение; значение_если_истина ;значение_если_ложь)

   

логическое_выражение: умова, яка потрібна перевірити

значение_если_истина: значення, що повертається, якщо умова істинна

значение_если_ложь: значення, що повертається, якщо умова помилкова

Лог_выражение        — це будь-яке значення або вираз, що приймає значення ІСТИНА або БРЕХНЯ. Наприклад, A10=100  — це логічний вираз; якщо значення в осередку A10 рівне 100, то вираз приймає значення ІСТИНА. Інакше  — БРЕХНЯ. Цей аргумент може бути використаний в будь-якому операторі порівняння.

Значение_если_истина       — це значення, яке повертається, якщо лог_выражение рівно ІСТИНА. Наприклад, якщо цей аргумент  — рядок «В межах бюджету» і лог_выражение рівно ІСТИНА, тоді функція ЕСЛИ відобразить текст «В межах бюджету». Якщо лог_выражение рівно ІСТИНА, а значение_если_истина порожнє, то повертається значення 0. Щоб відобразити слово ІСТИНА, необхідно використовувати логічне значення ІСТИНА для цього аргументу. Значение_если_истина може бути формулою.

Значение_если_ложь       — це значення, яке повертається, якщо лог_выражение рівно БРЕХНЯ. Наприклад, якщо цей аргумент  — рядок «Перевищення бюджету» і лог_выражение рівне БРЕХНЯ, то функція ЕСЛИ відобразить текст «Перевищення бюджету». Якщо лог_выражение рівно БРЕХНЯ, а значение_если_ложь опущене (тобто після значение_если_истина немає крапки з комою), то повертається логічне значення БРЕХНЯ. Якщо лог_выражение рівно БРЕХНЯ, а значение_если_ложь порожнє (тобто після значение_если_истина стоїть крапка з комою з подальшою закриваючою дужкою), то повертається значення 0. Значение_если_ложь може бути формулою.

Замітки

  •  До 7 функцій ЕСЛИ можуть бути вкладені один в одного як значення аргументів значение_если_истина і значение_если_ложь для конструювання складніших перевірок. Див. останній з приведених нижче прикладів.
  •  Коли значення аргументів значение_если_истина і значение_если_ложь обчислені, функція ЕСЛИ повертає набуте значення.
  •  Якщо один з аргументів функції ЕСЛИ є масивом, при виконанні функції ЕСЛИ обчислюються всі елементи масиву.

Microsoft Excel пропонує додаткові функції, які можна застосовувати для аналізу даних з використанням умов. Наприклад, для обчислення числа появ текстового рядка або числа в діапазоні осередків використовуйте функцію СЧЁТЕСЛИ. Для обчислення суми значень, що потрапляють в інтервал, заданий текстовим рядком або числами, використовуйте функцію СУММАЕСЛИ.

Приклад 3

А

1

Дані

2

15

3

9

4

8

Формула

Опис (результат)

=ЕСЛИ(A2=15; "ОК"; "Невірно")

Якщо значення в осередку A2 рівне 15, повертається "ОК". (ОК)

=ЕСЛИ(І(A2>A3; A2<A4); "ОК"; "Невірно")

Якщо 15 більше 9 і менше 8, повертається "ОК". (Невірно)

=ЕСЛИ(АБО(A2>A3; A2<A4); "ОК"; "Невірно")

Якщо 15 більше 9 або менше 8, повертається "ОК". (ОК)

Приклад 4

А

1

Дані

2

50

Формула

Опис (результат)

=ЕСЛИ(A2<=100;"Внутри бюджету";"Вне бюджету")

Якщо приведене вище число менше або рівно числу 100, формула відображає рядок «В межах бюджету». Інакше — рядок «Перевищення бюджету» (В межах бюджету)

=ЕСЛИ(A2=100;СУММ(B5:B15);"")

Якщо число рівне 100, обчислюється сума в діапазоні B5:B15. Інакше повертається порожній текст ("") ()

Приклад 5

А

B

1

Фактичні витрати

Передбачувані витрати

2

1500

900

3

500

900

4

500

925

Формула

Опис (результат)

=ЕСЛИ(A2>B2;"Превышение бюджету";"OK")

Перевіряє перший рядок на перевищення бюджету (Перевищення бюджету)

=ЕСЛИ(A3>B3;"Превышение бюджету";"OK")

Перевіряє другий рядок на перевищення бюджету (OK)

Приклад 6

А

1

Бал

2

45

3

90

4

78

Формула

Опис (результат)

=ЕСЛИ(A2>89;"A";ЕСЛИ(A2>79;"B";

ЕСЛИ(A2>69;"C";ЕСЛИ(A2>59;"D";"F"))))

Призначає буквену категорію першому балу (F)

=ЕСЛИ(A3>89;"A";ЕСЛИ(A3>79;"B";

ЕСЛИ(A3>69;"C";ЕСЛИ(A3>59;"D";"F"))))

Призначає буквену категорію другому балу (A)

=ЕСЛИ(A4>89;"A";ЕСЛИ(A4>79;"B";

ЕСЛИ(A4>69;"C";ЕСЛИ(A4>59;"D";"F"))))

Призначає буквену категорію третьому балу (C)

В предыдущем примере второе предложение ЕСЛИ является в то же время аргументом значение_если_ложь для первого предложения ЕСЛИ. Аналогично, третье предложение ЕСЛИ является аргументом значение_если_ложь для второго предложения ЕСЛИ. Например, если первое лог_выражение (Среднее>89) имеет значение ИСТИНА, то возвращается значение "A". Если первое лог_выражение имеет значение ЛОЖЬ, то вычисляется второе предложение ЕСЛИ и так далее.

Буквенниє категорії назначаются числам, іспользуя следующую табліцу.

Если балл равен

Категория

Больше 89

A

От 80 до 89

B

От 70 до 79

C

От 60 до 69

D

Меньше 60

F

Література:

 Уокенбах Д. Excel 2002. Библия пользователя. М.: Издательский дом «Вильямс», 2004. – 832с. [7], 194-214

Контрольні запитання:

  1.  Використання функцій логіки.
  2.  Функція ЕСЛИ.


 

А также другие работы, которые могут Вас заинтересовать

54377. Особенности взаимодействия и взаимного влияния культур народов России 26.59 KB
  Бабушка сидит на земле поджав под себя ноги она лечит соседку тетю Веру. Почему Ведь в книжках которые она мне читает колдуньи злые а бабушка добрая. Бабушка занята. Как ты бабушка Да миленький совсем как я.
54378. Розвязування задач за допомогою пропорцій 1.11 MB
  Мета та задачі уроку: Закріпити поняття відношення та пропорції їх основні властивості способи запису види залежності між величинами правило знаходження невідомого члена пропорції показати звязок музики архітектури кулінарії економіки з математикою підвищувати зацікавленість учнів предметом. Продовжувати формування навичок оформлення скороченої умови задачі за допомогою таблиці формувати навички складання пропорцій та добутків розвивати вміння знаходити невідомий член пропорції розвивати життєві полікультурні мовленеві...
54379. Фізичні якості м’язів. Робота м’язів 57 KB
  Мета: Освітня продовжити формувати знання учнів про функції мязів в організмі;ознайомитись з фізичними якостями мязів тіла людини; встановити відмінності динамічної та статичної роботи мязів; визначити причини втоми; вивести правило оптимальної роботи мязів. Розвиваюча розвивати уміння порівнювати функції та фізичні якості мязів робити висновки та узагальнення.
54380. ЕКОНОМІЧНИЙ СПОСІБ МИСЛЕННЯ ТА ПРОБЛЕМИ ЙОГО ВИХОВАННЯ В ПРОЦЕСІ ВИКЛАДАННЯ ЕКОНОМІКИ У ЗАГАЛЬНООСВІТНІХ НАВЧАЛЬНИХ ЗАКЛАДАХ 54 KB
  Адже нею є формування в учнів економічного способу мислення ЕСМ. Ще 1776 року у своїй епохальній праці Дослідження про природу і багатство народів Адам Сміт розкрив ЕСМ як метод всебічного дослідження змін що відбуваються у суспільстві. Але головним дослідником і популяризатором ідеї ЕСМ згодом став американський економіст Пол Хейне. Хейне винайшов цікаву аналогію для розуміння ЕСМ: дорожній рух в години пік.
54381. Основные тенденции развития российской культуры в конце XX - начале XXI веков 20.76 KB
  Одной из особенностей развития российской культуры рубежа XX-XXI вв. является ее деидеологизированность и плюрализм творческого поиска. В элитарной художественной литературе и изобразительном искусстве пост - советской России на первый план вышли произведения авангардистского направления
54382. Розвиток критичного мислення школярів на уроках української літератури: запитання які «пробуджують» думку 94 KB
  Дьюї належить твердження що фундаментальна мета сучасної освіти полягає не в наданні учням інформації а в тому щоб розвивати в них критичний спосіб мислення. Саме такий тип мислення надає найбільше можливостей молоді успішно розбудовувати своє життя в мінливому сучасному світі. Критичне мислення допомагає людині адекватно оцінювати нові обставини та формувати стратегію подолання проблем пристосовуватися до нових часом не передбачуваних політичних економічних або інших обставин.
54383. Конкурсно – розважальна програма: «Міс Екологія» 34 KB
  Людська цивілізація вступила в таку форму розвитку, коли її доля вирішується не науково-технічним прогресом, а глибиною екологічних знань та вмінням діяти відповідно до цих знань. Завданням нашого конкурсу є – визначити творчий потенціал кожної учасниці.
54384. MISTER OF THE 5-В FORM 58.15 KB
  Dear participants, guests, jurors. Thanks you for being so active, diligent and clever. It's high time to score the results of our contest and to announce the nominations.
54385. Виховний захід для третьокласників «Містер класу» 55 KB
  Тоненьке кругленьке серце чорненьке Хто на його слід погляне думку його взнає Олівець Що ми робимо олівцем Малюємо Наступний конкурс 2К Містер художник. Наступний конкурс Містер поет. Містер ерудит На подвірї ходить декілька кур.