17138

Майстер функцій. Функції логіки. Математичні функції

Лекция

Информатика, кибернетика и программирование

Лекція №14 Тема: Майстер функцій. Функції логіки. Математичні функції. План Майстер функцій. Функції логіки. Математичні функції. Функції Функції наперед певні формули які виконують обчислення по заданих величинах званих аргументами і у вк...

Украинкский

2013-06-29

122 KB

4 чел.

Лекція №14

Тема: Майстер функцій. Функції логіки. Математичні функції.  

План

  1.  Майстер функцій.
  2.  Функції логіки.
  3.  Математичні функції.

Функції

Функції  — наперед певні формули, які виконують обчислення по заданих величинах, званих аргументами, і у вказаному порядку. Ці функції дозволяють виконувати як прості, так і складні обчислення.

Структура функції

Структура функції починається із знаку рівності (=), за ним слідує ім'я функції, відкриваюча дужка, список аргументів, розділених комами, закриваюча дужка.

Ім'я функції. Для появи списку доступних функцій клацніть осередок і натисніть клавіші SHIFT+F3.

Аргументи. Існують різні типи аргументів: число, текст, логічне значення (ІСТИНА і БРЕХНЯ), масиви, значення помилки (наприклад #Н/Д), або посилання на осередок. Як аргументи використовуються константи, формули, або функції. У кожному конкретному випадку необхідно використовувати відповідний тип аргументу.

  Спливаюча підказка аргументу. Спливаюча підказка з синтаксисом і аргументами з'являється після введення функції. Наприклад, спливаюча підказка з'явиться після введення =ОКРУГЛ(). Спливаючі підказки з'являються тільки для вбудованих функцій.

Введення формул. 

   Діалогове вікно Майстер функцій полегшує введення функцій при створенні формул, що містять функції. При введенні функції у формулу діалогове вікно Майстер функцій відображає ім'я функції, всі її аргументи, опис функції і кожного аргументу, поточний результат функції і всієї формули.

В деяких випадках може потрібно використовування функції як одного з аргументів іншої функції. Наприклад, в наступній формулі функція СРЗНАЧ вкладена у функцію ЕСЛИ для порівняння середнього значення декількох значень з числом 50.

Допустимі типи обчислюваних значень.

     Вкладена функція, використовувана як аргумент, повинна обчислювати відповідний цьому аргументу тип даних. Наприклад, якщо аргумент повинен бути логічним, тобто мати значення або ІСТИНА, або БРЕХНЯ, то вкладена функція в результаті обчислень теж повинна давати логічне значення або ІСТИНА, або БРЕХНЯ. Інакше з'явиться повідомлення про помилку «#ЗНАЧ!».

Обмеження кількості рівнів вкладення функцій.

     У формулах можна використовувати до семи рівнів вкладення функцій. Коли функція б є аргументом функції А, функція б знаходиться на другому рівні вкладеності. Наприклад, функції СРЗНАЧ і СУМ вважаються функціями другого рівня, тому що обидва вони є аргументами функції ЕСЛИ. Функція, вкладена як аргумент у функцію СРЗНАЧ, буде функцією третього рівня і так далі.

Створення умовних формул з використанням функції ЕСЛИ

Приклад 1

А

 1

Дані

 2

15

 3

9

 4

8

Формула

Опис (результат)

=И(A2>A3; A2<A4)

15 більше 9 і менше 8? (БРЕХНЯ)

=ИЛИ(A2>A3; A2<A4)

15 більше 9 або менше 8? (ІСТИНА)

=НЕ(A2+A3=24)

15 плюс 9 не рівно 24? (БРЕХНЯ)

Опис функцій

И

Повертає значення ІСТИНА, якщо всі аргументи мають значення ІСТИНА; повертає значення БРЕХНЯ, якщо хоча б один аргумент має значення БРЕХНЯ.

Синтаксис

И (логическое_значение1; логическое_значение2; ...)

Логическое_значение1, логическое_значение2, ...       — це від 1 до 30 умов, що перевіряються, які можуть мати значення або ІСТИНА, або БРЕХНЯ.

Замітки

  •  Аргументи повинні бути логічними значеннями (такими, як ІСТИНА або БРЕХНЯ), масивами або посиланнями, що містять логічні значення.
  •  Якщо аргумент, який є посиланням або масивом, містить текст або порожні осередки, то такі значення ігноруються.
  •  Якщо вказаний інтервал не містить логічних значень, то І повертає значення помилки #ЗНАЧ!.

А

B

1

Формула

Опис (результат)

2

=И (ІСТИНА; ІСТИНА)

Всі аргументи — ІСТИНА (ІСТИНА)

3

=И (ІСТИНА; БРЕХНЯ)

Один аргумент — БРЕХНЯ (БРЕХНЯ)

4

=И(2+2=4; 2+3=5)

Всі аргументи розцінюються як ІСТИНА(ІСТИНА)

Приклад 2

А

 1

Дані

 2

50

 3

104

Формула

Опис (результат)

=И(1<A2; A2<100)

Оскільки 50 більше 1 і менше 100 (ІСТИНА)

=ЕСЛИ(І(1<A3; A3<100); A3; "Значення поза інтервалом.")

Показує друге число з приведених вище (якщо воно більше 1 і менше 100) або повідомлення (Значення поза інтервалом.)

=ЕСЛИ(І(1<A2; A2<100); A2; "Значення поза інтервалом.")

Показує перше число з приведених вище (якщо воно більше 1 і менше 100) або повідомлення (50)

ИЛИ

Повертає ІСТИНА, якщо хоча б один з аргументів має значення ІСТИНА; повертає БРЕХНЮ, якщо всі аргументи мають значення БРЕХНЯ.

Синтаксис

ИЛИ (логическое_значение1;логическое_значение2; ...)

Логическое_значение1, логическое_значение2,...        — від 1 до 30 умов, що перевіряються, які можуть мати значення або ІСТИНА, або БРЕХНЯ.

 

А

B

Формула

Опис (результат)

=ИЛИ(ІСТИНА)

Один аргумент має значення ІСТИНА (ІСТИНА)

=ИЛИ(1+1=1;2+2=5)

Всі аргументи приймають значення БРЕХНЯ (БРЕХНЯ)

=ИЛИ(ІСТИНА;ЛОЖЬ;ИСТИНА)

Принаймні один аргумент має значення ІСТИНА (ІСТИНА)

НЕ

Міняє на протилежне логічне значення свого аргументу. Функція не використовується в тих випадках, коли необхідно бути упевненим у тому, що значення не рівне деякій конкретній величині.

Синтаксис

НЕ(логическое_значение)

Логическое_значение        — величина або вираз, які можуть приймати два значення: ІСТИНА або БРЕХНЯ.

Замітки

Якщо логическое_значение має значення БРЕХНЯ, то функція не повертає значення ІСТИНА; якщо логическое_значение має значення ІСТИНА, то функція не повертає значення БРЕХНЯ.

А

B

Формула

Опис (результат)

=НЕ(БРЕХНЯ)

Міняє на протилежне значення БРЕХНЮ (ІСТИНА)

=НЕ(1+1=2)

Міняє значення ІСТИНА, якому рівний логічний вираз, на протилежне (БРЕХНЯ)

ЕСЛИ

Повертає одне значення, якщо задана умова при обчисленні дає значення ІСТИНА, і інше значення, якщо БРЕХНЯ.

Функція ЕСЛИ використовується при перевірці умов для значень і формул.

Синтаксис

ЕСЛИ(лог_выражение; значение_если_истина ;значение_если_ложь)

   

логическое_выражение: умова, яка потрібна перевірити

значение_если_истина: значення, що повертається, якщо умова істинна

значение_если_ложь: значення, що повертається, якщо умова помилкова

Лог_выражение        — це будь-яке значення або вираз, що приймає значення ІСТИНА або БРЕХНЯ. Наприклад, A10=100  — це логічний вираз; якщо значення в осередку A10 рівне 100, то вираз приймає значення ІСТИНА. Інакше  — БРЕХНЯ. Цей аргумент може бути використаний в будь-якому операторі порівняння.

Значение_если_истина       — це значення, яке повертається, якщо лог_выражение рівно ІСТИНА. Наприклад, якщо цей аргумент  — рядок «В межах бюджету» і лог_выражение рівно ІСТИНА, тоді функція ЕСЛИ відобразить текст «В межах бюджету». Якщо лог_выражение рівно ІСТИНА, а значение_если_истина порожнє, то повертається значення 0. Щоб відобразити слово ІСТИНА, необхідно використовувати логічне значення ІСТИНА для цього аргументу. Значение_если_истина може бути формулою.

Значение_если_ложь       — це значення, яке повертається, якщо лог_выражение рівно БРЕХНЯ. Наприклад, якщо цей аргумент  — рядок «Перевищення бюджету» і лог_выражение рівне БРЕХНЯ, то функція ЕСЛИ відобразить текст «Перевищення бюджету». Якщо лог_выражение рівно БРЕХНЯ, а значение_если_ложь опущене (тобто після значение_если_истина немає крапки з комою), то повертається логічне значення БРЕХНЯ. Якщо лог_выражение рівно БРЕХНЯ, а значение_если_ложь порожнє (тобто після значение_если_истина стоїть крапка з комою з подальшою закриваючою дужкою), то повертається значення 0. Значение_если_ложь може бути формулою.

Замітки

  •  До 7 функцій ЕСЛИ можуть бути вкладені один в одного як значення аргументів значение_если_истина і значение_если_ложь для конструювання складніших перевірок. Див. останній з приведених нижче прикладів.
  •  Коли значення аргументів значение_если_истина і значение_если_ложь обчислені, функція ЕСЛИ повертає набуте значення.
  •  Якщо один з аргументів функції ЕСЛИ є масивом, при виконанні функції ЕСЛИ обчислюються всі елементи масиву.

Microsoft Excel пропонує додаткові функції, які можна застосовувати для аналізу даних з використанням умов. Наприклад, для обчислення числа появ текстового рядка або числа в діапазоні осередків використовуйте функцію СЧЁТЕСЛИ. Для обчислення суми значень, що потрапляють в інтервал, заданий текстовим рядком або числами, використовуйте функцію СУММАЕСЛИ.

Приклад 3

А

1

Дані

2

15

3

9

4

8

Формула

Опис (результат)

=ЕСЛИ(A2=15; "ОК"; "Невірно")

Якщо значення в осередку A2 рівне 15, повертається "ОК". (ОК)

=ЕСЛИ(І(A2>A3; A2<A4); "ОК"; "Невірно")

Якщо 15 більше 9 і менше 8, повертається "ОК". (Невірно)

=ЕСЛИ(АБО(A2>A3; A2<A4); "ОК"; "Невірно")

Якщо 15 більше 9 або менше 8, повертається "ОК". (ОК)

Приклад 4

А

1

Дані

2

50

Формула

Опис (результат)

=ЕСЛИ(A2<=100;"Внутри бюджету";"Вне бюджету")

Якщо приведене вище число менше або рівно числу 100, формула відображає рядок «В межах бюджету». Інакше — рядок «Перевищення бюджету» (В межах бюджету)

=ЕСЛИ(A2=100;СУММ(B5:B15);"")

Якщо число рівне 100, обчислюється сума в діапазоні B5:B15. Інакше повертається порожній текст ("") ()

Приклад 5

А

B

1

Фактичні витрати

Передбачувані витрати

2

1500

900

3

500

900

4

500

925

Формула

Опис (результат)

=ЕСЛИ(A2>B2;"Превышение бюджету";"OK")

Перевіряє перший рядок на перевищення бюджету (Перевищення бюджету)

=ЕСЛИ(A3>B3;"Превышение бюджету";"OK")

Перевіряє другий рядок на перевищення бюджету (OK)

Приклад 6

А

1

Бал

2

45

3

90

4

78

Формула

Опис (результат)

=ЕСЛИ(A2>89;"A";ЕСЛИ(A2>79;"B";

ЕСЛИ(A2>69;"C";ЕСЛИ(A2>59;"D";"F"))))

Призначає буквену категорію першому балу (F)

=ЕСЛИ(A3>89;"A";ЕСЛИ(A3>79;"B";

ЕСЛИ(A3>69;"C";ЕСЛИ(A3>59;"D";"F"))))

Призначає буквену категорію другому балу (A)

=ЕСЛИ(A4>89;"A";ЕСЛИ(A4>79;"B";

ЕСЛИ(A4>69;"C";ЕСЛИ(A4>59;"D";"F"))))

Призначає буквену категорію третьому балу (C)

В предыдущем примере второе предложение ЕСЛИ является в то же время аргументом значение_если_ложь для первого предложения ЕСЛИ. Аналогично, третье предложение ЕСЛИ является аргументом значение_если_ложь для второго предложения ЕСЛИ. Например, если первое лог_выражение (Среднее>89) имеет значение ИСТИНА, то возвращается значение "A". Если первое лог_выражение имеет значение ЛОЖЬ, то вычисляется второе предложение ЕСЛИ и так далее.

Буквенниє категорії назначаются числам, іспользуя следующую табліцу.

Если балл равен

Категория

Больше 89

A

От 80 до 89

B

От 70 до 79

C

От 60 до 69

D

Меньше 60

F

Література:

 Уокенбах Д. Excel 2002. Библия пользователя. М.: Издательский дом «Вильямс», 2004. – 832с. [7], 194-214

Контрольні запитання:

  1.  Використання функцій логіки.
  2.  Функція ЕСЛИ.


 

А также другие работы, которые могут Вас заинтересовать

45262. Имидж фирмы: структура, этапы формирования и реализации 27 KB
  Имидж фирмы: структура этапы формирования и реализации. Имидж фирмы – целостное восприятие фирмы различными группами общественности формирующееся на основе известной им информации о различных сторонах деятельности фирмы. Структура: структуру имиджа фирмы составляют представления людей относительно фирмы которые условно можно разделить на группы: имидж товара или услуги – представления людей относительно уникальных характеристик которыми он обладает его отличительных свойств. внутренний имидж фирмы – представление сотрудников о фирме...
45263. Имидж ПР-специалиста: профессиональные составляющие и социально-личностные атрибуты 23.5 KB
  Блэку: наличие здравого смыла природное любопытство умение хорошо говорить и излагать вои мысли в письменной форме гибкость выносливость внимание к мелочам хорошее воспитание и образование целеустремленность умение знать и понимать людей чего они хотят. Профессиональная компетентность: психологическая компетентность умение разбираться в людях коммуникативная кть знание факторов эффективного делового общения видов коммуникации психологического воздействия аутопсихологическая кть самоконтроль самоээфективность...
45264. Самопрезентация специалиста как ПР-ресурс: специфика, формы, технологии 25.5 KB
  Самопрезентация специалиста как ПРресурс: специфика формы технологии. Самопрезентация является составной частью сложного процесса формирования профессионального имиджа специалиста. Самопрезентация может быть как начальным этапом какого-либо делового процесса так и отдельным самостоятельным элементом общения. В общем виде самопрезентация представляет собой управление производимым впечатлением умение представить себя и свое дело.
45265. GSM. Регистрация в сети 64 KB
  Регистрация в сети. При каждом включении телефона после выбора сети начинается процедура регистрации рис. Рассмотрим наиболее общий случай регистрацию не в домашней а в чужой так называемой гостевой сети будем предполагать что услуга роуминга абоненту разрешена. По номеру IMSI VLR гостевой сети определяет домашнюю сеть и запрашивает ее HLR.
45266. GSM. Обновление местоположения. Аутентификация и защита 91.5 KB
  Обновление местоположения. Один из вариантов определения местоположения периодически сообщать о расположении объектов в каждой соте. Другой крайний случай уведомлять систему при изменении местоположения мобильной станции широковещательным сообщением. Компромиссное решение используемое в GSM оповещение о местоположении при смене группы сот в зоне местоположения приводящей к ухудшению связи.
45267. GSM. Передача соединения (хэндовер). Роуминг 169 KB
  Переключение каналов между базовыми станциями контролируемыми разными BSC но одним MSC. Переключение каналов между базовыми станциями за которые отвечают не только разные BSC но и разные MSC. Варианты хэндовера В общем случае проведение хэндовера задача MSC. Но в двух первых случаях называемых внутренними хэндоверами чтобы снизить нагрузку на коммутатор и служебные линии связи процесс смены каналов управляется BSC а MSC лишь информируется о происшедшем.
45268. Протоколы сети GSM. Общая структура 37.5 KB
  Уровень 1 физический уровень который использует структуры канала рассмотренные выше по воздушному интерфейсу. Уровень 2 уровень звена передачи данных по Um интерфейс уровень звена передачи данных это модифицированная версия LPDпротокола используемого в ISDN; она называется LPDm. Уровень 3 сигнальный протокол из GSM использующий также модифицированную версию LPD; самостоятельно разделен на 3 подслоя.
45269. Протоколы сети GSM. Подсистемы сигнальных протоколов, использование ОКС№7 (BSSAP, DSSMAP) 97 KB
  Структура протоколов GSM Для передачи сигнальных сообщений между центром коммутации мобильной связи MSC и системой базовой станции Bse Sttion System используются MTP Messge Trnsfer Prt и подсистемы управления соединением канала сигнализации SCCP Signling Connection Control Prt которые являются частями системы ОКС № 7. Основные сведения о подсистеме управления соединением канала сигнализации ОКС № 7 SCCPCSS№7 Система управления соединением канала сигнализации SCCP Signling Connection Control Prt управляет логическими...
45270. Принципы построения сети сотовой связи на основе CDMA (многостанционный доступ с кодовым разделением каналов) 403 KB
  Каналы трафика и управления В CDM каналы для передачи от базовой станции к мобильной станции называются прямыми Forwrd. В обратном направлении подвижные станции отвечают асинхронно без использования пилотного сигнала при этом уровень мощности приходящий к базовой станции от каждой подвижной станции одинаков. Состав прямых каналов Пилотный канал Pilot Chnnel предназначен для установления начальной синхронизации контроля уровня сигнала базовой станции по времени частоте и фазе идентификации базовой станции. Канал синхронизации SCH ...