4206

Условная функция. Использование диапазона клеток с применением статических функций

Лабораторная работа

Информатика, кибернетика и программирование

Условная функция Цель: Научится: Пользоваться диапазоном клеток и стандартными статическими функциями. Использовать логические функции. Создавать сложные формулы. Работать с несколькими листами. Составлять логические выражения. Ход работы Используя...

Русский

2014-12-07

162.52 KB

6 чел.

Условная функция

Цель: Научится:

  1. Пользоваться диапазоном клеток и стандартными статическими функциями.
  2. Использовать логические функции.
  3. Создавать сложные формулы.
  4. Работать с несколькими листами.
  5. Составлять логические выражения.

Ход работы

Используя таблицу «Список и успеваемость студентов» из ЛР №1, формирую таблицу для расчёта сумм стипендий студентам экономического отделения в соответствии с представленной формой. При этом учитываю следующие условия:

  1. Студенты получают стипендию, если средний балл больше 3.
  2. Скопировал таблицу.
  3. Преобразовал исходную таблицу в соответствии с образцом.
  4. Переименовал «лист 1» в «Начисления».
  5. Ввожу формулу для расчета стипендии первому студенту. Для этого использую Мастер функций:
  6. вызываю мастер функций Вставка-Функция.
  7. выбираю вид функции в списке Категория –Логические, а в Функция – Если.
  8. Нажимаю ОК.
  9. Во втором окне ввожу  Логическое выражение G6>=3

                                           Значение если истина $K$3

                                           Значение если ложь 0

В итоге получаем формулу =если(G6>=3;$K$3;0).

  1. Стипендия не начисляется студентам обучающимся на платной основе.
  2. Копирую таблицу начисления 1 на лист 2 и пере меновую в Начисления 2
  3. В ячейке I6 набираю формулу =ЕСЛИ(И(H6>=1;G6>=3);$K$3;0), копирую формулу в диапазон I7:I17.
  4. Студенты, имеющие средний бал более 4,5 получают 50% надбавки к стипендии.
  5. Скопировал таблицу Начисления 2 на лист 3,  переименовал в Начисления 3.
  6. вывожу формулу надбавки первому студенту в ячейку J6 при помощи мастера функций, в итоге в ячейке J6 получаем формулу =ЕСЛИ(И(H6=1;G6>=4,5);$K$3*0,5;0), копирую её для ячеек J7:J17.
  7. в ячейку K6 ввожу  =I6+J6.

 Задача 2

Расчет заработной платы.

По данному образцу создаю и заполняю таблицу, переименовал «лист 4» в «расчетную ведомость»

  1. Итого начислено(=C8+D8+E8)
  2. Пенсионный фонд (=ЕСЛИ(F8>7875;(F8*0)+149,63;0) =ЕСЛИ(F10<=7875;F10*0,02;0))
  3. Фонд безработицы (=ЕСЛИ(F8>=7875;(F8*0)+39,38;0) =ЕСЛИ(F10<=7875;F10*0,05;0))
  4. Соцстрах (=ЕСЛИ(F8>7875;(F8*0)+78,75;0) =ЕСЛИ(F10<=7875;F10*0,01;0))
  5. Подоходный налог(=(F8-I8-H8-J8)*0,15)
  6. Итого удержано(=G8+I8+H8+J8+L8)
  7. Всего к оплате(=F8-M8)

Переименовал «лист 5» в «Платежная ведомость».

Создаю платежную ведомость по образцу, заполняю, копируя соответствующие колонки из расчетной ведомости.

Выполняю расчет итого к оплате.

Контрольные вопросы

  1. Максимально возможное до тех пор пока соблюдается возможность вариантов ложь/истинна.
  2. Позволяет узнать содержит ли ячейка число =ЕЧИСЛО(А1).
  3. Позволяет узнать число или буквенное значение в ячейке(=или(енечёт(A6);ечётн(A6))).
  4. Формула будет возвращать #ЗНАЧ!.

 

А также другие работы, которые могут Вас заинтересовать

1012. Создание и обработка баз данных 490 KB
  Создание базы данных. Система управления базами данных ACCESS. Создание таблиц в режиме конструктора. Заполнение таблиц данными (кроме вычисляемого поля). Запросы на выборку. Параметрические запросы. Создание и редактирование отчетов.
1013. База данных Колледж 559 KB
  Создание базы данных Колледж, в которой учтена специфик колледжа. Концептуальными требованиями являются данные о колледже и об абитуриенте. Создание таблиц в режиме конструктора. Создание кнопочных форм.
1014. Решение задач с использованием возможностей MS Excel 521 KB
  Протабулировать (вычислить) заданную функцию на указанном диапазоне с шагом h. Построить график функции. Найти сумму числового ряда и сравнить ее с точным решением, вычислив погрешности. Описать технологию работы со списками в электронной таблице Excel. Подготовить книгу Excel с примерами, демонстрирующими технологию работы со списками.
1019. Расчет механического привода 415.5 KB
  Проектный расчет валов редуктора и межосевого расстояния. Конструктивные размеры червяка и червячного колеса. Проектировочный и проверочный расчет передачи. Проверка прочности шпоночного соединения. Выбор смазки редуктора и уплотнительных устройств.
1020. Особенности синтеза цифрового автомата 249.5 KB
  Таблица кодирования внутренних состояний входных и выходных переменных. Построение комбинационного устройства для формирования управляющих сигналов на входах блока памяти. Построение комбинационного устройства для формирования выходных сигналов автоматов. Минимизация функций алгебры–логики по картам Карно.