4206

Условная функция. Использование диапазона клеток с применением статических функций

Лабораторная работа

Информатика, кибернетика и программирование

Условная функция Цель: Научится: Пользоваться диапазоном клеток и стандартными статическими функциями. Использовать логические функции. Создавать сложные формулы. Работать с несколькими листами. Составлять логические выражения. Ход работы Используя...

Русский

2014-12-07

162.52 KB

7 чел.

Условная функция

Цель: Научится:

  1. Пользоваться диапазоном клеток и стандартными статическими функциями.
  2. Использовать логические функции.
  3. Создавать сложные формулы.
  4. Работать с несколькими листами.
  5. Составлять логические выражения.

Ход работы

Используя таблицу «Список и успеваемость студентов» из ЛР №1, формирую таблицу для расчёта сумм стипендий студентам экономического отделения в соответствии с представленной формой. При этом учитываю следующие условия:

  1. Студенты получают стипендию, если средний балл больше 3.
  2. Скопировал таблицу.
  3. Преобразовал исходную таблицу в соответствии с образцом.
  4. Переименовал «лист 1» в «Начисления».
  5. Ввожу формулу для расчета стипендии первому студенту. Для этого использую Мастер функций:
  6. вызываю мастер функций Вставка-Функция.
  7. выбираю вид функции в списке Категория –Логические, а в Функция – Если.
  8. Нажимаю ОК.
  9. Во втором окне ввожу  Логическое выражение G6>=3

                                           Значение если истина $K$3

                                           Значение если ложь 0

В итоге получаем формулу =если(G6>=3;$K$3;0).

  1. Стипендия не начисляется студентам обучающимся на платной основе.
  2. Копирую таблицу начисления 1 на лист 2 и пере меновую в Начисления 2
  3. В ячейке I6 набираю формулу =ЕСЛИ(И(H6>=1;G6>=3);$K$3;0), копирую формулу в диапазон I7:I17.
  4. Студенты, имеющие средний бал более 4,5 получают 50% надбавки к стипендии.
  5. Скопировал таблицу Начисления 2 на лист 3,  переименовал в Начисления 3.
  6. вывожу формулу надбавки первому студенту в ячейку J6 при помощи мастера функций, в итоге в ячейке J6 получаем формулу =ЕСЛИ(И(H6=1;G6>=4,5);$K$3*0,5;0), копирую её для ячеек J7:J17.
  7. в ячейку K6 ввожу  =I6+J6.

 Задача 2

Расчет заработной платы.

По данному образцу создаю и заполняю таблицу, переименовал «лист 4» в «расчетную ведомость»

  1. Итого начислено(=C8+D8+E8)
  2. Пенсионный фонд (=ЕСЛИ(F8>7875;(F8*0)+149,63;0) =ЕСЛИ(F10<=7875;F10*0,02;0))
  3. Фонд безработицы (=ЕСЛИ(F8>=7875;(F8*0)+39,38;0) =ЕСЛИ(F10<=7875;F10*0,05;0))
  4. Соцстрах (=ЕСЛИ(F8>7875;(F8*0)+78,75;0) =ЕСЛИ(F10<=7875;F10*0,01;0))
  5. Подоходный налог(=(F8-I8-H8-J8)*0,15)
  6. Итого удержано(=G8+I8+H8+J8+L8)
  7. Всего к оплате(=F8-M8)

Переименовал «лист 5» в «Платежная ведомость».

Создаю платежную ведомость по образцу, заполняю, копируя соответствующие колонки из расчетной ведомости.

Выполняю расчет итого к оплате.

Контрольные вопросы

  1. Максимально возможное до тех пор пока соблюдается возможность вариантов ложь/истинна.
  2. Позволяет узнать содержит ли ячейка число =ЕЧИСЛО(А1).
  3. Позволяет узнать число или буквенное значение в ячейке(=или(енечёт(A6);ечётн(A6))).
  4. Формула будет возвращать #ЗНАЧ!.

 

А также другие работы, которые могут Вас заинтересовать

36693. Администрирование Web-сервера Apache. Виртуальный хостинг на основе имен 43.5 KB
  Пусть необходимо создать виртуальные хосты с именами www.ваша_фамилия1.ua и www.ваша_фамилия2.ua. Сначала необходимо создать на локальном сервере DNS запись, указывающую, что адресу 127.0.0.1 соответствуют несколько имен. Для этого откройте файл /etc/hosts и допишите в строку
36694. Данило Галицький 90.16 KB
  Метою цього завдання є опис практичного застосування ресурсів мережі Інтернет при вивченні історії та особисто персони Данила Галицького. В даному випадку переді мною постало завдання отримання інформація для роботи з моєю презентацією. Її темою було Данило Галицький
36695. Администрирование СУБД MySQL. Работа с таблицами системной базы данных mysql 62 KB
  Откройте их с помощью команд [ltF3] и [ltF4] и зайдите в систему под именем любого пользователя например user. В лабораторной работе создаваемые пользователи обозначаются user1 и user2. То есть вам необходимо подставить вместо user1 и user2 имена ivnov1 и ivnov2. Выполните команду для добавления пользователя user1 и задания ему привилегий: insert into user Host User Pssword Select_priv vlues ‘loclhost user1 pssword‘user1Y; Выполните команду для добавления пользователя user2 и задания ему привилегий: insert into...
36696. Типизированный файл 87.42 KB
  Типизированный файл состоит из последовательности записей одной и той же структуры. Структура записи задается типом, который может быть как стандартным, так и заданным в программе. Запрещено создавать файлы файлов и файлы объектов, а также файлы структурированных компонентов, содержащих файлы и объекты. Записи файла нумеруются начиная с 0.
36697. Использование команд GRANT и REVOKE для задания привилегий пользователей 49 KB
  Откройте их с помощью команд [ltF3] и [ltF4] и зайдите в систему под именем любого пользователя например user. Работу в СУБД MySQL от имени пользователей root user3 и user4 необходимо вести параллельно подключившись с разных терминалов открытых в начале выполнения лабораторной работы. В лабораторной работе создаваемые пользователи обозначаются user3 и user4. То есть вам необходимо подставить вместо user3 и user4 имена ivnov3 и ivnov4.
36698. ОПРЕДЕЛЕНИЕ ОТНОШЕНИЯ ТЕПЛОЕМКОСТЕЙ ГАЗА МЕТОДОМ КЛЕМАНА - ДЕЗОРМА 73 KB
  Основные теоретические положения к данной работе основополагающие утверждения: формулы схематические рисунки: Для определения отношения Сp Cv в случае воздуха в данной лабораторной работе применен метод предложенный Клеманом и Дезормом в котором использовано охлаждение газа при его адиабатическом расширении. Быстрое сжатие и быстрое расширение газа приблизительно можно рассматривать как адиабатический процесс. Отсюда видно что при адиабатическом сжатии температура газа повышается за счет работы внешних сил а при адиабатическом...
36699. Определение параметров импульсных сигналов, используемых для электростимуляции 495 KB
  Связь амплитуды формы импульса частоты следования импульсов длительности импульсного сигнала с раздражающим действием импульсного тока. Какова будет сила тока в начале разрядки конденсатора Через 6 мс напряжение на конденсаторе упадет до 250 В. Цель работы: Используя осциллограф С819 источник питания постоянного тока Б545 дифференцирующие и интегрирующие цепи.
36700. Изучение действия СВЧ поля на вещество 551 KB
  Переменные токи наведенные электрическим полем создают в диполе стоячую волну с пучностью тока в его середине. Они препятствуют ответвлению в гальванометр высокочастотного тока свободно пропуская выпрямленный.Исследование нагревания токами СВЧ электролита и диэлектрика.Делают вывод о влиянии СВЧ поля на вещество Воздействие переменными токами Первичное действие переменного тока и электромагнитного поля на биологические объекты в основном заключается в периодическом смещении ионов растворов электролитов и изменении поляризации...
36701. Градуирование электростатического вольтметра с помощью электрометра Томсона 396 KB
  Градуирование электростатического вольтметра с помощью электрометра Томсона. Цель работы: Градуирование шкалы электростатического вольтметра с помощью абсолютного электрометра Томсона т. Основные теоретические положения к данной работе основополагающие утверждения: формулы...