4206

Условная функция. Использование диапазона клеток с применением статических функций

Лабораторная работа

Информатика, кибернетика и программирование

Условная функция Цель: Научится: Пользоваться диапазоном клеток и стандартными статическими функциями. Использовать логические функции. Создавать сложные формулы. Работать с несколькими листами. Составлять логические выражения. Ход работы Используя...

Русский

2014-12-07

162.52 KB

6 чел.

Условная функция

Цель: Научится:

  1. Пользоваться диапазоном клеток и стандартными статическими функциями.
  2. Использовать логические функции.
  3. Создавать сложные формулы.
  4. Работать с несколькими листами.
  5. Составлять логические выражения.

Ход работы

Используя таблицу «Список и успеваемость студентов» из ЛР №1, формирую таблицу для расчёта сумм стипендий студентам экономического отделения в соответствии с представленной формой. При этом учитываю следующие условия:

  1. Студенты получают стипендию, если средний балл больше 3.
  2. Скопировал таблицу.
  3. Преобразовал исходную таблицу в соответствии с образцом.
  4. Переименовал «лист 1» в «Начисления».
  5. Ввожу формулу для расчета стипендии первому студенту. Для этого использую Мастер функций:
  6. вызываю мастер функций Вставка-Функция.
  7. выбираю вид функции в списке Категория –Логические, а в Функция – Если.
  8. Нажимаю ОК.
  9. Во втором окне ввожу  Логическое выражение G6>=3

                                           Значение если истина $K$3

                                           Значение если ложь 0

В итоге получаем формулу =если(G6>=3;$K$3;0).

  1. Стипендия не начисляется студентам обучающимся на платной основе.
  2. Копирую таблицу начисления 1 на лист 2 и пере меновую в Начисления 2
  3. В ячейке I6 набираю формулу =ЕСЛИ(И(H6>=1;G6>=3);$K$3;0), копирую формулу в диапазон I7:I17.
  4. Студенты, имеющие средний бал более 4,5 получают 50% надбавки к стипендии.
  5. Скопировал таблицу Начисления 2 на лист 3,  переименовал в Начисления 3.
  6. вывожу формулу надбавки первому студенту в ячейку J6 при помощи мастера функций, в итоге в ячейке J6 получаем формулу =ЕСЛИ(И(H6=1;G6>=4,5);$K$3*0,5;0), копирую её для ячеек J7:J17.
  7. в ячейку K6 ввожу  =I6+J6.

 Задача 2

Расчет заработной платы.

По данному образцу создаю и заполняю таблицу, переименовал «лист 4» в «расчетную ведомость»

  1. Итого начислено(=C8+D8+E8)
  2. Пенсионный фонд (=ЕСЛИ(F8>7875;(F8*0)+149,63;0) =ЕСЛИ(F10<=7875;F10*0,02;0))
  3. Фонд безработицы (=ЕСЛИ(F8>=7875;(F8*0)+39,38;0) =ЕСЛИ(F10<=7875;F10*0,05;0))
  4. Соцстрах (=ЕСЛИ(F8>7875;(F8*0)+78,75;0) =ЕСЛИ(F10<=7875;F10*0,01;0))
  5. Подоходный налог(=(F8-I8-H8-J8)*0,15)
  6. Итого удержано(=G8+I8+H8+J8+L8)
  7. Всего к оплате(=F8-M8)

Переименовал «лист 5» в «Платежная ведомость».

Создаю платежную ведомость по образцу, заполняю, копируя соответствующие колонки из расчетной ведомости.

Выполняю расчет итого к оплате.

Контрольные вопросы

  1. Максимально возможное до тех пор пока соблюдается возможность вариантов ложь/истинна.
  2. Позволяет узнать содержит ли ячейка число =ЕЧИСЛО(А1).
  3. Позволяет узнать число или буквенное значение в ячейке(=или(енечёт(A6);ечётн(A6))).
  4. Формула будет возвращать #ЗНАЧ!.

 

А также другие работы, которые могут Вас заинтересовать

23903. Еврипид Медея 17.48 KB
  В Колхиде правил могучий царь сын Солнца; дочь его царевнаволшебница Медея полюбила Ясона они поклялись друг Другу в верности и она спасла его. Вовторых когда они отплывали из Колхиды Медея из любви к мужу убила родного брата и разбросала куски его тела по берегу; преследовавшие их колхидяне задержались погребая его и не смогли настичь беглецов. Втретьих когда они вернулись в Иолк Медея чтобы спасти Ясона от коварства Пелия предложила дочерям Пелия зарезать их старого отца обещав после этого воскресить его юным.
23904. Софокл Антигона 17.64 KB
  Когда Эдип отрекся от власти и удалился в изгнание править стали вдвоем Этеокл и Полиник под надзором старого Креонта свойственника и советника Эдипа. После гибели Этеокла и Полиника власть над Фивами принял Креонт. Но Креонт думал не о людях и не о богах а о государстве и власти. Навстречу хору выходит Креонт и оглашает свой указ: герою честь злодею срам тело Полиника брошено на поругание к нему приставлена стража кто нарушит царский указ тому смерть.
23905. Софокл Трахинянки 17.08 KB
  Знаменит он только тем что в нем прожил свои последние годы величайший из греческих героев Геракл сын Зевса. Почти все греческие герои были царями в разных городах и городках кроме Геракла. Когда Геракл кончил свою подневольную службу он пошел на край Греции свататься к Деянире. Геракл схватился с богом в борьбе придавил его как гора; тот обернулся змеем Геракл стиснул ему горло; тот обернулся быком Геракл сломил ему рог.
23906. Филоктет - характеристика литературного героя 14.8 KB
  Филоктет характеристика литературного героя персонажа Филоктет ФИЛОКТЕТ герой трагедии Софокла Филоктет поставлена в 409 г. создали кроме Софокла и Эсхил и Еврипид обе хронологически предшествовали Софокловой но последние произведения не сохранились. на пути под Трою во время жертвоприношения у Софокла на Хрисе около Лемноса по другим версиям на о. исключительный для Софокла случай наученный Одиссеем выдает себя за жертву Атридов.
23907. Софокл Царь Эдип 16.7 KB
  Назвали мальчика Эдип. Эдип вырос сильным и умным. Эдип был в ужасе.
23908. Софокл Эдип в Колоне 16.43 KB
  Среди этой рощи стоял алтарь в честь героя Эдипа: считалось что этот фиванский герой здесь похоронен и охраняет эту землю. От кровосмесительного брака с матерью у Эдипа были два сына и две дочери: Этеокл и Полиник Антигона и Исмена. Когда Эдип ослепил себя за грехи и ушел от власти оба сына отшатнулись от него.
23909. ОРЕСТ МСТИТ ЗА УБИЙСТВО ОТЦА 14.38 KB
  Это был сын Агамемнона Орест спасенный в день гибели Агамемнона своей няней и воспитанный вдали от родины царем Фокиды Строфием. Только что Орест принес свою жертву отцу как в дверях дворца показались рабыни в черных одеждах. Орест и Пилад поспешно спрятались у могилы и стали смотреть что будут делать рабыни. По сходству их со своими волосами сразу догадалась она что это волосы Ореста.
23910. Эсхил Орестея 22.47 KB
  Но участь его оказалась ужасна а участь сына его Ореста еще ужаснее. Но в живых остается маленький сын Агамемнона и Клитемнестры Орест: чувство матери побеждает в Клитемнестре расчет мстительницы она отсылает его в чужой край чтобы Эгисф не погубил за отцом и сына. Орест растет в далекой Фокиде помышляя только об одном о мести за Агамемнона.