44163

Разработка программного обеспечения для формирования договоров фирмы «МегаКомок»

Дипломная

Информатика, кибернетика и программирование

Торговая деятельность связана с движением товаров и денежных средств, а значит и с формированием и печатью большого количества первичных документов. Программа управления торговлей МойСклад полностью реализует задачи благодаря следующим возможностям...

Русский

2013-11-10

2.89 MB

7 чел.

Введение

В настоящее время в условиях рыночной экономики появляется и функционирует всё большее число торговых предприятий. Каждое предприятие стремится получить максимальную прибыль при минимальных затратах.

В современных условиях одной из главных задач руководителя становится оптимизация производственного процесса на предприятии с целью наиболее эффективного использования рабочего времени, улучшения качества работы и увеличение её объёмов, а также снижения энергозатрат при ведении всей необходимой документации.

В условиях стремительного прогресса, рыночных отношений и конкурентной экономики своевременное и правильное решение стратегических и тактических задач определяет жизнеспособность торговой фирмы, предприятия. Документированная информация составляет основу управления, его эффективность в значительной степени базируются на производстве и потреблении информации.

Во время рыночных отношений немаловажное значение придается механизации и автоматизации делопроизводственных процессов, которые увеличивают производительность труда работников предприятия. Рационализации документационного обеспечения управления в предприятиях  необходимо уделить большое внимание, потому что недостатки в постановке этой работы приводят к серьезным трудностям в работе руководителя и предприятия в целом. За счет более совершенной системы документационного обеспечения управления достигается более быстрое движение и исполнение служебных документов, их сохранение, использование и правильный отбор на долгосрочное хранение.

В настоящее время для многих российских государственных организаций и коммерческих фирм характерно отсутствие упорядоченной системы ведения делопроизводства, несмотря на то, что именно рациональная и четко организованная работа с документами может существенно увеличить эффективность деятельности предприятия.

Для автоматизации широкого круга задач в области делопроизводства и документооборота на торговых предприятиях используются разнообразные программные продукты. Они представляют собой комплексное универсальное решение множества вопросов и успешно используются многими государственными и коммерческими предприятиями для автоматизации учета документов, организации коллективной работы сотрудников, контроля и анализа исполнительской дисциплины и решения ряда других задач.


Общая часть

1.1 Описание предметной области 

Комиссионный магазин - магазин, специализирующийся на продаже товаров бывших в употреблении, если точнее, то уже имевших хозяев. Магазин принимает для дальнейшей продажи товары от физических и юридических лиц за комиссионное вознаграждение.

Сделки заключаются в соответствии с постановлением Правительства РФ путём заключения комиссионного договора, в котором описывается наименование, количество и качество сданного на комиссию товара, устанавливается продажная цена и размер вознаграждения комиссионера.

Требования к товару:

  1.  Чистота товара
  2.  Внешний вид товара
  3.  Востребованность товара

Прием товара в комиссионных магазинах происходит по следующей схеме. Комиссионка принимает от населения товары на реализацию, но берет за это свою долю — 30-50% от стоимости товара, которая добавляется к его цене. В конечном итоге продавец может рассчитывать на 20-30% от первоначальной стоимости сдаваемой вещи. Цена, по которой будет выставлен товар, обговаривается продавцом с приемной комиссией магазина. Если она покажется сотрудникам магазина завышенной, ее посоветуют снизить до реальных величин. Если продавец откажется на это пойти, товар будет выставлен по его цене, но продавец должен быть готов к ее возможному снижению. Товар должен быть продан в первые 20-25 дней. Через несколько дней после покупки товара, продавец получает деньги на руки. Комиссионный магазин принимает товар на определенный срок, после которого вещь снимается с реализации и возвращается хозяину. Если вещь дорогостоящая, в комиссионном магазине попросят оплатить ее хранение (как правило, эта сумма не превышает 5% в месяц).

В настоящем разделе справочника бухгалтера рассмотрен порядок учета товаров в коммерческих организациях Российской Федерации.

Торговля товарами подразделяется на оптовую и розничную. Признаком деления торговых операций на оптовые и розничные, согласно ГК РФ, является цель приобретения покупателем товара. А именно:

Основными целями бухгалтерского учета товарных операций является:

  •  своевременное и полное отражение на счетах бухгалтерского учета информации о приобретении и продаже товаров на основании полученных и сформированных форм первичных документов;
  •  отражение данных о расходах, связанных с приобретением и продажей товаров;
  •  своевременное отражение данных о движении товаров на складах организации;
  •  формирование информации о выручке, прибыли, налогах, возникающих при продаже товаров.
  •  Для достижения этих целей необходимо решить следующие задачи бухгалтерского учета товарных операций:
  •  своевременное и правильное документальное оформление операций поступления товаров, а также оформление перемещения и реализации товаров;
  •  определение круга лиц (материально-ответственных работников), ответственных за приемку, отпуск и сохранность вверенных им ценностей;
  •  контроль за сохранностью товаров в местах их хранения и на всех этапах движения;
  •  контроль соответствия данных складского учета и оперативного учета движения товаров в местах хранения организации данным бухгалтерского учета;
  •  контроль за соблюдением установленных в организации норм товарных запасов, обеспечивающих бесперебойную реализацию;
  •  контроль за соответствием синтетического учета товаров, данным аналитического учета на начало каждого месяца (по оборотам и остаткам);
  •  проведение анализа эффективности реализации.

1.2 Анализ существующей ситуации

ООО "МегаКомок" – это предприятие, основным направлением деятельности которого является получение прибыли посредством удовлетворения общественных потребностей.

Для этого ООО "МегаКомок" предоставляет услуги населению по реализации вещей, бывших в употреблении, а также новых изделий.

В ассортименте магазина представлены следующие группы товаров: одежда, мебель, бытовая техника, головные уборы, обувь, прочее.

Договоры заполняются вручную, все данные  о клиентах берутся из справочника контрагенты.

Акты расторгаются вручную, акты хранятся в MS Word и печатаются, исправления делаются вручную.

Найденные ошибки в договорах и актах исправляются вручную.

На предприятии используется типовая конфигурация «Управление торговлей»  которая решает, прежде всего, задачи автоматизации:

  •  управление отношениями с клиентами;
  •  управление продажами;
  •  управление закупками;
  •  анализ цен и управление ценовой политикой;
  •  управление складскими запасами;
  •  управление денежными средствами;
  •  анализ данных;

В данной конфигурации «Управление Торговлей» не хватает функции создание и печати договоров, создание и  печать актов о расторжении договора, формирование данных на печатных формах.

Технологический процесс представлен на рисунке 1.

Рисунок 1 - Технологический процесс

Поступление товара: человек доставляет товар в приемную комиссию.

Оценка стоимости товара: качество товара, внешний вид, степень износа, предполагаемая востребованность для покупателя.

Заключение договора: Заключение договора с поставщиком, если товар продался, то выдаются средства поставщику.

Если товар не продается, то договор расторгается.

Модель взаимодействия сотрудников расположена на рисунке 2

Рисунок 2 – Модель взаимодействия сотрудников

  •  Поставщик отдает товар приемщику
  •  Заключение договора
  •  Договор записывается в папку  документов
  •  Характеристики товара записываются в папку документов
  •  Полученные товары перемещаются в торговый зал
  •  Если товар не продался, договор расторгается

1.3 Характеристики существующего программного обеспечения

На рынках труда есть разные программы которые помогут автоматизировать, определенные виды задач.

«АстроСофт: управление договорами» - это продукт, реализованный на платформе 1С, и предназначенный для автоматизации процессов и систем финансового управления и управления продажами в разрезе договорной деятельности.

Договорная работа в организации представляет собой сложный распределенный управленческий процесс взаимоотношения сотрудников фирмы по созданию, согласованию, исполнению и учету договоров. Как правило, работа с договорами включает в себя следующие этапы:

  1.  Инициация договора;
  2.  Процесс согласования договора;
  3.  Заключение договора;
  4.  Планирование ресурсов и исполнение обязательств по договору;
  5.  Анализ результатов;

Программа «Астрософт: управление договорами» позволит систематизировать, упростить и эффективно построить работу в разрезе договорных отношений. Данный продукт:
- дает возможность взаимосвязано планировать, контролировать и анализировать договорную деятельность,
- фиксирует все изменения статусов и параметров договоров,
- предоставляет полную, актуальную и структурированную информацию.

Рисунок - интерфейс программы АстроСофт

МойСклад - интернет-сервис управления торговлей и складского учета.

Торговая деятельность связана с движением товаров и денежных средств, а значит и с формированием и печатью большого количества первичных документов. Программа управления торговлей МойСклад полностью реализует задачи благодаря следующим возможностям:

  •  Вывод в формат Microsoft Excel, PDF, OpenOffice.org для печати или отправки по электронной почте;
  •  счет, накладная, ТОРГ-12, ТТН (1-Т), акт выполненных работ, счет-фактура;
  •  расходный и приходный кассовые ордера, платежное поручение;
  •  ТОРГ-13, ведомость ИНВ-3, МХ-1, МХ-3 и многие другие;
  •  Несложное создание собственных шаблонов печатных форм с помощью Microsoft Excel;
  •  Автоматическая сквозная нумерация документов;
  •  Архив распечатанных документов.

Рисунок – Интерфейс программы МойСклад

Программный продукт "1С:Предприятие 8. Управление торговлей" является тиражным решением, позволяющим в комплексе автоматизировать анализ и планирование торговых операций, обеспечивая тем самым эффективное

управление современным торговым предприятием.

В конфигурации 1С:Предприятие 8. Управление торговлей на основе введенных данных по торговым операциям можно произвести оперативную оценку суммы налога на добавленную стоимость с помощью сформированной книги продаж и книги покупок.

Однако конфигурация не предназначена для ведения полноценного бухгалтерского и налогового учета и формирования всех необходимых регламентных документов для предоставления их в государственные налоговые органы.

2 Специальная часть

2.1 Обоснование необходимости разработки программного обеспечения

Анализ организации работы с документами в предприятии показал необходимость введения изменений в систему работы по этому направлению.

Одной из главных задач стала оптимизация и эффективное управление документооборотом. В связи, с чем возникла необходимость усовершенствования программного обеспечения в этой области. Предприятие «МегаКомок» нуждалось в  доработке конфигурации, которая будет печатать акты расторжения договора, печать договоров, печать выплату комитентам, печать актов о наличии вещей у контрагента. В предприятии увеличится эффективность обслуживания клиентов, увеличится скорость обслуживания, уменьшатся трудозатраты на разработку договоров, актов. Заполнять документы и печатать договора станет намного легче и быстрее. Появится возможность просмотра данных о контрагентах, намного легче станет найти ошибки при заполнении и печати документов.

2.2 Обоснование выбора операционной системы

Существует большое количество разнообразных операционных систем с различными аппаратными требованиями и, соответственно, возможностями. При выборе необходимой ОС были приняты за наиболее важные критерии. Критерии следующие: аппаратные требования к ОС; поддерживаемое периферийное аппаратное обеспечение; полнота удовлетворения требованиям пользователя; способ взаимодействия ОС с пользователем; наличие различных информационных подсказок, встроенных  справочников; устойчивость системы к ошибкам  пользователя, отказам оборудования; сетевые возможности выбранной ОС; возможности системы по обеспечению совместимости с другими операционными системами; наличие широко известных пакетов прикладных программ работающих под данной ОС; возможности ОС по защите конфиденциальной информации.

Сравнение Windows

Знак  означает, что качество улучшено

Название возможности

Windows XP

Windows Vista

Windows 7

Упрощенное выполнение нескольких задач.

Общение и обмен в бесплатных программах по работе с фотографиями, электронной почтой и мгновенными сообщениями.

Более удобный и безопасный просмотр веб-страниц

Мгновенный поиск файлов и программ.

Открытие часто используемых программ и файлов парой щелчков мыши

Подключение к любым доступным беспроводным сетям тремя щелчками мыши.

Ускоренный переход между открытыми окнами.

Удобный обмен файлами, фотографиями и музыкой в домашней сети.

Работа с учетом потребностей пользователя

Название возможности

Windows Xp

Windows Vista

Windows 7

Персонализация рабочего стола с помощью тем и фотографий.

Более безопасное подключение к корпоративным сетям.

Полная совместимость с 64-разрядными ПК

Запуск бизнес-программ для Windows XP.

Встроенная защита от программ-шпионов и других вредоносных программ.

Обеспечение безопасности и конфиденциальности данных.

Ускоренный переход в спящий режим и возобновление работы.

В Windows 7 интерфейс поиска был значительно улучшен для того, чтобы пользователи могли быстрее и проще находить нужные им данные и мгновенно переходить к работе с ними. Результаты поиска сопровождаются краткими сведениями о найденных файлах и выдержками из их содержимого. Пользователи могут создавать более сложные запросы при помощи построителя запросов, встроенного в поле поиска.

Windows 7 позволяет искать документы не только на локальном ПК пользователя, но и на других компьютерах и устройствах. Используя Windows 7, разработчики и ИТ-специалисты могут указывать поисковые системы, хранилища документов, веб-приложения и собственные хранилища данных, в которых необходимо выполнять поиск, не разрабатывая и не распространяя дополнительное ПО для клиентских систем.

Операционная система Windows XP вышла в октябре 2001 года. Windows XP способна работать на компьютерах с частотой процессора не менее 233 МГц и с объемом оперативной памяти от 128 Мбайт. При этом для удобной и эффективной работы эти значения лучше удвоить. Таким образом, для Windows XP рекомендуется иметь процессор с тактовой частотой от 500 МГц и не менее 256 Мбайт оперативной памяти.

Многозадачность в Windows XP - это способность одновременно выполнять несколько программ. Например, в процессе подготовки текста в текстовом редакторе можно ещё параллельно печатать что-то на принтере и проверять на наличие вируса жесткий диск.

Windows Vista помогает поддерживать связь с нужными людьми и получать доступ к необходимой информации благодаря улучшенным функциям сети, синхронизации, просмотра веб-страниц, удаленного подключения и другим.

Операционная система Windows Vista помогает полностью использовать возможности компьютера благодаря улучшенным средствам диагностики, быстродействия и устранения неполадок, а также возможностям интуитивного поиска, более быстрому переходу между спящим и обычным режимами работы и многим другим функциям.

Windows Vista предлагает больше способов взаимодействия с компьютером - специальные возможности, интерфейс Windows Aero и поддержка планшетных ПК и ноутбуков, - чтобы вы могли успевать больше за меньшее время.

Для разработки программного продукта была выбрана операционная система Windows 7, так как она содержит средства и программы, предназначенные для надежной работы компьютера, управления системой и регулярного выполнения работ по плановому обслуживанию с целью поддержания оптимальной производительности.

2.3 Выбор технологии языка и инструментальных средств  

Технологией разработки (программирования) называют совокупность методов и средств, используемых в процессе разработки программного обеспечения.

Существует несколько этапов подхода к программированию:

Первый этап - «стихийное» программирование. В этот период практически отсутствовали сформулированные технологии, и программирование фактически было искусством. Первые программы имели простейшую структуру. Они состояли из собственно программы на машинном языке и обрабатываемых ею данных.

Второй этап – структурный подход к программированию. Структурный подход представляет собой совокупность рекомендуемых технологических приёмов, охватывающих выполнение всех этапов разработки программного обеспечения. В основе структурного подхода лежит декомпозиция (разбиение на части) сложных систем с целью последующей реализации в виде отдельных небольших подпрограмм.

Третий этап – объектный подход к программированию. Технология создания сложного программного обеспечения, основываясь на представлении программы в виде совокупности объектов, каждый из которых является экзем

пляром определенно типа (класса), а классы образуют иерархию с наследованием свойств. Взаимодействие программных объектов в такой системе осуществляется путём передачи сообщений.

Четвертый этап – компонентный подход и CASE – технологии. Такой подход предполагает построение программного обеспечения из отдельных компонентов – физически существующих частей программного обеспечения, которые взаимодействуют между собой через стандартизованные двоичные интерфейсы.

Таким образом технологией языка для разработки конфигурации является структурный подход.

Задача для усовершенствования документооборота, будет решаться на базе платформы 1С: Предприятия 8.2, путем доработки конфигурации Управление торговлей.

Система 1C: Предприятие 8.2  используется для широкого круга задач автоматизации экономической деятельности. Примеры таких задач - ведение различных форм бухгалтерского учета, автоматизация торговли, складского учета.

Важнейшее достоинство 1C: Предприятия 8.2 - возможность доработки стандартных конфигураций или даже создания абсолютно оригинальных продуктов. Чаще всего индивидуальная настройка состоит в доработке типовой конфигурации.

Система дает возможность создавать конфигурации, используя встроенный язык программирования и компоненты построения пользовательского интерфейса, дорабатывать и отлаживать их, исполнять разработанную конфигурацию для эксплуатации ее конечным пользователем. Набор объектов, структуры баз данных, алгоритмы определяет конфигурация системы. Фирма 1C поставляет типовые конфигурации. Однако эти конфигурации могут дополняться и изменяться.

Проведение объектов 1С определяется на встроенном языке.

Встроенный язык позволяет работать со справочниками, документами и другими объектами 1С. Можно, например, с помощью методов объектов выбрать все элементы справочника Сотрудники для вывода в отчет, или создать и сохранить любой документ поэтому для настройки конфигурации в соответствии с требованиями пользователя и для разработки новых конфигураций необходимо изучить возможности встроенного языка системы 1С.

2.4 Выбор методов и разработка основных алгоритмов решения задачи

На рисунке  3 представлена блок-схема алгоритма работы программы

Рисунок 3 – Блок-схема алгоритма программы

2.5 Формирование требований к программному обеспечению

Требования к программному обеспечению — совокупность утверждений относительно атрибутов, свойств или качеств программной системы, подлежащей реализации.

Определяют требования как:

  •  Условия или возможности, необходимые пользователю для решения проблем или достижения целей;
  •  Условия или возможности, которыми должна обладать система или системные компоненты, чтобы выполнить контракт или удовлетворять стандартам, спецификациям или другим формальным документам

2.5.1 Функциональные требования

Программный продукт должен реализовать следующие функции:

  •  Формировать данные из справочников в печатную форму;
  •  просмотр отчетов на экран и на печать;
  •  печать договоров;
  •  печать актов расторжения договора;
  •  печать акта о  вещах у контрагента.

2.5.2 Требования к надёжности

  •  Не должны вводиться отрицательные значения;
  •  должны вводится те значения, которые прописаны в формах;
  •  корректное заполнение документов;
  •  проведение документов, отчетов.

2.5.3 Требования к информационной и программной совместимости  

Требования для работы с программой:

В первую очередь на компьютере должна быть установлена операционная система, платформа 1С: Предприятие 8.2. Исходя из обоснования выбора операционной системы, предъявляемых к программному обеспечению, где будет использоваться программный продукт, была выбрана ОС Windows 7.

Для успешной работы программы, информационная база должна быть загружена в платформу 1С: Предприятие 8.2.

2.5.4 Требования к составу и параметрам технических средств

Минимальные:

  •  Операционная система – Windows XP;
  •  оперативная память 256мб;
  •  жесткий диск 5Гб.

Рекомендуемые:

  •  Операционная система: Windows 7, Windows Vista;
  •  жесткий диск 10ГБ и выше;
  •  оперативная память 1ГБ и выше.

2.6 Анализ требований и проектирование программного обеспечения

2.6.1 Анализ процесса обработки информации и выбор структур   данных для её хранения

Для решения задачи  выбрана платформа 1С: Предприятие 8.2, так как она позволяет реализовать все необходимые функциональные задачи программы.

Данные, которые 1С:Предприятие 8.2 использует всегда, могут быть разделены на 5 групп в соответствии с их назначением и мерой их ответственности:

  •  Информационные базы. К информационным базам относится наиболее ответственная информация, включающая: конфигурацию, все данные о хозяйственной деятельности предприятия а также административную информацию. Все данные, относящиеся к информационной базе, объединяются в базу данных. Потеря или искажение каких-то данных информационной базы может привести к потере работоспособности системы, построенной на базе 1С:Предприятия 8.2.
  •  Хранилище конфигурации содержит текущую конфигурацию и историю ее разработки при использовании в Конфигураторе средств групповой разработки.
  •  Журнал регистрации содержит список операций, совершенных над данной информационной базой. Эта информация не является необходимой для работы системы на базе 1С:Предприятия 8.2, но может быть важной с организационной точки зрения.
  •  Вспомогательные данные. К вспомогательным относятся такие данные, которые служат для удобства пользователя и не влияют на логику работы системы на базе 1С:Предприятия 8.2.
  •  Прочие файлы содержат информацию о расположении окон, текущих позициях, состоянии диалогов и других настройках, позволяющих пользователю работать наиболее комфортно. Различные конфигурации могут хранить в про файлах и другую информацию, которая может быть полезной, но не является необходимой.
  •  Другие вспомогательные данные. К ним относятся списки информационных баз, зарегистрированных на клиенте или на сервере, и некоторые другие данные.
  •  Временные данные. Эти данные использует приложение 1С:Предприятия 8.2 для служебных целей. Они актуальны только в пределах одного сеанса работы и после его завершения уничтожаются.

Хранилище конфигурации

Хранилище конфигурации используется при групповой разработке конфигураций и служит для хранения истории версий конфигурации, включая последнюю (текущую) версию. Все хранилище содержится в одном файле - 1Cv8ddb.1cd, который располагается в каталоге, заданном в качестве каталога хранилища конфигурации.

В процессе разработки конфигураций с использованием средств групповой разработки данные, хранимые в этом файле, являются жизненно важными. Поэтому рекомендуется их резервное копирование.

Журнал регистрации:
Журнал регистрации относится к информационной базе и служит для сохранения информации о событиях, возникающих в процессе работы пользователей с данной информационной базой. Эта информация может быть важной с организационной точки зрения, но не является необходимой для функционирования прикладного решения на базе 1С:Предприятия 8.2.

Журналы регистрации хранятся в специальных файлах 1Cv8.log по одному на каждую информационную базу.

Данные, которые определяют логику функционирования системы на базе 1С:Предприятия 8.2, относятся к информационной базе. Хранение информационной базы осуществляется в базе данных в виде набора таблиц, для чего 1С:Предприятие 8.2 может использовать одну из четырех систем управления базами данных (СУБД):

  •  Встроенную в 1С:Предприятие 8.2 (файловый вариант информационной базы). В этом случае все данные информационной базы хранятся в файле с именем 1Cv8.2 CD. Этот файл имеет двоичный формат и по сути является базой данных для встроенной в 1С:Предприятие 8.2 СУБД.
  •  Microsoft SQL Server (клиент-серверный вариант информационной базы). Все данные информационной базы хранятся в базе данных Microsoft SQL Server.
  •  PostgreSQL (клиент-серверный вариант информационной базы). Все данные информационной базы хранятся в базе данных PostgreSQL.
  •  IBM DB2 (клиент-серверный вариант информационной базы). Все данные информационной базы хранятся в базе данных IBM DB2.

Таким образом 1С:Предприятие 8.2 использует файловый вариант информационной базы, все данные информационной базы хранятся в файле с именем 1Сv8.2 CD.

2.6.2 Выделение информационных объектов, определение связей информационных объектов и логической структуры базы данных

Информационные объекты:

Склады

Таблица 1 справочник склады

Название

Тип данных

Код

Число

Наименование

Строка

Вид склада

ПеречислениеСсылка.ВидыСкладов

Тип склада

ПеречислениеСсылка.ВидыСкладов

Комментарий

Строка

Номер секции

Число

подразделение

СправочникСсылка.Подразделения

Подразделения

Таблица 2 справочник подразделения

Название

Тип данных

Код

Число

наименование

строка

Валюты

Таблица 3 справочник валюты

Название

Тип данных

Код

Число

Наименование

Строка

Полное наименование

Строка

Курс

Строка

кратность

строка

Номенклатура

Таблица 4 справочник номенклатура

Название

Тип данных

Единица измерения

СправочникСсылка.КлассификаторЕдиницИзмерения

Наименование

Строка

Артикул

Строка

Комментарий

Строка

Статья затрат

СправочникСсылка.СтатьиЗатрат

Весовой

Булево

вид номенклатуры

СправочникСсылка.ВидыНоменклатуры

Комплект

Булево

Страна

СправочникСсылка.КлассификаторСтранМира

Размер

ПеречислениеСсылка.РазмерыЦенников

Серийный номер

Булево

Изображение

СправочникСсылка.ХранилищеДополнительнойИнформации

поставщик

СправочникСсылка.Контрагенты

Контрагенты

Таблица 5 справочник контрагенты

Название

Тип данных

Код

Число

Наименование(фио)

Строка

Полное наименование

Строка

Комментарий

Строка

Инн

Строка

Кпп

Строка

Удостоверение

Строка

Юрфизлицо

ПеречислениеСсылка.ЮрФизЛицо

Регион

СправочникСсылка.Регионы

Банковский счет

СправочникСсылка.БанковскиеСчета

Расписание работы

Строка

Код по окпо

строка

Организации

Таблица 6 справочник организации

Название

Тип данных

Код

число

Наименование

строка

Инн

Строка

Кпп

Строка

Огрн

Строка

Юрфизлицо

ПеречислениеСсылка.ЮрФизЛицо

Банковский счет

СправочникСсылка.БанковскиеСчета

Дата выдачи свидетельства

Дата

Номер свидетельства

строка

В таблицах 1-6 представлены типовые информационные объекты которые используются для функций доработки конфигурации.

В таблице 7 представлены реквизиты документа АктРасторженияДоговора.

Таблица 7 – Документ АктРасторженияДоговора

Реквизит

Тип данных

Дата

Дата

Номер

Строка

Сумма

Число

Валюта

СправочникСсылка.Валюты

Контрагент

СправочникСсылка.Контрагенты

Организация

СправочникСсылка.Организации

Дата оплаты

Дата

Дата отгрузки

Дата

Склад группа

СправочникСсылка.Склады, СправочникСсылка.ГруппыДоступностиСкладов

Подразделение

СправочникСсылка.Подразделения

Ответственный

СправочникСсылка.Пользователи

Комментарий

ПеречислениеСсылка.ОснованиеРасторжения

Табличная часть Товары:

Номенклатура – СправочникСсылка.Номенклатура

Количество - число

Цена продажи - число

Сумма дополнительные расходы - число

Сумма – число

В таблице 8 представлены реквизиты документа ВыплатыКомитентам

Таблица 8 – Документ ВыплатыКомитентам

Реквизит

Тип данных

Дата

Дата

Номер

Строка

Сумма

Число

Валюта

СправочникСсылка.Валюты

Контрагент

СправочникСсылка.Контрагенты

Организация

СправочникСсылка.Организации

Дата оплаты

Дата

Дата отгрузки

Дата

Склад группа

СправочникСсылка.Склады, СправочникСсылка.ГруппыДоступностиСкладов

Подразделение

СправочникСсылка.Подразделения

Ответственный

СправочникСсылка.Пользователи

Комментарий

ПеречислениеСсылка.ОснованиеРасторжения

Табличная часть Товары:

Номенклатура – СправочникСсылка.Номенклатура

Количество - число

Цена продажи - число

Цена продажи - число

Сумма – число

В таблице 9 представлены реквизиты обработки ДоговорКомиссии

Таблица 9 – Обработка ДоговорКомиссии

Реквизит

Тип данных

ДатаДоговора

Дата

НомерДоговора

Строка

Контрагент

Справочник.Ссылка.Контрагенты

В таблице 10 представлены реквизиты обработки НаличиеВещей

Таблица 10 – Обработка Наличие вещей

Реквизит

Тип данных

ДатаДоговора

Дата

Контрагент

Справочник.Ссылка.Контрагенты

Модель сущность-связь (ER-модель) — модель данных, позволяющая описывать концептуальные схемы предметной области.

ER-модель используется при высокоуровневом (концептуальном) проектировании баз данных. С её помощью можно выделить ключевые сущности и обозначить связи, которые могут устанавливаться между этими сущностями.

Диаграмма ERD представлена на рисунке 4

Рисунок 4 - Диаграмма ERD

2.6.3 Построение функциональной схемы программы

Функциональная схема — документ, разъясняющий процессы, протекающие в отдельных функциональных цепях изделия (установки) или изделия (установки) в целом. Функциональная схема является экспликацией отдельных видов процессов, протекающих в целостных функциональных блоках и цепях устройства.

Функциональная схема представлена на рисунке 5

Рисунок 5 -  Функциональная схема

Акт расторжения договора:

В документ вводятся данные о контрагенте, заполняются данные, печатается акт о расторжении договора

Договор Комиссии:

Договор заключается после добавления данных в справочник контрагенты, после печатается договор комиссии.

Просмотр вещей у контрагента:

После заключения договора, вносятся данные о вещах контрагента в справочник контрагенты, далее печатается акт о наличии вещей контрагента.

2.6.4 Разработка структурной схемы программного продукта

Структурная схема — это совокупность элементарных звеньев объекта и связей между ними, один из видов графической модели. Под элементарным звеном понимают часть объекта, системы управления и т. д., которая реализует элементарную функцию.

Структурная схема представлена на рисунке 6.

Рисунок 6 -  Структурная схема

Для начала добавляется контрагент в справочник.

Заключается с ним договор, после истечения срока договора, он расторгается.

После внесения контрагента в справочник можно добавить список его вещей.

Просмотр вещей у контрагента происходит в справочнике Номенклатура

2.6.5 Детальная разработка алгоритмов

Процедура Печать() экспорт

 ТабДок = Новый ТабличныйДокумент;

 Макет = ПолучитьМакет("Акт");

 Область = Макет.ПолучитьОбласть("Область1");

 область.Параметры.Номер=Номер;

  область.Параметры.ном = ДоговорКонтрагента.Номер;

   область.Параметры.дат = Формат(ДоговорКонтрагента.Дата,"ДФ = ""dd ММММ гггг """"г.""""""");

 область.Параметры.основание=Комментарий;

 область.Параметры.Дата= Формат(Дата,"ДФ = ""dd ММММ гггг """"г.""""""");

 область.Параметры.Контрагент=Контрагент;

 ТабДок.Вывести(Область);

 Область2 = Макет.ПолучитьОбласть("Область2");

 ном=1;итого=0;

 запрос=новый запрос;

 Запрос.Текст="ВЫБРАТЬ

              | ПоступлениеНаКомиссию.ЦенаРозн,

              | ПоступлениеНаКомиссию.СуммаДопРасх,

              | ПоступлениеНаКомиссию.ЦенаЗакуп

              |ИЗ

              | РегистрНакопления.ПоступлениеНаКомиссию КАК ПоступлениеНаКомиссию

              |ГДЕ

              | ПоступлениеНаКомиссию.Номенклатура = &Номенклатура

              | И ПоступлениеНаКомиссию.Контрагент = &Контрагент" ;

Запрос.УстановитьПараметр("Контрагент",Контрагент);

 для каждого строка из товары цикл

  область2.Параметры.ном=Ном;

  область2.Параметры.товар= строка.номенклатура;

  запрос.УстановитьПараметр("Номенклатура",строка.номенклатура);

  Выборка=Запрос.Выполнить().Выгрузить();

  

  область2.Параметры.цена=Формат(строка.ЦенаПрод,"ЧЦ=10; ЧДЦ=2");

  Если  строка.СуммаДопРасх>0 тогда

  область2.Параметры.стоим=Формат(строка.СуммаДопРасх,"ЧЦ=10; ЧДЦ=2");

 Иначе

  попытка

  область2.Параметры.стоим=Формат(Выборка[0].СуммаДопРасх,"ЧЦ=10; ЧДЦ=2");

 исключение

  конецпопытки;

  КонецЕсли;

  компенсация=0;ценаРознич=0;

  Попытка

   ценаРознич=Выборка[0].ЦенаЗакуп;

  исключение

   ценаРознич= строка.ЦенаПрод;

  конецпопытки;

  

  Если  Комментарий=Перечисления.ОснованиеРасторжения.Инициатива тогда

   компенсация=строка.ЦенаПрод*25/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  ИначеЕсли  (ценаРознич>=8000) и  (ценаРознич<51000) и ((Комментарий=Перечисления.ОснованиеРасторжения.Инициатива)или(Комментарий=Перечисления.ОснованиеРасторжения.Окончание) )тогда

   компенсация=ценаРознич*3/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  ИначеЕсли  (ценаРознич>=51000)и ((Комментарий=Перечисления.ОснованиеРасторжения.Инициатива )или(Комментарий=Перечисления.ОснованиеРасторжения.Окончание) ) тогда

   компенсация=ценаРознич*2/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  Иначе

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  КонецЕсли;

  область2.Параметры.шт=строка.номенклатура.код;

  область2.Параметры.кол=строка.количество;

  ном=ном+1;

  итого=итого+компенсация+строка.СуммаДопРасх;

  ТабДок.Вывести(Область2);

 КонецЦикла;

 Область3 = Макет.ПолучитьОбласть("Область3");

 Область3.Параметры.итого=Формат(итого,"ЧЦ=10; ЧДЦ=2");

   //Область3.Параметры.итогоп=

  //числопрописью(итого,"L=ru_Ru");

 мВалютаРегламентированногоУчета = глЗначениеПеременной("ВалютаРегламентированногоУчета");

 Область3.Параметры.итогоп= ОбщегоНазначения.СформироватьСуммуПрописью(итого, мВалютаРегламентированногоУчета);

 ТабДок.Вывести(Область3);

 ТабДок.ОтображатьСетку = Ложь;

 ТабДок.Защита = Ложь;

 ТабДок.ТолькоПросмотр = Ложь;

 ТабДок.ОтображатьЗаголовки = Ложь;

 ТабДок.Показать();  

КонецПроцедуры

Рисунок – Детальный алгоритм

2.7  Проектирование пользовательского интерфейса

При проектировании интерфейса пользователя была составлена диаграмма состояний, описывающий процесс изменения состояний только одного класса, а точнее — одного экземпляра определенного класса, т.е. моделирует все возможные изменения в состоянии конкретного объекта. При этом изменение состояния объекта может быть вызвано внешними воздействиями со стороны других объектов или извне. На рисунке 17 представлен граф состояний интерфейса, предназначенного для добавления контрагентов в справочник, вывод данных контрагента в печатную форму, печать договора.

Рисунок 17 – Диаграмма состояний

2.8 Реализация программного обеспечения

Документ выплата комитентам, модуль объекта

Процедура печать нужна для формирования акта выплаты комитенту.

Создается новый документ, загружается созданный макет в документе.

Создаются области для формирования реквизитов, ставятся нужные форматы. Выводится таблица с товарами, подсчитывается цена товаров.

Процедура Печать() экспорт

ТабДок = Новый ТабличныйДокумент;

Макет = ПолучитьМакет("Акт");

Область = Макет.ПолучитьОбласть("Область1");

область.Параметры.Номер=Номер;

область.Параметры.Дата= Формат(Дата,"ДФ = ""dd ММММ гггг """"г.""""""");

область.Параметры.Контрагент=Контрагент;

ТабДок.Вывести(Область);

Область2 = Макет.ПолучитьОбласть("Область2");

ном=1;итого=0;

для каждого строка из товары цикл

область2.Параметры.ном=Ном;

область2.Параметры.товар= строка.номенклатура;

Если  Контрагент.Объем=Истина тогда область2.Параметры.цена="";

Иначе

область2.Параметры.цена=Формат(строка.ЦенаПрод,"ЧЦ=10; ЧДЦ=2");

КонецЕсли;

область2.Параметры.стоим=Формат(строка.Сумма,"ЧЦ=10; ЧДЦ=2");

ном=ном+1;   итого=итого+строка.сумма;

ТабДок.Вывести(Область2);

КонецЦикла;

Область3 = Макет.ПолучитьОбласть("Область3");

Область3.Параметры.итого=Формат(итого,"ЧЦ=10; ЧДЦ=2");

Область3.Параметры.итогоп=числопрописью(итого,"L=ru_Ru");

ТабДок.Вывести(Область3);

ТабДок.ОтображатьСетку = Ложь;

ТабДок.Защита = Ложь;

ТабДок.ТолькоПросмотр = Ложь;

ТабДок.ОтображатьЗаголовки = Ложь;

ТабДок.Показать();  

КонецПроцедуры

Обработка Договор комиссии, модуль объекта.

Процедура печать нужна для формирования договора комиссии.

Создается новый документ, загружается созданный макет в документе.

Создаются области для формирования реквизитов, ставятся нужные форматы.

Выводится договор, прописываются реквизиты указанные в форме документа.

Процедура Печать() экспорт

ТабДок = Новый ТабличныйДокумент;

Макет = ПолучитьМакет("Договор");

Область = Макет.ПолучитьОбласть("Область");

Область.Параметры.НомерДоговора =НомерДоговора;

Область.Параметры.ДатаДоговора = Формат(ДатаДоговора,"ДФ = ""dd ММММ гггг """"г.""""""");  

Область.Параметры.Контрагент = Контрагент.НаименованиеПолное;

Запрос1 = Новый Запрос;

Запрос1.Текст = "ВЫБРАТЬ

| КонтактнаяИнформация.Объект,

| КонтактнаяИнформация.Тип,

| КонтактнаяИнформация.Вид,

| КонтактнаяИнформация.Представление

|ИЗ

| РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация

|ГДЕ

| КонтактнаяИнформация.Объект = &Объект

| И КонтактнаяИнформация.Вид = &Вид";

Запрос1.УстановитьПараметр("Объект",Контрагент);

Запрос1.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента);

Результат1 = Запрос1.Выполнить().Выгрузить();

Попытка

Область.Параметры.Адрес = Результат1[0].Представление;

Исключение

КонецПопытки;

Запрос1.УстановитьПараметр("Объект",Контрагент);

Запрос1.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента);

Результат1 = Запрос1.Выполнить().Выгрузить();

Попытка

Область.Параметры.телефон = Результат1[0].Представление;

Исключение

КонецПопытки;

Запрос1.УстановитьПараметр("Объект",Контрагент);

Запрос1.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000025"));

Результат2 = Запрос1.Выполнить().Выгрузить();

Попытка

Область.Параметры.телефон1 = Результат2[0].Представление;

Исключение

КонецПопытки;

Запрос1.УстановитьПараметр("Объект",Контрагент);

Запрос1.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000013"));

Результат2 = Запрос1.Выполнить().Выгрузить();

Попытка

Область.Параметры.Телефон2 = Результат2[0].Представление;

Исключение

КонецПопытки;

Область.Параметры.Паспорт= Контрагент.ДокументУдостоверяющийЛичность;

ТабДок.Вывести(Область);

ТабДок.ОтображатьСетку = Ложь;

ТабДок.Защита = Ложь;

ТабДок.ТолькоПросмотр = Ложь;

ТабДок.ОтображатьЗаголовки = Ложь;

ТабДок.Показать();  

Конецпроцедуры

2.9 Тестирование программного обеспечения

Тестирование программного обеспечения — процесс исследования программного обеспечения (ПО) с целью получения информации о качестве продукта. 

Модели  жизненного  цикла  программного  обеспечения,  предполагает  три  стадии тестирования:

  •  автономное тестирование компонентов программного обеспечения;
  •  комплексное тестирование разрабатываемого программного обеспечения;
  •  системное или оценочное тестирование на соответствие основным критериям качества.

Для  повышения  качества  тестирования  рекомендуется  соблюдать  следующие  основные принципы:

  •  предполагаемые результаты должны быть известны до тестирования;
  •  следует избегать тестирования программы автором;
  •  необходимо досконально изучать результаты каждого теста;
  •  необходимо проверять действия программы на неверных данных;
  •  необходимо  проверять  программу  на  неожиданные  побочные  эффекты на неверных данных.

Существуют 3 различных подхода к формированию тестовых наборов:

  •  Ручной контроль, где все проектные решения, принятые на  том или ином  этапе, должны анализироваться с  точки  зрения их  правильности  и  целесообразности.
  •  Структурный  подход  базируется  на  том,  что  известка  структура  тестируемого программного  обеспечения,  в  том  числе  его  алгоритмы («стеклянный  ящик»).
  •  Функциональный подход  основывается на  том, что  структура программного  обеспечения не известна («черный  ящик»).

Основными методами ручного контроля являются:

  •  инспекции исходного текста,
    •  сквозные просмотры,
    •  проверка за столом,
    •  оценки программ.

Для курсовой работы был выбран структурный подход

Таблица  4 – Тесты для тестирования программы

Номер теста

Цель тестирования

Исходные данные

Ожидаемые результаты

1

Сохранение данных после заполнения

Заполнение данных

Данные были изменены. Сохранить?

2

Проверка документа

Данные документа

Оперативное проведение документов или неоперативное

3

Проверка корректности заполнения данных в поля

Не заполненные данные

В поле  введены некорректные данные

4

Проверка программы при не заполненных полях

На форме не заполнили поля

Индекс находится за пределами массива

 

Результаты тестов представлены на рисунках 9-12

Рисунок  9– тест 1

Рисунок  10– тест 2

Рисунок  11 – тест 3

Рисунок  12 – тест 4

Результаты, полученные в ходе тестирования, совпадают с ожидаемыми результатами. Программа соответствует требованиям.

3 Организация производства и труда

  1.  Руководство системного программиста

Программный продукт носит название «Разработка конфигурации на базе 1С:Предприятие ».

Доработка конфигурации заключается в  том, что нужно создать договора, акты расторжения договора, печати договоров и актов расторжения договора.

Хранение данных в документах и справочниках.

Конфигурация включает в себя базу данных, поисковую систему, парольную систему. Части связаны между собой через обработчики событий.

Для того чтобы начать эксплуатацию доработанной конфигурации, необходимо загрузить базу данных в платформу.

После запуска программы появится окно где необходимо произвести аутентификацию пользователя, после откроется главное меню в котором находятся данные конфигурации.

Закончить работу с программой можно с помощью нажатия кнопки, расположенной в правом верхнем углу с изображением крестика.

Для проверки работоспособности программы войдите в режим 1С:Предприятие, попробуйте изменить данные.

В режиме Конфигуратор внесите данные в базу данных, сохраните. Через некоторое время откройте заново и убедитесь что данные сохранились.

Если вы введете неправильные данные выйдет сообщение об ошибочно введенных данных.

При работе с программным продуктом могут возникнуть некоторые ошибки

Существует функция добавления новой информации в базу данных. Если пользователем будет введена некорректная информация, программа выдаст сообщение.

Для того чтобы конфигурация работала  нужен следующий минимальный набор аппаратных средств:

  •  системный блок (CELERON 433MHz, 32 RAM, 10 Gb HDD);
  •  монитор;
  •  клавиатура;
  •  манипулятор «мышь»;
  •  принтер формата А4.

   На ПК должна быть установлена операционная система Windows 7.

3.2 Руководство пользователя

 Перед началом работы с программой необходимо запустить 1С:Предприятие, появится окно под названием «Запуск 1С:Предприятие»  (рисунок  13), в списке информационных баз выбираем необходимую информационную базу и запускаем ее в режиме 1С:Предприятие.

Рисунок  13– Окно  запуска  программы

Для просмотра необходимых документов нужно выбрать пункт «Документы» (Рисунок 14)

Рисунок  14 - документы

Далее выбираем Договор комиссии, выплата комитенту, акт расторжения договора.

В обработке ДоговорКомиссии необходимо ввести номер договора, дату договора и выбрать контрагента.

Обработка представлена на рисунке 15

Рисунок  15 – Обработка договор комиссии

После заполнения необходимых данных нажмем на кнопку выполнить

Далее появляется договор комиссии с реквизитами от выбранного контрагента

Договор комиссии представлен на рисунках  16 - 17

Рисунок  16 – Договор комиссии

Рисунок  17 – Договор комиссии

Далее идет документ Выплаты комитентам

Документ Выплаты комитентам представлен на рисунке 18

Рисунок  18– Документ Выплата комитентам

Выберем документ и посмотрим информацию

Форма документа представлена на рисунке 19

Рисунок  19– форма документа

Затем щелкаем на кнопку печать и формируем акт о продаже товаров

Акт о продаже товаров принятых на комиссию представлена на рисунке 20

Рисунок  20 – Акт о продаже товаров

Далее на рисунке 21 представлен документ акт расторжения договора

Рисунок  21– акт расторжения договора

Выберем один документ и посмотрим его информацию

Форма документа представлена на рисунке 22

Рисунок  22 – форма документа

Затем щелкаем на кнопку печать и формируем акт о расторжении договора

Акт о расторжении договора представлен на рисунке 23

Рисунок  23 – акт о расторжении договора

4 Экономика производства

4.1 Расчёт затрат на создание программы

Основными трудозатратами являются затраты на исследование алгоритма решения задачи, на разработку блок схемы и алгоритма программы, на программирование, на отладку программы на персональном компьютере и на подготовку документации. Трудозатраты измеряются в человеко-часах (чел-час).

Для нахождения трудозатрат на разработку программного продукта необходимо произвести расчет по следующим показателям:

  •  условное число операторов в программе (Q)

Условное число операторов рассчитывается по формуле:

Q = q * c * (1 + p)                                                 , (1)

где     q - предполагаемое число операторов;

с - коэффициент новизны и сложности программы;

р - коэффициент коррекции программы в ходе ее разработки.

  •  исследование алгоритма, чел-час (tu)

Затраты труда на исследование алгоритма решения задачи с учетом уточнения описания и квалификации программиста вычисляются по формуле:

tи = (Q * B) / 80 * k                                                  , (2)

где     Q - условное число операторов в программе;

В - коэффициент увеличения затрат в зависимости от сложности программы;

k - коэффициент квалификации разработчика.

  •  разработка блок-схемы, чел-час

Расчёт затрат на разработку блок-схемы производится по формуле:

ta = Q / 70 * k                                                     , (3)

где  Q - условное число операторов;

       k - коэффициент квалификации разработчика.

  •  отладка программы, чел-час

Расчет трудозатрат на отладку производится по формуле:

tотл = Q / 45 * k                                                    , (4)

где   Q - условное число операторов;

k - коэффициент квалификации разработчика.

  •  подготовка материалов в  рукописи, чел-час

Трудовые затраты на подготовку документации  будут складываться из затрат труда на подготовку рукописного текста и затрат труда на редактирование, печать и оформление документации.

tд = tдп + tдр                                                          ,(5)

где  tдп - трудовые затраты на подготовку материалов в рукописи;

tдр - затраты на редактирование, печать и оформление документации.

  •  редактирование, печать и оформление документации, чел-час

Затраты на редактирование, печать и оформление прямо пропорционально зависит от затрат на подготовку материалов в рукописи:

tдр = 0,75 * tдп                                                  , (6)

  •  подготовка документации, чел-час

Трудозатраты на подготовку материалов в рукописи по формуле:

tдп = Q/150. * k                                               ,  (7)

где  Q - условное число операторов;

      k - коэффициент квалификации разработчика.

  •  программирование, чел-час

tп =0,25*( tи+ tа+ tотл+ tд)                                                                    , (8)

где tu - затраты труда на исследование алгоритма решения задачи, чел-час ;

tа - затраты на разработку блок-схемы алгоритма, чел-час;

tотл -  затраты на отладку программы на ПК, чел-час ;

tд - затраты на подготовку документации, чел-час

  •  итого трудовые затраты, чел-час

Трудозатраты измеряются в человеко-часах (чел-час). Расчет производится по формуле:

T = tи + tа + tп + tотл + tд                                           ,  (9)

где tu - затраты труда на исследование алгоритма решения задачи, чел-час ;

tа - затраты на разработку блок-схемы алгоритма, чел-час;

tп - затраты на программирование, чел-час ;

tотл -  затраты на отладку программы на ПК, чел-час ;

tд - затраты на подготовку документации, чел-час

Затраты  на разработку программного продукта включают в себя следующие статьи:

  •  Среднечасовая оплата труда, руб/час

Среднечасовую заработную плату можно определить по формуле:

ЗПсч = ЗПсмрвм                                                ,   (10)

где  ЗПсм – среднемесячная заработная плата, руб/мес;  

Фрвм - месячный фонд рабочего времени, час.

  •  Затраты на оплату труда и страховые взносы, руб

Расходы на оплату труда разработчика программы и страховые взносы в государственные внебюджетные фонды определяется по формуле:

Зот = Т * ЗПсчстр                                               ,  (11)

где  Т - трудоемкость разработки программного продукта, чел-час;

ЗПсч - среднечасовая оплата труда программиста, руб/час;

кстр - коэффициент, учитывающий страховые взносы.

  •  Балансовая стоимость компьютера, руб

Балансовая стоимость компьютера определяется по формуле:

Cбал = Цср + Зпр ,                                                         (12)

где    Цср – средняя рыночная цена , руб;

Зпр - прочие затраты, руб.

Рыночная цена ПК определяется исходя из стоимости компьютера необходимой комплектации в определенном магазине на момент выполнения работы.

  •  Прочие затраты, руб
  •  Затраты на вспомогательные материалы, руб
  •  Затраты на амортизацию, руб

Расчет затрат на амортизацию производится по формуле:

За = Cбала / 100,                                                             (13)

где  Cбал - балансовая стоимость компьютера, руб/шт

 На- норма амортизации, %.

  •  Затраты на оплату машинного времени, руб

Для расчета затрат на оплату машинного времени при отладке программы используются данные по трудоемкости работ по программированию и отладке программы:

Змв = Смч * (tп + tотл),                                                       (14)

где   Смч - стоимость машиночаса, руб/час;

        tп - затраты на программирование, час ;

        tотл -  затраты на отладку программы на ПК, час.

  •  Затраты на текущий ремонт компьютера, руб

Расчет затрат на текущий ремонт компьютера. Издержки на текущий ремонт приблизительно составляют 5% от балансовой стоимости компьютера. Рассчитывается по формуле:

Зтр = 0,05* Cбал,                                                    (15)

где  Cбал - балансовая стоимость компьютера, руб/шт.

  •  Прочие затраты

Расчет прочих затрат. Затраты на прочие расходы могут быть приняты в размере  6% от балансовой стоимости компьютера.

Зпроч = 0,06* Cбал ,                                                        (16)

где  Cбал - балансовая стоимость компьютера, руб/шт.

  •  Стоимость машиночаса, руб/час

Расчет стоимости машино-часа производится по формуле:

 Cмч = (За + Звм + Зтр + 3пр) / Tг,                                                    (17)

где  За - затраты на амортизацию, руб/год;

Звм - затраты на вспомогательные материалы, руб/год;

Зтр - затраты на текущий ремонт компьютера, руб/год;

Зпр - прочие затраты, руб/год;

Тг -  годовой фонд рабочего времени, час/год.

  •  Затраты на электроэнергию, руб

Расчет затрат на электроэнергию производится по формуле:

Зэл = Цэл * P * (tп + tотл + tд) ,                                             (18)

где  Цэл - стоимость электроэнергии, руб./ кВтч;

P - мощность, потребляемая ПК, кВт;

tп - затраты на программирование, час;

tотл - затраты на отладку, час;

tд - затраты на подготовку документации, час.

Стоимость электроэнергии равна действующему тарифу (смотри исходные данные)

  •  Затраты на разработку программного продукта, руб

Затраты на разработку программного продукта определяются по формуле:

Зрп = Зот + Змв + Зэл + 3п,                                              (19)

где    Зот  - Затраты на оплату машинного времени, руб

Змв  - Затраты на оплату труда и страховые взносы, руб

Зэл  - Затраты на электроэнергию, руб

3п  - Прочие затраты

К текущим затратам относятся такие виды затрат как затраты на разработку программного продукта в добавление к ним затрат на дополнительного приобретение программного обеспечения и дополнительного оборудования.

Формула для расчета единовременных затрат может выглядеть следующим образом:

К = Cбалдпорпрди                                         , (20)

где     К – единовременные затраты, руб;

Сбал – балансовая стоимость оборудования, руб;

Здпо - затраты на приобретение дополнительного программного  обеспечения, руб;

Зрп – затраты на разработку программного продукта, руб;

Зрди -  затраты на регистрацию доменного имени, руб.

Балансовая стоимость оборудования определяется по формуле (12). Цена оборудования равна сумме цен всех видов оборудования.

Расчёт текущих затрат представлен в таблице 3 – Расчёт единовременных затрат.

Таблица 1 для расчета трудозатрат на разработку программного обеспечения

Наименование показателя

Усл. обозн.

Значение

предполагаемое число операторов

q

1400,00

коэффициент новизны и сложности программы

с

1,26

коэффициент коррекции программы в ходе ее разработки

р

0,70

условное число операторов в программе

Q

2998,80

Коэффициент увеличения затрат

В

1,30

Коэффициент квалификации разработчика

k

0,80

Трудовые затраты

 

 

- исследование алгоритма, чел-час

38,98

- разработка блок-схемы, чел-час

34,27

- отладка программы, чел-час

tотл

53,31

- подготовка материалов в  рукописи, чел-час

tдп

15,99

- редактирование, печать и оформление документации, чел-час

tдр

12,00

- подготовка документации, чел-час

27,99

- программирование, чел-час

tп

38,64

Итого трудовые затраты, чел-час

T

193,20

Таблица 2 для расчета единовременных и дополнительных текущих затрат

Наименование показателя

Усл. обозн.

Значение

Итого трудовые затраты, чел-час

T

193,20

Среднемесячная заработная плата, руб/мес

ЗПсм

18000,00

Месячный фонд рабочего времени, час/мес

Фрв

165,50

Среднечасовая оплата труда, руб/час

ЗПсч

108,76

Коэффициент, учитывающий страховые взносы

кстр

1,30

Затраты на оплату труда и страховые взносы, руб

Зот

27316,00

Рыночная цена ПК, руб

Цср

15000,00

Прочие затраты, руб

Зпр

1200,00

Балансовая стоимость компьютера, руб

Cбал

16200,00

Норма амортизации, %

На

20,00

Затраты на амортизацию, руб

За

3240,00

Затраты на вспомогательные материалы, руб

Звм

162,00

Затраты на текущий ремонт компьютера, руб

Зтр

810,00

Прочие затраты, руб

Зпроч

972,00

Годовой фонд рабочего времени, час/год

Тг

1986,00

Стоимость машиночаса, руб/час

Cмч

2,61

Затраты на оплату машинного времени, руб

Змв

240,02

стоимость электроэнергии, руб./ кВтч

Цэл

2,79

мощность, потребляемая ПК, кВт

P

0,50

Трудозатраты на программирование, чел-час

tп

38,64

Трудозатраты на отладку программы, чел-час

tотл

53,31

Трудозатраты на подготовку документации, чел-час

27,99

Затраты на электроэнергию, руб

Зэл

167,32

Прочие затраты, руб

Зп

1386,17

Затраты на разработку программного продукта, руб

Зрп

29109,50

4.2 Расчёт экономической эффективности и срока окупаемости

Разрабатываемый программный продукт рассчитан на сокращение трудоёмкости работ по поиску информации.

Исходя из этого нужно рассчитать эффективность работы  при сокращении трудоемкости работ до и после внедрения программного продукта.

Для определения эффективности необходимо учесть дополнительные затраты на приобретаемое оборудование и текущие затраты.

Программные продукты являются нематериальными активами предприятия (НМА). На нематериальные активы насчитывается амортизация, что является одной из наиболее важных статей увеличения текущих затрат.  Дополнительные текущие затраты можно определить по формуле:

Здоп = Адпр                                                 ,     (22)

где Ад – дополнительные амортизационные отчисления, руб/год;

       Рпр- прочие дополнительные эксплуатационные расходы, руб/год.

Амортизация определяется по формуле:

                                   Ад = (На*К)/100                                                ,       (24)

 где   На – норма амортизационных отчислений, %;

         К – единовременные затраты, руб.

,                                              (25)

где На – норма амортизации, %;

     Тн – нормативный срок полезного использования, лет.

В таблице 3 представлен расчёт дополнительных и текущих затрат.

Таблица 3 - Расчет дополнительных и текущих затрат

Наименование

Усл. обознач

Значение

Стоимость приобретаемого оборудования, руб

Цср

0,00

Прочие затраты, руб

Зпр

0,00

Балансовая стоимость приобретаемого оборудования

Cбал

0,00

затраты на приобретение дополнительного программного  обеспечения, руб

Здпо

20000,00

Единовременные затраты, руб

К

49109,50

Срок полезного использования НМА, лет

Тн

5,00

Норма амортизации НМА,%

На

20,00

Амортизация НМА, руб/год

Ад

9821,90

Прочие дополнительные эксплуатационные расходы, руб/год

Рпр

0,00

Дополнительные текущие затраты, руб/год

Здоп

9821,90

Если в результате внедрения программного продукта происходит снижение трудоемкости работ, то его определяют по формуле:

∆Трр1р2                                                  ,  (26)

где  ∆Тр – снижение трудоемкости работ, чел-час/год;

Тр1 – трудоемкость работ до внедрения программного обеспечения, чел-час/год;

Тр2 – трудоемкость работ после внедрения программного обеспечения, чел-час/год.

Трудоемкость работ до и после внедрения программного обеспечения определяется по формуле:

Тр = Чисп * Т                                               ,  (27)

где  Тр –трудоемкость работ, чел-час;

 Чисп –  численность исполнителей, чел.;

 Т – время работы, час.

На основании снижения трудоемкости работ можно определить высвобождение численности работников.

Чвр = ∆Трmax                                              ,  (28)

где  Чвр – численность высвобождаемых работников, чел.;

∆Тр – снижение трудоемкости работ, чел-час/год;

Тmax – годовой фонд рабочего времени час/год.

Экономию от высвобождения численности можно определить по формуле:

Эсч= Чвр * Зсм * 12 * кстр                                      ,  (29)

где     Эсч –  экономия от сокращения численности, руб/год;

Чвр – численность высвобождаемых работников, чел.;

     Зсм – среднемесячная оплата труда сокращаемых работников, руб./месяц;

12 – количество месяцев в году;

кстр – коэффициент, учитывающий отчисления на социальные нужды.

Эффект от высвобождения численности персонала определяется по формуле:

Эф= Эсч - Здоп                                              , (30)

где     Эсч –  экономия от сокращения численности, руб/год;

Здоп – дополнительные эксплуатационные расходы, руб./год.

На основании экономического эффекта можно определить срок окупаемости единовременных затрат. Как отмечалось ранее, срок окупаемости является одним из важнейших показателей эффективности инвестиций и  характеризующий период возврата средств, инвестированных в проект.

                                                , (31)

где  Ток – срок окупемости затрат, лет;

      К– единовременные затраты, руб;

      Эф – годовой экономический эффект, руб/год.

Для того чтобы проект считался эффективным, полученный срок окупаемости должен быть не больше нормативного.

Экономическая эффективность в этом случае  характеризует величину годового экономического эффекта от одного рубля единовременных затрат. Она определяется по формуле:

                                                               , (32)

где Е – экономическая эффективность;

      Эф – годовой экономический эффект, руб/год;

      К – единовременные затраты, руб.

В таблице 4 произведены расчёты по оценке эффективности работы до и после внедрения программного продукта. Расчёты произведены в Excel документе под название «Расчёт трудозатрат» на Листе 3.

Таблица 4 - Оценка эффективности внедрения.

Наименование показателя

Значения

снижение трудоемкости работ, чел-час/год

280,00

трудоемкость работ до внедрения программного обеспечения чел-час/год;

320,00

трудоемкость работ после внедрения программного обеспечения чел-час/год;

40,00

трудоемкость работ, чел-час;

50,00

численность исполнителей, чел.;

10,00

время работы, час.

5,00

численность высвобождаемых работников, чел.;

0,14

– годовой фонд рабочего времени час/год

1986,00

экономия от сокращения численности, руб/год;

32990,94

среднемесячная оплата труда сокращаемых работников, руб./месяц

15000,00

коэффициент, учитывающий отчисления на социальные нужды

1,30

Эффект от высвобождения численности персонала

23169,04

дополнительные эксплуатационные расходы, руб./год

9821,90

срок окупемости затрат, лет;

2,12

единовременные затраты, руб

49109,50

экономическая эффективность

0,47

Итоговые значения основных расчетных показателей представлены в таблице 5 - Основные экономические показатели разработки и внедрения программного обеспечения.

Таблица 5 - Основные экономические показатели разработки и внедрения программного обеспечения.

Наименование показателя

Значения

Затраты на оплату труда и страховые взносы, руб

27316,00

Затраты на оплату машинного времени, руб

240,02

Затраты на электроэнергию, руб

167,32

Прочие затраты, руб

1386,17

Затраты на разработку программного продукта, руб

29109,50

Затраты на приобретение дополнительного программного  обеспечения, руб

20000,00

Итого единовременные затраты, руб

49109,50

Итого дополнительные текущие затраты, руб

9821,90

Экономический эффект, руб/год

23169,04

Экономическая эффективность

0,47

Срок окупаемости, лет

2,12

Заключение

Внедрение программного продукта считается целесообразным, т.к срок окупаемости 2,12 года, срок окупаемости незначительный по сравнению с нормативным - 3 года, а эффективность использования программного обеспечения на основании расчетных показателей 0,47, что выше нормы 0,33.

Однако следует отметить, что эффект будет условным, т.к. реального сокращения численности нет. Снижение трудоемкости работ позволит работнику в высвобождаемое время выполнять другие функции при сохранении прежней заработной платы, позволит повысить качество выполнения работы, что в конечном итоге выгодно предприятию.

5 Безопасность жизнедеятельности

5.1 Мероприятия по охране труда на рабочем месте оператора ПК

Каждый новый сотрудник предприятия получает первичный инструктаж по безопасности труда и проходит:

  1.  стажировку;
    1.  обучение устройству и правилам использования оборудования;
    2.  курс по санитарно-гигиенической подготовке;
    3.  проверку знаний по программированию;
    4.  теоретических знаний и приобретенных навыков при работе с ПК.

5.2 Общие требования по технике безопасности и охране труда

Для обеспечения более удобного  наблюдения за экраном монитора конструкция ПК должна обеспечивать:

- возможность поворота экрана монитора в горизонтальной и вертикальной плоскости с фиксацией в заданном положении;

- регулирование яркости и контрастности.

Дизайн  ПК должен предусматривать окраску корпуса в спокойные мягкие тона. Корпус ПК, клавиатура и другие блоки и устройства  должны иметь матовую поверхность и не иметь блестящих деталей, способных создавать блики.

5.3 Основные санитарно-технические требования в помещении

В целях предотвращения неблагоприятного влияния вредных факторов трудового процесса на здоровье пользователей персональными компьютерами необходимо соблюдать ряд рекомендации при организации работы:

  •  При выборе рабочего места, оборудованного компьютером, предпочтение следует отдавать помещениям, ориентированным на север или северо-восток.

  •  Не допускается оборудовать рабочее место   для работы с персональными компьютерами   в помещениях, расположенных в цокольных и подвальных помещениях.
  •  Площадь на одно рабочее место с ПК на базе электронно-лучевой трубки должна составлять не менее 6 м.кв.,  а при работе с жидкокристаллическими мониторами- 4,5м.кв.

5.4 Расчёт искусственной освещённости рабочего места

В настоящее время основная тенденция и важная закономерность развития источников света - это их дальнейшее совершенствование, в том числе повышение экономичности, надежности, эффективности, безопасности, качества цветопередачи.

Качество света определяется мощностью источника света, спектром излучения, его соответствию условиям выполняемой работы, отдыха и т.д.

Высокая зрительная работоспособность и производительность труда тесно связаны между собой рациональным производственным освещением. И основные требования к освещению на рабочем месте вне зависимости от источника света должны быть следующими:

  •  Помещения, предусмотренные для работы с  ПК, обязательно должны иметь искусственное и естественное освещение.
  •  Искусственное освещение в помещениях для эксплуатации ПК должно осуществляться системой общего равномерного освещения ( люстры, потолочные светильники), при необходимости к общему освещению дополнительно можно устанавливать светильники местного освещения.
  •  Нормируемая освещенность на поверхности стола 300-500 лк, на экране монитора - не более 300 лк.

Заключение

Результатом данного дипломного проекта является разработка программного обеспечения для формирования договоров, акты расторжения договоров,  формирование отчета наличия вещей у комитента, формирование акта выплат комитенту. Программа разработана для фирмы «МегаКомок». Также она подходит для всех предприятий подобного типа деятельности.

          Главным результатом проведенной работы является создание печатных форм для документов: акт расторжения договора, договора комиссии, акты выплаты комитентам, отчёт наличия вещей у комитента, который выполняет требуемый круг задач, с которыми сталкиваются работники организации при формировании договора, актов, документов.

В процессе проектирования определены требования к функциональным характеристикам, условиям эксплуатации, требования к операционной и программной совместимости, а также анализировался процесс обработки информации, выбрана структура данных для ее хранения. Также создался алгоритм и  разработан  пользовательский интерфейс.

В организационной части дипломного проекта представлено руководство пользователя и системного программиста.

Разработанное программное обеспечение позволило значительно повысить эффективность работы торгового предприятия «МегаКомок». Следовательно, разработанный программный продукт может быть широко востребован в торговой сфере.

Список литературы

  1.  Богачева Т.Г. 1С: Предприятие 8.2 «Управление торговлей» редакция 11
  2.  Радченко М.Г. 1С: Предприятие 8.2 «Практическое пособие разработчика»
  3.  Ажеронок В.А. Радченко М.Г. как настраивать 1С:Предприятие 8.2 при внедрении
  4.  Рыбалка В.В. 1C. Пример быстрой разработки приложений на платформе 1С:Предприятие 8.2.  
  5.  Разработка управляемого интерфейса Ажеронок В.А., Островерх А. В., Радченко М. Г., Хрусталева Е. Ю.
  6.  Радченко М.Г. 1С:Предприятие 8.2. Руководство пользователя
  7.  Радченко М.Г  1С:Предприятие 8.2. Руководство администратора
  8.  Радченко М.Г. 1С:Предприятие 8.2. Руководство разработчика Часть 1
  9.  Радченко М.Г. 1С:Предприятие 8.2. Руководство разработчика Часть 2 

ПРИЛОЖЕНИЕ А

Листинг программы

Процедура Печать() экспорт

ТабДок = Новый ТабличныйДокумент;

Макет = ПолучитьМакет("Договор");

Область = Макет.ПолучитьОбласть("Область");

Область.Параметры.НомерДоговора =НомерДоговора;

Область.Параметры.ДатаДоговора = Формат(ДатаДоговора,"ДФ = ""dd ММММ гггг """"г.""""""");  

Область.Параметры.Контрагент = Контрагент.НаименованиеПолное;

Запрос1 = Новый Запрос;

Запрос1.Текст = "ВЫБРАТЬ

               | КонтактнаяИнформация.Объект,

               | КонтактнаяИнформация.Тип,

               | КонтактнаяИнформация.Вид,

               | КонтактнаяИнформация.Представление

               |ИЗ

               | РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация

               |ГДЕ

               | КонтактнаяИнформация.Объект = &Объект

               | И КонтактнаяИнформация.Вид = &Вид";

 

Запрос1.УстановитьПараметр("Объект",Контрагент);

Запрос1.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента);

Результат1 = Запрос1.Выполнить().Выгрузить();

 

Попытка

    Область.Параметры.Адрес = Результат1[0].Представление;

Исключение

КонецПопытки;

Запрос1.УстановитьПараметр("Объект",Контрагент);

Запрос1.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.ТелефонКонтрагента);

Результат1 = Запрос1.Выполнить().Выгрузить();

Попытка

    Область.Параметры.телефон = Результат1[0].Представление;

Исключение

КонецПопытки;

 

  Запрос1.УстановитьПараметр("Объект",Контрагент);

 

Запрос1.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000025"));

 

Результат2 = Запрос1.Выполнить().Выгрузить();

 

Попытка

 Область.Параметры.телефон1 = Результат2[0].Представление;

Исключение

КонецПопытки;

Запрос1.УстановитьПараметр("Объект",Контрагент);

 

Запрос1.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000013"));

 

Результат2 = Запрос1.Выполнить().Выгрузить();

 

Попытка

 Область.Параметры.Телефон2 = Результат2[0].Представление;

Исключение

КонецПопытки;

Область.Параметры.Паспорт= Контрагент.ДокументУдостоверяющийЛичность;

   ТабДок.Вывести(Область);

   ТабДок.ОтображатьСетку = Ложь;

ТабДок.Защита = Ложь;

ТабДок.ТолькоПросмотр = Ложь;

ТабДок.ОтображатьЗаголовки = Ложь;

ТабДок.Показать();  

Конецпроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)

// Вставить содержимое обработчика.

ТабДокумент = Новый ТабличныйДокумент;

   макет= получитьмакет("Макет");

запрос=новый запрос;

запрос.УстановитьПараметр("Дата1",Дата);

запрос.УстановитьПараметр("Контр",Контрагент);

Запрос.УстановитьПараметр("Розн",справочники.ТипыЦенНоменклатуры.Найти

ПоКоду("000000004"));

запрос.Текст="ВЫБРАТЬ

             | ПоступлениеНаКомиссию1Остатки.Номенклатура,

             | ПоступлениеНаКомиссию1Остатки.ЦенаЗакупОстаток,

             | ЦеныНоменклатурыСрезПоследних.Цена,

             | ПоступлениеНаКомиссию1Остатки.КоличествоОстаток

             |ИЗ

             | РегистрНакопления.ПоступлениеНаКомиссию1.Остатки(&дата1, Контрагент = &Контр) КАК ПоступлениеНаКомиссию1Остатки

             |  ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&дата1, ТипЦен = &Розн) КАК ЦеныНоменклатурыСрезПоследних

             |  ПО ПоступлениеНаКомиссию1Остатки.Номенклатура = ЦеныНоменклатурыСрезПоследних.Номенклатура";

 

Выборка=запрос.Выполнить().Выбрать();

Областьмакета=макет.ПолучитьОбласть("шапка");

 Областьмакета.Параметры.контрагент=контрагент;

  Областьмакета.Параметры.дата=дата;

  ТабДокумент.Вывести(Областьмакета);

Областьмакета=макет.ПолучитьОбласть("Строка");

иткол=0;итцз=0;итцр=0;

Пока выборка.Следующий() цикл

Областьмакета.Параметры.кол=Выборка.КоличествоОстаток;

 Областьмакета.Параметры.Номенклатура=Выборка.Номенклатура;

 Областьмакета.Параметры.ЦенаЗакуп= Выборка.ЦенаЗакупОстаток ;

 Областьмакета.Параметры.ЦенаРозн=Выборка.Цена ;

 итцз=Выборка.ЦенаЗакупОстаток+итцз;

 иткол=Выборка.КоличествоОстаток+иткол;

 итцр= Выборка.Цена +итцр;

 

   ТабДокумент.Вывести(Областьмакета);

 

КонецЦикла;

 Областьмакета=макет.ПолучитьОбласть("итог");

 Областьмакета.Параметры.итцз=итцз;

 Областьмакета.Параметры.итцр=итцр;

 Областьмакета.Параметры.иткол=иткол;

 Областьмакета.Параметры.контрагент=контрагент;

ТабДокумент.Вывести(Областьмакета);

ТабДокумент.Показать();

КонецПроцедуры

Процедура Печать() экспорт

 ТабДок = Новый ТабличныйДокумент;

 Макет = ПолучитьМакет("Акт");

 Область = Макет.ПолучитьОбласть("Область1");

 область.Параметры.Номер=Номер;

  область.Параметры.ном = ДоговорКонтрагента.Номер;

   область.Параметры.дат = Формат(ДоговорКонтрагента.Дата,"ДФ = ""dd ММММ гггг """"г.""""""");

 область.Параметры.основание=Комментарий;

 область.Параметры.Дата= Формат(Дата,"ДФ = ""dd ММММ гггг """"г.""""""");

 область.Параметры.Контрагент=Контрагент;

 ТабДок.Вывести(Область);

 Область2 = Макет.ПолучитьОбласть("Область2");

 ном=1;итого=0;

 запрос=новый запрос;

 Запрос.Текст="ВЫБРАТЬ

              | ПоступлениеНаКомиссию.ЦенаРозн,

              | ПоступлениеНаКомиссию.СуммаДопРасх,

              | ПоступлениеНаКомиссию.ЦенаЗакуп

              |ИЗ

              | РегистрНакопления.ПоступлениеНаКомиссию КАК ПоступлениеНаКомиссию

              |ГДЕ

              | ПоступлениеНаКомиссию.Номенклатура = &Номенклатура

              | И ПоступлениеНаКомиссию.Контрагент = &Контрагент" ;

Запрос.УстановитьПараметр("Контрагент",Контрагент);

 для каждого строка из товары цикл

  область2.Параметры.ном=Ном;

  область2.Параметры.товар= строка.номенклатура;

  запрос.УстановитьПараметр("Номенклатура",строка.номенклатура);

  Выборка=Запрос.Выполнить().Выгрузить();

  

  область2.Параметры.цена=Формат(строка.ЦенаПрод,"ЧЦ=10; ЧДЦ=2");

  Если  строка.СуммаДопРасх>0 тогда

  область2.Параметры.стоим=Формат(строка.СуммаДопРасх,"ЧЦ=10; ЧДЦ=2");

 Иначе

  попытка

  область2.Параметры.стоим=Формат(Выборка[0].СуммаДопРасх,"ЧЦ=10; ЧДЦ=2");

 исключение

  конецпопытки;

  КонецЕсли;

  компенсация=0;ценаРознич=0;

  Попытка

   ценаРознич=Выборка[0].ЦенаЗакуп;

  исключение

   ценаРознич= строка.ЦенаПрод;

  конецпопытки;

  

  Если  Комментарий=Перечисления.ОснованиеРасторжения.Инициатива тогда

   компенсация=строка.ЦенаПрод*25/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  ИначеЕсли  (ценаРознич>=8000) и  (ценаРознич<51000) и ((Комментарий=Перечисления.ОснованиеРасторжения.Инициатива)или(Комментарий=Перечисления.ОснованиеРасторжения.Окончание) )тогда

   компенсация=ценаРознич*3/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  ИначеЕсли  (ценаРознич>=51000)и ((Комментарий=Перечисления.ОснованиеРасторжения.Инициатива )или(Комментарий=Перечисления.ОснованиеРасторжения.Окончание) ) тогда

   компенсация=ценаРознич*2/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  Иначе

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  КонецЕсли;

  область2.Параметры.шт=строка.номенклатура.код;

  область2.Параметры.кол=строка.количество;

  ном=ном+1;

  итого=итого+компенсация+строка.СуммаДопРасх;

  ТабДок.Вывести(Область2);

 КонецЦикла;

 Область3 = Макет.ПолучитьОбласть("Область3");

 Область3.Параметры.итого=Формат(итого,"ЧЦ=10; ЧДЦ=2");

   //Область3.Параметры.итогоп=

  //числопрописью(итого,"L=ru_Ru");

 мВалютаРегламентированногоУчета = глЗначениеПеременной("ВалютаРегламентированногоУчета");

 Область3.Параметры.итогоп= ОбщегоНазначения.СформироватьСуммуПрописью(итого, мВалютаРегламентированногоУчета);

 ТабДок.Вывести(Область3);

 

 ТабДок.ОтображатьСетку = Ложь;

 ТабДок.Защита = Ложь;

 ТабДок.ТолькоПросмотр = Ложь;

 ТабДок.ОтображатьЗаголовки = Ложь;

 ТабДок.Показать();  

КонецПроцедуры

Процедура ОбработкаПроведения(Отказ, Режим)

////{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

//// Данный фрагмент построен конструктором.

//// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

//// регистр Регистр Приход

//

  запрос=новый запрос;

 запрос.Текст= "ВЫБРАТЬ

               | ПоступлениеНаКомиссию1Остатки.Номенклатура,

               | ПоступлениеНаКомиссию1Остатки.Контрагент,

               | ПоступлениеНаКомиссию1Остатки.ДатаПоступл,

               | ПоступлениеНаКомиссию1Остатки.ДоговорКонтр,

               | ПоступлениеНаКомиссию1Остатки.Валюта,

               | ПоступлениеНаКомиссию1Остатки.КоличествоОстаток,

               | ПоступлениеНаКомиссию1Остатки.СуммаДопРасхОстаток,

               | ПоступлениеНаКомиссию1Остатки.ЦенаЗакупОстаток,

               | ПоступлениеНаКомиссию1Остатки.ЦенаРознОстаток

               |ИЗ

               | РегистрНакопления.ПоступлениеНаКомиссию1.Остатки КАК ПоступлениеНаКомиссию1Остатки

               |ГДЕ

               | ПоступлениеНаКомиссию1Остатки.Номенклатура =

&Номенклатура

               | И ПоступлениеНаКомиссию1Остатки.Контрагент = &Контрагент

               | И ПоступлениеНаКомиссию1Остатки.ДоговорКонтр = &ДоговорКонтр" ;

запрос.УстановитьПараметр("Контрагент",Контрагент);

запрос.УстановитьПараметр("ДоговорКонтр",ДоговорКонтрагента);

    

Для Каждого ТекСтрокаТовары Из Товары Цикл

запрос.УстановитьПараметр("Номенклатура",ТекСтрокаТовары.Номенклатура);

//запрос.УстановитьПараметр("Контрагент",Контрагент);

Выборка=запрос.Выполнить().Выгрузить();

Движение = Движения.ПоступлениеНаКомиссию1.Добавить();

Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

Движение.Период = Дата;

Движение.Контрагент = Контрагент;

Движение.ДоговорКонтр = ДоговорКонтрагента;   

Движение.ДатаПоступл = Выборка[0].ДатаПоступл;

Движение.Количество= ТекСтрокаТовары.Количество;

Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;

Движение.ЦенаЗакуп= Выборка[0].ЦенаЗакупОстаток;

Движение.ЦенаРозн=  Выборка[0].ЦенаРознОстаток;

ДВИЖЕНИЕ.Валюта=справочники.Валюты.НайтиПоКоду("643");

Движение.СуммаДопРасх=ТекСтрокаТовары.СуммаДопРасх;

 КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

  СуммаДокумента=0;

Для каждого строка из товары цикл

 СуммаДокумента= СуммаДокумента+строка.сумма;

КонецЦикла

КонецПроцедуры

Процедура Печать() экспорт

 ТабДок = Новый ТабличныйДокумент;

 Макет = ПолучитьМакет("Акт");

 Область = Макет.ПолучитьОбласть("Область1");

 область.Параметры.Номер=Номер;

  область.Параметры.ном = ДоговорКонтрагента.Номер;

   область.Параметры.дат = Формат(ДоговорКонтрагента.Дата,"ДФ = ""dd ММММ гггг """"г.""""""");

 область.Параметры.основание=Комментарий;

 область.Параметры.Дата= Формат(Дата,"ДФ = ""dd ММММ гггг """"г.""""""");

 область.Параметры.Контрагент=Контрагент;

 ТабДок.Вывести(Область);

 Область2 = Макет.ПолучитьОбласть("Область2");

 ном=1;итого=0;

 запрос=новый запрос;

 Запрос.Текст="ВЫБРАТЬ

              | ПоступлениеНаКомиссию.ЦенаРозн,

              | ПоступлениеНаКомиссию.СуммаДопРасх,

              | ПоступлениеНаКомиссию.ЦенаЗакуп

              |ИЗ

              | РегистрНакопления.ПоступлениеНаКомиссию КАК ПоступлениеНаКомиссию

              |ГДЕ

              | ПоступлениеНаКомиссию.Номенклатура = &Номенклатура

              | И ПоступлениеНаКомиссию.Контрагент = &Контрагент" ;

Запрос.УстановитьПараметр("Контрагент",Контрагент);

 для каждого строка из товары цикл

  область2.Параметры.ном=Ном;

  область2.Параметры.товар= строка.номенклатура;

  запрос.УстановитьПараметр("Номенклатура",строка.номенклатура);

  Выборка=Запрос.Выполнить().Выгрузить();

  

  область2.Параметры.цена=Формат(строка.ЦенаПрод,"ЧЦ=10; ЧДЦ=2");

  Если  строка.СуммаДопРасх>0 тогда

  область2.Параметры.стоим=Формат(строка.СуммаДопРасх,"ЧЦ=10; ЧДЦ=2");

 Иначе

  попытка

  область2.Параметры.стоим=Формат(Выборка[0].СуммаДопРасх,"ЧЦ=10; ЧДЦ=2");

 исключение

  конецпопытки;

  КонецЕсли;

  компенсация=0;ценаРознич=0;

  Попытка

   ценаРознич=Выборка[0].ЦенаЗакуп;

  исключение

   ценаРознич= строка.ЦенаПрод;

  конецпопытки;

  

  Если  Комментарий=Перечисления.ОснованиеРасторжения.Инициатива тогда

   компенсация=строка.ЦенаПрод*25/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  ИначеЕсли  (ценаРознич>=8000) и  (ценаРознич<51000) и ((Комментарий=Перечисления.ОснованиеРасторжения.Инициатива)или(Комментарий=Перечисления.ОснованиеРасторжения.Окончание) )тогда

   компенсация=ценаРознич*3/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  ИначеЕсли  (ценаРознич>=51000)и ((Комментарий=Перечисления.ОснованиеРасторжения.Инициатива )или(Комментарий=Перечисления.ОснованиеРасторжения.Окончание) ) тогда

   компенсация=ценаРознич*2/100;

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  Иначе

   область2.Параметры.комп=Формат(компенсация,"ЧЦ=10; ЧДЦ=2");

   

  КонецЕсли;

  область2.Параметры.шт=строка.номенклатура.код;

  область2.Параметры.кол=строка.количество;

  ном=ном+1;

  итого=итого+компенсация+строка.СуммаДопРасх;

  ТабДок.Вывести(Область2);

 КонецЦикла;

 Область3 = Макет.ПолучитьОбласть("Область3");

 Область3.Параметры.итого=Формат(итого,"ЧЦ=10; ЧДЦ=2");

   //Область3.Параметры.итогоп=

  //числопрописью(итого,"L=ru_Ru");

 мВалютаРегламентированногоУчета = глЗначениеПеремен-

ной("ВалютаРегламентированногоУчета");

 Область3.Параметры.итогоп= ОбщегоНазначения.СформироватьСуммуПрописью(итого, мВалютаРегламентированногоУчета);

 ТабДок.Вывести(Область3);

 

 ТабДок.ОтображатьСетку = Ложь;

 ТабДок.Защита = Ложь;

 ТабДок.ТолькоПросмотр = Ложь;

 ТабДок.ОтображатьЗаголовки = Ложь;

 ТабДок.Показать();

КонецПроцедуры


4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

56

57

58

59

60

61

62

63

64

65

66

67

68

69

70

71

72

73

74

75

76

77

78

79


 

А также другие работы, которые могут Вас заинтересовать

4522. Автоматизированные информационно-управляющие системы 194.04 KB
  Цель работы Целью работы является изучение методов статистического моделирования временных рядов. Теоретическая часть Методы моделирования одномерных временных рядов Динамика рядов показателей состояния участков территориальных систем в общем случае...
4523. Практическое использование методов и средств диагностики 20.13 KB
  Практическое использование методов и средств диагностики Классификация диагностического оборудования В настоящее время нет достаточно четкой и полной классификации диагностического оборудования. Это создает определенные трудности при решении многих ...
4524. Расчет состава шихты, материального и теплового балан-сов агломерационного процесса 338.5 KB
  Введение Расчет агломерационной шихты ведут с целью определения такого соотношения между ее компонентами, которое обеспечит получение агломерата заданного качества. В простейшем случае при заданном расходе руды и коксовой мелочи необходимо вычислить...
4525. Грошово-кредитні системи зарубіжних країн 989 KB
  Розглянуто етапи еволюції грошово-кредитних систем, охарактеризовано їхні основні складові. Проаналізовано грошово-кредитну політику країн із розвиненою економікою. Окремий розділ присвячено огляду діяльності міжнародних валютно-кредитних та фінансо...
4526. Изучение теодолитов. Поверки. Производство измерений 225.5 KB
  Изучение теодолитов. Поверки. Производство измерений Цель работы: Изучить устройство, поверки теодолита Т30, принципы и порядок измерения горизонтальных и вертикальных углов с помощью теодолита. Описание и общая схема теодолита Т30 с осями...
4527. Расчет надземного трубопровода на прочность и продольную устойчивость 22.04 KB
  Расчет надземного трубопровода на прочность и продольную устойчивость Постановка цели: Определить допустимое расстояние между опорами надземного балочного перехода газопровода произвести расчет данного участка на прочность и продольную устойчивость...
4528. Маркетинг. Учебно-практическое пособие 214.5 KB
  Введение Учебно-практическое пособие разработано в соответствии с требованиями Государственного образовательного стандарта Министерства образования РФ. Маркетинг – это процесс планирования и управления мероприятиями по разработке новых изделий...
4529. Технологическая схема производства асбестовых листов 50.39 KB
  Введение Материалы, применяемые для отделки строительных конструкций и сооружений, домов и квартир, должны защищать их от воздействия окружающей среды, придавать завершающее архитектурное оформление, создавать особые санитарно-гигиенические условия...
4530. Характеристика и принципы использования буровых долот в процессе бурения скважин 485.29 KB
  Введение. Бурение скважин — это процесс сооружения направленной горной выработки большой длины и малого (по сравнению с длиной) диаметра. Начало скважины на поверхности земли называют устьем, дно — забоем. Нефть и газ добывают, строя скваж...