6167

Принципи конфігурування коммутатора Cisco Catalyst 2960

Лабораторная работа

Коммуникация, связь, радиоэлектроника и цифровые приборы

Мета роботи: Вивчити принципи конфігурування коммутатора CiscoCatalyst 2960. Порядок виконання роботи Виконання даної лабораторної роботи, складається з двох частин: Підготовки на емуляторі Packet Tracerv 4 Робота на ко...

Украинкский

2012-12-30

610.5 KB

23 чел.

Мета роботи: Вивчити принципи конфігурування коммутатора Cisco Catalyst 2960.

Порядок виконання роботи

Виконання даної лабораторної роботи, складається з двох частин:

  1.  Підготовки на емуляторі Packet Tracer v4.1
  2.  Робота на комутаторі Cisco Catalyst 2960
  3.  Ознайомитись з теоретичними відомостями.
  4.  Скласти макет згідно схеми в емуляторі Packet Tracer  і провести конфігурацію комутатора.
  5.  Підєднати до комутатора Cisco Сatalyst 2960 робочу станцію через консольний та Ethernet порти.
  6.  Перевірити початковий статус комутатора.
  7.  Провести конфігурування комутатора Cisco Catalyst 2960.
  8.  Закінчити роботу, підготувати звіт.

Теоретичні відомості

Комутатори є пристроями 2-го рівня, які використовуються для пом'якшення браку смуги пропускання і вирішення проблеми переповнювання в мережі. Комутатори можуть сегментувати локальну мережу LAN на сегменти (segments), які складаються з двох робочих станцій. Таким чином з одного великого сегменту створюються вільні від колізій домени. Хоча комутатор LAN ліквідовує колізійні домени (collision domains), всі приєднані до нього пристрої залишаються частиною одного широкомовного домена (broadcast domain). Внаслідок цього всі вузли, приєднані до комутатора LAN, отримують широкомовні повідомлення від всього лише одного вузла, що передає їх.

У розділі приведений огляд базових атрибутів комутаторів, а також їх операційні характеристики. Основна увага в ній приділена базовій конфігурації, тестуванню і управлінню комутаторами, що працюють на основі IOS Cisco. Також приведені рекомендації по установці IP-адрес портів і інших параметрів конфігурації комутаторів.

Настройка адресного простору комутатора

Комутатор мережі Ethernet може дізнатися адреси всіх пристроїв мережі шляхом прочитування МАС-адрес джерел кожного отримуваного фрейма кожного отримуваного фрейма даних і реєструючи порт, через який фрейм поступив на комутатор. Після цього комутатор додає цю інформацію в свою базу даних пересилки, звану також таблицею комутації. Адреси реєструються в цій таблиці динамічно, тобто у міру надходження. Це означає, що у міру прочитування нових адрес вони аналізуються і зберігаються в пам'яті, що адресується за змістом (content-addressable mетоrу- САМ). Якщо адреса джерела в отриманому фреймі відсутня в пам'яті САМ, то він аналізується і зберігається для майбутнього використання.

При кожному записі адреси в пам'ять реєструється поточний час. Це дозволяє зберігати адресу протягом заданого періоду часу. При кожному використанні цієї адреси або виявлення його в пам'яті САМ (при аналізі нових адрес) він отримує нову мітку часу. Якщо протягом певного часу на адресу не було посилань, то він видаляється із списку. Шляхом видалення застарілих адрес, пам'ять  САМ підтримує точну і повнофункціональну базу даних пересилки. Це особливо важливо якщо у робочої станції замінюється карта мережевого інтерфейсу (мережевий адаптер).

Якщо станції А потрібно передати дані станції В, то посилані нею дані проходять через комутатор, як показано на рис. 1.1. Слід пам'ятати про те, що при проходженні даних по мережі комутатор функціонує на 2-му рівні, тобто проглядає лише адресу управління доступом до середовища, званий МАС-адресою (Media Access Control - MAC). Як показано на рис. 1.2, у міру проходження фреймів даних через комутатор здійснюється проглядання МАС-адрес джерел і, при необхідності, їх збереження в адресній таблиці.

Рис.1.1.Приклад проведення комутації в середовищі локальної мережі LAN

При необхідності переслати фрейм комутатор аналізує його МАС-адресу і проглядає свою пам'ять САМ у пошуках порту, з якого можна було б відправити фрейм за цією адресою. Якщо комутатор не знаходить в своїй таблиці пересилки позиції, відповідної цій адресі, то він розсилає цей фрейм зі всіх своїх портів, за винятком того, на якому він був отриманий (така розсилка називається лавинною, flood), як показано на рис. 1.3. Якщо станція А посилає фрейм станції В, то комутатор розсилає його зі всіх своїх портів, оскільки пункт призначення невідомий. Проте коли станція В відповідає станції А, комутатор розглядає МАС-адресу станції В як адресу джерела і створює для неї позицію в пам'яті САМ. Тепер комутатору відомо, де станція В під’єднана.

Рис.1.2.Оновлення таблиці передачі

Тепер дані пересилаються через комутатор від станції А до станції В і при цьому не потрібна лавинна розсилка. Комутатор посилає дані тільки з порту 3, оскільки йому відоме розташування станції А в мережі. Як показано на рис. 1.4, станція В посилає дані комутатору. На рис. 1.5 показано як комутатор передає дані від станції В до станції А. Першочергова передача даних вказала комутатору звідки поступила МАС-адреса, що дозволило йому надалі передавати дані по мережі ефективнішим чином.

Рис.1.3. Лавинна передачі фрейма

Рис.1.4.Передача даних від станції В до комутатора

Рис.1.5.Передача даних від станції В до станції А

Тестування стандартної конфігурації комутатора Catalyst

При першому включенні живлення комутатора в його файлі поточної конфігурації (running configuration file) містяться стандартні установки. Комутатор має стандартне ім'я Switch. На консолі і лініях віртуального терміналу (virtual terminal - vty) паролі не встановлені. У прикладі 1.1 команда show run використовується для відображення стандартної конфігурації комутатора, що працює в середовищі операційної системи Cisco IOS, такого, наприклад, як комутатор серії Cisco 2960.

Приклад1.1

Switch#show run

Building configuration...

Current configuration : 925 bytes

!

version 12.2

no service password-encryption

!

hostname Switch

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

Властивості портів комутатора

Для проглядання властивостей інтерфейсу використовується команда І0S show interface. У ній необхідно вказати номер слота і порту (у форматі 0/1). За замовчуванням порти комутатора (інтерфейси) встановлені на автоматичний режим, як показано в прикладі 1.2. Це означає, що вони автоматично визначають режим роботи - дуплексний або напівдуплексний, а також швидкість порту - 10 Мбіт/с або 100 Мбіт/с

Приклад.1.2

Switch#show interface FastEthernet0/1

FastEthernet0/1 is down, line protocol is down (disabled)

 Hardware is Lance, address is 0060.2fe0.1201 (bia 0060.2fe0.1201)

 MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec,

    reliability 255/255, txload 1/255, rxload 1/255

 Encapsulation ARPA, loopback not set

 Keepalive set (10 sec)

 Half-duplex, 100Mb/s

 input flow-control is off, output flow-control is off

 ARP type: ARPA, ARP Timeout 04:00:00

 Last input 00:00:08, output 00:00:05, output hang never

 Last clearing of "show interface" counters never

 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

 Queueing strategy: fifo

 Output queue :0/40 (size/max)

 5 minute input rate 0 bits/sec, 0 packets/sec

 5 minute output rate 0 bits/sec, 0 packets/sec

    956 packets input, 193351 bytes, 0 no buffer

    Received 956 broadcasts, 0 runts, 0 giants, 0 throttles

    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

    0 watchdog, 0 multicast, 0 pause input

    0 input packets with dribble condition detected

    2357 packets output, 263570 bytes, 0 underruns

Переваги використання стандартної конфігурації

У цій стандартній конфігурації комутатор має один широкомовний домен і може управлятися і конфігуруватися через консольний порт з використанням інтерфейсу командного рядка. У цій конфігурації також встановлений протокол дерева, що пов'язує. При цьому забезпечений підвищений рівень безпеки, оскільки комутатору ще не була призначена IP-адреса.

Для невеликих мереж стандартна конфігурація може виявитися цілком достатньою. Користувач відразу може скористатися перевагами мікросегментації і високої продуктивності мережі, які забезпечуються комутатором.

Комутатор може бути вже сконфігурований і потрібно буде тільки ввести паролі для входу і діставання доступу до режимів користувача: EXEC, ENABLE і PRIVILEGED EXEC. Вхід в режим конфігурації комутатора походить з режиму PRIVІLEDGED EXEC. У командному рядку стандартна заставка для привілейованого exec-режиму має вид Switch*. У ЕХЕС-режимі користувача заставка має вид Switch>.

Зміна стандартних установок комутатора

При необхідності користувач може повністю змінити існуючу конфігурацію як показано в прикладі. 1.3. Для цього слід виконати описані нижче дії.

Видалити існуючу VLAN-інформацію шляхом видалення файлу vlan.dаt бази даних VLAN з флэш-каталога.

Видалити резервний файл конфігурації startup-config. (У прикладі показано як зробити це для комутаторів catalyst 2960 і 1900).

Перезавантажити комутатор.

Приклад 1.3

Налаштування комутатора

Стандартними кроками по налаштуванню комутатора є:

  •  Призначення комутатору імені і завдання паролів
  •  Призначення комутатору IP-адреси і шлюзу за умовчанням
  •  Установка характеристик портів

Комутатору необхідно призначити ім'я, а на консолі і на каналах vty (Telnet) повинні бути задані паролі, як показано в прикладі 1.4.

Приклад 1.4

Призначення комутатору IP-адреси і шлюзу за замовчуванням

Дтя того, щоб до комутатора могли дістати доступ Teinet і інші додатки TCP/IP, йому необхідно призначити IP-адресу і задати стандартний шлюз (шлюз за замовчуванням). У прикладі 1.5 показано як це зробити для комутаторів моделей Catalyst 2960 і 1900. За замовчуванням мережа VLAN 1 є віртуальною мережею по замовчуванню. У мережі, побудованій на комутаторах, всі пристрої об'єднаної мережі повинні знаходитися в мережі управління VLAN. Це дозволяє з однієї робочої станції діставати доступ до всіх пристроїв об'єднаної мережі, конфігурувати їх і керувати ними.

Приклад 1.5

Установка характеристик порту

Порти FastEthernet комутатора за замовчуванням встановлені на автоматичне визначення швидкості передачі і на дуплексний режим. Це дозволяє інтерфей-

адміністраторові потрібно упевнитися в тому, що який-небудь інтерфейс має конкретну швидкість передачі (10 Мбіт/с або 100 Мбіт/с) або режим того, що дуплексує (дуплексний або напівдуплексний), то ці значення можуть бути встановлені уручну, як показано в прикладі 1.6.

Приклад 1.6

  1.  Встановити звязок з комутатором через програму HiperTerminal.

Базова конфігурація

  1.  Зайти в exec-mode

Switch>enable

3. Зайти в режим конфігурації

Switch#conf t

4. Задати базові настройки комутатора (ім’я коммутатору, пароль на вхід з консолі, на віртуальні термінали (vty), ip-address комутатора та default-gateway)

 

Switch(config)#hostname Lviv

Lviv(config)#enable password cisco

5. Задати ір-адрес vlan 1 та шлюз

Lviv(config)#int vlan 1

Lviv(config-if)#ip address 172.16.0.2 255.255.0.0

Lviv(config-if)#no shutdown

Lviv(config-if)#exit

Lviv(config)#ip default-gateway 172.16.0.1

Lviv(config)#end

6. Проглянути мас-адреси які присутні на комутаторі

Lviv#show mac-address-table

         Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

  1    000c.85eb.7202    DYNAMIC     Gig1/2

  1    0090.2bc3.5201    DYNAMIC     Gig1/1

7. командою ipconfig /all визначити мас-адресу компютера який підключений через Ethernet-port до комутатора.

8. Сконфігурувати статичні таблиці мас-address комутатора

Lviv(config)#mac-address-table static (MAC-ADDRESS) vlan 1 int fa0/1

Lviv(config)#exit

9.Переглянути створену mac-table

Lviv#show mac-address-table

         Mac Address Table

-------------------------------------------

Vlan    Mac Address       Type        Ports

----    -----------       --------    -----

  1    0009.7c4d.0939    STATIC      Fa0/1

  1    000c.85eb.7202    DYNAMIC     Gig1/2

  1    0090.2bc3.5201    DYNAMIC     Gig1/1

10. Сконфігурувати port security 

Lviv(config)# interface fa0/9

Lviv(config-if)# switchport port-security

Lviv(config-if)# switchport port-security maximum 1

11. Скопіювати поточну конфігурацію в стартову конфігурцію

Lviv#copy running-config startup-config

12. Переглянути поточну конфігурацію

Lviv#show running-config

13. Підєднати до захищеного порту порту комп’ютер з іншою мас-адресою

14. Переглянути поточну конфігурацію

15. Видалити startu-config

Lviv#erase startup-config

Команди які необхідно засвоїти

Enable – дає доступ в режим конфігурації

configure terminal -  дає доступ в привілейований режим конфігурації

hostname – задає імя комутатору

show running-config – показує активну конфігурацію комутатора

copy running-config startup-config – зберігає конфігурацію комутатора

enable password – задає пароль

show interface – показує інтерфейс

show mac-address-table – показує які пристрої прикріплені до якого інтерфейсу

port security – безпечний порт

Контрольні питання

  1.  Які початкові установки конфігурації, задаються в комутаторі?
  2.  Про що інформують LED на передній панелі комутатора?
  3.  Для чого призначений безпечний режим роботи портів?
  4.  Яка команда висвічує на дисплей конфігурацію комутатора?
  5.  Чим відрізняються комутатори другого та третього рівнів?


 

А также другие работы, которые могут Вас заинтересовать

81044. Образование СНГ. Становление отношений РФ со странами СНГ 43.13 KB
  Становление отношений РФ со странами СНГ Содру́жество Незави́симых Госуда́рств СНГ региональная международная организация международный договор призванная регулировать отношения сотрудничества между странами ранее входившими в состав СССР. СНГ не является надгосударственным образованием и функционирует на добровольной основе. СНГ было основано главами БССР РСФСР и Украины путём подписания 8 декабря 1991 года в Вискулях Беловежская пуща под Брестом Беларусь Соглашения о создании Содружества Независимых Государств известно в СМИ...
81045. Интеграционные процессы в странах СНГ 44.53 KB
  После получения независимости страны СНГ при наличии разности видения перспектив и возможностей строят рыночную экономику и демократические государства. Национальная идея как основа государственности получила закрепление в преамбуле многих конституций стран СНГ. В процессе жизнедеятельности страны СНГ прошли сложный путь само индетификации определения целей прерогатив развития.
81046. Этапы эволюции ЕС. Правовая основа ЕС 48.21 KB
  Хартию основных социальных прав трудящихся призванную сделать более гармоничными индивидуальные и коллективные права трудящихся и закрепить уже завоеванные права. Европейское право является самостоятельной правовой системой находящейся на стыке национального права государств-членов ЕС и права международного. К функциональным принципам относятся принцип верховенства права и принцип прямого действия. Принцип верховенства права ЕС означает приоритет норм права ЕС над нормами национального...
81047. Взаимоотношения ЕС и России. Зоны противоречий ЕС-РФ 49.13 KB
  В практическом плане это должно было вылиться в сближение экономик России и Евросоюза углубление совместного сотрудничества в борьбе с организованной преступностью терроризмом незаконной миграцией а в перспективе и в отмену визового режима. По статистике на Евросоюз приходится половина объёма внешней торговли России а государстваучастники этой организации являются крупнейшими прямыми инвесторами в российскую экономику. ЕС главный для России источник современных технологий.
81048. Азиатско-тихоокеанский регион в международной системе 52.02 KB
  Развитие права норм и механизмов регулирования международных отношений в АТР как и в других регионах мира связано с такими организациями как: Ассоциация государств ЮгоВосточной Азии АСЕАН АзиатскоТихоокеанское экономическое сотрудничество АТЭС Асеановский региональный форум АРФ Шанхайская организация сотрудничества ШОС и др. Роль США в АТР АТР объединяет около 25 стран бассейна Тихого океана. Факторы повлиявшие на выделение АТР в особую зону мирового развития: передел мира после 2 ой мировой войны США становится лидером;...
81049. Внешняя политика Китайской народной республики 49.14 KB
  Документ подписали глава МИД КНР Ян Цзечи и министр иностранных дел России Сергей Лавров который находится в Китае с рабочим визитом. Таким образом между РФ и КНР окончательно урегулирована территориальная проблема переговоры по которой длились более 40 лет поставлена точка в пограничном размежевании между нашими странами и завершено юридическое оформление общей границы. Дополнительное соглашение между РФ и КНР о российско-китайской государственной границе на её восточной части было подписано в Пекине...
81050. Позиция РФ в Азиатско- Тихоокеанском регионе. Китай. Япония 53.61 KB
  Более 70 внешнеторгового оборота России с азиатскими странами приходится на государства АзиатскоТихоокеанского региона АТР. Наиболее крупными торговыми партнерами России в регионе являются Китай Япония и Республика Корея Южная Корея. Этот процесс завершил урегулирование пограничных проблем в отношениях России и КНР многолетний переговорный процесс который был начат ещё СССР и КНР в 1964 и который помимо переговоров дипломатов сопровождался ещё и кровопролитием с обеих сторон. В отношениях России с КНР важнейшей задачей на ближайшее...
81051. Многосторонние международные институты и международные организации в современных международных отношениях 41.21 KB
  Международные правительственные организации МПО членами которых выступают национальные правительства и которые создаются посредством заключения договоров между государствами. МПО выполняют роль надгосударственных образований т. МПО в зависимости от целей и членства разделяются на универсальные ООН региональные АСЕАН МЕРКОСУР ШОС и функциональные организации МАГАТЕ. В настоящее время существует свыше 300 МПО.
81052. Современная дипломатия как средство регулирования МО 40.72 KB
  съезды конференции совещания и встречиподготовка и заключение многосторонних и 2х мн договоров Участие в работе мн организаций и их органовОсуществление постоянного представительства госва за границей чз посольстваПубликация дипломатическойдокументацииОсвещение в печати позиции правительства по мн вопросамНаиболее часто встречаемые формы диплом документации письма ноты меморандумы.Формы Д:1Двусторонняя Д осуществляемая на постоянной основе через представительства одного госва на территории др2 временная Д. путем посылки в др госво...