62976

Решение биквадратного уравнения в EXCEL

Конспект урока

Педагогика и дидактика

Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: Алгоритм решения биквадратного уравнения. На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel.

Русский

2014-06-15

76 KB

28 чел.

Урок . Решение биквадратного уравнения в EXCEL.

    Уравнение вида: ax4 + bx2 + c = 0, где a, b, c - любые действительные числа, называется биквадратным.

2. Алгоритм решения биквадратного уравнения.

  1.      Прежде всего сделаем замену y = x2. Получим квадратное уравнение ay2 + by + c = 0.
        Решим полученную систему квадратных уравнений.
           y = x
    2
           ay
    2 + by + c = 0.
        Начнем с решения квадратного уравнения.
        Далее в зависимости от значения переменной
    y будем решать второе уравнение y=x2 и находить значения переменной x.
  2.     вычислим дискриминант квадратного уравнения: d = b2 - 4ac.
        Далее в зависимости от значения дискриминанта
    d и от значений переменной y могут встретиться следующие случаи:
  3.  Случай 1: Если d<0, то действительных решений нет.
  4.                 Если d>=0, то вычислим
  5.  Случай 2: Если d>=0 и y1<0 и y2<0, то действительных решений нет
  6.  Случай 3: Если d>=0 и y1>=0 и y2>=0, то получим 4 решения биквадратного уравнения:
  7.  Случай 4: Если d>=0 и y1>=0 и y2<0, то получим 2 решения биквадратного уравнения:
  8.  Случай 5: Если d>=0 и y2>=0 и y1<0, то получим 2 решения биквадратного уравнения:

2. Блок-схема алгоритма решения биквадратного уравнения.   

3. Проект решения биквадратного уравнения в Excel.


  1.      В ячейку A1 записать наименование задачи: Решение биквадратного уравнения ax4 + bx2 + c = 0.
  2.      Вторую строку пропустить.
  3.      В третьей строке указать заголовки столбцов: № п/п; a= ; b= ; c= ; d= ; y1 ; y2 ; x1= ; x2= ; x3= ; x4= ;
  4.      Начиная с 4-ой строки, будем располагать матрицу с числовыми значениями коэффициентов a, b, c исходной задачи и необходимые формулы для вычисления значений расчетных величин: d, y1, y2, x1, x2, x3, x4:
  5.  В ячейку E4 поместить формулу для вычисления d
    =C4*C4 - 4B4*D4 и нажать клавишу Enter.
  6.  В ячейку F4 поместить формулу для вычисления y1
    =ЕСЛИ(E4<0;"решений нет";(-C4-КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  7.  В ячейку G4 поместить формулу для вычисления y2
    =ЕСЛИ(E4<0;"решений нет";(-C4+КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  8.  В ячейку H4 поместить формулу для вычисления x1
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);-КОРЕНЬ(F4);-КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  9.  В ячейку I4 поместить формулу для вычисления x2
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);+КОРЕНЬ(F4);+КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  10.  В ячейку J4 поместить формулу для вычисления x3
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  11.  В ячейку K4 поместить формулу для вычисления x4
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  12.     Проект решения задачи вычисления корней биквадратного уравнения ax4 + bx2 + c = 0 получен.
    Остается опробовать его или, как говорят программисты, отладить полученный проект.
    Поместим в таблицу Excel матрицу с коэффициентами a, b, c следующих пяти исходных биквадратных уравнений:

       8x
    4 - 6x2 + 200 = 0
         x
    4 + 5x2 + 6 = 0
         x
    4 - 5x2 + 6 = 0
         x
    4 + x2 - 6 = 0
         x
    4 - x2 - 6 = 0


        Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: "Алгоритм решения биквадратного уравнения". На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel. Их Вы видите в соответствующих столбцах "a=", "b=", "c=" названной таблицы.
        Остается выравнять по длине документа название проекта, данное в ячейке A1 первой строки: "Решение биквадратного уравнения ax
    4 + bx2 + c = 0". Это можно сделать, если вначале выделить данное название по длине документа и затем нажать кнопку с буквой "а" посередине и стрелками справа, слева, сверху и снизу:
        Помимо того, нужно четко показать столбцы и строки таблицы. Воспользуйтесь для этого командами выделения границ, представленными ниже нарисунке:

    .


 

А также другие работы, которые могут Вас заинтересовать

83714. Исследование эффекта Джоуля-Томпсона при адиабатическом истечении газа 438 KB
  Идеальный газ – модель газа, в которой пренебрегаются размеры молекул по сравнению с расстоянием между ними, т.е. молекулы рассматриваются как материальные точки, также пренебрегаются силы взаимодействия между молекулами (за исключением моментов столкновения).
83716. Определение коэффициента термического расширения (линейного) твёрдого тела 117.05 KB
  Определить температуру металлической проволоки при протекании через неё электрического тока. Измерить удлинение проволоки при нагревании. В данной работе экспериментально определяется коэффициент термического расширения твердого тела металлической проволоки.
83717. Моделювання типових радіотехнічних сигналів 1.34 MB
  Вивчити основні можливості програми MathCad, ознайомитися з елементами загальної теорії радіотехнічних сигналів, освоїти порядок моделювання найпростіших радіотехнічних сигналів. При підготовці до виконання лабораторної роботи необхідно вивчити даний опис, що відповідає розділам рекомендованої літератури...
83718. MS Access 2007: Создание запросов 351.77 KB
  Для объединения записей из связанных таблиц в группы (чтобы в результирующей таблице запроса не было повторяющихся записей) Сортировка Вывод инструкций сортировки записей Вывод на экран Определяет, будет ли отражено поле в результирующей таблице Условие отбора Содержит первое условие...
83719. Электронные промышленные устройства 113.15 KB
  Изучить правила работы с лабораторным стендом, назначения и принцип действия используемых микросхем. Синтезировать и начертить схему дешифратора 3-разрядного числа. Смонтировать дешифратор и проверить его работу. Изучить принцип работы дешифратора К155ИД4. Начертить схему исследования дешифратора.
83720. Виявлення вражаючих факторів регіональних природних загроз. Визначення параметрів і наслідків повеней 331.95 KB
  Поширення землетрусів підлягає певним закономірностям: там, де формуються великі гори та впадини, звичайно і проявляються сильні землетруси. На земній кулі щорічно реєструється більше ста тисяч підземних поштовхів, з яких близько ста — з певним ступенем руйнування.
83721. ДЕРЕВА І ГРАФИ В МОВІ ПРОГРАМУВАННЯ С 221.77 KB
  Дерева. Основні поняття Дерева являють собою найбільш важливі нелінійні структури що зустрічаються в обчислювальних алгоритмах. Існує кілька класів дерев серед яких особливою популярністю користуються бінарні двійкові дерева.
83722. Исследование операционных усилителей и схем на их основе 134.02 KB
  Цель работы: изучение принципа работы, основных параметров и характеристик операционного усилителя; измерение основных параметров операционного усилителя; исследование масштабных усилителей на операционных усилителях.