62976

Решение биквадратного уравнения в EXCEL

Конспект урока

Педагогика и дидактика

Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: Алгоритм решения биквадратного уравнения. На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel.

Русский

2014-06-15

76 KB

8 чел.

Урок . Решение биквадратного уравнения в EXCEL.

    Уравнение вида: ax4 + bx2 + c = 0, где a, b, c - любые действительные числа, называется биквадратным.

2. Алгоритм решения биквадратного уравнения.

  1.      Прежде всего сделаем замену y = x2. Получим квадратное уравнение ay2 + by + c = 0.
        Решим полученную систему квадратных уравнений.
           y = x
    2
           ay
    2 + by + c = 0.
        Начнем с решения квадратного уравнения.
        Далее в зависимости от значения переменной
    y будем решать второе уравнение y=x2 и находить значения переменной x.
  2.     вычислим дискриминант квадратного уравнения: d = b2 - 4ac.
        Далее в зависимости от значения дискриминанта
    d и от значений переменной y могут встретиться следующие случаи:
  3.  Случай 1: Если d<0, то действительных решений нет.
  4.                 Если d>=0, то вычислим
  5.  Случай 2: Если d>=0 и y1<0 и y2<0, то действительных решений нет
  6.  Случай 3: Если d>=0 и y1>=0 и y2>=0, то получим 4 решения биквадратного уравнения:
  7.  Случай 4: Если d>=0 и y1>=0 и y2<0, то получим 2 решения биквадратного уравнения:
  8.  Случай 5: Если d>=0 и y2>=0 и y1<0, то получим 2 решения биквадратного уравнения:

2. Блок-схема алгоритма решения биквадратного уравнения.   

3. Проект решения биквадратного уравнения в Excel.


  1.      В ячейку A1 записать наименование задачи: Решение биквадратного уравнения ax4 + bx2 + c = 0.
  2.      Вторую строку пропустить.
  3.      В третьей строке указать заголовки столбцов: № п/п; a= ; b= ; c= ; d= ; y1 ; y2 ; x1= ; x2= ; x3= ; x4= ;
  4.      Начиная с 4-ой строки, будем располагать матрицу с числовыми значениями коэффициентов a, b, c исходной задачи и необходимые формулы для вычисления значений расчетных величин: d, y1, y2, x1, x2, x3, x4:
  5.  В ячейку E4 поместить формулу для вычисления d
    =C4*C4 - 4B4*D4 и нажать клавишу Enter.
  6.  В ячейку F4 поместить формулу для вычисления y1
    =ЕСЛИ(E4<0;"решений нет";(-C4-КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  7.  В ячейку G4 поместить формулу для вычисления y2
    =ЕСЛИ(E4<0;"решений нет";(-C4+КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  8.  В ячейку H4 поместить формулу для вычисления x1
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);-КОРЕНЬ(F4);-КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  9.  В ячейку I4 поместить формулу для вычисления x2
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);+КОРЕНЬ(F4);+КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  10.  В ячейку J4 поместить формулу для вычисления x3
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  11.  В ячейку K4 поместить формулу для вычисления x4
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  12.     Проект решения задачи вычисления корней биквадратного уравнения ax4 + bx2 + c = 0 получен.
    Остается опробовать его или, как говорят программисты, отладить полученный проект.
    Поместим в таблицу Excel матрицу с коэффициентами a, b, c следующих пяти исходных биквадратных уравнений:

       8x
    4 - 6x2 + 200 = 0
         x
    4 + 5x2 + 6 = 0
         x
    4 - 5x2 + 6 = 0
         x
    4 + x2 - 6 = 0
         x
    4 - x2 - 6 = 0


        Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: "Алгоритм решения биквадратного уравнения". На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel. Их Вы видите в соответствующих столбцах "a=", "b=", "c=" названной таблицы.
        Остается выравнять по длине документа название проекта, данное в ячейке A1 первой строки: "Решение биквадратного уравнения ax
    4 + bx2 + c = 0". Это можно сделать, если вначале выделить данное название по длине документа и затем нажать кнопку с буквой "а" посередине и стрелками справа, слева, сверху и снизу:
        Помимо того, нужно четко показать столбцы и строки таблицы. Воспользуйтесь для этого командами выделения границ, представленными ниже нарисунке:

    .


 

А также другие работы, которые могут Вас заинтересовать

44771. Особенностями приготовления блюд немецкой кухни 178.5 KB
  Целью выполнения курсовой работы является ознакомление с особенностями приготовления блюд немецкой кухни, закрепление и углубление знаний будущего инженера, способного не только технически грамотно владеть существующими технологическими процессами, но и совершенствовать их и создавать новые, обеспечивающие повышение качества продукции и эффективность производства.
44772. Анализ технологии приготовления вторых горячих блюд из рыбы 1.85 MB
  Обитатели глубин содержат необходимые нашему организму витамины (особенно А и D), жиры, белки (мясо рыб содержит 18% белков). Белки мяса рыб легче усваиваются организмом человека, чем белки мяса животных. Ценной составной частью рыб, особенно океанических, является жир. Рыбий жир характеризуется высоким содержанием непредельных жирных кислот
44773. Изучение кисломолочных напитков, обогащенных бифидобактериями 309 KB
  Кисломолочные продукты – это молочные продукты, вырабатываемые сквашиванием молока или сливок чистыми культурами молочнокислых бактерий с добавлением или без добавления дрожжей и уксуснокислых бактерий. Кисломолочные напитки пользуются заслуженной популярностью у миллионов людей различных стран мира.
44774. Проблемы имплементации международно-правовых стандартов по запрещению рабства и принудительного труда в РФ 313.5 KB
  Предмет исследования составляют нормы, содержащиеся в международно-правовых актах в сфере предупреждения и запрещения рабства и принудительного труда (международные конвенции, декларации и рекомендации), а также нормы российского законодательства в указанной области.
44775. Анализ ассортимента и оценка качества чайных товаров на ООО «Чайный дом» 221 KB
  Следует отметить, что от выпуска высококачественной продукции выигрывает и национальная экономика, поскольку в этом случае увеличиваются экспортный потенциал и доходная часть платежного баланса страны, повышается авторитет государства в мировом сообществе.
44776. Анализ ассортимента, потребительских свойств и экспертиза качества товаров, реализуемых торговым предприятием на примере мучных кондитерских изделий 241 KB
  Отрасль продолжает сохранять большую привлекательность для иностранных вложений, поскольку, по оценкам иностранных аналитиков, российский кондитерский рынок сохраняет потенциальные возможности для дальнейшего расширения, при условии сохранения относительной стабильности в экономике страны в целом.
44777. Применение форм 7.9 MB
  Применение форм Цели работы: научиться создавать формы ввода-вывода; научиться создавать кнопочные формы. Перейдите на закладку Формы выделите форму Список и нажмите клавишу [Delete]. С помощью автоформы можно просматривать или вводить данные. Порядок работы: В окне базы данных выберите вкладку Формы.
44779. Создание и использование запросов (продолжение) 2.09 MB
  Предположим, прошел год, студенты перешли на следующий курс, изменились их личные данные, некоторые закончили колледж, пришли новые. Нужно обновить базу данных