62976

Решение биквадратного уравнения в EXCEL

Конспект урока

Педагогика и дидактика

Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: Алгоритм решения биквадратного уравнения. На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel.

Русский

2014-06-15

76 KB

7 чел.

Урок . Решение биквадратного уравнения в EXCEL.

    Уравнение вида: ax4 + bx2 + c = 0, где a, b, c - любые действительные числа, называется биквадратным.

2. Алгоритм решения биквадратного уравнения.

  1.      Прежде всего сделаем замену y = x2. Получим квадратное уравнение ay2 + by + c = 0.
        Решим полученную систему квадратных уравнений.
           y = x
    2
           ay
    2 + by + c = 0.
        Начнем с решения квадратного уравнения.
        Далее в зависимости от значения переменной
    y будем решать второе уравнение y=x2 и находить значения переменной x.
  2.     вычислим дискриминант квадратного уравнения: d = b2 - 4ac.
        Далее в зависимости от значения дискриминанта
    d и от значений переменной y могут встретиться следующие случаи:
  3.  Случай 1: Если d<0, то действительных решений нет.
  4.                 Если d>=0, то вычислим
  5.  Случай 2: Если d>=0 и y1<0 и y2<0, то действительных решений нет
  6.  Случай 3: Если d>=0 и y1>=0 и y2>=0, то получим 4 решения биквадратного уравнения:
  7.  Случай 4: Если d>=0 и y1>=0 и y2<0, то получим 2 решения биквадратного уравнения:
  8.  Случай 5: Если d>=0 и y2>=0 и y1<0, то получим 2 решения биквадратного уравнения:

2. Блок-схема алгоритма решения биквадратного уравнения.   

3. Проект решения биквадратного уравнения в Excel.


  1.      В ячейку A1 записать наименование задачи: Решение биквадратного уравнения ax4 + bx2 + c = 0.
  2.      Вторую строку пропустить.
  3.      В третьей строке указать заголовки столбцов: № п/п; a= ; b= ; c= ; d= ; y1 ; y2 ; x1= ; x2= ; x3= ; x4= ;
  4.      Начиная с 4-ой строки, будем располагать матрицу с числовыми значениями коэффициентов a, b, c исходной задачи и необходимые формулы для вычисления значений расчетных величин: d, y1, y2, x1, x2, x3, x4:
  5.  В ячейку E4 поместить формулу для вычисления d
    =C4*C4 - 4B4*D4 и нажать клавишу Enter.
  6.  В ячейку F4 поместить формулу для вычисления y1
    =ЕСЛИ(E4<0;"решений нет";(-C4-КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  7.  В ячейку G4 поместить формулу для вычисления y2
    =ЕСЛИ(E4<0;"решений нет";(-C4+КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  8.  В ячейку H4 поместить формулу для вычисления x1
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);-КОРЕНЬ(F4);-КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  9.  В ячейку I4 поместить формулу для вычисления x2
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);+КОРЕНЬ(F4);+КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  10.  В ячейку J4 поместить формулу для вычисления x3
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  11.  В ячейку K4 поместить формулу для вычисления x4
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  12.     Проект решения задачи вычисления корней биквадратного уравнения ax4 + bx2 + c = 0 получен.
    Остается опробовать его или, как говорят программисты, отладить полученный проект.
    Поместим в таблицу Excel матрицу с коэффициентами a, b, c следующих пяти исходных биквадратных уравнений:

       8x
    4 - 6x2 + 200 = 0
         x
    4 + 5x2 + 6 = 0
         x
    4 - 5x2 + 6 = 0
         x
    4 + x2 - 6 = 0
         x
    4 - x2 - 6 = 0


        Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: "Алгоритм решения биквадратного уравнения". На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel. Их Вы видите в соответствующих столбцах "a=", "b=", "c=" названной таблицы.
        Остается выравнять по длине документа название проекта, данное в ячейке A1 первой строки: "Решение биквадратного уравнения ax
    4 + bx2 + c = 0". Это можно сделать, если вначале выделить данное название по длине документа и затем нажать кнопку с буквой "а" посередине и стрелками справа, слева, сверху и снизу:
        Помимо того, нужно четко показать столбцы и строки таблицы. Воспользуйтесь для этого командами выделения границ, представленными ниже нарисунке:

    .


 

А также другие работы, которые могут Вас заинтересовать

83011. Тестування і ремонт струменевих багатофункціональних пристроїв. Методи вимірювання опору, ємності, індуктивності, добротності 172.15 KB
  В даній курсовій роботі ми розглянемо основні види струменевих пристроїв,їхні характеристики, основні несправності, та методи їх усунення. Також розглянемо тему: Методи вимірювання опору,за допомогою мостів Вінтстона, метод вимірювання ємності, за допомогою фарадметру, а також і методи вимірювання індуктивності і добротності.
83012. Програмне забезпечення операційної системи Android 2.22 MB
  Android має досить простий і інтуїтивно зрозумілий інтерфейс. Всі потрібні програми розміщуються одночасно на головному екрані і в меню апарату, яке викликається натисканням на центральну сенсорну клавішу або відповідну кнопку на екрані. Всі налаштування розташовуються в секції «Налаштування», а кожна дія користувача пояснюється коментарями і підказками при першому запуску смартфону.
83013. Створення база даних в СУБД InterBase 208.5 KB
  Також у InterBase реалізований механізм блокування на рівні запису. Це значить, що сервер блокує тільки ті записи, що реально були змінені користувачем, і не блокує всю сторінку даних цілком. Ця особливість знижує імовірність конфліктів при багатокористувацькому режимі роботи.
83015. Кожухотрубний теплообмінник 1.39 MB
  Схема теплообмінного апарата та її опис Кожухотрубні теплообмінники через простоту конструкції та надійність є на сьогоднішній день найпоширенішими апаратами серед рекуперативних теплообмінників що використовуються у промисловості.
83016. Технология продукции и организация ресторанного дела 230 KB
  Курсовая работа - самостоятельная разработка конкретной темы с элементами научного анализа, отражающая приобретенные студентом теоретические знания и практические навыки, умение работать с литературой, анализировать источники, делать обстоятельные и обоснованные выводы.
83017. ОРГАНІЗАЦІЯ ВИКОНАННЯ ВАНТАЖНИХ ОПЕРАЦІЙ НА МІСЦЯХ ЗАГАЛЬНОГО ТА НЕЗАГАЛЬНОГО КОРИСТУВАННЯ 1.49 MB
  У залежності від обсягу та характеру роботи, яка виконується на МЗК ВР, передбачені: криті та відкриті склади і платформи, площадки для контейнерів, великовагових та інших вантажів, підвищена колія, пристрої для перевантаження з вагонів безпосередньо на автотранспорт або через склад...
83018. Лікувальні можливості Трускавця і Східниці 396.5 KB
  У Трускавці успішно лікуються наступні захворювання: Урологічна патологія: хронічні запальні захворювання нирок та сечовивідних шляхів хронічний пієлонефрит та цистит в період клініко-амбулаторної ремісії без ознак вираженої ниркової недостатності і артеріальної гіпертензії...