62976

Решение биквадратного уравнения в EXCEL

Конспект урока

Педагогика и дидактика

Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: Алгоритм решения биквадратного уравнения. На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel.

Русский

2014-06-15

76 KB

8 чел.

Урок . Решение биквадратного уравнения в EXCEL.

    Уравнение вида: ax4 + bx2 + c = 0, где a, b, c - любые действительные числа, называется биквадратным.

2. Алгоритм решения биквадратного уравнения.

  1.      Прежде всего сделаем замену y = x2. Получим квадратное уравнение ay2 + by + c = 0.
        Решим полученную систему квадратных уравнений.
           y = x
    2
           ay
    2 + by + c = 0.
        Начнем с решения квадратного уравнения.
        Далее в зависимости от значения переменной
    y будем решать второе уравнение y=x2 и находить значения переменной x.
  2.     вычислим дискриминант квадратного уравнения: d = b2 - 4ac.
        Далее в зависимости от значения дискриминанта
    d и от значений переменной y могут встретиться следующие случаи:
  3.  Случай 1: Если d<0, то действительных решений нет.
  4.                 Если d>=0, то вычислим
  5.  Случай 2: Если d>=0 и y1<0 и y2<0, то действительных решений нет
  6.  Случай 3: Если d>=0 и y1>=0 и y2>=0, то получим 4 решения биквадратного уравнения:
  7.  Случай 4: Если d>=0 и y1>=0 и y2<0, то получим 2 решения биквадратного уравнения:
  8.  Случай 5: Если d>=0 и y2>=0 и y1<0, то получим 2 решения биквадратного уравнения:

2. Блок-схема алгоритма решения биквадратного уравнения.   

3. Проект решения биквадратного уравнения в Excel.


  1.      В ячейку A1 записать наименование задачи: Решение биквадратного уравнения ax4 + bx2 + c = 0.
  2.      Вторую строку пропустить.
  3.      В третьей строке указать заголовки столбцов: № п/п; a= ; b= ; c= ; d= ; y1 ; y2 ; x1= ; x2= ; x3= ; x4= ;
  4.      Начиная с 4-ой строки, будем располагать матрицу с числовыми значениями коэффициентов a, b, c исходной задачи и необходимые формулы для вычисления значений расчетных величин: d, y1, y2, x1, x2, x3, x4:
  5.  В ячейку E4 поместить формулу для вычисления d
    =C4*C4 - 4B4*D4 и нажать клавишу Enter.
  6.  В ячейку F4 поместить формулу для вычисления y1
    =ЕСЛИ(E4<0;"решений нет";(-C4-КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  7.  В ячейку G4 поместить формулу для вычисления y2
    =ЕСЛИ(E4<0;"решений нет";(-C4+КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  8.  В ячейку H4 поместить формулу для вычисления x1
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);-КОРЕНЬ(F4);-КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  9.  В ячейку I4 поместить формулу для вычисления x2
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);+КОРЕНЬ(F4);+КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  10.  В ячейку J4 поместить формулу для вычисления x3
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  11.  В ячейку K4 поместить формулу для вычисления x4
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  12.     Проект решения задачи вычисления корней биквадратного уравнения ax4 + bx2 + c = 0 получен.
    Остается опробовать его или, как говорят программисты, отладить полученный проект.
    Поместим в таблицу Excel матрицу с коэффициентами a, b, c следующих пяти исходных биквадратных уравнений:

       8x
    4 - 6x2 + 200 = 0
         x
    4 + 5x2 + 6 = 0
         x
    4 - 5x2 + 6 = 0
         x
    4 + x2 - 6 = 0
         x
    4 - x2 - 6 = 0


        Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: "Алгоритм решения биквадратного уравнения". На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel. Их Вы видите в соответствующих столбцах "a=", "b=", "c=" названной таблицы.
        Остается выравнять по длине документа название проекта, данное в ячейке A1 первой строки: "Решение биквадратного уравнения ax
    4 + bx2 + c = 0". Это можно сделать, если вначале выделить данное название по длине документа и затем нажать кнопку с буквой "а" посередине и стрелками справа, слева, сверху и снизу:
        Помимо того, нужно четко показать столбцы и строки таблицы. Воспользуйтесь для этого командами выделения границ, представленными ниже нарисунке:

    .


 

А также другие работы, которые могут Вас заинтересовать

4635. Освітлення виробничих приміщень 466 KB
  Освітлення виробничих приміщень Перевірний розрахунок природного освітлення. Для виконання перевірного розрахунку креслять необхідні креслення приміщень (при бічному освітленні - поперечний розріз і план приміщення, при горішньому - поперечний, п...
4636. Регулювання якості повітряного середовища 92.5 KB
  Регулювання якості повітряного середовища Кондиціонування повітря Кондиціонер типу спліт-система має два блока, один розташовується усередині приміщення, другій зовні на стіні будівлі. У першому блоці розташовані компресор, вентилятор, в...
4637. Охорона праці. Конспект лекцій. Нещасні випадки та види інструктажів 214.5 KB
  Лекція Основні визначення в галузі охорони праці. Трудова діяльність – це джерело розвитку суспільства, створення матеріальних, культурних і духовних цінностей, передумова існування як кожної окремої людини, так і людства в цілому....
4638. Дослідження машини постійного струму 61 KB
  Дослідження машини постійного струму Мета роботи. Ознайомитися з конструкцією та паспортом машини. Оволодіти способами передпускової розмітки виводів машини постійного струму та розрахунками за паспортними даними. Обладнання та прилади. Машина...
4639. Исследование характеристик диодов и стабилитронов 55 KB
  Исследование характеристик диодов и стабилитронов Цель работы. Научиться составлять и рассчитывать схемы включения полупроводниковых приборов, экспериментальным путем получить их вольтамперные характеристики. Подготовка к лабораторной работе...
4640. Фармакология, курс лекций 971.42 KB
  Педиатрическая фармакология – изучает особенности действия лекарств на детский организм. Перинатальная фармакология – изучает действие ЛС на плод (от 24 нед. до родов) и организм новорожденного (в первые 4 недели жизни). Гериатрическая фармакология – изучает особенности действия и применения ЛС у лиц пожилого и старческого возраста. Фармокогенетика – изучает роль генетических факторов в чувствительности организма к лекарствам.
4641. Вивчення основних схем включення операційних підсилювачів 132.5 KB
  Вивчення основних схем включення операційних підсилювачів Мета роботи: Ознайомитися з основними схемами включення операційних підсилювачів і методикою вибору їх параметрів Підготовка до лабораторної роботи та її виконання. Операційним підсилювачем...
4642. Наближені обчислення, рекурентні співвідношення, обґрунтування коректності 108.5 KB
  Наближені обчислення, рекурентні співвідношення, обґрунтування коректності Постановка задачі Завдання:Обчислити значень функції на інтервалі Результати оформити у вигляді таблиці...
4643. Принципи побудови кінематичної структури передавального механізму - коробки швидкостей 4.93 MB
  Мета роботи:ознайомитися з принципами побудови кінематичної структури передавального механізму (коробки швидкостей), застосуванням графоаналітичного методу кінематичного розрахунку приводу із ступінчастим регулюванням швидкостей. Кінемат...