62976

Решение биквадратного уравнения в EXCEL

Конспект урока

Педагогика и дидактика

Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: Алгоритм решения биквадратного уравнения. На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel.

Русский

2014-06-15

76 KB

10 чел.

Урок . Решение биквадратного уравнения в EXCEL.

    Уравнение вида: ax4 + bx2 + c = 0, где a, b, c - любые действительные числа, называется биквадратным.

2. Алгоритм решения биквадратного уравнения.

  1.      Прежде всего сделаем замену y = x2. Получим квадратное уравнение ay2 + by + c = 0.
        Решим полученную систему квадратных уравнений.
           y = x
    2
           ay
    2 + by + c = 0.
        Начнем с решения квадратного уравнения.
        Далее в зависимости от значения переменной
    y будем решать второе уравнение y=x2 и находить значения переменной x.
  2.     вычислим дискриминант квадратного уравнения: d = b2 - 4ac.
        Далее в зависимости от значения дискриминанта
    d и от значений переменной y могут встретиться следующие случаи:
  3.  Случай 1: Если d<0, то действительных решений нет.
  4.                 Если d>=0, то вычислим
  5.  Случай 2: Если d>=0 и y1<0 и y2<0, то действительных решений нет
  6.  Случай 3: Если d>=0 и y1>=0 и y2>=0, то получим 4 решения биквадратного уравнения:
  7.  Случай 4: Если d>=0 и y1>=0 и y2<0, то получим 2 решения биквадратного уравнения:
  8.  Случай 5: Если d>=0 и y2>=0 и y1<0, то получим 2 решения биквадратного уравнения:

2. Блок-схема алгоритма решения биквадратного уравнения.   

3. Проект решения биквадратного уравнения в Excel.


  1.      В ячейку A1 записать наименование задачи: Решение биквадратного уравнения ax4 + bx2 + c = 0.
  2.      Вторую строку пропустить.
  3.      В третьей строке указать заголовки столбцов: № п/п; a= ; b= ; c= ; d= ; y1 ; y2 ; x1= ; x2= ; x3= ; x4= ;
  4.      Начиная с 4-ой строки, будем располагать матрицу с числовыми значениями коэффициентов a, b, c исходной задачи и необходимые формулы для вычисления значений расчетных величин: d, y1, y2, x1, x2, x3, x4:
  5.  В ячейку E4 поместить формулу для вычисления d
    =C4*C4 - 4B4*D4 и нажать клавишу Enter.
  6.  В ячейку F4 поместить формулу для вычисления y1
    =ЕСЛИ(E4<0;"решений нет";(-C4-КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  7.  В ячейку G4 поместить формулу для вычисления y2
    =ЕСЛИ(E4<0;"решений нет";(-C4+КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
  8.  В ячейку H4 поместить формулу для вычисления x1
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);-КОРЕНЬ(F4);-КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  9.  В ячейку I4 поместить формулу для вычисления x2
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(F4);
    ЕСЛИ(И(F4>=0;G4<0);+КОРЕНЬ(F4);+КОРЕНЬ(G4)))))
    и нажать клавишу Enter.
  10.  В ячейку J4 поместить формулу для вычисления x3
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  11.  В ячейку K4 поместить формулу для вычисления x4
    =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(G4);
    ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет"))))
    и нажать клавишу Enter.
  12.     Проект решения задачи вычисления корней биквадратного уравнения ax4 + bx2 + c = 0 получен.
    Остается опробовать его или, как говорят программисты, отладить полученный проект.
    Поместим в таблицу Excel матрицу с коэффициентами a, b, c следующих пяти исходных биквадратных уравнений:

       8x
    4 - 6x2 + 200 = 0
         x
    4 + 5x2 + 6 = 0
         x
    4 - 5x2 + 6 = 0
         x
    4 + x2 - 6 = 0
         x
    4 - x2 - 6 = 0


        Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: "Алгоритм решения биквадратного уравнения". На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel. Их Вы видите в соответствующих столбцах "a=", "b=", "c=" названной таблицы.
        Остается выравнять по длине документа название проекта, данное в ячейке A1 первой строки: "Решение биквадратного уравнения ax
    4 + bx2 + c = 0". Это можно сделать, если вначале выделить данное название по длине документа и затем нажать кнопку с буквой "а" посередине и стрелками справа, слева, сверху и снизу:
        Помимо того, нужно четко показать столбцы и строки таблицы. Воспользуйтесь для этого командами выделения границ, представленными ниже нарисунке:

    .


 

А также другие работы, которые могут Вас заинтересовать

48232. КОНСПЕКТ ЛЕКЦІЙ З ЕТИКИ ТА ЕСТЕТИКИ 874.5 KB
  Етика вивчає мораль як особливу сферу життєдіяльності людини аналізує природу структуру та соціальну роль моралі досліджує її походження історичний розвиток теоретично обґрунтовує певну систему моральних поглядів і норм. Терміном етичний мислитель позначав чесноти що стосуються людської вдачі характеру на відміну від чеснот діаноетичних тобто пов'язаних з мисленням розумом людини. По суті з етичною проблематикою ми стикаємося всюди де тільки має місце цілісне духовне філософське осмислення людини як у доарістотелівських...
48233. Конспект лекцій з логіки 682 KB
  Відповідно до нормативних вимог Закону Про освіту і Болонського процесу курс лекцій з дисципліни âЛогікаâ включає в себе такі теми: предмет структура і призначення дисципліни поняття судження основні закони логіки умовивід логічні основи теорії аргументації доведення тести й самостійні завдання з логіки. Засвоївши курс âЛогікаâ студенти повинні: Знати: основний зміст усіх тем світоглядний потенціал законів логіки категорій особливості логічного...
48234. Конспект лекцій з релігієзнавства 492 KB
  Релігієзнавство являє собою комплекс суспільних наук, об'єктом вивчення котрих є релігія. Кожна з цих наукових дисциплін, виходячи з специфіки свого предмета, розглядає ту чи іншу сторону цього складного явища, що дозволяє в рамках релігієзнавства представити його цілісну картину
48235. Теорія соціальної роботи 141 KB
  Вступ до соціальної роботи: Підручник для студентів вищих навчальних закладів За ред. Вступ Зв'язки соціальної роботи з іншими дисциплінами мають взаємний характер. Адже здійснення соціальної допомоги передбачає попередній збір інформації її системний аналіз висування гіпотез побудову моделей розвитку.
48236. ЕКОНОМІЧНИЙ АНАЛІЗ (ТЕОРЕТИЧНІ ОСНОВИ) 802.03 KB
  Розглядаються теоретичні основи економічного аналізу, зокрема його значення та роль у системі управління підприємством, предмет та види економічного аналізу, його метод, методика факторного аналізу, характеристика способів детермінованого факторного аналізу, використання економіко-математичних методів в економічному аналізі, методика виявлення і розрахунку резервів, організація та інформаційне забезпечення аналітичних досліджень. Після кожної теми наведені контрольні питання для перевірки засвоєння матеріалу.
48237. ДВИГАТЕЛИ ВНУТРЕННЕГО СГОРАНИЯ 5.35 MB
  Остов двигателя Уравновешивание одноцилиндрового двигателя. Уравновешивание четырехцилиндрового однорядного двигателя Уравновешивание двухцилиндрового Vобразного двигателя.
48238. Л.Д. Малевич. Українська мова професійного спілкування 282.5 KB
  Стилі і норми української літературної мови в професійному спілкуванні Мовне законодавство в Україні Природа і функції мови. Місце української мови серед мов світу. Правовий статус української мови.
48239. УКРАЇНСЬКА МОВА ЗА ПРОФЕСІЙНИМ СПРЯМУВАННЯМ 888.5 KB
  Усне ділове спілкування. Етика ділового спілкування її предмет та завдання. Структура ділового спілкування. Мовленнєвий етикет Правила усного спілкування фахівця зустрічі переговори телефонне спілкування.
48240. ІСТОРІЯ УКРАЇНИ 430.5 KB
  Програма з курсу Історія України Укл. ВСТУПНЕ СЛОВО Пропоновані матеріали підготовлено з урахуванням проекту навчальної програми з курсу Історія України для вищих навчальних закладів освіти і передбачають розвязання таких завдань: а використання останніх досягнень світової і вітчизняної історичної науки в процесі викладання історії України; б постійне підвищення і вдосконалення наукового і виховного рівня викладання; в забезпечення реалізації в ході навчання принципів історизму та обєктивності в оцінці конкретних подій і явищ; г...