6809

Базова VLAN Конфігурація

Лабораторная работа

Коммуникация, связь, радиоэлектроника и цифровые приборы

Базова VLAN Конфігурація Діаграма топології Таблиця адрес Пристрій (Ім'я хоста) Інтерфейс IP адрес Маска підмережі Шлюз по замовчуванню S1 VLAN 99 172.17.99.11 255.255.255.0 N/A S2 VLAN....

Украинкский

2013-01-08

572 KB

10 чел.

Базова VLAN Конфігурація 

Діаграма топології

Таблиця адрес

Пристрій

(Ім’я хоста)

Інтерфейс

IP адрес

Маска підмережі

Шлюз по замовчуванню

S1

VLAN 99

172.17.99.11

255.255.255.0

N/A

S2

VLAN 99

172.17.99.12

255.255.255.0

N/A

S3

VLAN 99

172.17.99.13

255.255.255.0

N/A

PC1

NIC

172.17.10.21

255.255.255.0

172.17.10.1

PC2

NIC

172.17.20.22

255.255.255.0

172.17.20.1

PC3

NIC

172.17.30.23

255.255.255.0

172.17.30.1

PC4

NIC

172.17.10.24

255.255.255.0

172.17.10.1

PC5

NIC

172.17.20.25

255.255.255.0

172.17.20.1

PC6

NIC

172.17.30.26

255.255.255.0

172.17.30.1

Початкові призначення портів (Комутатори 2 і 3)

Порт

Призначення

Мережа

Fa0/1 – 0/5

802.1q Trunks (Native VLAN 99)

172.17.99.0 /24

Fa0/6 – 0/10

VLAN 30 – Guest (Default)

172.17.30.0 /24

Fa0/11 – 0/17

VLAN 10 – Faculty/Staff

172.17.10.0 /24

Fa0/18 – 0/24

VLAN 20 – Students

172.17.20.0 /24

Мета роботи

По завершенні цієї роботи ви зможете:

  •  Прокласти мережу відповідно до діаграми топології
  •  Стирати стартову конфігурацію і перезавантажувати комутатор в стан за замовчуванням
  •  Виконувати базові завдання конфігурації комутатора
  •  Створювати VLAN мережі
  •  Призначати порти комутатора в VLAN
  •  Додавати, переміщати і змінювати порти
  •  Перевіряти VLAN конфігурацію
  •  Підключення ліній зв’язку між комутаторами
  •  Перевірка конфігурації ліній
  •  Збереження конфігурації VLAN

Завдання 1: Підготовка мережі

Крок 1: Створення мережі, аналогічно тій, що зображена на діаграмі.

Ви можете використовувати будь-який комутатор в вашій роботі при умові що він має необхідні інтерфейси показані в топології. 

Зауваження:  якщо ви використовуєте комутатори 2900 чи 2950, то виходи можуть відрізнятись.  Також, певні команди можуть відрізнятись або бути недійсними.

Крок 2: Стирання будь-якої існуючої конфігурації на комутаторах, та ініціалізація усіх портів в стані shutdown.

Якщо необхідно, дивіться в Lab 2.5.1, Додаток 1, процедуру очищення конфігурації комутатора.

Хорошою практикою є відключення усіх портів що не використовуються в комутаторах шляхом встановлення їх в стан shutdown. Відключіть усі порти на комутаторах:

Switch#config term

Switch(config)#interface range fa0/1-24

Switch(config-if-range)#shutdown

Switch(config-if-range)#interface range gi0/1-2

Switch(config-if-range)#shutdown

Завдання 2: Налаштування базової конфігурації комутатора

Крок 1: Налаштуйте комутатори відповідно до наступних принципів.

  •  Налаштуйте ім’я хоста комутатора.
  •  Відключіть пошук DNS.
  •  Налаштуйте EXEC режимі пароль для class.
  •  Налаштуйте пароль для cisco для консольних з’єднань.
  •  Налаштуйте пароль для cisco для віртуальних інтерфейсів.

Крок 2: Повторно включіть порти користувачів на S2 і S3.

S2(config)#interface range fa0/6, fa0/11, fa0/18

S2(config-if-range)#switchport mode access

S2(config-if-range)#no shutdown

S3(config)#interface range fa0/6, fa0/11, fa0/18

S3(config-if-range)#switchport mode access

S3(config-if-range)#no shutdown

Завдання 3: Налаштування і активація Ethernet інтерфейсів

Крок 1: Налаштування ПК.

Ви можете виконувати цю роботу використовуючи тільки 2 ПК шляхом зміни ІР адрес для двох ПК відповідно до задачі, яку необхідно виконати. Наприклад, якщо ви бажаєте первірити з’єднання між ПК1 і ПК2, тоді налаштовуєте ІР адреси для цих ПК відповідно до таблиці на початку цієї роботи. Окрім того ви зможете налаштувати ІР адреси і шлюзи по замовчуванню для усіх шести ПК.

Завдання 4: Налаштування VLAN на комутаторі

Крок 1: Створення VLAN на комутаторі S1.

Використайте vlan vlan-id команду в режимі глобальної конфігурації для того щоб додати VLAN до комутатора S1. У цій лабораторній роботі потрібно налаштувати 4 мережі VLAN: VLAN 10 (faculty/staff); VLAN 20 (students); VLAN 30 (guest); і VLAN 99 (management). Після створення VLAN, ви опинитесь у режимі конфігурації vlan, де ви зможете призначити ім’я для VLAN за допомогою команди name vlan name.

S1(config)#vlan 10

S1(config-vlan)#name faculty/staff

S1(config-vlan)#vlan 20

S1(config-vlan)#name students

S1(config-vlan)#vlan 30

S1(config-vlan)#name guest

S1(config-vlan)#vlan 99

S1(config-vlan)#name management

S1(config-vlan)#end

S1#

Крок 2: Перевірка чи VLAN була створена на S1.

Використайте команду show vlan brief щоб пересвідчитись що VLAN була створена.

S1#show vlan brief

VLAN Name                            Status    Ports

---- ------------------------------- --------- -----------------------------

1    default                         active    Fa0/1, Fa0/2, Fa0/4, Fa0/5

                                              Fa0/6, Fa0/7, Fa0/8, Fa0/9

                                              Fa0/10, Fa0/11, Fa0/12, Fa0/13

                                              Fa0/14, Fa0/15, Fa0/16, Fa0/17

                                              Fa0/18, Fa0/19, Fa0/20, Fa0/21

                                              Fa0/22, Fa0/23, Fa0/24, Gi0/1

                                              Gi0/2

10   faculty/staff                   active

20   students                        active

30   guest                           active

99   management                      active 

Крок 3: Налаштування VLAN на комутаторах S2 і S3.

Створіть і назвіть мережі VLAN 10, 20, 30, і 99 на S2 і S3 використовуючи команди з Кроку 1. Перевірте правильність налаштування за допомогою команди show vlan brief.

Які порти зараз призначені для чотирьох щойно створених мереж VLAN? _______________________________

Крок 4: Призначення портів комутатора до VLAN мереж на S2 і S3.

Подивіться  до таблиці призначення портів на сторінці 1. Порти призначені до VLAN мереж в режимі налаштування конфігурації, використовуючи команду switchport access vlan vlan-id. Ви можете призначити кожний порт індивідуально або використовуючи команду interface range щоб спростити завдання, як показано нижче. Команди показані тільки для S3, але ви повинні налаштувати обидва S2 і S3 аналогічно. Після завершення збережіть конфігурацію.

S3(config)#interface range fa0/6-10

S3(config-if-range)#switchport access vlan 30

S3(config-if-range)#interface range fa0/11-17

S3(config-if-range)#switchport access vlan 10

S3(config-if-range)#interface range fa0/18-24

S3(config-if-range)#switchport access vlan 20

S3(config-if-range)#end

S3#copy running-config startup-config

Destination filename [startup-config]? [enter]

Building configuration...

[OK]

Крок 5: Визначення які порти були додані.

Використайте команду  show vlan id vlan-number на S2 щоб побачити які порти були призначені для VLAN 10.

Які порти були призначені для VLAN 10? _______________________________________________________

Примітка: show vlan name vlan-name відображає той самий результат.

Також ви можете переглянути інформацію назначення VLAN використовуючи команду show interfaces interface switchport.

Крок 6: Призначення керуючої VLAN.

Керуюча VLAN це будь-яка VLAN яку ви налаштуєте для доступу до управління комутатора. VLAN 1 служить, як керуюча VLAN, якщо ви спеціально не призначили іншу. Ви призначаєте керуючій VLAN IP адресу і маску підмережі. Комутатором можна керувати через HTTP, Telnet, SSH, або SNMP. Оскільки в out-of-the-box налаштуванні Cisco комутатора VLAN 1 є VLAN по замовчуванні,то  VLAN 1 поганий вибір для керуючої VLAN. Небажано щоб випадковий користувач підключався до комутатора по замовчуванню для управління VLAN. Нагадуємо, що ви налаштували VLAN 99  керуючою раніше у цій роботі.

У режимі налаштування інтерфейсу, використайте команду ip address щоб призначити керуючі IP адреси для комутаторів.

S1(config)#interface vlan 99

S1(config-if)#ip address 172.17.99.11 255.255.255.0

S1(config-if)#no shutdown

S2(config)#interface vlan 99

S2(config-if)#ip address 172.17.99.12 255.255.255.0

S2(config-if)#no shutdown

S3(config)#interface vlan 99

S3(config-if)#ip address 172.17.99.13 255.255.255.0

S3(config-if)#no shutdown

Призначення керуючих адрес дозволяє IP зв’язок між комутаторами, і також дозволяє будь-якому хосту підключеному до порту, який призначений для VLAN 99, з’єднатись з комутатором. Оскільки VLAN 99 налаштована як керуюча VLAN, усі порти призначеній цій VLAN визначаються як керуючі порти і необхідно забезпечити контроль пристроїв, які можуть бути підключені до цих портів.

Крок 7: Налаштування транкінгу і первинної VLAN для портів транкінгу на усіх комутаторах.

Транки це з'єднання між комутаторами, що дозволяє комутаторам обмінюватись інформацією для усіх VLAN. По замовчуванню, транк порт належить усім VLAN, як протилежний до порту доступу, який може належати тільки одній VLAN. Якщо коммутатор підтримує ISL і 802.1Q VLAN інкапсуляцію, транкам необхідно вказати який метод використовувати. Оскільки, комутатор 2960 підтримує тільки 802.1Q транкінг, то це не входить у нашу лабораторну роботу.

Первинна VLAN призначена для 802.1Q транк порту. У топології, первинною VLAN є VLAN 99. 802.1Q транк порт підтримує трафік що приходить із багатьох VLAN (мічений трафік) так само добре, як і трафік який надходить не із VLAN (немічений трафік).  802.1Q транк порт поміщає немічений трафік у первинну VLAN. Немічений трафік генерується комп’ютером, який підключений до порту комутатора, який налаштований для первинної VLAN. Однією із IEEE 802.1Q специфікацій для первинних VLAN є забезпечення зворотної сумісності  неміченого трафіку нероздільного із спадковими LAN сценаріями. Для цілей цієї лабораторної роботи, первинна VLAN служить як загальний ідентифікатор на протилежних кінцях транк з’єднання. Небажано використовувати VLAN1 як первинну VLAN.

Використайте команду interface range в глобальному режимі конфігурації для спрощення конфігурації транкінгу.

S1(config)#interface range fa0/1-5

S1(config-if-range)#switchport mode trunk

S1(config-if-range)#switchport trunk native vlan 99

S1(config-if-range)#no shutdown

S1(config-if-range)#end

S2(config)# interface range fa0/1-5

S2(config-if-range)#switchport mode trunk     

S2(config-if-range)#switchport trunk native vlan 99

S2(config-if-range)#no shutdown

S2(config-if-range)#end

S3(config)# interface range fa0/1-5

S3(config-if-range)#switchport mode trunk    

S3(config-if-range)#switchport trunk native vlan 99

S3(config-if-range)#no shutdown

S3(config-if-range)#end

Переконайтесь, що транки були налаштовані за допомогою команди show interface trunk.

S1#show interface trunk

Port        Mode         Encapsulation  Status        Native vlan

Fa0/1       on           802.1q         trunking      99

Fa0/2       on           802.1q         trunking      99

Port      Vlans allowed on trunk

Fa0/1       1-4094

Fa0/2       1-4094

Port        Vlans allowed and active in management domain

Fa0/1       1,10,20,30,99

Fa0/2       1,10,20,30,99

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/1       1,10,20,30,99

Fa0/2       1,10,20,30,99

Крок 8: Перевірка наявності зв’язку між комутаторами.

З S1, пропінгуйте керуючу адресу на S2 і S3.

S1#ping 172.17.99.12

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.17.99.12, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

S1#ping 172.17.99.13

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.17.99.13, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

Крок 9: Пінг декількох хостів з PC2.

Пропінгуйте з хоста PC2 хост PC1 (172.17.10.21). Чи є пінг запит успішним? _________

Пропінгуйте з хоста PC2 комутатор VLAN 99 IP адресу 172.17.99.12. Чи є пінг запит успішним? _________

Оскільки ці хости належать до різних підмереж і різних VLAN, вони не можуть з’єднуватись без пристрою 3 рівня для маршрутизації між окремими під мережами.

Пропінгуйте з хоста PC2 хост PC5. Чи є пінг запит успішним? _________

Оскільки PC2 є у одній VLAN і одній під мережі із PC5, то пінг запит є успішним.

Крок 10: Переміщення PC1 в одну VLAN із PC2.

Порт до якого підключений PC2 (S2 Fa0/18) назначений для VLAN 20, і порт до якого підключений  PC1 (S2 Fa0/11)  назначений для VLAN 10. ПереназначтеS2 Fa0/11 порт для VLAN 20. Нема необхідності видаляти порт із VLAN, щоб змінити його приналежність до VLAN. Після того як ви пере назначите порт новій VLAN, цей порт автоматично видалиться із старої VLAN.

S2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

S2(config)#interface fastethernet 0/11

S2(config-if)#switchport access vlan 20

S2(config-if)#end

Пропінгуйте з хоста PC2 хост PC1. Чи є пінг запит успішним? _________

Навіть тоді, коли порти до яких підключені PC1 і PC2 належать до однієїї VLAN, вони все ще належать до різних підмереж, тому вони не можуть з’єднуватись напряму.

Крок 11: Зміна IP адреси і мережі на PC1.

Змініть IP адрес для PC1 на 172.17.20.21. Маска підмережі і шлюз по замовчуванню можна не змінювати. Знову  пропінгуйте з хоста PC2 хост PC1, використовуючи щойно змінений IP адрес.

Чи є пінг запит успішним? _________

Чому саме цей запит успішний? ____________________________________________________________________________________

Завдання 5: Документація налаштувань комутатора

На кожному комутаторі, скопіюйте робочу конфігурацію у текстовий файл і збережіть файл для використання у майбутньому.

Завдання 6: Завершення роботи

Видаліть конфігурації і перезавантажте комутатори. Відключіть і складіть кабелі. Для PC хостів що зазвичай використовуються для інших мереж (наприклад LAN університету чи інтернет), підключіть відповідні кабелі і відновіть налаштування TCP/IP .

All contents are Copyright © 1992–2007 Cisco Systems, Inc. All rights reserved. This document is Cisco Public Information. Page 1 of 7


 

А также другие работы, которые могут Вас заинтересовать

51177. АСУ ТП технологического процесса «АСУ ТП технологического процесса теплообмена 78.31 KB
  Датчик давления Метран 55 предназначен для измерения давления жидкости в том числе агрессивных сред пара газа. Выпускают: а датчик для измерения избыточного давления – Метран 55 ДИ Метран55ЕхДИ – взрывозащищенное исполнение. Верхний предел измерений:01 МПа ÷ 100 МПа; б датчик для измерения давления разрежения – Метран 55 ДВ Метран55ЕхДВ – взрывозащищенное исполнение. Пределы измерений: 37 01 МПа ÷ 006 МПа; в датчик для измерения абсолютного давления – Метран55ДА...
51180. Изучение последовательного порта UART 33.85 KB
  Цели работы Изучить схему подключения микроконтроллера к компьютеру. Изучить особенности работы последовательного асинхронного порта UART. Освоить методику расчета скорости последовательного порта. Изучить особенности программирования UART. Изучить способы отладки программ на учебном лабораторном стенде LESO1.
51182. Банкет за столом с частичным обслуживанием с официантами на 30 персон по случаю Дня Рождения 512.5 KB
  Ресторан - предприятие общественного питания с широким ассортиментом блюд сложного приготовления, включая заказные и фирменные, вино-водочные, табачные и кондитерские изделия, с повышенным уровнем обслуживания в сочетании с организацией досуга.
51183. Изучение таймеров микроконтроллера 39.03 KB
  Цели работы Изучить особенности работы таймеров микроконтроллера. Изучить методику конфигурирования таймеров. Научиться формировать с помощью таймера временные интервалы. Изучить способы отладки программ на учебном лабораторном стенде LESO1.