6818

Базова VTP конфігурація

Лабораторная работа

Информатика, кибернетика и программирование

Базова VTP конфігурація Мета роботи Після виконання цієї лабораторної роботи ви зможете: Створити мережу відповідно до діаграми топології Видалити стартову конфігурацію і перезавантажити комутатор у режим по замовчуванню Налаштуват...

Украинкский

2014-12-28

200 KB

2 чел.

Базова VTP конфігурація

Мета роботи

Після виконання цієї лабораторної роботи ви зможете:

  •  Створити мережу відповідно до діаграми топології
  •  Видалити стартову конфігурацію і перезавантажити комутатор у режим по замовчуванню
  •  Налаштувати комутатори
  •  Налаштувати VLAN Транкінг Протокол (VTP) на усіх комутаторах
  •  Дозволити транкінг для з’єднань між комутаторами
  •  Перевірити конфігурацію транків
  •  Відредагувати VTP режими і переглянути вплив
  •  Створити VLAN мережі на VTP сервері, і поширити VLAN інформацію  між комутаторами у мережі
  •  Пояснити відмінності в роботі між VTP прозорим, серверним, і користувацьким режимом
  •  Призначити порти комутаторів для VLAN
  •  Зберегти VLAN конфігурацію
  •  Дозволити VTP обрізання у мережі
  •  Пояснити як обрізання зменшує неважливий трафік у LAN

Діаграма топології  

Таблиця адрес

Пристрій

(Ім’я хоста)

Інтерфейс

IP Адрес

Маска підмережі

Шлюз по замовчуванню

S1

VLAN 99

172.17.99.11

255.255.255.0

N/A

S2

VLAN 99

172.17.99.12

255.255.255.0

N/A

S3

VLAN 99

172.17.99.13

255.255.255.0

N/A

PC1

NIC

172.17.10.21

255.255.255.0

172.17.10.1

PC2

NIC

172.17.20.22

255.255.255.0

172.17.20.1

PC3

NIC

172.17.30.23

255.255.255.0

172.17.30.1

PC4

NIC

172.17.10.24

255.255.255.0

172.17.10.1

PC5

NIC

172.17.20.25

255.255.255.0

172.17.20.1

PC6

NIC

172.17.30.26

255.255.255.0

172.17.30.1

Призначення портів (Комутатори 2 і 3)

Порти

Призначення

Мережа

Fa0/1 – 0/5

802.1q Trunks (Native VLAN 99)

172.17.99.0 /24

Fa0/6 – 0/10

VLAN 30 – Guest (Default)

172.17.30.0 /24

Fa0/11 – 0/17

VLAN 10 – Faculty/Staff

172.17.10.0 /24

Fa0/18 – 0/24

VLAN 20 – Students

172.17.20.0 /24

Завдання 1: Підготовка мережі

Крок 1: Створення мережі відповідно до діаграми топології.

У цій лабораторній роботі можна використовувати будь-який комутатор, якщо у нього є необхідні інтерфейси зазначені у топології. Вихідні дані у цій лабораторній дані отримані для комутаторів 2960. Для інших типів комутаторів вихідні дані можуть відрізнятись.  Якщо ви використовуєте старіші комутатори, то деякі команди можуть відрізнятись, або бути недоступними.

Зауважте, у таблиці адрес  для PC налаштований шлюз по замовчуванню. Це повинен бути IP адрес локального маршрутизатора, який не входить у завдання цієї лабораторної роботи. Шлюз по замовчуванню і маршрутизатор будуть потрібні для з’єднання PC у різних VLAN. Про це піде мова у наступних розділах.

Встановіть консольне з’єднання для усіх трьох комутаторів.

Крок 2: Видалення будь-якої існуючої конфігурації на комутаторах.

Якщо необхідно, перейдіть до лабораторної роботи 2.5.1, додаток 1, щоб отримати інструкції по видаленню конфігурацій комутаторів і VLAN. Використайте команду show vlan щоб пересвідчитись, що існує тільки стандартна VLAN і усі порти призначені для VLAN 1.

Switch#show vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -----------------------------

1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4

                                               Fa0/5, Fa0/6, Fa0/7, Fa0/8

                                               Fa0/9, Fa0/10, Fa0/11, Fa0/12

                                               Fa0/13, Fa0/14, Fa0/15,Fa0/16

                                               Fa0/17, Fa0/18, Fa0/19,Fa0/20

                                               Fa0/21, Fa0/22, Fa0/23,Fa0/24

                                               Gig1/1, Gig1/2

1002 fddi-default                     active    

1003 token-ring-default               active    

1004 fddinet-default                  active    

1005 trnet-default                    active    

Крок 3: Відключення усіх портів за допомогою команди  shutdown.

Повторіть ці команди для кожного комутатора у топології.

Switch(config)#interface range fa0/1-24

Switch(config-if-range)#shutdown

Switch(config-if-range)#interface range gi0/1-2

Switch(config-if-range)#shutdown

Завдання 2: Налаштування базової конфігурації комутаторів

Крок 1: Налаштуйте базову конфігурацію для S1, S2, і S3.

Налаштуйте S1, S2, і S3 комутатори керуючись нижчевикладеними принципами і збережіть ваші налаштування:

  •  Налаштуйте ім’я хоста для комутатора як зазначено в топології.
  •  Відключіть пошук DNS.
  •  Для  EXEC режиму встановіть пароль class.
  •  Для консольних з'єднань встановіть пароль cisco.
  •  Для віртуальних інтерфейсів встановіть пароль cisco.

 (Вихідні дані для S1)

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#hostname S1

S1(config)#enable secret class

S1(config)#no ip domain-lookup 

S1(config)#line console 0

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#line vty 0 15

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#end

%SYS-5-CONFIG_I: Configured from console by console

S1#copy running-config startup-config 

Destination filename [startup-config]?

Building configuration...

[OK]

Крок 2: Повторне включення користувацьких портів на S2 і S3.

Налаштуйте користувацькі порти у режим доступу. Перевірте діаграму топології, щоб дізнатись які порти з’єднані з кінцевим обладнанням користувачів.

S2(config)#interface fa0/6

S2(config-if)#switchport mode access

S2(config-if)#no shutdown

S2(config-if)#interface fa0/11

S2(config-if)#switchport mode access

S2(config-if)#no shutdown

S2(config-if)#interface fa0/18

S2(config-if)#switchport mode access

S2(config-if)#no shutdown

S3(config)#interface fa0/6

S3(config-if)#switchport mode access

S3(config-if)#no shutdown

S3(config-if)#interface fa0/11

S3(config-if)#switchport mode access

S3(config-if)#no shutdown

S3(config-if)#interface fa0/18

S3(config-if)#switchport mode access

S3(config-if)#no shutdown

Крок 3: Повторне включення транк портів на S1, S2 і S3

S1(config)#interface fa0/1                                                                                                           S1(config-if)#no shutdown                                                                                     S1(config)#interface fa0/2                                                                                                      S1(config-if)#no shutdown

S2(config)#interface fa0/1                                                                                                          S2(config-if)#no shutdown   

S3(config)#interface fa0/2                                                                                                          S3(config-if)#no shutdown                                                                                                                                                                                                                                                             

Завдання 3: Налаштування Ethernet інтерфейсів на PC

Налаштуйте Ethernet інтерфейси PC1, PC2, PC3, PC4, PC5, і PC6 за допомогою IP адрес і шлюзів по замовчуванню, які зазначені у таблиці адрес на початку цієї лабораторної.

Переконайтесь, що  PC1 пінгує PC4, PC2 пінгує PC5, і PC3 пінгує PC6.

Завдання 4: Налаштування VTP на комутаторах

VTP дозволяє мережевому адміністратору контролювати узгодженість між різними VLAN у мережі шляхом створення VTP доменів. У кожному VTP домені, один або більше комутаторів налаштовані як VTP сервери. VLAN створюються на VTP сервері і інформація про них розсилається на інші комутатори  мережі у домені. Загальна VTP конфігурація полягає у налаштуванні робочого режиму, домені, і паролю. У цій лабораторній роботі ви будете використовувати S1 як VTP сервер, із S2 і S3 налаштованими як VTP клієнти або у VTP прозорому режимі.  

Крок 1: Перевірка існуючих налаштувань VTP на усіх трьох комутаторах.

S1#show vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 255

Number of existing VLANs        : 5

VTP Operating Mode              : Server

VTP Domain Name                 :

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Disabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD

Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Local updater ID is 0.0.0.0 (no valid interface found)

S2#show vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 255

Number of existing VLANs        : 5

VTP Operating Mode              : Server

VTP Domain Name                 :

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Disabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD

Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Local updater ID is 0.0.0.0 (no valid interface found)

S3#show vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 255

Number of existing VLANs        : 5

VTP Operating Mode              : Server

VTP Domain Name                 :

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Disabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD

Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Зауважте, що усі три комутатори знаходяться у серверному режимі. Серверний режим є стандартним режимом VTP для більшості комутаторів Catalyst.

Крок 2: Налаштування робочого режиму, імені домена, і VTP паролю на усіх комутаторах.

Назвіть домен VTP іменем Lab4 і вставновіть пароль  cisco на усіх трьох комутаторах. Встановіть на S1 серверний режим, S2 користувацький режим, і S3 прозорий режим.

S1(config)#vtp mode server

Device mode already VTP SERVER.

S1(config)#vtp domain Lab4

Changing VTP domain name from NULL to Lab4

S1(config)#vtp password cisco

Setting device VLAN database password to cisco

S1(config)#end 

S2(config)#vtp mode client

Setting device to VTP CLIENT mode

S2(config)#vtp domain Lab4

Changing VTP domain name from NULL to Lab4

S2(config)#vtp password cisco

Setting device VLAN database password to cisco

S2(config)#end 

S3(config)#vtp mode transparent

Setting device to VTP TRANSPARENT mode.

S3(config)#vtp domain Lab4

Changing VTP domain name from NULL to Lab4

S3(config)#vtp password cisco

Setting device VLAN database password to cisco

S3(config)#end 

Зауваження: Ім’я домену VTP може бути отримане користувацьким комутатором від серверного комутатора, але тільки тоді, коли домен користувацького комутатора не налаштований. Він не отримає імені, якщо вже було встановлене якесь ім’я. Саме тому, корисно вручну налаштовувати доменні імена на усіх комутаторах для забезпечення правильного налаштування доменного імені. Комутатори у різних VTP доменах не обмінюються VLAN інформацією.

Крок 3: Налаштування транкінгу і первинної VLAN для транк портів на усіх трьох комутаторах.

Використайте команду interface range у глобальному режимі конфігурації для того щоб спростити це завдання.

S1(config)#interface range fa0/1-5

S1(config-if-range)#switchport mode trunk

S1(config-if-range)#switchport trunk native vlan 99

S1(config-if-range)#no shutdown

S1(config-if-range)#end

S2(config)# interface range fa0/1-5

S2(config-if-range)#switchport mode trunk     

S2(config-if-range)#switchport trunk native vlan 99

S2(config-if-range)#no shutdown

S2(config-if-range)#end

S3(config)# interface range fa0/1-5

S3(config-if-range)#switchport mode trunk     

S3(config-if-range)#switchport trunk native vlan 99

S3(config-if-range)#no shutdown

S3(config-if-range)#end

Крок 4: Налаштування безпеки портів на S2 і S3 рівня доступу комутаторів.

Налаштуйте порти fa0/6, fa0/11, і fa0/18 так, щоб вони  працювали тільки з певним хостом і отримували MAC адрес хоста динамічно.  

S2(config)#interface fa0/6

S2(config-if)#switchport port-security 

S2(config-if)#switchport port-security maximum 1

S2(config-if)#switchport port-security mac-address sticky 

S2(config-if)#interface fa0/11

S2(config-if)#switchport port-security 

S2(config-if)#switchport port-security maximum 1

S2(config-if)#switchport port-security mac-address sticky 

S2(config-if)#interface fa0/18 

S2(config-if)#switchport port-security 

S2(config-if)#switchport port-security maximum 1

S2(config-if)#switchport port-security mac-address sticky 

S2(config-if)#end

S3(config)#interface fa0/6

S3(config-if)#switchport port-security 

S3(config-if)#switchport port-security maximum 1

S3(config-if)#switchport port-security mac-address sticky 

S3(config-if)#interface fa0/11

S3(config-if)#switchport port-security 

S3(config-if)#switchport port-security maximum 1

S3(config-if)#switchport port-security mac-address sticky 

S3(config-if)#interface fa0/18 

S3(config-if)#switchport port-security 

S3(config-if)#switchport port-security maximum 1

S3(config-if)#switchport port-security mac-address sticky 

S3(config-if)#end

Крок 5: Налаштування VLAN на VTP сервері.

Для цієї лабораторної роботи необхідні додаткові 4 VLAN:

  •  VLAN 99 (управління)
  •  VLAN 10 (викладач/персонал)
  •  VLAN 20 (студент)
  •  VLAN 30 (гість)

Налаштуйте їх на VTP сервері.

S1(config)#vlan 99

S1(config-vlan)#name management

S1(config-vlan)#exit

S1(config)#vlan 10

S1(config-vlan)#name faculty/staff

S1(config-vlan)#exit

S1(config)#vlan 20 

S1(config-vlan)#name students

S1(config-vlan)#exit

S1(config)#vlan 30

S1(config-vlan)#name guest

S1(config-vlan)#exit

Перевірте чи  усі VLAN були створені на S1 використовуючи команду show vlan brief .

Крок 6: Перевірка чи створені VLAN на S1 буле передані до S2 і S3.

Використайте команду show vlan brief   на S2 і S3 щоб пересвідчитись чи VTP сервер передав свої VLAN конфігурації на усі комутатори.

S2#show vlan brief

VLAN Name                             Status    Ports

---- -------------------------------- --------- -----------------------------

1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5

                                               Fa0/6, Fa0/7, Fa0/8, Fa0/9

                                               Fa0/10, Fa0/11, Fa0/12,Fa0/13

                                               Fa0/14, Fa0/15, Fa0/16,Fa0/17

                                               Fa0/18, Fa0/19, Fa0/20,Fa0/21

                                               Fa0/22, Fa0/23, Fa0/24, Gi0/1

                                               Gi0/2

10   faculty/staff                    active

20   students                         active

30   guest                            active

99   management                       active 

S3#show vlan brief

VLAN Name                             Status    Ports

---- -------------------------------- --------- -----------------------------

1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5

                                               Fa0/6, Fa0/7, Fa0/8, Fa0/9

                                               Fa0/10, Fa0/11, Fa0/12,Fa0/13

                                               Fa0/14, Fa0/15, Fa0/16,Fa0/17

                                               Fa0/18, Fa0/19, Fa0/20,Fa0/21

                                               Fa0/22, Fa0/23, Fa0/24, Gi0/1

                                               Gi0/2

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

VLAN налаштовані на всіх комутаторах однаково? ________________________

Поясніть чому S2 і S3 мають відмінні VLAN налаштування. __________________________

____________________________________________________________________________________

____________________________________________________________________________________

Крок 7: Створіть нову VLAN на комутаторах  2 і 3.

S2(config)#vlan 88

%VTP VLAN configuration not allowed when device is in CLIENT mode.

S3(config)#vlan 88

S3(config-vlan)#name test

S3(config-vlan)#

Чому ви не змогли створити нову VLAN на S2, а на  S3 змогли? ____________________________

____________________________________________________________________________________

Видаліть VLAN 88 з S3.

S3(config)#no vlan 88

Крок 8: Ручне налаштування VLAN.

Налаштуйте чотири VLAN вказані у Кроці  5 на комутаторі S3.

S3(config)#vlan 99

S3(config-vlan)#name management

S3(config-vlan)#exit

S3(config)#vlan 10

S3(config-vlan)#name faculty/staff

S3(config-vlan)#exit

S3(config)#vlan 20 

S3(config-vlan)#name students

S3(config-vlan)#exit

S3(config)#vlan 30

S3(config-vlan)#name guest

S3(config-vlan)#exit

Тепер ви розумієте переваги VTP. Ручне налаштування втомливе і є можливість помилитись. І кожна помилка може зашкодити зв’язку всередині VLAN. Також, такі помилки можуть ускладнювати усунення неполадок.

Крок 9: налаштування адрес керуючого інтерфейсу на усіх трьох комутаторах.

S1(config)#interface vlan 99

S1(config-if)#ip address 172.17.99.11 255.255.255.0

S1(config-if)#no shutdown

S2(config)#interface vlan 99

S2(config-if)#ip address 172.17.99.12 255.255.255.0

S2(config-if)#no shutdown

S3(config)#interface vlan 99

S3(config-if)#ip address 172.17.99.13 255.255.255.0

S3(config-if)#no shutdown

Переконайтесь, що усі комутатори налаштовані правильною за допомогою команди ping. З S1, пропінгуйте керуючий інтерфейс на S2 і S3. З S2, пропінгуйте керуючий інтерфейс на S3.

Чи пінг запити виявились успішними? ___________________________________________

Якщо ні, то перевірте налаштування комутаторів і спробуйте знову.

Крок 10: Assign switch ports to VLANs.

Відповідно до таблиці призначення портів на початку цієї лабораторної роботи, призначте порти для VLAN. Використайте команду interface range Щоб спростити це завдання. Порти не призначаються за допомогою VTP. Призначення портів потрібно налаштовувати на кожному комутаторі вручну, або динамічно використовуючи VMPS сервер. Команди вказані тільки для S3, але S2 і S1 комутатори треба налаштувати аналогічно. По завершенню збережіть налаштування.

S3(config)#interface range fa0/6-10

S3(config-if-range)#switchport access vlan 30

S3(config-if-range)#interface range fa0/11-17

S3(config-if-range)#switchport access vlan 10

S3(config-if-range)#interface range fa0/18-24

S3(config-if-range)#switchport access vlan 20

S3(config-if-range)#end

S3#copy running-config startup-config

Destination filename [startup-config]? [enter]

Building configuration...

[OK]

S3#

Завдання 5: Налаштування VTP обрізання на комутаторах

VTP обрізання дозволяє VTP серверу заглушити IP широкомовний трафік для конкретної VLAN для комутаторів які не мають жодних портів цієї VLAN. По замовчуванню, усі невідомі одноадресні і широкомовні передачі у VLAN заливають повністю VLAN. Усі комутатори у мережі отримують усі широкомовні розсилання, навіть коли всього декілька користувачів підключені до цієї VLAN. VTP спрощення використовується для знищення або заглушення цього непотрібного трафіку. Обрізання зберігає пропускну здатність LAN  оскільки широкомовні передачі не посилаються комутаторам, які їх не потребують.

Обрізання налаштовується на серверному комутаторі за допомогою команди vtp pruning в глобальному режимі конфігурації. Це налаштування передається до клієнтських комутаторів.

Перевірте налаштування VTP обрізання на кожному комутаторі використовуючи команду show vtp status . VTP обрізання повинне бути включене на кожному комутаторі.

S1#show vtp status

VTP Version                     : 2

Configuration Revision          : 17

Maximum VLANs supported locally : 255

Number of existing VLANs        : 9

VTP Operating Mode              : Server

VTP Domain Name                 : Lab4

VTP Pruning Mode                : Enabled

<output omitted>

Task 6: Завершення роботи

Видаліть конфігурації і перезавантажте комутатори. Відключіть і складіть кабелі. Для PC хостів що зазвичай використовуються для інших мереж (наприклад LAN університету чи інтернет), підключіть відповідні кабелі і відновіть налаштування TCP/IP .


 

А также другие работы, которые могут Вас заинтересовать

7843. Технология возрождения традиционного народного творчества в современных условиях 19.67 KB
  Технология возрождения традиционного народного творчества в современных условиях Интерес к возрождению национальных культур - яркая примета нашего времени. Начиная с 1989 года, по всей стране идет активный процесс создания различных общественны...
7844. Технология проведения выставок народного художественного творчества 22.35 KB
  Технология проведения выставок народного художественного творчества Выставки также занимают особое место в арсенале средств социально-культурной деятельности, так как они представляют широкие возможности демонстрации результатов народного художестве...
7845. Законодательные основы организации и руководства НХТ в Российской Федерации 17.52 KB
  Законодательные основы организации и руководства НХТ в Российской Федерации В современной России в течение последних десяти лет (с 1991 г.) принят, по сути дела, целый свод законов, охватывающих основные направления СКД и создающих правовые основы д...
7846. Кадровое обеспечение коллективов народного художественного творчества 17.83 KB
  Кадровое обеспечение коллективов народного художественного творчества Социально-культурная сфера в целом обеспечена высококвалифицированными специалистами. На протяжении десятилетий ведется подготовка педагогических и культурно-досуговых кадров. В т...
7847. Материально-техническое обеспечение коллективов народного художественного творчества 18.3 KB
  Материально-техническое обеспечение коллективов народного художественного творчества Наличие хорошей материально-технической базы является одним из важнейших условий успешной социокультурной деятельности. К сожалению, материально-техническую базу бо...
7848. Планирование и учет работы коллектива народного художественного творчества 18.87 KB
  Планирование и учет работы коллектива народного художественного творчества Планирование- это обоснованная разработка приемов и результатов деятельности на определенный период. Планы, разрабатываемые и используемые в сфере культуры, различаются...
7849. Руководство народным художественным творчеством в культурно–досуговых учреждениях 20.19 KB
  Руководство народным художественным творчеством в культурно–досуговых учреждениях Административное руководство НХТ в культурно-досуговых учреждениях (клубе, сельском Доме культуры, районном Доме культуры, досуговом центре и др.) осуществляется ...
7850. Технология создания коллектива народного художественного творчества 20.19 KB
  Технология создания коллектива народного художественного творчества Технология создания коллектива народного художественного творчества состоит из нескольких блоков. 1 блок. Выявление интересов и потребностей потенциальных участников в определенном ...
7851. Специфика организационного процесса в социокультурной сфере 20.09 KB
  Специфика организационного процесса в социокультурной сфере Организационный фактор занимает важное место в социокультурной деятельности (СКД). С одной стороны, организация - это часть социокультурного менеджмента, с другой - вполне самостоятельная с...