6823

Базовий Spanning Tree Protocol

Лабораторная работа

Информатика, кибернетика и программирование

Базовий Spanning Tree Protocol Мета роботи Після виконання цієї лабораторної роботи ви зможете: Створити мережу відповідно до діаграми топології Видалити стартову конфігурацію і перезавантажити комутатор у режим по замовчуванню...

Украинкский

2014-12-28

266 KB

3 чел.

Базовий Spanning Tree Protocol

Мета роботи

Після виконання цієї лабораторної роботи ви зможете:

  •  Створити мережу відповідно до діаграми топології
  •  Видалити стартову конфігурацію і перезавантажити комутатор у режим по замовчуванню 
  •  Налаштувати комутатори
  •  Переглянути і пояснити стандартну поведінку Spanning Tree Protocol (STP, 802.1D)
  •  Переглянути результат змін топології Spanning Tree 

Діаграма топології

Таблиця адрес

Пристрій

(ім’я хоста)

Інтерфейс

IP адреса

Маска підмережі

Шлюз по замовчуванню

S1

VLAN 1

172.17.10.1

255.255.255.0

N/A

S2

VLAN 1

172.17.10.2

255.255.255.0

N/A

S3

VLAN 1

172.17.10.3

255.255.255.0

N/A

PC1

NIC

172.17.10.21

255.255.255.0

172.17.10.254

PC2

NIC

172.17.10.22

255.255.255.0

172.17.10.254

PC3

NIC

172.17.10.23

255.255.255.0

172.17.10.254

PC4

NIC

172.17.10.27

255.255.255.0

172.17.10.254

Завдання 1: Базове налаштування комутаторів

Крок 1: Створення мережі відповідно до діаграми топології.

У цій лабораторній роботі можна використовувати будь-який комутатор, якщо у нього є необхідні інтерфейси зазначені у топології. Вихідні дані у цій лабораторній дані отримані для комутаторів 2960. Для інших типів комутаторів вихідні дані можуть відрізнятись. 

Встановіть консольні з’єднання до усіх трьох комутаторів.

Крок 2: Видалення будь-якої існуючої конфігурації на комутаторах.

Очистіть NVRAM, видаліть файл vlan.dat, і перезавантажте комутатори.  Якщо необхідно, перейдіть до лабораторної роботи 2.5.1, додаток 1, щоб отримати інструкції по видаленню конфігурацій комутаторів і VLAN.. Після завершення перезавантаження, використайте привілейовану EXEC команду show vlan щоб пересвідчитись, що існує тільки VLAN по замовчуванню і усі порти призначені VLAN 1.

S1#show vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -----------------------------

1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4

                                               Fa0/5, Fa0/6, Fa0/7, Fa0/8

                                               Fa0/9, Fa0/10, Fa0/11, Fa0/12

                                               Fa0/13, Fa0/14, Fa0/15,Fa0/16

                                               Fa0/17, Fa0/18, Fa0/19,Fa0/20

                                               Fa0/21, Fa0/22, Fa0/23,Fa0/24

                                               Gig0/1, Gig0/2

1002 fddi-default                     active    

1003 token-ring-default               active    

1004 fddinet-default                  active    

1005 trnet-default                    active    

Крок 3: Налаштування базових параметрів комутаторів.

Налаштуйте S1, S2, і S3 комутатори дотримуючись наступних порад:

  •  Налаштуйте ім’я комутатора.
  •  Відключіть пошук DNS.
  •  Для EXEC режиму встановіть пароль class.
  •  Для консольних з'єднань встановіть пароль cisco.
  •  Для віртуальних інтерфейсів встановіть пароль cisco.

 (Вихідні дані для S1)

Switch>enable

Switch#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#hostname S1

S1(config)#enable secret class

S1(config)#no ip domain-lookup 

S1(config)#line console 0

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#line vty 0 15

S1(config-line)#password cisco

S1(config-line)#login

S1(config-line)#end

%SYS-5-CONFIG_I: Configured from console by console

S1#copy running-config startup-config 

Destination filename [startup-config]?

Building configuration...

[OK]

Завдання 2: Підготовка мережі 

Крок 1: Відключення усіх портів за допомогою команди shutdown.

Переконайтесь, що порти комутатора є неактивними за допомогою команди  shutdown. Використайте команду interface-range щоб спростити це завдання.

S1(config)#interface range fa0/1-24

S1(config-if-range)#shutdown

S1(config-if-range)#interface range gi0/1-2

S1(config-if-range)#shutdown

S2(config)#interface range fa0/1-24

S2(config-if-range)#shutdown

S2(config-if-range)#interface range gi0/1-2

S2(config-if-range)#shutdown

S3(config)#interface range fa0/1-24

S3(config-if-range)#shutdown

S3(config-if-range)#interface range gi0/1-2

S3(config-if-range)#shutdown

Крок 2: Повторне включення користувацьких портів на S2 і S3 в режимі доступу.

Перегляньте діаграму топології, щоб дізнатись які порти S2 призначені для доступу користувацького обладнання. Ці три порти мають бути встановлені в режим доступу і включені за допомогою команди no shutdown.

S1(config)#interface fa0/3

S1(config-if)#switchport mode access

S1(config-if)#no shutdown

S2(config)#interface range fa0/6, fa0/11, fa0/18

S2(config-if-range)#switchport mode access

S2(config-if-range)#no shutdown

Крок 3: включення транк портів на S1, S2 і S3.

У цій лабораторній роботі використовується тільки одна VLAN, але транкінг ми налаштовуємо на усіх комутаторах, щоб мати можливість додавати інші VLAN у майбутньому.

S1(config-if-range)#interface range fa0/1, fa0/2 

S1(config-if-range)#switchport mode trunk        

S1(config-if-range)#no shutdown

S2(config-if-range)#interface range fa0/1, fa0/2 

S2(config-if-range)#switchport mode trunk        

S2(config-if-range)#no shutdown

S3(config-if-range)#interface range fa0/1, fa0/2 

S3(config-if-range)#switchport mode trunk        

S3(config-if-range)#no shutdown

Крок 4: Налаштування адреси керуючого інтерфейсу на усіх трьох комутаторах.

S1(config)#interface vlan1

S1(config-if)#ip address 172.17.10.1 255.255.255.0

S1(config-if)#no shutdown

S2(config)#interface vlan1

S2(config-if)#ip address 172.17.10.2 255.255.255.0

S2(config-if)#no shutdown

S3(config)#interface vlan1

S3(config-if)#ip address 172.17.10.3 255.255.255.0

S3(config-if)#no shutdown

Перевірте коректність налаштування комутаторів шляхом виконання ping -запиту між ними. З S1, здійсніть ping-запит керуючого інтерфейсу на S2 і S3. З S2, здійсніть ping-запит керуючого інтерфейсу на S3.

Чи були ping-запити успішними? ___________________________________________

Якщо ні, перевірте правильність налаштування комутаторів і спробуйте знову.

Завдання 3: Налаштування Ethernet інтерфейсів на PC

Налаштуйте Ethernet інтерфейси PC1, PC2, PC3, PC4, PC5, і PC6 за допомогою IP адрес і шлюзів по замовчуванню, які зазначені у таблиці адрес на початку цієї лабораторної.

Завдання 4: Налаштування Spanning Tree

Крок 1: Перевірте конфігурацію по замовчуванню 802.1D STP.

Використовуючи команду show spanning-tree перегляньте таблицю spanning tree на кожному комутаторі. Вибір кореня залежить від BID кожного комутатора у вашій лабораторній роботі в результаті різних вихідних даних.

S1#show spanning-tree

VLAN0001

 Spanning tree enabled protocol ieee

 Root ID    Priority    32769

            Address     0019.068d.6980

            This bridge is the root

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

 Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

            Address     0019.068d.6980

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1            Desg FWD 19        128.3    P2p

Fa0/2            Desg FWD 19        128.4    P2p

Fa0/3            Desg FWD 19        128.5    P2p

S2#show spanning-tree

VLAN0001

 Spanning tree enabled protocol ieee

 Root ID    Priority    32769

            Address     0019.068d.6980

            Cost        19

            Port        1 (FastEthernet0/1)

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

 Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

            Address     001b.0c68.2080

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1            Root FWD 19        128.1    P2p

Fa0/2            Desg FWD 19        128.2    P2p

Fa0/6            Desg FWD 19        128.6    P2p

Fa0/11           Desg FWD 19        128.11   P2p

Fa0/18           Desg FWD 19        128.18   P2p

S3#show spanning-tree

VLAN0001

 Spanning tree enabled protocol ieee

 Root ID    Priority    32769

            Address     0019.068d.6980

            Cost        19

            Port        1 (FastEthernet0/1)

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

 Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

            Address     001b.5303.1700

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1            Root FWD 19        128.1    P2p

Fa0/2            Altn BLK 19        128.2    P2p

              

Крок 2: Перевірка вихідних даних.

Мостовий ідентифікатор (bridge ID), зберігається у spanning tree BPDU складається з пріоритету моста, system ID extension, і MAC адреси. Комбінація пріоритету моста і system ID extension називають bridge ID priority. System ID extension завжди є номером VLAN.   Наприклад, system ID extension для VLAN 100 є 100. Використовуючи пріоритет мосту по замовчуванню 32768,  bridge ID priority для VLAN 100 буде 32868 (32768 + 100).

Команда show spanning-tree показує значення bridge ID priority. Зауваження: Значенняпріоритетув дужках представляє значення пріоритету мосту, за яким слідує значення system ID extension.

Дайте відповідь на наступні запитання.

  1.  Що таке bridge ID priority для комутаторів S1, S2, і S3 у VLAN 1?
    1.  S1 _______
    2.  S2 _______
    3.  S3 _______
  2.  Який комутатор є кореневим для VLAN 1 spanning tree?  ________________
  3.  Які порти spanning tree є в режимі блокування на кореневому комутаторі?   _________________
  4.  Чи мають заблоковані порти інші некореневі комутатори? _________Який комутатор і порт знаходяться в заблокованому режимі?    _________
  5.  Яким чином STP вибирає кореневий комутатор?  _________________________
  6.  Оскільки всі пріоритети мосту однакові, що ще комутатор використовує щоб визначити корінь ?  ________________________

Завдання 5: Перегляд результат змін топології 802.1D STP 

Давайте розглянемо що станеться, якщо ми навмисно імітуємо неполадку з’єднання.

Крок 1: Встановлення комутаторів в режим налагодження spanning tree використовуючи команду debug spanning-tree events.

S1#debug spanning-tree events

Spanning Tree event debugging is on

S2#debug spanning-tree events

Spanning Tree event debugging is on

S3#debug spanning-tree events

Spanning Tree event debugging is on

Крок 2:  Навмисне закриття порту на кореневому комутаторі. Приклад вказаний для  S1, оскільки він є кореневим. Ваш кореневий комутатор може відрізнятись.

S1(config)#interface fa0/1

S1(config-if)#shutdown

Крок 3:  Запис даних налагодження з некореневих комутаторів. У цьому зразку ми записуємо дані з S2 і S3, оскільки вони є некореневими.

S2#

1w2d: STP: VLAN0001 we are the spanning tree root

S2#

1w2d: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

1w2d: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down

S2#

1w2d: STP: VLAN0001 heard root 32769-0019.068d.6980 on Fa0/2

1w2d:     supersedes 32769-001b.0c68.2080

1w2d: STP: VLAN0001 new root is 32769, 0019.068d.6980 on port Fa0/2, cost 38

1w2d: STP: VLAN0001 sent Topology Change Notice on Fa0/2

S3#

1w2d: STP: VLAN0001 heard root 32769-001b.0c68.2080 on Fa0/2

1w2d: STP: VLAN0001 Fa0/2 -> listening

S3#

1w2d: STP: VLAN0001 Topology Change rcvd on Fa0/2

1w2d: STP: VLAN0001 sent Topology Change Notice on Fa0/1

S3#

1w2d: STP: VLAN0001 Fa0/2 -> learning

S3#

1w2d: STP: VLAN0001 sent Topology Change Notice on Fa0/1

1w2d: STP: VLAN0001 Fa0/2 -> forwarding

Базуючись на даних цього зразка, у випадку неполадки з’єднання між S2 і кореневим комутатором, що є первинним результатом для кореня spanning tree?______________________  

Як тільки S2 отримує нову інформацію про Fa0/2, який ми отримуємо результат?____________________

Порт Fa0/2 на S3 був заблокований  перед неполадкою зв’язку між S2 і S1 .  Через які стани він повинен пройти у наслідок зміни топології? __________________________________

Крок 4:  Перевірка змін топології spanning tree за допомогою команди show spanning-tree.

S2#show spanning-tree

VLAN0001

 Spanning tree enabled protocol ieee

 Root ID    Priority    32769

            Address     0019.068d.6980

            Cost        38

            Port        2 (FastEthernet0/2)

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

 Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

            Address     001b.0c68.2080

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/2            Root FWD 19        128.2    P2p

Fa0/6            Desg FWD 19        128.6    P2p

Fa0/11           Desg FWD 19        128.11   P2p

Fa0/18           Desg FWD 19        128.18   P2p

S3#show spanning-tree

VLAN0001

 Spanning tree enabled protocol ieee

 Root ID    Priority    32769

            Address     0019.068d.6980

            Cost        19

            Port        1 (FastEthernet0/1)

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

 Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

            Address     001b.5303.1700

            Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1            Root FWD 19        128.1    P2p

Fa0/2            Desg FWD 19        128.2    P2p

Дайте відповідь на запитання.

1.  Що змінилось у відправці даних комутатором S2? __________________________________

2.  Що змінилось у відправці даних комутатором S3?__________________________________

Завдання 6:  Запис конфігурації за допомогою команди show run , на кожному комутаторі.

S1#show run

!<output omitted>

!

hostname S1

!

!         

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport mode trunk

!

interface FastEthernet0/3

switchport mode access

!

! <output omitted>

!

interface Vlan1

ip address 172.17.10.1 255.255.255.0

!

end

S2#show run

!<output omitted>

!

hostname S2

!

!         

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport mode trunk

!

! <output omitted>

!

interface FastEthernet0/6

switchport mode access

!

interface FastEthernet0/11

switchport mode access

!

interface FastEthernet0/18

switchport mode access

!

!

interface Vlan1

ip address 172.17.10.2 255.255.255.0

!

end

S3#show run

!<output omitted>

!

hostname S3

!

!         

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport mode trunk

!

!

! <output omitted>

!

interface Vlan1

ip address 172.17.10.3 255.255.255.0

!

end

Завдання 7: Завершення роботи

Видаліть конфігурації і перезавантажте комутатори. Відключіть і складіть кабелі. Для PC хостів що зазвичай використовуються для інших мереж (наприклад  LAN університету чи інтернет), підключіть відповідні кабелі і відновіть налаштування TCP/IP .


 

А также другие работы, которые могут Вас заинтересовать

76906. Черепные нервы. I, II пары черепных нервов. Проводящий путь зрительного анализатора 181.6 KB
  Они составляют проводниковую часть обонятельного и зрительного анализаторов. Оба имеют общее происхождение, т.к. развиваются как производные переднего мозгового пузыря, его нижней стенки. Оба несут восходящие (чувствительные) нервные волокна, соединяющие рецепторные поля анализаторов с подкорковыми центрами обоняния и зрения и, таким образом, входят в сенсорную систему.
76907. Глазодвигательный, блоковый, отводящий нервы 181.24 KB
  Глазодвигательный блоковый и отводящий нервы связаны в одну группу по причинам: единого происхождения и развития обусловленного передними головными миотомами из которых возникают мышцы глазного яблока; схожим строением волокон которые имеют нисходящее направление и по функции являются двигательными; общностью иннервации глазных мышц. Корешки нерва выходят на основании головного мозга в межножковой ямке по медиальной поверхности ножек мозга где для них имеется борозда. Ресничный узел лежит на латеральной полуокружности влагалища...
76908. Тройничный нерв. V пара черепных нервов, ее ветви, топография и области иннервации 185.93 KB
  V пара тройничные нервы правый и левый смешанные: чувствительные двигательные вегетативные. Нервы развиваются вместе с производными первой висцеральной дуги челюстями и жевательными мышцами кожей лица слизистой полости носа и рта. Ствол тройничного нерва возникает при объединении чувствительного и двигательного корешков на выходе из мозга.
76909. Лицевой нерв, его топография, ветви и области иннервации 181.44 KB
  VII пара включает два нерва лицевой и промежуточный смешанные нервы двигательные парасимпатические и чувствительные. Промежуточный нерв нередко обозначают как XIII пару и тогда в VII паре остается только лицевой двигательный нерв. Нерв выходит из мозга в поперечной борозде между мостом и продолговатым мозгом латерально от оливы направляясь по задней черепной яме к внутреннему слуховому проходу куда вступает вместе с VIII парой.
76910. Преддверно-улитковый нерв. VIII пара черепных нервов и топография ее ядер. Проводящие пути органов слуха и равновесия 183.89 KB
  Преддверная и улитковая части VIII пары объединяются во внутреннем слуховом проходе и направляются через заднюю черепную яму к мозговому стволу к его поперечной борозде между мостом и продолговатым мозгом где латеральнее лицевого и промежуточного нервов входят во внутрь моста и заканчиваются синапсами на ядрах вестибулярного поля моста. Вестибулярное поле находится в латеральных углах ромбовидной ямки на него проецируются два улитковых и четыре вестибулярных ядра залегающих в вентролатеральных отделах моста. Улитковые ядра: переднее и...
76911. Языкоглоточный нерв. IX пара черепных нервов, их ядра, топография и области иннервации 180.17 KB
  IX пара языкоглоточные нервы смешанные развиваются из заднего мозгового пузыря. Корешки нерва 45 выходят позади оливы продолговатого мозга и сливаются в короткий ствол. Чувствительные узлы нерва: верхний в яремном отверстии нижний в области каменистой ямки височной кости содержат псевдоуниполярные нейроны центральные отростки которых формируют чувствительный корешок нерва.
76912. Блуждающий нерв, его ядра, их топография; ветви и области иннервации 181.14 KB
  Краниальная часть нерва отдает ветви: менингиальную веточку для твердой мозговой оболочки в задней черепной яме; ушную ветвь которая через сосцевидный каналец и барабаннососцевидную щель подходит к коже наружного слухового прохода и ушной раковине. Ветви шейной части: глоточные к глоточному сплетению и через него к слизистой мышцамконстрикторам глотки мышцам мягкого неба кроме напряжителя из тройничного нерва шейные верхние сердечные ветви к сердечным сплетениям гортанные верхние нервы к перстнещитовидной мышце наружная...
76913. Прибавочный и подъязычный нервы 181.56 KB
  Обе пары XI XII по выходе из черепа идут между внутренней яремной веной и внутренней сонной артерией и ложатся под заднее брюшко двубрюшной мышцы. Из черепа ствол нерва выходит через яремное отверстие вместе с IX X парами и внутренней яремной веной занимая при этом латеральное положение. Внутренняя веточка для соединения с блуждающим нервом; наружная ветвь для трапециевидной и грудиноключичнососцевидной мышц; Наружная ветвь проходит между внутренней яремной веной и внутренней сонной артерией а затем уходит под заднее брюшко...
76914. Вегетативная, автономная нервная система. Вегетативная часть нервной системы, ее деление и характеристика отделов 185.72 KB
  В надсегментарных вегетативных центрах которые располагаются в коре полушарий базальных ядрах мозжечке различают: центры чувствительные по восприятию внутренней рецепции; центры двигательные по координации гладкомышечных и сердечных сокращений в органах и сосудах. Подкорковые вегетативные центры Полосатое тело центры терморегуляции слюно и слезоотделения образования слизи. Ретикулярная формация ствола мозга зрачковый рефлекс центры дыхания сердечный сосудистый глотания и рвоты и другие регуляции обмена веществ и...