6830

Конфігурування бездротового маршрутизатора Linksys WRT54GL

Лабораторная работа

Коммуникация, связь, радиоэлектроника и цифровые приборы

Конфігурування бездротового маршрутизатора Linksys WRT54GL Мета: Навчитися налаштовувати бездротові маршрутизатори, на основі моделі Linksys WRT54GL, задавати ім'я бездротовій мережі SSID, налаштовування вбудованого сервера DHCP, конфігур...

Украинкский

2013-01-08

835 KB

7 чел.

Конфігурування бездротового маршрутизатора Linksys WRT54GL

Мета: Навчитися налаштовувати бездротові маршрутизатори, на основі моделі Linksys WRT54GL,  задавати ім’я бездротовій мережі SSID, налаштовування вбудованого сервера DHCP, конфігурування інтерфейсів WAN, LAN, Wireless, налаштування шифрування WEP.

Теоретичні відомості

У цьому завданні ви будете конфігурувати бездротовий маршрутизатор Linksys, дозволяючи віддаленим компютерам отримувати безпечний бездротовий доступ до мережі.

Пристрій Linksys WRT54GL сполучає в собі вбудований комутатор на 4 порти, маршрутизатор і точку бездротового доступу. У цій лабораторній роботі необхідно настроїти один з компонентів цього багатофункціонального пристрою, а саме точку бездротового доступу, щоб дозволити доступ бездротовим клієнтам. Будуть настроєні основні бездротові можливості багатофункціонального пристрою.

У маршрутизаторі Linksys WRT54GL є функції провідного й бездротового зв'язку, і він сам виступає як точка доступу в бездротовій мережі. Незалежно від того, чи використовується пристрій для підключення до провідних або бездротових вузлів, основні параметри конфігурації, такі як паролі, IP-адреси й настроювання DHCP, повинні бути однаковими. Основні операції настроювання, такі як зміна пароля, повинні виконуватися до того, як точка доступу підключена в робочу мережу.

При побудової бездротової мережі важливо, щоб бездротові компоненти були підключені до відповідної мережі WLAN. Для цього використовується ідентифікатор набору послуг (SSID).

SSID - це ім'я бездротової мережі, що являє собою рядок з букв і цифр, чутливий до регістра, має довжину до 32 символів. Цей ідентифікатор пересилається в заголовку всіх кадрів, переданих по мережі WLAN. Ідентифікатор SSID повідомляє бездротовим пристроям, до якої бездротової мережі WLAN вони належать і з якими пристроями вони взаємодіють.

Для забезпечення зв'язку всі бездротові пристрої в мережі WLAN повинні мати спільний ідентифікатор SSID, незалежно від типу установки мережі WLAN.

Фільтрація MAC-адрес дозволяє задати перелік пристроїв, що заборонені чи мають дозвіл на з'єднання з бездротовою мережею, за допомогою їхніх MAC-адрес. При кожній спробі бездротового клієнта встановити з'єднання або асоціюватися із точкою доступу він повинен передати свою MAC-адресу. Якщо включено функцію фільтрація по MAC-адресах, то бездротовий маршрутизатор або точка доступу виконає пошук MAC-адреси цього пристрою по своєму попередньо заданому списку.

Аутентифікація - це надання дозволу на вхід у мережу за результатами перевірки дійсності набору облікових даних. Її ціль - з'ясувати, чи є пристрій, що намагається встановити з'єднання, довіреним пристроєм. Найпоширеніша аутентифікація по імені користувача й паролю. У бездротовому середовищі аутентифікація дозволяє виконати перевірку дійсності підключеного вузла. Якщо включені функції аутентифікації й фільтрації MAC-адрес, то в першу чергу виконується аутентифікація.

Аутентифікація може блокувати зловмиснику доступ у бездротову мережу, але не зможе запобігти перехопленню переданих даних. Шифрування - це процес перетворення даних таким чином, що навіть перехоплення інформація виявиться марним. Протокол WEP - це механізм безпеки, що дозволяє шифрувати мережний трафік у процесі передачі. У протоколі WEP для шифрування й розшифровки даних використовуються попередньо настроєні ключі. Для ефективної роботи протоколу WEP точка доступу, а також кожен бездротовий пристрій, що має дозвіл на доступ у мережу, повинні використовувати загальний WEP-ключ. Без цього ключа пристрої не зможуть розпізнати дані, передані по бездротовій мережі.

Маршрутизатор Linksys WRT54GL підтримує чотири типи настроювань режиму безпеки:

  •  WEP
  •  WPA (бездротовий захищений доступ), що використовує попередній ключ (PSK);
  •  WPA Enterprise, що використовує службу віддаленої аутентифікації користувачів (RADIUS);
  •  RADIUS.

Щоб захистити мережу, використовуйте найвищий рівень шифрування із запропонованих для обраного режиму безпеки. Далі перераховані режими безпеки й рівні шифрування від найменш захищеного (WEP) до найбільш захищеному (WPA2 з AES)

  •  WEP;
  •  WPA
    •  TKIP (Temporal Key Integrity Protocol);
    •  AES (Advanced Encryption System);
  •  WPA2
    •  TKIP;
    •  AES.

AES підтримується тільки новими пристроями, що містять співпроцесор. Щоб забезпечити сумісність із усіма пристроями, виберіть протокол TKIP.

Для аутентификації довжина попереднього ключа повинна бути від 8 до 63 символів. Цей ключ є загальним для пристрою Linksys і всіх підключених пристроїв.


Схема макету

Завдання лабораторної роботи

  •  Виконати зєднання з маршрутизатом, увійти до інтерфейсу конфігурування.
  •  Призначити ІР адреси інтерфейсам WAN i LAN.
  •  Встановити назву ідентифікатора мережі SSID, призначити ключ WEP для шифрування.
  •  Сконфігуруйте параметри віддаленого управління, призначити пароль адміністратора.
  •  Дозволити відповідати на запити команди ping.
  •  Налаштуйте з’єднання з бездротовою мережею PC3
  •  Перевірте зв’язок компютера РС3 за допомогою команди ping з LAN і WAN інтерфейсами маршрутизатора Linksys, з субінтерфейсом Fa0/1.88 маршрутизатора R1, з компютерами РС1, РС2.
  •  Визначте МАС адресу компютера РС4, сконфігуруйте МАС фільтрацію на бездротовому марштуризаторі, щоб заборонити доступ до мережі компютеру РС.
  •  Забороніть проходження трафіку telnet через маршрутизатор.


Порядок виконання роботи

Завдання 1 : Завантажити початкову конфігурацію

Крок 1. Завантажте конфігурацію маршрутизатора R1

hostname R1

!

interface FastEthernet0/0

ip address 172.17.50.1 255.255.255.0

no shutdown

!

interface FastEthernet0/1

no ip address

no shutdown

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 172.17.10.1 255.255.255.0

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

ip address 172.17.20.1 255.255.255.0

!

interface FastEthernet0/1.88

encapsulation dot1Q 88

ip address 172.17.88.1 255.255.255.0

!

Крок 2. Завантажте конфігурацію комутатора S2.

hostname S2

!

interface FastEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

no shutdown

!

interface FastEthernet0/7

switchport access vlan 88

switchport mode access

no shutdown

!

interface FastEthernet0/11

switchport access vlan 10

switchport mode access

no shutdown

!

interface FastEthernet0/18

switchport access vlan 20

switchport mode access

no shutdown

! 

Завдання 2: Зєднайтесь з бездротовим маршрутизатором, і увійдіть в режим конфігурування.

Крок 1. Відновлення фабричних настроювань.

Відновіть фабричні настроювання пристрою Linksys, натиснувши кнопку RESET й утримуючи її протягом 5 секунд.

Крок 2. Виконання фізичного з’єднання.

Використовуючи прямий кабель, підключіть ваш комп'ютер (мережну плату Ethernet) до багатофункціонального пристрою (Port 1 на Linksys WRT54GL).

Крок 3. Призначення адреси комп’ютеру.

IP-адреса Linksys WRT54GL за замовчуванням: 192.168.1.1, маска підмережі : 255.255.255.0. Для можливості обміну даними комп'ютер і пристрій Linksys повинні перебувати в одній мережі. Змініть IP-адресу комп'ютера на 192.168.1.2 і переконаєтеся, що вказана маска підмережі 255.255.255.0. Введіть внутрішню адресу пристрою Linksys (192.168.1. 1) як шлюз за замовчуванням.

Клацніть Start > Control Panel > Network Connections. Клацніть правою кнопкою миші по бездротовому підключенню й виберіть пункт Properties. Виберіть протокол Інтернету (TCP/IP) і введіть адресу, як зазначено нижче.

Крок 4. Доступ через веб-браузер.

Відкрийте веб-браузер (наприклад, Internet Explorer, Netscape або Firefox), введіть у поле адреси IP-адресу пристрою Linksys за замовчуванням (192.168.1.1) і натисніть клавішу Enter.

Крок 2. Авторизація з пристроєм.

Відобразиться екран із запитом імені користувача й пароля. Залишіть поле імені користувача порожнім, а в поле пароля введіть admin. Це пароль по умовчанню для пристрою Linksys. Клацніть OK. Паролі вводяться з врахуванням регістра. Зауважте, що залишати заводські username і password є поганою практикою. Ми змінимо password в одному з наступних завдань.

Завдання 3: Конфігурування опцій в закладці Setup бездротового маршрутизатора  Linksys

Крок 1. Встановлення статичної IP адреси для з’єднання з Internet.

По замовчуванню на екран виводиться сторінка маршрутизатора ‘Setup’. Зауважте що у меню Ви знаходитесь у секції ‘Setup’ яка у закладці ‘Basic Setup’

На екрані Setup знайдіть розташування опції Internet Connection Type під розділом Internet Setup. Меню опуститься після натискання, виберіть зі списку Static IP.

Крок 2. Встановлення IP адреси, маски, адреси шлюзу по замовчуванню для мережі VLAN 88.

Встановіть IP адресу 172.17.88.25

Встановіть маску мережі 255.255.255.0.

Встановіть адресу шлюзу по замовчуванню 172.17.88.1.

Крок 3. Встановлення IP параметрів маршрутизатора.

На цій же сторінці, опустіться вниз до секції Network Setup. Для поля Router IP введіть наступне:

Встановіть IP адресу 172.17.40.1, маску 255.255.255.0.

Під секцією DHCP Server Setting, впевніться що сервер DHCP увімкнений.

Крок 4. Збереження конфігурації.

Натисніть на кнопку Save Settings внизу екрану Setup.

Зауважте що діапазон IP адрес для DHCP відповідає IP адресі маршрутизатора. Послугами сервера користуватимуться бездротові клієнти і клієнти, що під’єднані до комутатора. IP адресу маршрутизатора клієнти використовують як шлюз по замовчуванню.

Крок 5. Повторне з’єднання з маршрутизатором.

Оскільки ми змінили IP адресу маршрутизатора необхідно підключитись наново використовуючи нові адреси.

Підключіться до маршрутизатора. Для доступу Вам необхідна IP адреса яку ви отримаєте через DHCP або встановіть власну адресу з цього діапазону.

Підключіться до графічного інтерфейсу маршрутизатора використовуючи його IP адресу 172.17.88.25, таким же чином як описано в Завданні 2.

Завдання 4: Налаштування параметрів в закладці Wireless бездротового маршрутизатора Linksys.

Крок 1. Встановлення назви мережі SSID.

Натисніть на закладку Wireless.

Під секцією Network Name (SSID), перейменуйте назву мережі з Default в WRS_LAN

Збережіть настройки, натиснувши кнопку Save Settings.

Крок 2. Встановлення режиму безпеки.

Виберіть вкладку Wireless Security на екрані Wireless.

Змініть режим безпеки Security Mode з Disabled на WEP.

Використовуючи шифрування по замовчуванню 40/64-Bit, встановіть значення ключа Key1 - 1234567890

Збережіть настройки, натиснувши кнопку Save Settings.

Завдання 5: Налаштування параметрів в закладці Administration бездротового маршрутизатора Linksys.

Крок 1. Встановлення паролю маршрутизатора.

Натисніть на закладку Administration.

Під секцією Router Access введіть новий пароль для пристрою Linksys, а потім підтвердіть його. Новий пароль повинен складатися не більше ніж з 32 символів і не повинен містити пробілів. Пароль необхідний для доступу до веб-утиліти пристрою Linksys і до майстра установки.

Змініть пароль маршрутизатора на cisco123.

Крок 2. Встановлення віддаленого управління.

Під секцією Remote Access, встановіть enable у remote management

Збережіть настройки, натиснувши кнопку Save Settings.

Маршрутизатор вимагатиме ввести новий пароль. Введіть у полі password cisco123, поле username надалі залишайте пустим.

Можливість доступу до веб-утиліти через бездротову мережу включена за замовчуванням. Цю

функцію можна відключити для підвищення рівня безпеки.

Завдання 6: Налаштування параметрів в закладці Security бездротового маршрутизатора Linksys.

Для безпеки по замовчуванню інтерфейси LAN/Wireless (172.17.40.1) маршрутизатора не відповідають на пакети ping яки прийшли з інтерфейсу WAN (для прикладу з PC1 і PC2). Для перевірки зв’язку ми дозволимо цю функцію.

Крок 1. Дозволити анонімні internet запити.

Натисніть вкладку Security. 

Під секцією Internet Filter, зніміть галочку Filter Anonymous Internet Requests.

Завдання 7: Налагодьте бездротове з’єднання на PC

Крок 1. Від’єднайте Ethernet з’єднання PC3 з WRS2.

Крок 2: Використайте Windows XP для з’єднання з бездротовим маршрутизатором.

Знайдіть іконку Wireless Network Connection в панелі задач, або зайдіть в Start > Control Panel > Network Connections.

Виберіть Wireless Network Connection.

Увійдіть у меню File виберіть Status.

Клацніть по View Wireless Networks.  

Знайдіть SSID ‘WRS_LAN’ у списку доступних мережних з’єднань і підключіться до нього.

На запит WEP паролю введіть ключ який ми призначили в Завданні 3, 1234567890 і клацніть Connect.

Крок 3: Перевірка з’єднання.

У вікні  Status, виберіть закладку Support.

Перевірте чи PC3 отримав IP адресу з діапазону DHCP сервера WRS2.

Завдання 8: Перевірте зв'язок.

Крок 1. Пінгуйте інтерфейс LAN/Wireless маршрутизатора WRS2

На PC3, натисніть Start->Run

Надрукуйте cmd, натисніть Enter. Відкриється командний рядок.

В командному рядку надрукуйте без лапок “ping 172.17.40.1”.

Крок 2. Пінгуйте інтерфейс Fa0/1.88 маршрутизатора R1.

В командному рядку надрукуйте без лапок “ping 172.17.88.1

Крок 3. Пінгуйте компютери PC1 і PC2 з компютера PC3

В командному рядку надрукуйте без лапок “ping 172.17.10.21

Повторіть пінг для адреси комп’ютера PC2, 172.17.20.22.

Завдання 9: Налаштування МАС фільтрації.

Крок 1. Налаштування і перевірка зв’язку.

Для комп’ютера PC4 налаштуйте з’єднання таким же чином як вказано у Завданні 7 і перевірте зв'язок як вказано у Завданні 8. Команда ping повинна виконатись успішно.

Крок 2. Визначення МАС адреси комп’ютера PC4.

На PC4, натисніть Start->Run

Надрукуйте cmd, натисніть Enter. Відкриється командний рядок.

В командному рядку надрукуйте ipconfig /all. Перепишіть МАС адресу бездротового адаптера.

Крок 3. З’єднайтесь з маршрутизатором, використовуючи веб-браузер.  

Крок 4. Увімкнення фільтрування по МАС адресі.

Натисніть на закладку Wireless. 

Зайдіть у секцію Wireless MAC Filter.

Встановіть перемикач у положення Enabled.

Встановіть перемикач у положення Prevent PCs listed below from accessing the wireless network.

Введіть МАС адресу комп’ютера PC4. У нашому випадку 00:05:4E:49:64:87 . Це заборонить доступ до бездротової мережі будь-якій станції з такою МАС адресою.

Примітка: Кнопка Wireless Client List показує текучі бездротові з’єднання кінцевих станцій з маршрутизатором. Використовуючи опцію Save to MAC filter list, можна автоматично додати потрібну MAC адресу до списку заборонених адрес.

Крок 6. Перевірка зв’язку.

Перевірте зв'язок як вказано у Завданні 8. Команда ping не повинна виконатись успішно.

Task 10: Налаштування параметрів в закладці Access Restrictions бездротового маршрутизатора Linksys.

Заборонити проходження трафіку через маршрутизатор по протоколу Telnet, для користувачів які отримують від сервера DHCP ІР адреси з діапазону (172.17.30.150 – 174).

Крок 1. Налагодження параметрів закладки Access Restrictions.

Увійдіть до закладки Access Restrictions. Встановіть наступні опції:

• В полі Policy Name введіть назву фільтру ‘No_Telnet‘

• Увімкніть цей фільтр. Перемикач Status встановіть у положення Enabled.

• Дозволити доступ до Інтернету. Internet access – Allow. У полі Schedule всі галочки мають бути відмічені.

•У полі Blocked Application додати Telnet (23 - 23)

Крок 2. Визначення діапазону заблокованих IP адрес.

Застосуйте цю конфігурацію для клієнтів, що використовують IP адреси 172.17.30.150 – 174. Натисніть кнопку Edit List зверху вікна конфігурації і введіть потрібний діапазон адрес.

Збережіть настройки

Контрольні запитання.

  1.  Для чого призначений SSID?
  2.  Як у бездротових мережах запобігають перехопленню переданих даних?
  3.  Які режими шифрування даних підтримує пристрій Linksys WRT54GL? Який з цих режимів найкращий?
  4.  Для чого використовується фільтрація MAC-адрес?
  5.  Які канали можна використати для конфігурування радіо-інтерфейсу?
  6.  Скільки неперекриваючих каналів існує в стандарті 802.11g.
  7.  Що таке WEP-ключ?


 

А также другие работы, которые могут Вас заинтересовать

34094. Договор дарения земельного участка. Наследование земельных участков 32 KB
  Договор дарения земельного участка. Право дарения земельного участка имеют собст ДАРЕНИЕ венники земли граждане и юридические лица ЗЕМЕЛЬНОГО на основании Указа Президента РФ О регули УЧАСТКА ровании земельных отношений и развитии аг рарной реформы в России п. Для обеспечения заключения договоров дарения так же как и договоров мены Комитетом РФ по земельным ресурсам и землеустройству была разработана форма договора дарения земельного участка1. Договор дарения земельного участка должен быть оформлен...
34095. Общая долевая собственность на земельные участки 63.5 KB
  Право общей долевой собственности на земельный участок 1 возникает на основе юридических фактов обусловливающих право собственности граждан и юридических лиц. Право собственности на земельные доли предметом рассмотрения в данной статье не является. Право частной собственности на землю. N 13051 О собственности в СССР но которые не были надлежаще оформлены и зарегистрированы имеют право бесплатно приобрести право собственности на указанные земельные участки в соответствии с правилами установленными ст.
34096. Общая совместная собственность на земельные участки 26.5 KB
  Общая совместная собственность на земельные участки. Общая собственность на земельные участки Существует 2 вида: долевая; общая совместная. Общая долевая собственность возникает при попадании двум и более лицам неделимого участка в случаях предусмотренных в законе или договоре. Совместная собственность возникает в следующих случаях прямо предусмотренных законами: общая собственность супругов если брачным контрактом не предусмотрено иное; возникает собственность крестьянскофермерских хозяйств если соглашением между членами...
34097. Изъятие (выкуп) земельных участков для государственных и муниципальных нужд: основания, порядок 62.5 KB
  Следует иметь в виду что предполагаемое назначение объекта должно соответствовать полномочиям органа принимающего решение об изъятии земельного участка. Например решение об изъятии земельного участка для целей связанных с защитой Государственной границы России может быть принято только органами государственной власти Российской Федерации согласно п. Данное обстоятельство по сути означает что в случае возникновения судебного спора орган принявший решение об изъятии земельного участка должен будет представить суду убедительные...
34098. Право ограниченного пользования чужим земельным участком (сервитут). Обременения земельного участка 33 KB
  Обременения земельного участка. Однако возможно рассмотрение сервитута в качестве обременения земельного участка.С точки зрения собственника земельного участка который соседи используют для прохода к водоему сервитут является ограничением его права. Публичные сервитуты могут устанавливаться для:1 прохода или проезда через земельный участок;2 использования земельного участка для ремонта коммунальных инженерных электрических и других линий и сетей а также транспортной инфраструктуры;3 размещения на участке межевых и геодезических знаков...
34099. Право пользования земельным участком собственником недвижимости. Последствия утраты собственником недвижимости права пользования земельным участком 93 KB
  В случае когда земельные участки находящиеся в государственной или муниципальной собственности предоставляются за плату наряду с решением органа государственной власти или местного самоуправления о предоставлении земельного участка юридический состав образует также договор куплипродажи земельного участка. При наследовании земельного участка по наследству переходят также находящиеся в границах этого земельного участка поверхностный почвенный слой замкнутые водоемы находящиеся на нем лес и растения. Раздел земельного участка...
34100. Права и обязанности субъектов, использующих землю. Защита их прав 52.5 KB
  Взаимосвязанные между собой права и обязанности субъектов земельных правоотношений составляют суть содержания любого правоотношения. Права субъектов земельных правоотношений можно классифицировать на две основные группы: 1. Право на действия субъектов земельных правоотношений можно подразделить на: а виды действий. Право на бездействие субъектов земельных правоотношений можно подразделить на: а полное бездействие.
34101. онятие и особенности ответственности в области использования и охраны земель 25.5 KB
  Ответственность за земельные правонарушения. Ответственность нужно понимать в двояком смысле: юридическая ответственность как правовой институт в объективном смысле это совокупность юридических норм устанавливающих неблагоприятные последствия за совершение правонарушения в области использования и охраны земель и порядок их возложения на правонарушителя; в субъективном смысле юридическая ответственность это обязанность лица виновного в совершении правонарушения претерпеть неблагоприятные последствия предусмотренные законом...
34102. Земельно-правовая ответственность. Дисциплинарная ответственность в области использования и охраны земель 29 KB
  Специфической санкцией земельноправовой ответственности является земельного участка у собственника либо принудительное прекращение прав на земельный участок. 45 и 47 ЗК орган государственного земельного контроля налагает административное взыскание и одновременно выносит предупреждение о необходимости устранения нарушения; в этом предупреждении указывается допущенное правонарушение его содержание суть устанавливается срок для устранения допущенного правонарушения; разъясняются права земледельца землепользователя в случае...