6836

Конфігурування протоколу OSPF

Лабораторная работа

Информатика, кибернетика и программирование

Конфігурування протоколу OSPF Мета: Ознайомитися з протоколом маршрутизації OSPF, навчитися створювати конфігурацію цього протоколу та тестувати OSPF - маршрутизацію. Задачі поставлені у лабораторній роботі виконуються в два етапи 1. На віртуал...

Украинкский

2013-01-08

230 KB

13 чел.

Конфігурування протоколу OSPF

Мета: Ознайомитися з протоколом маршрутизації OSPF, навчитися створювати конфігурацію цього протоколу та тестувати OSPF – маршрутизацію.

Задачі поставлені у лабораторній роботі виконуються в два етапи

1. На віртуальному емуляторі Packet Tracer 4.1.

2. На лабораторному макеті мережі на базі маршрутизаторів  Cisco 2801

Порядок виконання роботи.

  1.  Ознайомитись з короткими теоретичними відомостями.
  2.  Відновити створену в попередній лабораторній роботі конфігурацію мережі на віртуальному емуляторі Packet Tracer 4.1.
  3.  Сконфігурувати пртокол OSRF на усіх маршрутизаторах.
  4.  Перевірити створену конфігурацію за допомогою команд ping та traсeroute.
  5.  Задати смугу пропускання для кожного послідовного інтерфейсу.
  6.  Виявити призначений і резервний маршрутизатори і змінити їх піоритет.
  7.  Протестувати налаштування маршрутизаторів.
  8.  Пункти 2-7 виконати для створення конфігурації мережі на лабораторному макеті.
  9.  Закінчити роботу, підготувати і здати звіт.

Теоретичні відомості

З детальнішими теоретичними відомостями можна ознайомитись у пункті 3.

Конфігурація протоколу OSPF для однієї зони

Для того, щоб конфігурувати на маршрутизаторі протокол OSPF, необхідно включити цей протокол і сконфігурувати мережеві адреси маршрутизатора і задати інформацію про зону, як показано на рис. 3.16, виконавши наступні дії:

 Етап 1. Включити на маршрутизаторі використання протоколу OSPF, використовуючи команду:

 router(config)#  router ospf process-id

Ідентифікатор ID процесу (аргумент process-id) є номером процесу на локальному маршрутизаторі. Цей ідентифікатор ID використовується для ідентифікації одного процесу серед декількох процесів, що працюють на одному і тому ж маршрутизаторі. Це номер може бути будь-яким значенням з діапазону від 1 до 65535. Нумерація процесів не обов'язково повинна починатися з 1. Більшість мережевих адміністраторів використовують один і той же ID процесу у всій автономній системі AS. На одному і тому ж маршрутизаторі можуть виконуватися декілька OSPF-процесів, проте це не рекомендується, оскільки в цьому випадку створюється декілька екземплярів баз даних, які збільшують службове навантаження на маршрутизатор.

Етап 2. Ідентифікувати IP-мережі на маршрутизаторі, використовуючи команду

router (conf ig-router) # network address wildcard-mask area area-id

Для кожної мережі необхідно задати зону, до якої належить ця мережа. Значення address може бути адресою мережі, підмережі або адресою інтерфейсу.

Про те, як слід інтерпретувати адресу, маршрутизатор дізнається шляхом порівняння його з маскою шаблону. Ця маска необхідна тому, що протокол OSPF, на відміну від протоколів Rip vl і IGRP підтримує маршрутизацію CIDR і VLSM. Аргумент area-id є обов'язковим навіть у тому випадку, коли протокол OSPF конфігурується лише в одній окремій зоні. Знов слід зазначити, що до однієї зони можуть належати декілька IP-мереж. Проектування і реалізація великих мереж OSPF починається з конфігурації маршрутизації OSPF в окремій зоні. Протокол OSPF конфігурується аналогічно іншим протоколам маршрутизації. Деякі відмінності полягають в тому, як окремі мережі анонсуються і включаються в директиву network. Це викликано тим, що протокол OSPF є протоколом стану каналу, а не дистанційно-векторним (як, наприклад, протоколи Rip vl і IGRP).

Для успішного функціонування протоколу OSPF потрібні ідентифікатор процесу (process identifier- process ID) і ідентифікатор маршрутизатора (router identifier - router ID). Ідентифікатор маршрутизатора береться з активного інтерфейсу. Якщо цей інтерфейс виходить з ладу, то даний процес OSPF продовжуватися не може. Для забезпечення стійкої роботи протоколу OSPF як ідентифікатора маршрутизатора конфігурується адреса петлевого інтерфейсу (loopback address). Додатково в мережах множинного доступу вибирається призначений маршрутизатор (designated router - DR). При розповсюдженні інформації про стан каналу цей маршрутизатор виступає від імені решти всіх маршрутизаторів. Можлива ситуація, коли як призначений маршрутизатор потрібно вибрати деякий заздалегідь вказаний маршрутизатор. В цьому випадку даному маршрутизатору привласнюється найвищий пріоритет.

В таблиці 4.4.1 наведені команди, котрі будуть корисними під час виконання даної лабораторної роботи для створення активної конфігурації маршрутизаторів, а також остаточної перевірки та усунення помилок конфігураційних файлів.

Таблиця 4.4.1 Команди тестування конфігурації протоколу OSPF

Команда

Опис

show ip protocol

Відображає параметри таймерів, фільтрів, метрики, параметри мережі і іншу інформацію, що відноситься до всього маршрутизатора.

show ip route

Відображає відомі маршрутизатору маршрути і джерела, з яких вони отримані. Використання цієї команди є одним з кращих способів перевірити з'єднання локального маршрутизатора з рештою частини об'єднаної мережі.

show ip ospf interface

Перевіряє, чи були зконфігуровані інтерфейси в необхідних зонах. Якщо не вказана адреса петлевого інтерфейсу, то адреса цього інтерфейсу розглядається як ідентифікатор даного маршрутизатора. Ця команда також виводить значення інтервалів таймерів, включаючи інтервал розсилки повідомлень Hello і відображає відносини суміжності з сусідніми пристроями.

show ip ospf

Виводить число виконань алгоритму вибору найкоротшого шляху (shortest path first - SPF). Вона також виводить значення інтервалу розсилки повідомлень про зміни в стані каналу в умовах, коли змін в топології мережі не відбувається.

show ip ospf neighbor detail

Відображає докладний список сусідніх пристроїв, їх пріоритети і стан (наприклад, стани hit, exstart, або full)

show ip ospf database

Відображає вміст топологічної бази даних, підтримуваної даним маршрутизатором. Ця команда також відображає ID маршрутизатора і ID OSPF-процессу. При використанні в даній команді різних ключових слів може бути відображений ряд типів баз даних. Докладнішу інформацію про ключові слова можна отримати за адресою www.cisco.com

clear ip route*

Очищає всю IP-таблицу маршрутизації.

clear ip route a.b.c.d

Видаляє з таблиці маршрутизації тільки маршрут, заданий адресою a.b.c.d.

debug ip ospf

Виконує відладку операцій протоколу OSPF.


Хід виконання роботи

  1.  Ознайомившись з короткими теоретичними відомостями, перейдемо до виконання лабораторної роботи.

Після ознайомлення з теоретичними відомостями можна починати виконувати поставленні завдання по створенню конфігурації протоколу OSPF на основі створеної мережі.

  1.  Відновити створену в попередній лабораторній роботі конфігурацію мережі згідно рис.:

Спочатку потрібно перевірити початкові настройки та переконатися у фізичній справності мережі.

Після отримання позитивного результату приступимо до включення та налаштування протоколу OSPF.

3. Сконфігуруємо пртокол OSRF на усіх маршрутизаторах.

Отже, скориставшись вище приведеним прикладом, сконфігуруєм на всіх маршрутизаторах протокол OSPF і вкажимо ідентифікатор ID, що дорівнює 112. Особливістю конфігурування протоколу OSPF є використання оберненої маски під мережі, тобто маску 255.255.255.0 будемо записувати як 0.0.0.255.

Сконфігуруєм  4 маршрутизатори

Приклад 4.4.1 Router0. Конфігурування OSPF

Router0#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router0(config)#router ospf 112

Router0(config-router)#network 192.168.0.0 0.0.0.3 area 0

Router0(config-router)#network 192.168.4.0 0.0.0.255 area 0

Router0(config-router)#

00:32:27: %OSPF-5-ADJCHG: Process 112, Nbr 192.168.3.1 on FastEthernet0/1 from LOADING to FULL, Loading Done

Приклад 4.4.2 Router1. Конфігурування OSPF

outer1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router1(config)#router ospf 112

Router1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Router1(config-router)#network 192.168.0.8 0.0.0.3 area 0

Router1(config-router)#network 192.168.0.4 0.0.0.3 area 0

Router1(config-router)#

Приклад 4.4.3 Router2. Конфігурування OSPF

Router2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router2(config)#router ospf 112

Router2(config-router)#network 192.168.2.0 0.0.0.255 area 0

Router2(config-router)#network 192.168.0.12 0.0.0.3 area 0

Router2(config-router)#network 192.168.0.8 0.0.0.3 area 0

Router2(config-router)#

00:17:35: %OSPF-5-ADJCHG: Process 112, Nbr 192.168.1.1 on Serial0/2/0 from LOADING to FULL, Loading Done

00:30:42: %OSPF-5-ADJCHG: Process 112, Nbr 192.168.3.1 on Serial0/2/1 from LOADING to FULL, Loading Done

Router2(config-router)#

Приклад 4.4.4 Router3. Конфігурування OSPF

Router3#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router3(config)#router ospf 112

Router3(config-router)#network 192.168.0.12 0.0.0.3 area 0

00:30:42: %OSPF-5-ADJCHG: Process 112, Nbr 192.168.2.1 on Serial0/2/1 from LOADING to FULL, Loading Done

Router3(config-router)#network 192.168.0.4 0.0.0.3 area 0

Router3(config-router)#

00:30:50: %OSPF-5-ADJCHG: Process 112, Nbr 192.168.1.1 on Serial0/2/0 from EXCHANGE to FULL, Exchange Done

Router3(config-router)#network 192.168.3.0 0.0.0.255 area 0

Router3(config-router)#network 192.168.0.0 0.0.0.3 area 0

Router3(config-router)#

00:32:27: %OSPF-5-ADJCHG: Process 112, Nbr 192.168.4.1 on FastEthernet0/1 from LOADING to FULL, Loading Done

4. Перевіримо створену конфігурацію за допомогою команд ping та traсeroute.

Після завершення конфігурування протоколу, протестуємо  мережу і перевіримо чи працює протокол. Для цього можна використати ряд команд групи show, а також команди: ping, traceroute, як це було зроблено у попередніх лабораторних роботах.

5. Задамо смугу пропускання для кожного послідовного інтерфейсу.

Перевіримо стан кожного послідовного інтерфейсу і збільшимо смугу пропускання для ефективнішого використання мережі.

Приклад 4.4.5 Router1. Вивід інформації про стан інтерфейсів

---частина інформації пропущена---

Serial0/2/0 is up, line protocol is up (connected)

 Hardware is HD64570

 Internet address is 192.168.0.9/30

 MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec, rely 255/255, load 1/255

 Encapsulation HDLC, loopback not set, keepalive set (10 sec)

 Last input never, output never, output hang never

 Last clearing of "show interface" counters never

 Input queue: 0/75/0 (size/max/drops); Total output drops: 0

 Queueing strategy: weighted fair

 Output queue: 0/1000/64/0 (size/max total/threshold/drops)

    Conversations  0/0/256 (active/max active/max total)

    Reserved Conversations 0/0 (allocated/max allocated)

 5 minute input rate 72 bits/sec, 0 packets/sec

 5 minute output rate 70 bits/sec, 0 packets/sec

    396 packets input, 32588 bytes, 0 no buffer

    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

    388 packets output, 31648 bytes, 0 underruns

    0 output errors, 0 collisions, 0 interface resets

    0 output buffer failures, 0 output buffers swapped out

    0 carrier transitions

    DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

---частина інформації пропущена---

Отже, смуга пропускання для інтерфейсу S0/2/0 рівна 56 Кбіт/с. Збільшимо її до 1000 Кбіт/с. Виконаємо це завдання на усіх маршрутизаторах, після чого знову перевіримо стан інтерфейсів.

Приклад 4.4.6 Router1. Вивід інформації про стан інтерфейсів

---частина інформації пропущена---

Serial0/2/0 is up, line protocol is up (connected)

 Hardware is HD64570

 Internet address is 192.168.0.9/30

 MTU 1500 bytes, BW 100000 Kbit, DLY 20000 usec, rely 255/255, load 1/255

 Encapsulation HDLC, loopback not set, keepalive set (10 sec)---частина інформації пропущена---

Змінивши смугу пропускання на послідовних інтерфейсах ми задали кращу оцінку каналам. Оскільки відомо, що метрика, використовувана протоколом OSPF, напряму залежить від смуги пропускання каналу. Ще одним методом задання каналу оцінки є використання наступної команди:

Router(config-if)#ip ospf cost number

6. Виявимо призначений і резервний маршрутизатори і змінимо їх пріоритет.

Значення параметру number знаходиться в межах 1÷65535.

З огляду на топологію створеної мережі вибір призначеного і резервного маршрутизатора можливий лише в мережі 192.168.0.0, оскільки вона є широкомовною. Для виявлення DR і BDR маршрутизаторів скористаємось командою show ip ospf neighbor detail.

Приклад 4.4.7 Router3. Вивід інформації по команді show ip ospf neighbor detail

Router3#show ip ospf neighbor detail

Neighbor 192.168.4.1, interface address 192.168.0.1

   In the area 0 via interface FastEthernet0/1

   Neighbor priority is 1, State is FULL, 6 state changes

   DR is 192.168.0.1 BDR is 192.168.0.2

   Options is 0x00

   Dead timer due in 00:00:39

   Neighbor is up for 01:24:37

   Index 1/1, retransmission queue length 0, number of retransmission 0

   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

   Last retransmission scan length is 0, maximum is 1

   Last retransmission scan time is 0 msec, maximum is 0 msec

Neighbor 192.168.1.1, interface address 192.168.0.6

   In the area 0 via interface Serial0/2/0

   Neighbor priority is 1, State is FULL, 7 state changes

   DR is 0.0.0.0 BDR is 0.0.0.0

   Options is 0x00

   Dead timer due in 00:00:39

   Neighbor is up for 01:08:56

   Index 2/2, retransmission queue length 0, number of retransmission 0

   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

   Last retransmission scan length is 0, maximum is 1

   Last retransmission scan time is 0 msec, maximum is 0 msec

Neighbor 192.168.2.1, interface address 192.168.0.13

   In the area 0 via interface Serial0/2/1

   Neighbor priority is 1, State is FULL, 7 state changes

   DR is 0.0.0.0 BDR is 0.0.0.0

   Options is 0x00

   Dead timer due in 00:00:39

   Neighbor is up for 01:00:06

   Index 3/3, retransmission queue length 0, number of retransmission 0

   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

   Last retransmission scan length is 0, maximum is 0

   Last retransmission scan time is 0 msec, maximum is 0 msec

Отже, призначеним маршрутизатором є Router0, а резервним Router3. Даний вибір був здійснений по ІР – адресах, оскільки пріоритет при конфігуруванні був не змінений і залишився по замовчуванню (рівний 1), то вибір відбувається по ІР – адресі інтерфейсу. Призначеним вибирається той маршрутизатор в якого менша ІР – адреса.

Поміняємо місцями призначений і резервний маршрутизатори, а саме Router0 – BDR та Router3 – DR (налаштування пріоритету рівного 0 унеможливлює вибір маршрутизатора в якості DR і BDR). Для виконання поставленої задачі скористаємось командою:

router(config-if)#ip ospf priority number

Маршрутизатору Router3 задамо значення пріоритету рівне 15, а на Router0 залишимо без зміни (тобто рівне 1).

Приклад 4.4.8 Router3. Задання маршрутизатору пріоритету рівного 15.

Router3#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router3(config)#interface fa 0/1

Router3(config-if)#ip ospf priority 15

Router3(config-if)#exit

Після виконання вище приведених дій збережемо активну конфігурацію і перезавантажимо маршрутизатор. Це потрібно виконати для того, щоб відбувся вибір DR/BDR маршрутизатора. Оскільки він проходить один раз, і після його встановлення зміна неможлива без перезавантаження.

7. Протестуємо налаштування маршрутизаторів.

Перевіримо створену конфігурацію протоколу OSPF за допомогою команд приведених у таб. 4.4.1.

8. Виконуємо пункти 2-7 для створення конфігурації мережі на лабораторному макеті.

8. По закінченню роботи підготуєм і здамо звіт.

Контрольні питання

  1.  Який тип пакетів OSPF використовується для установки та підтримки відносин суміжності між сусідніми маршрутизаторами?
  2.  На чому основана оцінка каналу в протоколі OSPF, що приймається по замовчуванню?
  3.  Який адрес багатоадресної розсилки представляє всі OSPF – маршрутизатори?
  4.  Чим забезпечується стійкість функціонування протоколу OSPF?
  5.  В якому стані знаходяться маршрутизатори мережі OSPF після того, як були вибрані назначений (DR) і резервний (BDR) маршрутизатори?


 

А также другие работы, которые могут Вас заинтересовать

24118. Психоанализ и проблема человека (З.Фрейд, К.Г. Юнг, Э.Фромм) 17.18 KB
  В психике человека Фрейд сначала выделял две относительно автономные но постоянно взаимодействующие между собой структуры бессознательного оно и сознательного Я а затем добавил к ним сверх Я которое внедряется в Я но без специального анализа не осознается им. По мнению Фрейда причиной невроза является особого рода конфликт между оно Я и сверх Я . Согласно теории Фрейда оно набрало свою изна чальную силу но параллельно с этим развивалось и я . Так как инстинкты или оно служат всего лишь внутренним наполнителем то можно...
24119. Русская философия о человеке и обществе 15.01 KB
  Ориентация на гуманитарное знание на литературу и искусство на проблемы человека является безусловной доминантой в русской философии XX века. в виде религиозной философии человека. близкая к художественному творчеству Ориентация на гуманитарное знание на литературу и искусство на проблемы человека основа рус. во весь рост встали проблемы единства человека с космосом космической природы человека и космического масштаба человеческой деятельности.
24120. Русские философы о судьбах России 15.34 KB
  Россия соединяет внутри себя два мира и поэтому в русской душе всегда боролись два начала: восточное и западное. Бердяев называет русскую историю прерывной и выделяет в ней пять периодов дающих пять разных образов России: Россия киевская; Россия времен татарского ига; Россия московская; Россия петровская; Россия советская. Главное нельзя забывать что Россия является самой молодой цивилизацией и ее истинные возможности в новом свободном государстве скоро раскроются поновому с новыми перспективами.
24121. Русский космизм 13.96 KB
  во весь рост встали проблемы единства человека с космосом космической природы человека и космического масштаба человеческой деятельности. Разум и творчество поднимут человека в космос где со временем изменится его физическая природа он приблизится к высшим организмам.
24122. Основные категории философской онтологии: «бытие», «небытие», «инобытие». Виды бытия 15.11 KB
  Основные категории философской онтологии: бытие небытие инобытие. Одна из первых философских школы которая ввела слово Бытие была школа элеатов. Парменид обращает внимание на такой аспект всякого сущего как бытие. Есть сущее и есть существование этого сущего которое и называют бытием.
24123. Категория «материя». Основные характеристики материи (время, пространство, движение, системность) 15.51 KB
  Основные характеристики материи время пространство движение системность. характеристика материи через основной вопрос мировоззрения а не через понятие вещества или набор его свойств. Существует и другая точка зрения согласно которой нужно отказаться от представления о материи как субстанции гносеологический признак материи. Но важнейшими свойствами являются: пространство; время; движение как способ существования материи.
24124. Категория «дух», «идеальное». Объективная и субъективная реальность 16.14 KB
  Категория дух идеальное. Идеальное в идеалистической традиции понимается как самостоятельное нематериальное начало существующее вне пространства и времени дух идеи. Дух философия философское понятие часто отождествляемое с невещественным началом. Определение соотношения духа и материи зачастую считается основным вопросом философии.
24125. Основной вопрос философии и классификация философских направлений 15.65 KB
  Основной вопрос философии и классификация философских направлений. Основной вопрос философии метафилософская и историкофилософская концепция в философии марксизма согласно которой основной проблемой философии на протяжении всей её истории является вопрос об отношении сознания к материи мышления к бытию духа к природе. в философии Зап. неопозитивизм РасселВинтгенштейн Карнап Шлик который отвергая возможность философии как теоретического познания мировоззренческих проблем противопоставляет науку философии сводит задачу философии к...
24126. Диалектика как учение о всеобщей связи и развитии, её основные принципы. Диалектика и метафизика. Диалектика и синергетика 16.66 KB
  Диалектика как учение о всеобщей связи и развитии её основные принципы. Диалектика и метафизика. Диалектика и синергетика. Диалектика как учение о всеобщей связи и развитии Диалектика такое понимание мира и такой способ мышления при кот.