6843

Усунення несправностей корпоративних мереж

Лабораторная работа

Информатика, кибернетика и программирование

Усунення несправностей корпоративних мереж Мета навчання Після завершення цієї лабораторної роботи ви зможете: З'єднайти мережу відповідно до топологічної діаграми Стертипоточну конфігурацію і перезавантажит...

Украинкский

2013-01-08

386 KB

5 чел.

   

Усунення несправностей корпоративних мереж

Мета навчання

Після завершення цієї лабораторної роботи ви зможете:

  •  З’єднайти мережу відповідно до топологічної діаграми
  •  Стерти поточну конфігурацію і перезавантажити маршрутизатора в стан за замовчуванням
  •  завантажити маршрутизатори і комутатори з поставленими сценарієм
  •  Знайти і виправити всі помилки
  •  За документувати виправлені мережі

Топологічна схема

Таблиця адресації

Device

Interface

IP Address

Subnet Mask

Default Gateway

R1

Fa0/0

192.168.10.1

255.255.255.0

N/A

Fa0/1

192.168.11.1

255.255.255.0

N/A

S0/0/0

10.1.1.1

255.255.255.252

N/A

S0/0/1

10.3.3.1

255.255.255.252

N/A

R2

Fa0/1

192.168.20.1

255.255.255.0

N/A

S0/0/0

10.1.1.2

255.255.255.252

N/A

S0/0/1

10.2.2.1

255.255.255.252

N/A

Lo0

209.165.200.225

255.255.255.224

209.165.200.226

R3

Fa0/1

N/A

N/A

N/A

Fa0/1.11

192.168.11.3

255.255.255.0

N/A

Fa0/1.30

192.168.30.1

255.255.255.0

N/A

S0/0/0

10.3.3.2

255.255.255.252

N/A

S0/0/1

10.2.2.2

255.255.255.252

N/A

S1

VLAN10

DHCP

255.255.255.0

N/A

S2

VLAN11

192.168.11.2

255.255.255.0

N/A

S3

VLAN30

192.168.30.2

255.255.255.0

N/A

PC1

NIC

192.168.10.10

255.255.255.0

192.168.10.1

PC2

NIC

192.168.11.10

255.255.255.0

192.168.11.1

PC3

NIC

192.168.30.10

255.255.255.0

192.168.30.1

TFTP Server

NIC

192.168.20.254

255.255.255.0

192.168.20.1

Сценарій

Вас попросили, щоб ви виправити помилки конфігурації в корпоративній мережі. Для цієї лабораторної, не використовуйте Логін або захист паролем на будь-якій консолі задля запобігання випадкового блокування. Використовуйте ciscoccna для всіх паролів в цьому сценарії.


Примітка: Із-за того що ця лабораторна є акумулятивною, ви будете використовувати всі знання та рекомендації щодо усунення неполадок, які ви придбали з попереднього матеріалу, щоб успішно завершити цю лабораторну.

Вимоги

  •  S2 є сполучним коренем дерева для VLAN 11 і S3 є сполучним коренем дерева для VLAN 30
  •  S3 є сервером VTP з S2 в якості клієнта.
  •  Послідовний зв'язок між R1 і R2 є ретрансляцією кадрів. Переконайтеся, що кожен маршрутизатор може пінгувати свої інтерфейс ретрансляції кадрів. 
  •  Послідовний зв'язок між R2 і R3 використовує HDLC інкапсуляцію.
  •  Послідовний зв'язок між R1 і R3 використовує PPP.
  •  Послідовний зв'язок між R1 і R3 з перевіркою автентичності з використанням CHAP.
  •  R2 повинно мати надійну процедуру входу, тому що це маршрутизатор з сторони Інтернету.
  •  Всі VTY лінії, за винятком тих, що належать до R2, дозволити з'єднання тільки з підмереж показаних на діаграмі топології, за винятком громадських адрес.

Hint:

R2# telnet 10.1.1.1 /source-interface loopback 0

Trying 10.1.1.1 ...

% Connection refused by remote host

  •  Вихідний IP-адреса спуфінг повинен бути виключений на всі зєднання, які не з'єднуються з іншими маршрутизаторами.
  •  Протоколи маршрутизації повинні бути безпечними. Всі RIP маршрутизатори повинні використовувати MD5 аутентифікацію.
  •  R3 не повинен бути в змозі виконатиTelnet до R2 через безпосередньо пов'язаний послідовний порт.
  •  R3 має доступ до обох VLAN 11 і 30 через порт Fast Ethernet 0 / 0.
  •  Сервер TFTP не повинні отримати будь-який трафік, який має адресу джерела за межами підмережі. Всі пристрої мають доступ до сервера TFTP.
  •  Всі компоненти на 192.168.10.0 підмережі повинен бути в змозі отримати їх IP-адреси від DHCP на R1. Це включає в себе S1
  •  R1 повинний бути доступним через SDM..
  •  Всі адреси показано на схемі, повинні бути доступні з будь-якого пристрою.

Завдання 1: Завантажте Маршрутизатори з Поставляним Сценарієм

!------------------------------------------

!                  R1

!------------------------------------------

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

security passwords min-length 6

enable secret 5 ciscoccna

!

ip cef

!

ip dhcp pool Access1

  network 192.168.10.0 255.255.255.0

  default-router 192.168.10.1

!

no ip domain lookup

!

username R3 password 0 ciscoccna

username ccna password 0 ciscoccna

!

interface FastEthernet0/0

ip address 192.168.10.1 255.255.255.0

ip rip authentication mode md5

ip rip authentication key-chain RIP_KEY

no shutdown

!

interface FastEthernet0/1

ip address 192.168.11.1 255.255.255.0

ip rip authentication mode md5

ip rip authentication key-chain RIP_KEY

no shutdown

!

interface Serial0/0/0

ip address 10.1.1.1 255.255.255.252

ip rip authentication mode md5

ip rip authentication key-chain RIP_KEY

encapsulation frame-relay

 

clockrate 128000

frame-relay map ip 10.1.1.1 201

frame-relay map ip 10.1.1.2 201 broadcast

no frame-relay inverse-arp

no shutdown

!

interface Serial0/0/1

ip address 10.3.3.1 255.255.255.252

ip rip authentication mode md5

ip rip authentication key-chain RIP_KEY

encapsulation ppp

ppp authentication chap

no shutdown

!

!

router rip

version 2

passive-interface default

 network 192.168.10.0

network 192.168.11.0

no auto-summary

!

ip classless

!

no ip http server

!

ip access-list standard Anti-spoofing

permit 192.168.10.0 0.0.0.255

deny  any

ip access-list standard VTY

permit 10.0.0.0 0.255.255.255

permit 192.168.10.0 0.0.0.255

permit 192.168.11.0 0.0.0.255

permit 192.168.20.0 0.0.0.255

permit 192.168.30.0 0.0.0.255

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

access-class VTY in

login local

!

end

!------------------------------------------

!                  R2

!------------------------------------------

no service password-encryption

!

hostname R2

!

security passwords min-length 6

enable secret ciscoccna

!

aaa new-model

!

aaa authentication login LOCAL_AUTH local

aaa session-id common

!

ip cef

!

no ip domain lookup

!

key chain RIP_KEY

key 1

 key-string cisco

username ccna password 0 ciscoccna

!

interface Loopback0

description Simulated ISP Connection

ip address 209.165.200.245 255.255.255.224

!

interface FastEthernet0/0

ip address 192.168.20.1 255.255.255.0

ip access-group TFTP out

ip access-group Anti-spoofing in

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

ip address 10.1.1.2 255.255.255.0

 ip nat inside

encapsulation frame-relay

 no keepalive

frame-relay map ip 10.1.1.1 201 broadcast

no frame-relay inverse-arp

!

interface Serial0/0/1

ip address 10.2.2.1 255.255.255.0

ip access-group R3-telnet in

ip nat inside

ip rip authentication mode md5

ip rip authentication key-chain RIP_KEY

clockrate 128000

!

!

router rip

version 2

passive-interface default

no passive-interface Serial0/0/0

no passive-interface Serial0/0/1

network 10.0.0.0

network 192.168.20.0

default-information originate

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 209.165.200.226

!

no ip http server

ip nat inside source list NAT interface FastEthernet0/0 overload

!

ip access-list standard Anti-spoofing

permit 192.168.20.0 0.0.0.255

deny  any

ip access-list standard NAT

permit 10.0.0.0 0.255.255.255

permit 192.168.0.0 0.0.255.255

!

ip access-list extended R3-telnet

deny   tcp host 10.2.2.2 host 10.2.2.1 eq telnet

deny   tcp host 10.3.3.2 host 10.2.2.1 eq telnet

deny   tcp host 192.168.11.3 host 10.2.2.1 eq telnet

deny   tcp host 192.168.30.1 host 10.2.2.1 eq telnet

permit ip any any

!

ip access-list standard TFTP

permit 192.168.20.0 0.0.0.255

!

control-plane

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

exec-timeout 15 0

logging synchronous

login authentication local_auth

transport output telnet

line vty 0 4

exec-timeout 15 0

logging synchronous

login authentication local_auth

transport input telnet

!

end

!------------------------------------------

!                  R3

!------------------------------------------

no service password-encryption

!

hostname R3

!

security passwords min-length 6

enable secret ciscoccna

!

no aaa new-model

!

ip cef

!

no ip domain lookup

!

key chain RIP_KEY

key 1

 key-string cisco

username R1 password 0 ciscoccna

username ccna password 0 ciscoccna

!

interface FastEthernet0/1

no shutdown

!

interface FastEthernet0/1.11

encapsulation dot1Q 11

ip address 192.168.11.3 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/1.30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

ip access-group Anti-spoofing in

no snmp trap link-status

!

!

interface Serial0/0/0

ip address 10.3.3.2 255.255.255.252

encapsulation ppp

clockrate 125000

ppp authentication chap

!

interface Serial0/0/1

ip address 10.2.2.2 255.255.255.252

!

router rip

version 2

passive-interface default

no passive-interface FastEthernet0/0.11

no passive-interface FastEthernet0/0.30

no passive-interface Serial0/0/0

no passive-interface Serial0/0/1

network 10.0.0.0

network 192.168.11.0

network 192.168.30.0

no auto-summary

!

ip classless

!

ip http server

!

ip access-list standard Anti-spoofing

permit 192.168.30.0 0.0.0.255

deny  any

ip access-list standard VTY

permit 10.0.0.0 0.255.255.255

permit 192.168.10.0 0.0.0.255

permit 192.168.11.0 0.0.0.255

permit 192.168.20.0 0.0.0.255

permit 192.168.30.0 0.0.0.255

!

control-plane

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

exec-timeout 15 0

logging synchronous

line vty 0 4

access-class VTY in

exec-timeout 15 0

logging synchronous

login local

!

end

!-----------------------------------------

!                S1

!-----------------------------------------

no service password-encryption

!

hostname S1

!

security passwords min-length 6

enable secret ciscoccna

!

no aaa new-model

vtp domain CCNA_Troubleshooting

vtp mode transparent

vtp password ciscoccna

ip subnet-zero

!

no ip domain-lookup

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 10

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 10

switchport mode access

!

interface range FastEthernet0/3-24

!

interface GigabitEthernet0/1

shutdown

!

interface GigabitEthernet0/2

shutdown

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan10

ip address dhcp

no ip route-cache

!

ip default-gateway 192.168.10.1

ip http server

!

control-plane

!

line con 0

exec-timeout 0 0

logging synchronous

line vty 0 4

password ciscoccna

login

line vty 5 15

no login

!

end

!-----------------------------------------

!                S2

!-----------------------------------------

no service password-encryption

!

hostname S2

!

security passwords min-length 6

enable secret ciscoccna

!

no aaa new-model

vtp domain CCNA_Troubleshooting

vtp mode transparent

vtp password ciscoccna

ip subnet-zero

!

no ip domain-lookup

!

no file verify auto

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

spanning-tree vlan 11 priority 24576

spanning-tree vlan 30 priority 28672

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

switchport access vlan 11

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 11

switchport mode access

!

interface FastEthernet0/3

switchport trunk native vlan 99

switchport trunk allowed vlan 11,30

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk native vlan 99

switchport trunk allowed vlan 11,30

switchport mode trunk

!

interface range FastEthernet0/5-24

shutdown

!

interface GigabitEthernet0/1

shutdown

!

interface GigabitEthernet0/2

shutdown

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan11

ip address 192.168.11.2 255.255.255.0

no ip route-cache

!

ip http server

!

control-plane

!

line con 0

exec-timeout 0 0

logging synchronous

line vty 0 4

password ciscoccna

login

line vty 5 15

no login

!

end

!-----------------------------------------

!                S3

!-----------------------------------------

no service password-encryption

!

hostname S3

!

security passwords min-length 6

enable secret ciscoccna

!

no aaa new-model

vtp domain CCNA_troubleshooting

vtp mode server

vtp password ciscoccna

ip subnet-zero

!

no ip domain-lookup

!

no file verify auto

!

spanning-tree mode rapid-pvst

spanning-tree extend system-id

spanning-tree vlan 11 priority 28672

spanning-tree vlan 30 priority 24576

!

vlan internal allocation policy ascending

!

!

interface FastEthernet0/1

switchport trunk allowed vlan 30

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/3

switchport trunk native vlan 99

switchport trunk allowed vlan 11,30

switchport mode trunk

!

interface FastEthernet0/4

switchport trunk native vlan 99

switchport trunk allowed vlan 11,30

switchport mode trunk

!

interface range FastEthernet0/5-24

shutdown

!

interface GigabitEthernet0/1

shutdown

!

interface GigabitEthernet0/2

shutdown

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan30

ip address 192.168.30.2 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.30.1

ip http server

!

control-plane

!

line con 0

exec-timeout 5 0

logging synchronous

line vty 0 4

password ciscoccna

login

line vty 5 15

no login

!

end

Завдання 2: Знайти і виправити всі помилки мережі

Завдання 3: Переконайтеся, що вимоги повністю задоволені

Завдання 4:   Задокументуйте виправлену мережу

Завдання 5: Завершення роботи

Стерти конфігурації і перезавантажити маршрутизатори. Від’єднайте і покладіть на зберігання кабелів. Для ПК хостів, які правильно пов'язана з іншими мережами (такими як шкільні LAN або Інтернет), підключіть відповідні кабель і відновіть параметри TCP / IP.


 

А также другие работы, которые могут Вас заинтересовать

79004. Неклассическая модель научного знания. Философский и общенаучный смысл теории относительности. Парадоксы неклассической науки 36.5 KB
  Философский и общенаучный смысл теории относительности. Эти события привели к кризису ньютоновской парадигмы классической физической теории господствовавшей в XVII первой половине XIX в. Кризис разрешился революцией в физике породившей: теорию относительности частную или специальную СТО и общую ОТО; квантовую механику нерелятивистскую и релятивистскую квантовую теорию поля; Эти теории ознаменовали переход от классической к неклассической науке. Создание теории относительности.
79005. Постнеклассическая наука, её ценностно-целевые ориентиры. Парадигма нелинейного мира 35.5 KB
  Парадигма нелинейного мира. В контексте различных и даже противоречивых концепций можно говорить о новой научной картине мира создаваемой постнеклассической наукой Процесс ее построения еще не завершен но основные контуры уже очевидны. Исходные философские идеи новой науки: единство мира заключается в том что на всех уровнях организации действуют общие законы; системное видение в противовес механическому пониманию мира; синтез детерминизма многовариантности и случайности; отказ от концепции редукционизма: нахождение изоморфных законов в...
79007. Особенности научного знания. Наука и другие формы миропостижения (философия, искусство, религия) 48.5 KB
  Ответ на вопрос о том что исследуется раскрывает природу предмета науки а ответ на вопрос о том как осуществляется исследование раскрывает метод исследования. Философия же в отличие от науки выносит универсальные суждения и стремится открыть законы всего мирового целого. В отличие от науки ценностная компонента знания неустранима из философии. Это с одной стороны натурфилософия как попытка строить универсальные картины мира без опоры на данные науки а с другой позитивизм призывающий философию отказаться от обсуждения...
79008. Роль науки в образовании и формировании современного человека 30.5 KB
  Роль науки в образовании распространяется на все компоненты образовательного процесса цели средства результаты принципы формы и методы. Образовательный процесс выступает в качестве исходной территории на которой происходит встреча индивида и науки а также его подготовка к жизнедеятельности в данном обществе формирование зрелой личности. В этой связи достаточно часты обращения к античной идее пайдейя обозначающей процесс формирования индивида включающий в себя три составляющие: воспитанность образованность и культура....
79009. Структура эмпирического и теоретического знания 47 KB
  Теоретический уровень научного познания как и эмпирический имеет ряд подуровней среди которых можно выделить следующие по степени общности: а аксиомы теоретические законы; б частные теоретические законы описывающие структуру свойства и поведение идеализированных объектов; в частные единичные высказывания утверждающие нечто о конкретных во времени и пространстве состояниях свойствах и отношениях некоторых идеализированных объектов Абстрагирование и идеализация начало теоретического познания. Научные законы регулярные...
79010. Эксперимент и наблюдение 38.5 KB
  Наблюдение и эксперимент в научном познании виды эксперимента. Существуют три основных метода опосредственного получения нового знания операциональный экспериментальный и логикоматематический. Эмпирическая процедура может выступать как средство выявления точного и однозначного физического смысла тех или иных ключевых понятий для чего в их определения должен входить метод позволяющий в каждом конкретном случае на основе эксперимента решить правильно ли применение этого понятия в данной познавательной ситуации или нет. При...
79011. Гипотеза и теория 29.5 KB
  К числу основных из них относятся проблема гипотеза теория и закон выступающие вместе с тем как формы узловые моменты построения и развития знания на теоретическом его уровне. Гипотеза научное допущение или предположение истинное значение которого не определено. Гипотеза это предположение о существовании какойто вещи явления свойства связи отношения и т. Научная гипотеза должна отвечать ряду требований главные из которых: соответствие фактам которые эта гипотеза собирается объяснить; внутренняя непротиворечивость; проверяемость;...
79012. Идеалы и нормы науки. Мотивация научной деятельности 37 KB
  Историческая изменчивость идеалов и норм рождает потребность их разумного объяснения и применения. Внутренний мотив это познавательная потребность информация заключенная в объекте на который направлено внимание человека. Познавательная потребность характеризуется следующими основными критериями: интенсивное стремление субъекта к знанию и к познавательной деятельности на основании чего избирается его направленность; активный поиск ожидание информации; формулирование вопросов задач и проблемных ситуаций; ...