69583

Практическая маршрутизация

Практическая работа

Информатика, кибернетика и программирование

При построении IP сетей особое внимание следует уделять соответствию присвоенных адресов интерфейсов маршрутизатора и подключенных кабелей. Иначе возможны ситуации когда, например, к порту маршрутизатора 1.0.0.1 подключен по невнимательности узел 2.0.0.10.

Русский

2014-10-07

3.72 MB

10 чел.

Практическая маршрутизация

Задание 1. Осуществить конфигурацию IP сети по следующей схеме.

При построении IP сетей особое внимание следует уделять соответствию присвоенных адресов интерфейсов маршрутизатора и подключенных кабелей. Иначе возможны ситуации когда, например, к порту маршрутизатора 1.0.0.1 подключен по невнимательности узел 2.0.0.10. Важно, так же не забывать сконфигурировать шлюз по умолчанию на каждом узле.

Для проверки правильности конфигурирования можно использовать, например, файловую службу Windows, которая работает на каждом компьютере, обращаясь, не по NetBIOS именам, а по IP адресам. При этом, если система не работает так, как ожидается, необходимо запускать анализатор и проводить анализ трафика в сети – это единственный способ эффективно искать и устранять неисправности.

После того, как сеть заработает, необходимо послушать трафик этой сети при передаче пакетов между узлами, обращая внимание на МАС адреса получателей в кадрах и на ARP запросы/ответы. Трафик сохранить в отдельные файлы с соответствующими названиями. 

После выполнения задания необходимо проанализировать таблицу маршрутизации на сервере-маршрутизаторе обоими средствами, сравнить результаты, проанализировать и сделать выводы о различиях таблиц маршрутизации, выдаваемых обоими средствами Windows.

Задание 2. Модифицировать сеть, применив в ней вместо классовых адресов маски переменной длины. Исходная сеть класса С 200.1.1.0, в левой сети – 100 узлов, в средней сети – 40 узлов, в правой сети – 20 узлов. Физическая сеть не демонтируется. После выполнения задачи необходимо, захватить трафик сети при передачи данных между узлами, обращая внимание на МАС адреса в заголовках кадров Ethernet и ARP запросы/ответы построить схему взаимодействия хостов в полученной сети.

Иногда, при конфигурировании IP протокола на хостах возникает следующая ошибка адресации:

На среднем узле вместо маски 255.255.255.192 ошибочно указывается маска 255.255.255.128. Тогда при проверке взаимодействия выясняется, что левый узел без проблем общается с правым (их конфигурация верна), а средний узел думает, что левый с ним в разных сетях (так оно и есть, поэтому взаимодействие возможно), а правый с ним в одной сети, следовательно ему будут напрямую посланы ARP запросы, которые он разумеется не сможет получить и на которые он, разумеется, не сможет ответить. Следовательно, коммуникации левый-средний возможны, а коммуникации средний-правый не возможны. Если доступ к настройкам неверно отконфигурированного узла временно закрыт то правильная диагностика ошибки в этом случае, возможна только с применением анализатора пакетов.

Методы проверки работы третьего уровня

Для проверки работы функций третьего уровня необходимо инициировать сетевое взаимодействие, которое, как известно, начинается обычно на прикладном уровне, т.е., например, пользователь обратился к файловой службе другого компьютера, и это привело к отправке IP пакетов, правильное прохождение которых по сети и есть цель, которую мы преследуем.

Но удобно ли для начала сетевого взаимодействия  использовать, файловую или какую-то другую службу? А вдруг такой службы на компьютере, к которому мы обращаемся, нет? Пока мы использовали обращениями к файловой службе Windows, а если придется обращаться к компьютеру с установленным Linux, компьютеру, ОС которого нам неизвестна, например, аппаратному маршрутизатору и т.д.? Даже знание операционной системы компьютера к которому мы обращаемся, не гарантирует того, что мы знаем запущенные на нем приложения, кроме того, неудобно обращаться к службам другого узла для проверки правильности работы третьего уровня, так как необходимо иметь обширный комплект клиентских приложений. Было бы хорошо, если бы на ВСЕХ узлах и маршрутизаторах поддерживающих IP, был бы компонент, которому можно было бы послать определенного типа IP пакет и получить пакет в ответ, не привязываясь к каким либо прикладным службам. Это было бы удобно, так как:

  •  Было бы универсально для любого маршрутизатора или узла – не нужно было бы думать, какое приложение использовать для проверки возможности обмена IP пакетами
  •  Было бы удобно с точки зрения программного обеспечения, необходимого для проверки возможности обмениваться IP пакетами – достаточно было бы одной программы, посылающей и принимающей такие пакеты для проверки возможности организации взаимодействия с любым узлом и маршрутизатором.
  •  Не приводило бы к интенсивному трафику при проверке работы сети: та же файловая служба Windows, как мы видели, отправляет и принимает много пакетов, которые занимают сеть и затрудняют изучение происходящего в анализаторе протоколов.

И конечно же, в стеке TCP/IP есть подобная функция. Для этого используется специальный протокол ICMP, который мы будем изучать позже, который выполняет множество важных и полезных функций. Однако нас сейчас интересует только одна функция этого протокола – возможность послать «Эхо-запрос» и получить «Эхо-ответ». Если сформировать специальным образом (изучено будет чуть позже детально) пакет «Эхо-запрос» и отправить его на любой узел, поддерживающий IP, то в ответ будет непременно сгенерирован специальный пакет «Эхо-ответ», приход которого можно зафиксировать. Т.е., если нам необходимо проверить возможность отправки пакетов на некоторый узел, мы посылаем на него «Эхо-запрос» и если «Эхо-ответ» получен, то возможность обмениваться пакетами между проверяемыми узлами есть, иначе – возможности обмениваться пакетами нет. Удобно то, что ICMP поддерживается всеми IP узлами, и нет необходимости использовать приложения на узлах, с которыми необходимо обменяться пакетами с тестовыми целями.

Сейчас протокол ICMP нами не изучается, это будет сделано несколько позднее, мы просто познакомимся с диагностическим инструментом для изучения IP сетей на данном этапе.

Рассмотрим утилиту ping.exe. Эта программа используется для генерации ICMP пакетов заданного назначения.

Пример использования ключа «-t»,

Так выглядит обмен пакетами с узлом 192.168.0.1 при помощи утилиты ping.exe.

Кроме того, при диагностике составных сетей часто не достаточно просто проверить возможность обмена IP пакетами, в случае, если обмен пакетами не возможен, так же необходимо выяснить, на каком именно маршрутизаторе происходит потеря пакета из-за неверной на строки или неправильной работы аппаратного или программного обеспечения. Для решения и этой задачи в протоколе ICMP есть специальные средства, которые так же скоро будут детально рассмотрены, а пока,  рассмотрим утилиту tracert.exe – как пример работы описанной системы.

Запуск программы tracert.exe на станции 1.0.0.10  из первого задания для проверки пути следования пакетов до станции 3.0.0.10 даст следующие результаты.

Т.е. мы получим путь следования пакетов сетевого уровня в соответсвии с настроенной маршрутизацией: в начале на адрес шлюза, а затем – как следует из схемы подключения – в адрес получателя 3.0.0.10.

Итак, на данный момент рассмотрены способы настройки маршрутизации для взаимодействия хостов в разных IP сетях объединенных одним маршрутизатором, так же представлены инструменты, позволяющие проверять работоспособность построенных конфигураций сетей не зависимо от прикладных программ, выполнемых в данный момент на взаимодействующих хостах – программы работающие с пакетами ICMP.

Далее рассмотрим построение сетей состоящих из нескольких маршрутизаторов. Рассмотрим порядок построения сети по следующей схеме:

Прежде всего, выберем, какие компьютеры могут участвовать в данной сети. В качестве маршрутизаторов выберем компьютеры, имеющие не менее двух сетевых карт (хотя это необязательно, но пока не будем усложнять) и установленную OС Windows Server. В качестве рядовых участников сети можно выбрать компьютеры, имеющие хотя бы одну сетевую карту и любую ОС.

После выбора компьютеров, как и в предыдущем примере, назначаем IP адреса интерфейсам согласно схеме.

Далее подключаем интерфейсы, при этом контролируем соответствия подключаемых интерфейсов и назначенных IP адресов. После подключения интерфейсов проверяется их взаимная достижимость внутри одной IP сети. Так, для предложенной схемы эта проверка состоит из трех этапов: в начале на одном из участников левого сегмента (например, на станции 1.0.0.10) выполняется команда ping 1.0.0.1 и в случае успеха, аналогичное действие выполняется для среднего сегмента (например, на маршрутизаторе R1) выполняется команда ping 3.0.0.2 и в случае успеха, аналогичное действие выполняется для правого сегмента (например, на станции 2.0.0.10) выполняется команда ping 2.0.0.10 и в случае успеха сеть считается подключенной правильно.

Следующим действием является включение маршрутизации на обоих маршрутизаторах в режиме «Сетевой маршрутизатор». Но одного включения службы маршрутизации недостаточно, чтобы узлы 1.0.0.10 и 2.0.0.10 могли обмениваться эхо-пакетами. Это связано с тем, что в сети присутствует не один маршрутизатор, к которому подключены все сети как в прошлом примере, а несколько маршрутизаторов. Значит, необходимо указать в таблицах маршрутизации каждого из маршрутизаторов маршруты в сети, к которым данный маршрутизатор не подключен напрямую. Для этого существует два известных нам способа работы с таблицей маршрутизации: с помощью утилиты route.exe и с помощью оснастки «Маршрутизация и удаленный доступ к сети». Эти же инструменты позволяют и манипулировать строками таблицы маршрутизации – добавлять, удалять и модифицировать строки.

Вот как выглядит процедура настройки маршрутизатора на примере R1.

В начале переименуем подключенные инетрфейсы по порядку подключения сетевых карт в систему – первая карта eth0 (Ethernet № 0), вторая карта eth1 (Ethernet № 1). Присвоим каждому интерфейсу свой IP адрес и маску, позиции шлюза оставляем не заполненными.

Далее выбираем в левом поле консоли оснастку «Статические маршруты» (Static Routes), и в контекстном меню выбираем «Новый статический маршрут» (New Static Routes).

Заполняем предложенную форму следующим образом

Поле «Интерфейс» (Interface) содержит обозначение интерфейса который будет использоваться для реализации создаваемого маршрута – в нашем случае записывается маршрут в сеть 2.0.0.0 , а из схемы подключения следует, что эта сеть достигается если пакет выпущен из интерфейса с адресом 3.0.0.1, обозначенного нами как eth1.

Поле «Направление» (Destination) содержит адрес сети в которую создается маршрут – в нашем случае маршрут создается в сеть 2.0.0.0.

Поле «Маска сети» (Network Mask) содержит маску сети в которую создается маршрут. Как вы помните, маска используется для отбора пакетов прибывающих на маршрутизатор для отправки по создаваемому маршруту – в нашем случае это маска 255.0.0.0 , т.е. пакеты, в адресе получателя которых будет первый байт равный 2, будут отправлены по создаваемому нами маршруту и так будет до тех пор пока не будет создан маршрут в сеть, начинающуюся с 2 но с более длинной маской – в этом случае логика работы усложнится.

Поле «Шлюз» (Gateway) содержит адрес следующего маршрутизатора на который нужно переслать пакет для достижения сети назначения. В нашем случае, в соответствии со схемой это адрес 3.0.0.2.

Вот как выглядит созданный маршрут

Для удаления используется правый клик на строке маршрута и выбор пункта контекстного меню «Удалит» (Delete)

Маршруты, создаваемые в оснастке «Маршрутизация и удаленный доступ» сохраняются и после перезагрузки ситемы.

Так же возможно создавать маршруты при помощи консоли. Для это используют команду route.

route add  опция добавления маршрута

  1.  адрес сети в которую создается маршрут

mask   опция указывающая, что дальше будет записана маска

  1.  маска для создаваемого маршрута
    1.  адрес следующего маршрутизатора

При добавлении ключа –p созданный маршрут остается и после перезагрузки  операционной системы или рестарта интерфейса – в противном случае маршрут исчезает. О добавлении Постоянного маршрута (Persistent routes) свидетельствует так же соответсвующая запись внизу таблицы маршрутизации.

  

Удаление созданного маршрута независимо от типа (постоянный или нет) происходит при помощи опции delete

Аналогично конфигурируем R2. После чего проверим работоспособность созданной сети при помощи команды ping. Запустим ping на станции 1.0.0.10

C:\>ping 2.0.0.10 –t

И проанализируем фрагменты трафика на каждом участке следования пакетов

На участке 1.0.0.10 – 1.0.0.1

В начале станция 1.0.0.10 широковещательным ARP запросом разрешает МАС адрес шлюза 1.0.0.1 и получив ответ отправляет эхо-запрос в адрес 2.0.0.10 на интерфейс шлюза 00:02:44:7e:5b:28. Эхо-ответы от станции 2.0.0.10 приходят так же с интерфейса маршрутизатора 00:02:44:7e:5b:28.

На участке  3.0.0.1 – 3.0.0.2, т.е. на участке между маршрутизаторами взаимодействия происходят аналогично. Обратите внимание – изменяется только канальный уровень взаимодействия – при этом полностью сохраняется инкапсуляция сетевого уровня.

В начале R1 разрешает МАС адрес следующего маршрутизатора с IP адресом 3.0.0.2. После чего отправляет запросы в соответсвии с маршрутом на интерфейс маршрутизатора 00:02:44:7e:5b:83. Эхо-ответы от станции 2.0.0.10 в адрес станции 1.0.0.10 приходят так же с интерфейса  следующего маршрутизатора в соответсвии с его маршрутом в сеть 2.0.0.0.

На участке 2.0.0.1-2.0.0.10 так же в начале происходит выяснение МАС адреса получателя, так как пакет предназначается в подключенную сеть – после чего осуществляется передача эхо-запроса в адрес получателя. Эхо-ответ от станции 2.0.0.10 в адрес 1.0.0.10 направляется на шлюз в соответствии с настройками маршрутизации, т.е. на шлюз по умолчанию.

Приведенные выше фрагменты взаимодействия на каждом участке составной сети практически подтверждают идею межсетевого взаимодействия на третьем уровне – т.е. форма передачи информации на третьем уровне не изменяется на всем пути следования – изменяется лишь транспорт доставки – в нашем случае это заголовки канального уровня Ethernet. Но для того что бы такая передача осуществлялась, т.е. что бы пакеты в составной сети передавались в нужном направлении необходима верная настройка маршрутизации так как именно маршрутные таблицы и адреса шлюзов являются основными инструментами для реализации маршрута передачи пакетов в составной сети.

Рассмотрим, как выглядит таблица маршрутизации узла, на примере 2.0.0.10.

Первая строчка таблицы описывает «Маршрут по умолчанию» через шлюз 2.0.0.1. Следующая строка описывает маршрут в свою сеть, маршрут реализуется через интерфейс подключенный в сеть. Третья строчка описывает маршрут к своему интерфейсу – маршрут реализуется через Loop Back (Обратной петли) интерфейс – что означает в нашем случае, что адрес 2.0.0.10 является адресом интерфейса подключенного в систему. Четвертая строчка описывает широковещание в сеть 2.0.0.0 или в «заданную» сеть – запись используется в случае если адрес сети получателей известен. Следующая строчка описывает маршрут в сеть интерфейса обратной петли, и говорит что адрес интерфейса 127.0.0.1. Предпоследняя строчка описывает нулевую группу мультикаст. И последняя строчка – описывает широковещание в свою сеть. Как видно, таблица маршрутизации на узле имеет полное сходство с таблицей маршрутизации на шлюзе, разница заключается только в количестве интерфейсов.

Добавление и удаление записей в таблицу маршрутизации узла выполняется из командной строки при помощи команды route так же как и для сервера.

Итак, мы рассмотрели простейшее конфигурирование маршрутизатора на базе Windows Server. В дальнейшем в этом курсе мы рассмотрим дополнительные возможности этого программного маршрутизатора по мере изучения еще ряда технологий, связанных с IP маршрутизацией. Пока же мы временно отложим изучение маршрутизатора в Windows.

Рассмотрим инструменты для самостоятельно работы в домашних условиях, с помощью которого можно отрабатывать навыки конфигурирования маршрутизатора имея в своем распоряжении даже один компьютер.

Вспомним уже использовавшуюся нами технологию виртуальных машин. С помощью VMWare можно построить простейшую сеть с маршрутизацией даже на одном виртуальном компьютере. При этом доступны следующие функции:

  •  взаимодействие между различными виртуальными машинами запущенными одновременно на одном компьютере
  •  взаимодействие между виртуальной машиной и хост компьютером.
  •  разделение с хост машиной подключенных  сетевых адаптеров

Описанные функции реализуются меню Edit-Virtual Network Settings

В случае если на хост компьютере установлена одна сетевая карта, то настройка имеет вид

Если же сетевых карт две, то

Т.е. в этом случае каждой виртуальной сети назначается свой сетевой адаптер, соответственно для каждой виртуальной машины назначается своя виртуальная сеть. Маршрутизатором в данном случае выступает хост компьютер.

Для первой виртуальной машины (Windows XP Professional) настройка имеет вид

Для второй виртуальной машины (Windows 2000 Professional) настройка имеет вид

В предыдущих версиях VMWare настройка имеет вид

В результате получится, что первая виртуальная машина в одной сети с первым сетевым адаптером хост машины, вторая виртуальная машина в одной сети со вторым сетевым адаптером хост машины, и теперь на хост машине можно запустить маршрутизацию между двумя сетями, которым она принадлежит, причем в каждой сети будет по одному узлу на виртуальных машинах.

Но, в общем случае, не получится сделать сеть с многими маршрутизаторами, так как с помощью VMWare в одну виртуальную машину можно передать только один сетевой адаптер, и кроме того нельзя запустить виртуальную машину из под виртуальной машины. Но если в вашем распоряжении есть два компьютера соединенные в сеть, то, установив на каждом из  них по виртуальной машине, можно построить сеть из 4 машин, в которой будет два маршрутизатора и их соединит реальная сеть.

Итак, на данный моент нами рассотрены методы конфигурирования маршрутизатора в Windows в простейшем случае, когда вся настройка ограничивается лишь конфигурированием интерфейсов и статических маршрутов. Разумеется, этого не достаточно, чтобы говорить об умении полностью использовать возможности службы «Маршрутизация и удаленный доступ  сети». Однако, построение IP сетей осуществляется не только маршрутизаторами на базе ОС Windows Server но и при помощи аппаратных маршрутизаторов. На сегодняшний день рынок аппаратных маршрутизаторов насчитывает достаточное количество производителей в различных ценовых категориях. Значительная доля продукции Cisco на этом рынке, говорим о том, что именно маршрутизаторы этой компании являются во многих случаях наиболее популярными, и именно модели этой фирмы рассматриваются в качестве классических примеров конфигурации аппаратных маршрутизаторов.

Для изучения основных приемов конфигурации аппаратных маршрутизаторов Cisco мы будем использовать программные эмуляторы. Сегодня мы начинаем с комплекса Boson NetSim.

До начала работы по конфигурированию сети необходимо нарисовать ту сеть, которую затем мы будем настраивать с помощью Network Designer, а затем загрузить сохраненную сеть в сам NetSim.

Например:

  1.  Запускаем дизайнер.

  1.  Выбираем самую простую серию 800, в ней выбираем маршрутизатор с двумя портами Ethernet – 808. Выносим на поле справа.

  1.  Выбираем пару свичей и рабочих станций, и также переносим на поле справа

  1.  Получаем примерно такой рисунок (файл, описывающий данную сеть приложен, 1router.top):

  1.  Соединяем участников схемы. Например, правый клик на РС2

т.е. мы выбираем подключение к сетевой карте РС2 Ethernet 0, т.к. карта одна, далее

т.е. мы выбираем подключение в свич 1на интерфейсc свича Ethernet 0/1.

И так далее для каждого участника схемы. После подключения схема имеет вид

После создания, сохраняем схему в файл используя стандартную команду меню File. И выбираем в том же меню опцию загрузки в NetSim

Теперь переходим к конфигурированию. Начнем с конфигурирования узлов. Очевидно, что для того, чтобы научится конфигурировать узлы с Windows, нам не нужен никакой эмулятор. Так же очевидно, что разработчикам NetSim не был совершенно никакого резона качественно эмулировать конфигурирование адреса и маски на рабочей станции – это может сделать каждый на реальных  системах. Поэтому разработчики пошли по следующему пути: конфигурирование узла совершенно не похоже в данном эмуляторе на конфигурирование реального узла – просто нужно настроить узлы в соответствии с правилами принятыми в данному эмуляторе, а затем переходит к конфигурированию маршрутизаторов, которое выполнено в данном программном продукте хорошо.

Пример конфигурирование узла с помощью команды ipconfig.

И после  появления внизу экрана приглашения вида C:\>

Конфигурируем PC1:

ipconfig /ip 10.0.0.10 255.0.0.0

ipconfig /dg 10.0.0.1

Конфигурируем PC2:

ipconfig /ip 192.168.0.10 255.255.255.0

ipconfig /dg 192.168.0.1

Обратите внимание, узлы в реальной Windows так не конфигурируются, но в данном эмуляторе достоверность конфигурирования узлов и не нужна.

Переходим к настройке маршрутизатора.

Маршрутизатор Cisco (точнее его операционная система IOS) может предлагать пользователю несколько консолей с различным уровнем привилегий для выполнения различных задач. Пока рассмотрим этот вопрос упрощенно.

Первая консоль с приглашением Router>. В этом режиме администратор может пользоваться командой ping, traceroute и командой show. Команда show используется для просмотра конфигурации роутера.

Для перехода в привилегированный режим используется команда enable. Вход в привилегированный режим можно защитить паролем. Подтверждением перехода в указанный режим является изменения приглашения на Router#

Для настройки интерфейсов и маршрутизации необходимо перейти в режим конфигурирования. Конфигурировать можно с консоли (терминала), так же можно загрузить настройки из сети и не только, но пока нас интересует именно конфигурирование с терминала.

Для начала конфигурирования используется команда configure terminal, подтверждением перехода в режим конфигурирования является изменение приглашения на Router(config)# . Для того, чтобы нарисованная сеть работала, нам необходимо настроить адреса интерфейсам, а таблица маршрутизации получится автоматически так как все сети подключены. Следовательно, наша задача «минимум» - сконфигурировать интерфейсы нашего маршрутизатора. Пример настройки маршрутизатора:

Сначала выбираем интерфейс. Выведем список продолжения команды interface 

Router(config)#interface ?

Выбираем нужный интерфейс:

Router(config)#interface Ethernet 0

Выведем список команд:

Router(config-if)#?

Просмотрим синтаксис команды ip:

Router(config-if)#ip ?

Для назначения IP адреса, выясним синтаксис команды ip address

Router(config-if)#ip address ?

Задаем адрес:

Router(config-if)# ip address 10.0.0.1 255.0.0.0

Теперь интерфейс получил адрес, проверим командой show

Выведем show interfaces

Router#show interfaces

Обратите внимание, интерфейс Ethernet 0 находится в состоянии административного отключения, следовательно, настройки адреса недостаточно, интерфейс еще необходимо включить. Что бы посмотреть состояние не всех интерфейсов, а только нужного используют сочетание:

Router#show interfaces Ethernet 0

Как включить интерфейс? Для это используют сочетание

Router(config-if)#no shutdown

Возвращаемся в на предыдущий уровень командой exit.

Router(config-if)#exit

Снова смотрим состояние интерфейса:

Router#show interfaces Ethernet 0

Обратите внимание, применение команды no универсально, например, при необходимости отменить назначенный интерфейсу ip адрес дается команда

Router(config-if)#no ip address

Аналогично конфигурируем интерфейс Ethernet 1.

Router(config)#interface Ethernet 1

Router(config-if)# ip address 192.168.0.1 255.255.255.0

Router(config-if)#no shutdown

Проверим состояние интерфейса

Router#show interfaces Ethernet 1

Интерфейсы настроены.

Проверим, могут ли порты маршрутизатора обмениваться пакетами со станциями в подключенных сетях:

Router#ping 192.168.0.10

Router#ping 10.0.0.10

Теперь посмотрим ARP кэш маршрутизатора

Router#show arp

Выведем настройки ip на интерфейсах:

Router#show ip interface

Выведем индивидуально настройки по каждому интерфейсу..

Router#show ip interface Ethernet 0

Router#show ip interface Ethernet 1

Просмотрим таблицу маршрутизации:

Router#show ip route

Проанализируем таблицу маршрутизации

Обратите внимание, в таблице присутствует только две стоки о подключенных сетях в отличие от маршрутизатора в Windows, но это не значит, что данный маршрутизатор не умеет обрабатывать широковещательные, групповые пакеты, или пакета направленные его интерфейсам. Просто об этом нет записей в таблице маршрутизации – имеет место другой подход.

Теперь, когда маршрутизатор настроен, необходимо проверить, могут ли узлы обмениваться пакетами:

С узла 1 запускаем ping на узел 2

и наоборот

При конфигурировании сети были использованы команды:

Enable   - переход в привилегированный режим

configure terminal - переход в режим конфигурации

interface   - выбор интерфейса для конфигурирования

ip address  - назначение IP адреса интерфейсу 

no ip address  - отмена IP адреса интерфейса

shutdown   - выключение интерфейса

no shutdown  - включение интерфейса

show arp   - вывод содержимого arp кэша

show interfaces - вывод информации по интерфейсам

show ip route  - вывод таблицы маршрутизации.

Конфигурация этой сети сохранена в папке 1router.

Теперь усложним задачу: пусть в сети два маршрутизатора и есть необходимость вносить записи в таблицу маршрутизации вручную:

Пример конфигурации сети:

PC1:

C:\>ipconfig /ip 1.0.0.10 255.0.0.0

C:\>ipconfig /dg 1.0.0.1

PC2:

C:\>ipconfig /ip 2.0.0.10 255.0.0.0

C:\>ipconfig /dg 2.0.0.1

Router1:

Router>enable

Router#configure terminal

Router(config)#interface ethernet0

Router(config-if)#ip address 3.0.0.1 255.0.0.0

Router(config-if)no shutdown

Router(config)#interface ethernet1

Router(config-if)#ip address 1.0.0.1 255.0.0.0

Router(config-if)no shutdown

Router2:

Router>enable

Router#configure terminal

Router(config)#interface ethernet0

Router(config-if)#ip address 3.0.0.2 255.0.0.0

Router(config-if)no shutdown

Router(config)#interface ethernet1

Router(config-if)#ip address 2.0.0.1 255.0.0.0

Router(config-if)no shutdown

Все интерфейсы настроены, проверим с помощью ping взаимодействие соседних интерфейсов. Обмена пакетами между станциями нет, так как нет маршрутов на обоих маршрутизаторах в неподключенные сети. Добавим эти маршруты, при помощи команды команду ip route:

Router1:

Router(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.2

Router2:

Router(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

Выведем таблицу маршрутизации обоих маршрутизаторов.

Router#show ip route

Для первого маршрутизатора

Для второго маршрутизатора

Таблица содержит введенные нами статически маршруты:

Конфигурация этой сети охранена в папке 2routera.

Продолжаем рассматривать построение сетей при помощи аппаратных роутеров.

Рассмотрим пример сети:

Есть некоторая компания, подключившая свою сеть к Интернет с помощью провайдера и получившая в свое распоряжение идентификатор класса С 210.1.1.0. Эта компания установила в своем офисе маршрутизатор, подключила его глобальной линий связи к провайдеру (провайдер адресовал сеть точка-точка из своего диапазона адресов), и использует свой диапазон класса С не разбивая его на подсети, так как не имеет в этом потребности. Тогда в таблице маршрутизации маршрутизатора клиента будет только одна запись помимо записи о подключенной сети – запись о маршруте по умолчанию, требующая передать все пакеты на все адреса (кроме внутренних) маршрутизатору провайдера по адресу 198.1.2.1. В свою очередь в таблице маршрутизатора провайдера существует в общем случае множество записей о маршрутах к множеству сетей а Интернет, но для данного клиента у маршрутизатора провайдера есть только одна запись: все пакеты в сеть класса С (210.1.1.0/24) отправлять на 198.1.2.2. Представим себе, что компании пришлось по мере роста сети разбить свою сеть на подсети неравной длины, например в центральном офисе компании сеть разделена на две части, подсеть 1 содержит 100 узлов, подсеть 2 содержит 50 узлов. Кроме того у компании появился удаленный филиал, в котором 20 узлов и еще необходимо адресовать сеть из двух узлов для глобальной сети между маршрутизаторами компании (см .рисунок).  Какова будет теперь таблица маршрутизации маршрутизатора компании, который подключен к провайдеру? В этой таблице автоматически появятся записи уже не о двух, а о четырех подключенных сетях, так администратору компании же будет необходимо добавить маршрут в сеть 210.1.1.192/27 через 210.1.1.225 и по-прежнему будет строка о маршруте 0.0.0.0/0 на провайдера (на адрес198.1.2.1). таблица маршрутизации маршрутизатора установленного на филиале очень проста: в ней кроме записей о подключенных сетях необходимо сделать запись о маршруте к 0.0.0.0/0 через 210.1.1.226. Всю эту работу необходимо проделать администратору компании если он хочет разбить свою сеть на подсети. А что должен сделать провайдер для того, чтобы учесть изменения в сети клиента?

До модификаций, сделанных клиентом, у провайдера была про сети клиента только одна запись в таблице маршрутизации: 210.1.1.0/24 через 198.1.2.2. Что теперь? Теперь у клиента 4 сети и в таблице маршрутизации провайдера тоже можно попробовать сделать четыре записи:

Network   Gateway

210.1.1.0/25  198.1.2.2

210.1.1.128/26  198.1.2.2

210.1.1.192/27  198.1.2.2

210.1.1.224/30  198.1.2.2

Но при этом, очевидно, что все эти маршруты можно агрегировать строкой вида:

Network   Gateway

210.1.1.0/24  198.1.2.2

Таким образом маршрутизатору провайдера нет нужды менять своею таблицу: как ни режь на куски свое адресное пространство клиент, все равно все его 255 IP адресов остаются доступными для маршрутизатора провайдера через порт 192.1.2.2, поэтому провайдер ничего не должен делать в случае, если клиент разбивает свою сеть на подсети, а это значит, что клиент волен разбивать свою сеть на подсети не отдавая в этом никому отчета, в том числе и провайдеру! По сути, мы обсуждали уже это в предыдущих уроках, но скорее как факт, еще не зная как работает маршрутизатор, теперь же мы можем не только понять со всей ясностью, почему это так, но и убедиться в этом прямым экспериментом.  

Может возникнуть еще один вопрос – перечисленные сети формально говоря нельзя агрегировать описанным способом, так как у клиента осталось еще некоторое количество адресного пространства, и лишь когда он его израсходует, можно будет говорить об агрегировании ВСЕХ клиентских подсетей в сеть класса С 210.1.1.0, но клиент же все равно оставить все свои подсети ЗА маршрутизатором провайдера, следовательно маршрут для маршрутизатора провайдера не изменится ни при каких обстоятельствах.

Сымитировать описанную выше ситуация с помощью Boson NetSim. Сначала построим и сконфигурируем первоначальную неразбитую на подсети сеть. Затем изменим структуру сети клиента и убедимся, что все будет продолжать работать без изменения настроек маршрутизатора провайдера.

Создаем сеть в Boson Network Designer. Сымитирует Интернет одним узлом, подключенным к провайдеру – именно с ним будут проверять связь узлы из клиентской сети для проверки возможности доступа к Интернет, именно с этого узла можно будет проверить доступность из Интернет всех узлов клиента. 

PC1 – узел в Интернет (адрес 1.1.1.2)

PC2 – узел в сети клиента (210.1.1.10)

Router1 – маршрутизатор провайдера (второй интерфейс в одной сети с узлом Интернет, адрес интерфейса 1.1.1.1)

Router2 – маршрутизатор клиента

Сконфигурируем эту систему в Boson NetSim. На втором маршрутизаторе создадим маршрут по умолчанию на маршрутизатор провайдера, на маршрутизаторе провайдера создадим маршрут в сеть 210.1.1.0/24. По ходу выполнения задания возникнет один нюанс, не рассмотренный ранее – конфигурирование Serial интерфейса. Во-первых, при конфигурировании Serial интерфейса возникает вопрос о скорости этого интерфейса. Скорость устанавливается в режиме конфигурации интерфейса командой clock rate.

Во-вторых, возникает вопрос о том, какой протокол канального уровня (ppp или hdlc) использовать. Меняем инкапсуляцию на ppp.

Serial интерфейс не поднимается при попытке подачи команды no shutdown если не поднят интерфейс с другой стороны соединения, если не задан clock rate и если не совпадает протокол канального уровня с двух сторон соединения. При последующем конфигурировании второй стороны работа интерфейса начинается автоматически.

Полностью сконфигурированный пример находится в папке \before.

Вторая часть задания: построить сеть после того, как клиент произвел разделение своей внутренней сети на подсети.

PC1 – узел в Интернет (адрес 1.1.1.2)

PC2 – узел в первой подсети клиента (210.1.1.10)

PC3 – узел во второй подсети клиента (210.1.1.130)

PC4 – узел в третьей подсети клиента (210.1.1.200)

Router1 – маршрутизатор провайдера (второй интерфейс в одной сети с узлом Интернет, адрес интерфейса 1.1.1.1)

Router2 – маршрутизатор клиента, подключенный к провайдеру

Router3 – удаленный маршрутизатор клиента

Конфигурируем маршрутизаторы:

Router1:

Router1>enable

Router1#configure terminal

Router1(config)#interface ethernet 0

Router1(config-if)#ip add 1.1.1.1 255.0.0.0

Router1(config-if)#no shutdown

Router1(config-if)#interface serial 0

Router1(config-if)#ip add 198.1.2.1 255.255.255.252

Router1(config-if)#clock rate 19200

Router1(config-if)#encapsulation ppp

Router1(config-if)#no shutdown

Router1(config-if)#exit

Router1(config)#ip route 210.1.1.0 255.255.255.0 198.1.2.2

Router2:

Router2>enable

Router2#configure terminal

Router2(config)#interface ethernet 0

Router2(config-if)#ip add 210.1.1.1 255.255.255.128

Router2(config-if)#no shutdown

Router2(config)#interface ethernet 1

Router2(config-if)#ip add 210.1.1.129 255.255.255.192

Router2(config-if)#no shutdown

Router2(config-if)#interface serial 0

Router2(config-if)#ip add 198.1.2.2 255.255.255.252

Router2(config-if)#encapsulation ppp

Router2(config-if)#no shutdown

Router2(config-if)#interface serial 1

Router2(config-if)#ip add 210.1.1.226 255.255.255.252

Router2(config-if)#clock rate 19200

Router2(config-if)#encapsulation ppp

Router2(config-if)#no shutdown

Router2(config-if)#exit

Router2(config)#ip route 210.1.1.192 255.255.255.224 210.1.1.225

Router2(config)#ip route 0.0.0.0 0.0.0.0 198.1.2.1

Router3:

Router3>enable

Router3#configure terminal

Router3(config)#interface ethernet 0

Router3(config-if)#ip add 210.1.1.193 255.255.255.224

Router3(config-if)#no shutdown

Router3(config-if)#interface serial 0

Router3(config-if)#ip add 210.1.1.225 255.255.255.252

Router3(config-if)#encapsulation ppp

Router3(config-if)#no shutdown

Router3(config-if)#exit

Router3(config)#ip route 0.0.0.0 0.0.0.0 210.1.1.226

Полностью сконфигурированный пример находится в папке \after.

Обратите внимание на строку в таблице маршрутизации Router1:

Router1(config)#ip route 210.1.1.0 255.255.255.0 198.1.2.2

Это означает, что маршрутизатору провайдера совершенно не нужно знать внутреннюю структуру сети клиента.

После настройки необходимо проверить все таблицы маршрутизации и запустить ping с каждого узла на каждый, убедившись, что все узлы системы могут взаимодействовать друг с другом.

Задание для самостоятельной работы: 

- создать конфигурацию описанной выше сети самостоятельно.


 

А также другие работы, которые могут Вас заинтересовать

82912. Співучі труби. Мідні духові 33 KB
  Мета: поглибити знання про духові інструменти познайомити із мідною духовою групою особливостями звучання інструментів що входять до її складу; підвести учнів до усвідомлення значимості мідних духових інструментів для; розвивати музичну пам’’ять спостережливість...
82913. Причини виникнення пожежі – порушення правил протипожежної безпеки. Правила поведінки під час виникнення пожежі 46.5 KB
  Вогонь Правильно а звідки береться вогонь Відгадайте ще одну загадку. І мають душу щедру Хоч дерева сини Згоряючи до щенту Вогонь дають вони. Бесіда Отже сьогодні ми поговоримо про вогонь. Вогонь як ви знаєте може бути добрим другом для людини але може бути і страшним ворогом який забирає життя.
82914. Вода та її властивості 180 KB
  Давайте пригадаємо що таке природа На які групи вона поділяється Повітряземля і водаце природа Природа це я і ти це природа.вода Гостею нашого сьогоднішнього уроку буде вода а наша краплинка просто відірвалась від неї. Хто пригадає: який колір має вода смак запах Сьогодні краплинка хоче розповісти нам про властивості води.
82915. Лісові зони світу 33.5 KB
  Що побачили куди потрапили Чому це ліс Які ознаки лісу знаєте це великі ділянки землі на яких ростуть дерева розташовані близько одне від одного. Проте ліс – це не тільки дерева але й інші рослини і тварини які живуть серед дерев. Кожна група рослин утворює свій поверх ярус...
82916. Зелене диво Землі — рослини. Різноманітність живих організмів. Значення рослин у природі та житті людей 52.5 KB
  Мета: продовжити формувати поняття природа нежива і жива, уявлення про царства живої природи, значення рослин, різноманітність рослин на землі, про види рослин; продовжити виробляти навички дослідницької роботи та спостереження; розвивати логічне мислення, виховувати естетичні почуття.
82917. Як розмножуються тварини 265.5 KB
  Мета: ознайомити учнів з особливостями розмноження комах, риб, плазунів, земноводних, птахів, звірів; розвивати вміння спостерігати, аналізувати, порівнювати, робити висновки; виховувати пізнавальний інтерес до природи, бажання досліджувати, берегти і вивчати природу.
82918. Крымские горы, урок правоведения 65.5 KB
  Ознакомить учеников с географическим положением климатом растительным и животным миром Крымских гор; развивать познавательный интерес наблюдательность творческие навыки; воспитывать любовь и бережное отношение к природе патриотические и эстетические чувства; Оборудование: компьютер мультимедийный экран проектор мультимедийная презентация Крымские горы слайды с картой Крымских гор картины и фотографии с изображением изучаемых объектов демонстрационные материалы карточки для индивидуальной работы учебник для 4 класса...
82919. Басни И.А.Крылова 197.5 KB
  Урок сопровождается презентацией в которой отражается каждое из заданий Игра проверяет знания по басням: Ворона и Лисица Стрекоза и муравей Слон и Моська Кукушка и петух Мартышка и очки Зеркало и обезьяна Лебедь Щука и Рак Чиж и голубь Заяц на ловле Задачи урока: 1 закрепить знания учащихся о жанре басни и баснях...
82920. Визначні місця Лондона 69 KB
  London is the most interesting place in the world. There are about 10 thousand streets in London. About eight million people live in the city. There are a lot of bridges over the Thames. Tower Bridge is the most famous. It is more than 100 years old. From Tower Bridge you can see the Tower of London.