71373

Маршрутизація в мережах TCP/IP

Лабораторная работа

Информатика, кибернетика и программирование

Встановити і налаштувати відповідно до варіанта маршрутизатори для протоколу IPv4 на базі Quagga. Маршрутизатори повинен поширювати інформацію про безпосередньо приєднані мережі. Зібрати схему GNS3 представлену на рисунку 1.

Украинкский

2014-11-06

5.23 MB

0 чел.

Лабораторна робота №4 

Маршрутизація в мережах TCP/IP

Завдання на лабораторну роботу:

1. Встановити і налаштувати відповідно до варіанта маршрутизатори для протоколу IPv4 на базі Quagga. Маршрутизатори повинен поширювати інформацію про безпосередньо приєднані мережі.

2. Зібрати схему GNS3 представлену на рисунку 1.

Рисунок 1 – схема мережі

3. Маршрутизатори під’єднанні, за допомогою захвату віртуальної машини GNS, хости імітуються за допомогою VPCS GNS3. На комутаторі і головному маршрутизаторі налаштовано VLAN.

Варіанти завдань:

варіанту

Протокол

IF1

IF2

IF3

VLAN ID

1

RIP

192.168.1.1/24

192.168.3.2/24

172.20.0.3/16

2,4

2

RIP

192.168.2.1/24

192.168.1.2/24

172.21.0.3/16

3,2

3

RIP

192.168.3.1/24

192.168.2.2/24

172.22.0.3/16

4,3

4

RIP

10.18.51.65/26

10.18.51.194/26

192.168.5.3/24

5,7

5

RIP

10.18.51.129/26

10.18.51.66/26

192.168.6.3/24

6,5

6

RIP

10.18.51.193/26

10.18.51.130/26

192.168.7.3/24

7,6

7

OSPF

172.16.1.1/24

172.16.3.2/24

192.168.8.3/24

8,10

8

OSPF

172.16.1.2/24

172.16.2.1/24

192.168.9.3/24

9,8

9

OSPF

172.16.3.1/24

172.16.2.2/24

192.168.10.3/24

10,9

10

RIP

172.17.0.1/16

172.19.0.2/16

192.168.11.3/24

11,13

11

RIP

172.18.0.1/16

172.17.0.2/16

192.168.12.3/24

12,11

12

RIP

172.19.0.1/16

172.18.0.2/16

192.168.13.3/24

13,12

13

OSPF

192.168.4.1/28

192.168.4.34/28

172.23.0.3/16

14,16

14

OSPF

192.168.4.17/28

192.168.4.2/28

172.24.0.3/16

15,14

15

OSPF

192.168.4.33/28

192.168.4.18/28

172.25.0.3/16

16,15

16

RIP

192.168.3.2/24

192.168.1.1/24

172.20.0.3/16

3,5

17

RIP

192.168.1.2/24

192.168.2.1/24

172.21.0.3/16

2,3

18

RIP

192.168.2.2/24

192.168.3.1/24

172.22.0.3/16

2,7

19

RIP

10.18.51.194/26

10.18.51.65/26

192.168.5.3/24

4,1

20

RIP

10.18.51.66/26

10.18.51.129/26

192.168.6.3/24

12,2

21

RIP

10.18.51.130/26

10.18.51.193/26

192.168.7.3/24

7,8

22

OSPF

172.16.3.2/24

172.16.1.1/24

192.168.8.3/24

9,10

23

OSPF

172.16.2.1/24

172.16.1.2/24

192.168.9.3/24

11,8

24

OSPF

192.168.4.33/28

172.16.3.1/24

192.168.10.3/24

6,9

25

RIP

172.19.0.2/16

172.17.0.1/16

192.168.11.3/24

4,7

26

RIP

172.17.0.2/16

172.18.0.1/16

192.168.12.3/24

5,9

27

RIP

172.18.0.2/16

172.19.0.1/16

192.168.13.3/24

15,5

28

OSPF

192.168.4.34/28

192.168.4.1/28

172.23.0.3/16

3,9

29

OSPF

192.168.4.2/28

192.168.4.17/28

172.24.0.3/16

9,4

30

OSPF

192.168.4.33/28

172.25.0.3/16

192.168.4.18/28

11,12

Приклад виконання 30-го варіанту завдань:

  1. Запустити ОС FreeBSD за допомогою віртуальної машини та виконати вхід під користувачем root.
  2. За допомогою програми WinSCP через ssh завантажимо інсталяційні пакети:

1

2

Користувач

Адреса інтерфейсу em1

2

1

1

  1. Перейдемо в створений каталог в системі (цей каталог знадобиться в майбутньому для встановлення інших додаткових пакетів, не варто його знищувати):

cd /home/asd/packages

  1. Виконаємо інсталяцію пакета quagga

pkg_add quagga-0.99.21.tbz

Щоб встановити пакет існує велике різноманіття способів, але вони всі потребують підключення інтернету, а також встановлюють найновішу версію пакету ака може суттєво відрізнятись від потрібною, тому щоб було менше проблем в налаштуванні все-таки рекомендується ставити версії пакетів які надані викладачем.

  1. Скопіювати конфігураційні файли і виконаємо обов’язкові налаштування:

cp /usr/local/share/examples/quagga/zebra.conf.sample /usr/local/etc/quagga/zebra.conf

cp /usr/local/share/examples/quagga/ospfd.conf.sample /usr/local/etc/quagga/ospfd.conf

echo "quagga_enable="YES"">>/etc/rc.conf // дозволити запуск програми

echo "gateway_enable="YES"">>/etc/rc.conf // машина являється шлюзом

Спробуємо запустити

/usr/local/etc/rc.d/quagga start

Тепер вимкнемо машину

shutdownp now

3

  1. Скопіюємо віртуальну машину, щоб створити FreeBSDv30COPY і ще одну копію головного маршрутизатора для збереження налаштувань, так як GNS3 може їх знищити

1

3

2

1

Для єкономії місця копія буде «Сполоученою», якщо проблем з вільним простором не виникає можна робити повні копії

2

1

Так само пробимо вовторно для FreeBSDv30COPY

  1. Синхронізуємо FreeBSDv30COPY і FreeBSDv30-2 з GNS3

1

2

1

3

2

1

  1. Налаштуємо мережу в GNS3

Так має виглядати мережевий інтерфейс C1 VPCS

Так має виглядати мережевий інтерфейс C2 VPCS (цими новоствореними інтерфейсами VPCS мають бути під’єднанні до комутатора)

Налаштування віртуальних мереж на комутаторі, всі системи мають бути з’єднані з комутатором, як показано на першому рисунку за допомогою Manual дроту (для зручності)

  1. Запустимо створені віртуальні машини через GNS3

  1. Проведемо налаштування мережевих інтерфейсів на віртуальній машині FreeBSDv30-2

Задамо адресу інтерфейсу (теж саме що і vlan1):

echo "ifconfig_em2="inet 192.168.4.18 netmask 255.255.255.240"" >> /etc/rc.conf

Створимо два віртуальні інтерфейси:

echo "cloned_interfaces="vlan1 vlan2"" >> /etc/rc.conf

Налаштування віртуальних інтерфейсів:

echo "ifconfig_vlan1="inet 192.168.4.33/28 vlan 11 vlandev em2"" >> /etc/rc.conf

echo "ifconfig_vlan2="inet 172.25.0.3/16 vlan 12 vlandev em2"" >> /etc/rc.conf

Щоб налаштування застосувались виконаємо команду /etc/rc.d/netif restart або перезавантажемо систему.

  1. Проведемо налаштування мережевих інтерфейсів на віртуальній машині FreeBSDv30COPY

echo "ifconfig_em1="inet 192.168.4.19 netmask 255.255.255.240"" >> /etc/rc.conf

  1. Проведемо налаштування мережевих інтерфейсів на віртуальному хості С1, С2, для цього запустимо VPCS GMS3 і виконаємо команди як показано на рисунку

Цифрами 1 і 2 можна переключатись з одного сімулятора на інший. Командою ping було перевірено правельність роботи мережі.

  1. Проведемо налаштування quagga на віртуальній машині FreeBSDv30-2

Цей пакет має майже ідентичний синтаксис налаштувань, як Cisco обладнання, тому хто знайомий з цим, не відчує не яких проблем в налаштуванні більш складнішої мережі. Виконаємо:

telnet 127.0.0.1 ospfd

Пароль за замовчуванням: zebra

Після того, як ми підключилися до консолі виконуємо таку послідовність команд:

ospfd> enable

ospfd# configure terminal

ospfd(config)# router ospf

ospfd(config-router)# router-id 192.168.4.18

ospfd(config-router)# network 192.168.4.16/28 area 0

ospfd(config-router)# network 192.168.4.32/28 area 0

ospfd(config-router)# network 172.25.0.0/16 area 0

ospfd(config-router)# neighbor 192.168.4.19

ospfd(config-router)# default-information originate

ospfd(config-router)# write memory

Configuration saved to /usr/local/etc/quagga/ospfd.conf

ospfd(config-router)#

  1. Проведемо налаштування quagga на віртуальній машині FreeBSDv30COPY

Підключаємось так само і виконуємо:

ospfd> enable

ospfd# configure terminal

ospfd(config)# router ospf

ospfd(config-router)# router-id 192.168.4.19

ospfd(config-router)# network 192.168.4.16/28 area 0

ospfd(config-router)# neighbor 192.168.4.18

ospfd(config-router)# redistribute connected

ospfd(config-router)# write memory

Configuration saved to /usr/local/etc/quagga/ospfd.conf

ospfd(config-router)#

  1. Проведемо працездатність мережі

Контрольні питання:

1. З якою метою в OSPF вводиться поняття область мережі?

2. Особливості архітектури пакета Quagga.

3. Які характеристики використовуються для оцінки маршрутів в алгоритмах маршрутизації?

4. Що показує значення змінної net.inet.ip.forwarding під FreeBSD?

5. Сутність алгоритмів маршрутизації стану зв'язків.

6. Який параметр за замовчуванням використовується як метрики в OSPF?

7. Основні відмінності протоколів RIPv1 і RIPv2.

8. Яка максимальна відстань між мережами допустима в протоколі RIP?

9. Класифікація алгоритмів маршрутизації.

10. Сутність дистанційно-векторних алгоритмів маршрутизації.

11. Які вимоги пред'являються до алгоритмів динамічної маршрутизації?

Література

  1.  http://www.hilik.org.ua/quagga-setup-rip/
  2.  http://muff.kiev.ua/content/quagga-prevrashchenie-servera-v-polnofunktsionalnyi-marshrutizator
  3.  http://www.hilik.org.ua/%D0%BD%D0%B0%D1%81%D1%82%D1%80%D0%B0%D0%B8%D0%B2%D0%B0%D0%B5%D0%BC-ospf-%D0%B2-quagga/
  4.  http://xgu.ru/wiki/VLAN_%D0%B2_FreeBSD
  5.  http://skill-admin.blogspot.com/2012/10/virtualbox-gns3-virtualbox-in-gns3.html

 

А также другие работы, которые могут Вас заинтересовать

53771. Конспект уроку з фізичної культури Для учнів 2-А класу - реферат українською 29.5 KB
  Ходьба: руки за голову навприсядки стрибками на носках на п‘ятках4. Загальнорозвиваючі вправи на місціА Вп руки до плечейКолові рухи руками вперед назад 8р вперед8р назадБ Вп руки в сторониКолові рухи руками вперед назад 1012 раз Руки пряміВ Вп права рука вгорі ліва внизу; 12 переміна положень рук 1012 раз Руки пряміГ Вп руки вперед. Схрещення рук 1012 раз Руки пряміД Вп ноги нарізно руки на поясі 1 нахил вліво 2 в. 1012 раз Руки опущені ноги пряміІІ.
53772. Організуючі, стройові та ЗРВ. Спеціальні бігові та стрибкові вправи. Рухливі ігри 75 KB
  Стройові вправи: Праворуч Ліворуч Кругом Ліворуч Ліворуч Рівняйсь струнко Ходьба: звичайна навшпиньках на пятках з високим підніманням стегна руки перед собою у напівприсіді у повному присіді звичайна. руки на пояс. руки до плечей колові оберти зігнутими в ліктях руками вперед назад. руки в сторони сжаті в кулачки на 123 розвести руки в сторони на 4 зігнути руки до...
53773. Ярослав Стельмах. «Митькозавр із Юрківки, або химера лісогвого озера». Характеристика образів Сергія і Митька, їхньої поведінки у складних ситуаціях 48.5 KB
  Мета: Удосконалювати навички визначення рис характеру героїв твору вміння висловлювати свої думки про прочитане; розвивати навички переказу виразного і вибіркового читання спостережливість увагу; виховувати допитливість доброту любов до ближніх. Обладнання: схема з рисами характеру героїв портрет Ярослава Стельмаха. Завдання: учні мають удосконалити навички визначати риси характеру героїв твору і оцінювати їхні вчинки; закріпити вміння переказувати твір віднаходити цитати за поданим завданням висловлювати своє враження про...
53774. Малювання композиції Дерева у лісі 656 KB
  Провести бесіду В художникаграфіка; розвивати умінняспостерігати і виявляти особливості будови дерев різних порід; ознайомити звиразними особливостями ліній різної товщини навчити прийомам роботи зпаличкою пензлем пером або восковими крейдами на вибір учителя ітушшю; формувати уміння заповнювати зображенням усю площину аркушапаперу; виховувати любов до рідної природи дбайливе ставлення до матеріалівта інструментів акуратність під час роботи з тушшю;...
53775. Дієслова майбутнього часу 65.5 KB
  Життя прожити не поле перейти Хочеш знати не соромся питати Гарно того вчити хто хоче все знати Щоб довго жити треба працю любити Знайдіть дієслова в неозначеній формі. Чи можна визначити за цими дієсловами коли відбулася дія і хто її виконує Чому Не можна бо неозначена форма дієслова не вказує ні на час ні на особу 2. Запитання вчителя : Що називається дієсловом Частина мови що означає дію предмета і відповідає на питання що робити Що робив Що зробив Що робить Що зробить Що буде робити Яким...
53776. Підготовка до творчої роботи. «Мій улюблений герой казки» 58.5 KB
  Мій улюблений герой казки. Мій улюблений герой казки. Що складає основний зміст більшості казок В основі казки захоплива розповідь про вигадані події і явища які сприймаються і переживаються як реальні. Які різновиди казок ви знаєте Казки про тварин фантастичні побутові...
53777. Розвиток національного театру («Березіль» Леся Курбаса та Харківський театр ім. І.Франка). Пєси В.Винниченка, М.Куліша, І. Дніпровського, І. Кочерги 104.5 KB
  Антоніна Куліш дружина митця у своїх мемуарах Спогади про Миколу Куліша завершених у 1953 році у Філадельфії детально виклала один із драматичних моментів його дитячих літ записаний зі слів письменника що засвідчує що мати його неодноразово била за брехню та інші провини. Чаплинські інтелігенти особливо енергійний шкільний вчитель Володимир Пилипович Губенко...
53778. Групи слів за значенням. Омоніми 103 KB
  Мета: поглибити знання учнів набуті у молодшій школі; навчити пятикласників знаходити в тексті омоніми; сприяти виробленню вмінь та навичок правильно використовувати різні за значенням групи слів в усному та писемному монологічному і діалогічному мовленні; за допомогою вправ різнотипного характеру розвивати творчі здібності логічне й образне мислення та мовлення спостережливість пам'ять логіку викладу думокуміння аналізувати експериментувати досліджувати й порівнювати мовний матеріал робити правильні...
53779. Незмінювані іменники 39.5 KB
  Мета: поглибити знання учнів про незмінювані іменники навчити визначати в них рід розвивати вміння вживати незмінювані іменники у звязному мовленні розвивати творче мислення виховувати бажання збагачувати свій лексикон. Лінгвістичний двобій Двоє учнів по черзі ставлять підготовлені вдома питання Яка частина мови називається іменником За чим змінюється іменник Як визначити рід іменника Які іменники належать до власних назв Як пишуться власні назви До якого роду належать назви осіб за професією чи...