75501

Управляющие оператора, используемые для при программировании в 1С

Доклад

Информатика, кибернетика и программирование

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения

Русский

2015-01-15

25 KB

1 чел.

70. Управляющие оператора, используемые для при программировании в 1С

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения = (равно), <> (не равно), > (больше), < (меньше), <= (меньше либо равно), >=(больше или равно), при этом сравнение производится только над значениями одинаковых типов (то есть нельзя, например, сравнивать число и строку). Из нескольких сравнений можно построить более сложное условие с помощью булевых операций «и», «или», «не». Порядок сравнений можно определять с помощью круглых скобок.

Оператор ветвления

Если <Логическое_выражение> Тогда

ИначеЕсли <Логическое_выражение> Тогда

Иначе

КонецЕсли;

Циклы

Пока <Логическое_выражение> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Для <Имя_переменной> = <Выражение1> По <Выражение2> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Величина приращения счетчика при каждом выполнении цикла равна 1. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Обработка ошибок

Попытка

[Исключение]

КонецПопытки;

Работа с транзакциями

Транзакции применяются для выполнения длительных и критических для функционирования системы операций. В некоторых случаях система сама начинает транзакцию и специально описывать ее не надо. Например, это происходит при проведении документов: так как в программе могут работать одновременно несколько пользователей, то при записи документа (например, продажа товара со склада) недопустима ситуация «одновременного» проведения двух документов – все равно один из них должен быть проведен раньше, чем другой (иначе можно продать один и тот же товар два раза!). Поэтому система выполняет проведение документа в режиме транзакции, – база данных становится недоступной для записи остальных пользователей. Естественно, что при большом количестве пользователей, которые активно вводят данные в программу, работа системы замедляется. Одним из решений этой проблемы может быть установка версии для SQL, в этом случае процедуры записи выполняется на отдельном компьютере (сервере базы данных) с помощью MS SQL Server 7.0.

В остальных случаях транзакцию начать и зафиксировать с помощью следующих функций:

НачатьТранзакцию();

[ОтменитьТранзакцию();]

ЗафиксироватьТранзакцию();

Отмена транзакции применяется в случае обнаружения какой-то некорректной ситуации. В этом случае все изменения, внесенные в базы данных с момента начала транзакции, отменяются. Чтобы зафиксировать изменения необходимо выполнить функцию ЗафиксироватьТранзакцию().


 

А также другие работы, которые могут Вас заинтересовать

77706. Технологии развития современной памяти 115 KB
  Всего за несколько десятилетий в области технологий хранения данных произошли разительные перемены а появление флешпамяти без преувеличения можно назвать революцией. Сегодня принцип хранения информации в электронных устройствах конечно отличается от условных расчётов Фейнмана но размер единичного элемента хранения известен около 40 нм в коммерческих устройствах на основе флешпамяти. Технологии устройств памяти следующего поколения будут использовать новые материалы обладать временем доступа в единицы наносекунд и хранить информацию...
77707. Трёхмерная графитовая память 35.5 KB
  На сделанных сканирующим электронным микроскопом снимках видны графитовая полоска неизменённой ячейки памяти вверху и содержащей бит данных Выход нашли исследователи из Университета Райса Rice University в Хьюстоне которые показали что родственник графена графит может быть адаптирован для создания быстрых высокоёмких устройств хранения обладающих преимуществами по сравнению с флэшпамятью которой комплектуется сегодня множество мобильных устройств. Ячейки памяти могут быть расположены в виде вертикальных массивов что в...
77709. Современные тенденции развития носителей информации 697 KB
  Интерфейс IDE Что бы ни говорили сторонники SCSI широкое распространение IDEустройств на сегодняшний день свершившийся факт. В идеале каждое IDEустройство стоит подключать к отдельному каналу в этом пожалуй заключается основное преимущество SCSI. И это одно из главных преимуществ IDE перед SCSI. SCSI Smll Computer System Interfce Несмотря на кажущееся засилье устройств с интерфейсом IDE EIDE по объемам выпуска за SCSI жесткими дисками всетаки остается около 27 рынка.
77711. УСТРОЙСТВО СОВРЕМЕННЫХ МОДЕМОВ 1011.5 KB
  Эти требования приводят к тому что в отличных по конструкции модемах одни и те же методы и протоколы реализованы различными способами. Один из вариантов исполнения модема можно представить в виде изображенном на рис. Устройство современного модема: 1 порт интерфейса DTE DCE; 2 порт канального интерфейса Рис. Устройство современного модема Модем состоит из адаптеров портов канального и DTE DCE интерфейсов; универсального PU сигнального DSP и модемного процессоров; постоянного ПЗУ ROM постоянного энергонезависимого...
77712. RAID - массивы 69.5 KB
  В своей статье Cse for Redundnt rrys of Inexpensive Discs RID избыточный массив недорогих дисков они описали каким образом можно объединить несколько дешевых жестких дисков в одно логическое устройство так чтобы в результате повышались емкость и быстродействие системы а отказ отдельных дисков не приводил к отказу всей системы. С момента выхода статьи прошло уже 15 лет но технология построения RIDмассивов не утратила актуальности и сегодня. Единственное что изменилось с тех пор это расшифровка аббревиатуры RID.