75501

Управляющие оператора, используемые для при программировании в 1С

Доклад

Информатика, кибернетика и программирование

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения

Русский

2015-01-15

25 KB

1 чел.

70. Управляющие оператора, используемые для при программировании в 1С

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения = (равно), <> (не равно), > (больше), < (меньше), <= (меньше либо равно), >=(больше или равно), при этом сравнение производится только над значениями одинаковых типов (то есть нельзя, например, сравнивать число и строку). Из нескольких сравнений можно построить более сложное условие с помощью булевых операций «и», «или», «не». Порядок сравнений можно определять с помощью круглых скобок.

Оператор ветвления

Если <Логическое_выражение> Тогда

ИначеЕсли <Логическое_выражение> Тогда

Иначе

КонецЕсли;

Циклы

Пока <Логическое_выражение> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Для <Имя_переменной> = <Выражение1> По <Выражение2> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Величина приращения счетчика при каждом выполнении цикла равна 1. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Обработка ошибок

Попытка

[Исключение]

КонецПопытки;

Работа с транзакциями

Транзакции применяются для выполнения длительных и критических для функционирования системы операций. В некоторых случаях система сама начинает транзакцию и специально описывать ее не надо. Например, это происходит при проведении документов: так как в программе могут работать одновременно несколько пользователей, то при записи документа (например, продажа товара со склада) недопустима ситуация «одновременного» проведения двух документов – все равно один из них должен быть проведен раньше, чем другой (иначе можно продать один и тот же товар два раза!). Поэтому система выполняет проведение документа в режиме транзакции, – база данных становится недоступной для записи остальных пользователей. Естественно, что при большом количестве пользователей, которые активно вводят данные в программу, работа системы замедляется. Одним из решений этой проблемы может быть установка версии для SQL, в этом случае процедуры записи выполняется на отдельном компьютере (сервере базы данных) с помощью MS SQL Server 7.0.

В остальных случаях транзакцию начать и зафиксировать с помощью следующих функций:

НачатьТранзакцию();

[ОтменитьТранзакцию();]

ЗафиксироватьТранзакцию();

Отмена транзакции применяется в случае обнаружения какой-то некорректной ситуации. В этом случае все изменения, внесенные в базы данных с момента начала транзакции, отменяются. Чтобы зафиксировать изменения необходимо выполнить функцию ЗафиксироватьТранзакцию().


 

А также другие работы, которые могут Вас заинтересовать

48656. Порівняння заробітної плати в Україні та інших країнах світу 242 KB
  Нарешті необхідність належної збалансованості економічних інтересів учасників виробництва потребує збільшення частки оплати праці у структурі суспільного продукту. Отже для розвитку економіки збільшення інвестицій необхідне зростання рівня оплати праці. Актуальність теми дослідження зумовлена необхідністю наближення рівня продуктивності працізаробітної плати і доходів найманих працівників до рівня розвинутих країн. Це зумовлює необхідність здійснення системного дослідження оплати праці в Україні та інших країнах світу.
48657. Расчет структуры электромагнитных полей 373 KB
  Для заданной геометрии и параметров среды получены аналитические выражения значений потенциалов и напряженностей полей внутри и вне цилиндрической полости, а также значение вектора магнитной индукции в заданной точке
48658. Комерційна діяльність 336.49 KB
  Руські торгівці вели зовнішню торгівлю вроздріб, кожен сам по собі, на свій страх і ризик. Від цього сили і засоби окремих руських купців, як правило, недостатніми для цього діла, тому вони не могли витримати конкуренцію закордонних купців і постійно залишались в «мінусах»
48659. СПОСОБИ ПОЛІПШЕННЯ ТЕПЛОІЗОЛЯЦІЇ БУДІВЕЛЬ СТАРОЇ ЗАБУДОВИ 565 KB
  Метою цієї роботи є визначення порядку чергування огороджувальних шарів стіни несуча та теплоізолююча частина що забезпечить найменші темп та швидкість її охолодження з метою вибору оптимальних варіантів енергозберігаючих рішень по утепленню житлових приміщень старої забудови постійного та періодичного опалення. У роботі проведено розрахунок розподілу температури по шарах для різних конструкцій утеплених стін визначено кількість теплоти що треба витратити на кожен квадратний метр поверхні стіни аби температура у приміщенні стала...
48660. История политических и правовых учений 688.6 KB
  История политических и правовых учений – юридическая наука и учебная дисциплина исторического профиля. В то же время, как и юриспруденция в целом, она относится к числу гуманитарных (социально-гуманитарных) наук. В этом качестве она взаимодействует с другими гуманитарными науками, но прежде всего и главным образом с философией.
48662. Державні запозичення та фінансова безпека держави 268.5 KB
  Зумовили досить стрімке накопичення боргу та концентрацію платежів щодо його обслуговування у вузькому часовому інтервалі. Недаремно на суспільно – психологічному й емоційному рівнях сприймання державних запозичень варіює від апокаліпсичного образу смертоносної проблеми до чудодійного засобу вирішення всіх проблем що знайшло своє відображення в науково – теоретичних уявленнях про природу державного боргу. Функціонування державного кредиту можливе при таких суспільно – економічних умовах: матеріально – майновому розшаруванні й соціальній...
48663. Методи розрахунку новітніх макроекономічних показників 156 KB
  Із нових макроекономічних показників ми розглянемо індекс людського розвитку індекс економічної свободи та рівень глобалізації. Актуальність даної теми дослідження полягає в тому що новітні макроекономічні показники дають змогу комплексно охарактеризувати стан економіки та рівень життя тієї чи іншої країни. Розвиток всього суспільства здійснюється надзвичайно швидкими темпами тому необхідно покращувати методику розрахунку цих показників враховувати нові чинники та фактори що впливають на їх рівень. Об’єктом дослідження є індекс...