75501

Управляющие оператора, используемые для при программировании в 1С

Доклад

Информатика, кибернетика и программирование

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения

Русский

2015-01-15

25 KB

1 чел.

70. Управляющие оператора, используемые для при программировании в 1С

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения = (равно), <> (не равно), > (больше), < (меньше), <= (меньше либо равно), >=(больше или равно), при этом сравнение производится только над значениями одинаковых типов (то есть нельзя, например, сравнивать число и строку). Из нескольких сравнений можно построить более сложное условие с помощью булевых операций «и», «или», «не». Порядок сравнений можно определять с помощью круглых скобок.

Оператор ветвления

Если <Логическое_выражение> Тогда

ИначеЕсли <Логическое_выражение> Тогда

Иначе

КонецЕсли;

Циклы

Пока <Логическое_выражение> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Для <Имя_переменной> = <Выражение1> По <Выражение2> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Величина приращения счетчика при каждом выполнении цикла равна 1. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Обработка ошибок

Попытка

[Исключение]

КонецПопытки;

Работа с транзакциями

Транзакции применяются для выполнения длительных и критических для функционирования системы операций. В некоторых случаях система сама начинает транзакцию и специально описывать ее не надо. Например, это происходит при проведении документов: так как в программе могут работать одновременно несколько пользователей, то при записи документа (например, продажа товара со склада) недопустима ситуация «одновременного» проведения двух документов – все равно один из них должен быть проведен раньше, чем другой (иначе можно продать один и тот же товар два раза!). Поэтому система выполняет проведение документа в режиме транзакции, – база данных становится недоступной для записи остальных пользователей. Естественно, что при большом количестве пользователей, которые активно вводят данные в программу, работа системы замедляется. Одним из решений этой проблемы может быть установка версии для SQL, в этом случае процедуры записи выполняется на отдельном компьютере (сервере базы данных) с помощью MS SQL Server 7.0.

В остальных случаях транзакцию начать и зафиксировать с помощью следующих функций:

НачатьТранзакцию();

[ОтменитьТранзакцию();]

ЗафиксироватьТранзакцию();

Отмена транзакции применяется в случае обнаружения какой-то некорректной ситуации. В этом случае все изменения, внесенные в базы данных с момента начала транзакции, отменяются. Чтобы зафиксировать изменения необходимо выполнить функцию ЗафиксироватьТранзакцию().


 

А также другие работы, которые могут Вас заинтересовать

73917. Феномен глобалізації та процеси глобальних політичних змін: основні концепції та методологічні підходи 44 KB
  Блінова частина якої до якої і пишеться коментар має назву Феномен глобалізації та процеси глобальних політичних змін: основні концепції та методологічні підходи. Фактично прочитавши більшість джерел до семінару №2 у мене склалися деякі погляди на розглядувані речі звісно пов‘язані із процесом глобалізації чи то антиглобалізації які вмістити до якогось конкретного джерела виявилося дуже складним. З одного боку наявність численної кількості визначень може йти на користь вивченню глобалізації адже ця численність є прямим фактом...
73918. Кінець світу, який ми знаємо 98 KB
  Вотерса Кінець світу який ми знаємо. Від цього залежить і мислення людей яке радше ґрунтуватиметься на припущенні гетерогенності світу сильної несхожості усіх його частин а не на припущенні про одну світову сім‘ю. Останнє матиме вплив і на дії людей в усіх кінцях світу які ряснітимуть розмаїтістю. Країни обиралися за таким критеріями: Британія як дуже впливовий член ЄС і як одна з передових країн світу; Україна порівняння світової ситуації із справа в нашому суспільстві; США одна з провідних і найвпливовіших країн світу; Індія ...
73920. Підприємець – не обов’язково лідер 196.5 KB
  Вже минуло більш як два з половиною століття з тих часів, як економісти та соціологи почали систематично розглядати діяльність підприємців, але й досі не існує єдиного загальноприйнятого визначення підприємця. Тож чи дивно, що науковці не накреслили і загальноприйнятого образу підприємця.
73921. Гроші – це лише символ, реальна вартість полягає у виробленому товарі 60 KB
  Вартість грошей як товару. Відносна вартість трансакційних грошей. Вартість грошей що нагромаджуються. Подруге критично проанілізувати в чому полягає реальна вартість грошей і якщо у виробленому товарі то чому саме так.
73923. The critique of modern democracy. Alternatives: participatory approach 44 KB
  In modern world we can often here such an expression as “democratical processes”. In general it is used with undoubted positive illumination, promoted like panacea in the field of political organization of the society.
73924. Вартість та оптимізація структури капіталу 111.5 KB
  Капітал є однією з фундаментальних економічних категорій, сутність якої наукова думка досліджує протягом багатьох століть. Серед основних харектеристик, які формують економічну сутність капіталу, слід виділити...
73925. УПРАВЛІННЯ ІНВЕСТИЦІЯМИ 311 KB
  Оцінка ефективності інвестиційних проектів. Тому передусім слід відзначити помилковість віднесення до форм інвестицій реінвестиції які характеризують не обєкт вкладення капіталу а процес використання доходу отриманого від інвестиційних операцій у процесі реінвестицій згідно з цим же законом інвестиційний доход може бути використано на здійснення як капітальних так і фінансових інвестицій.