75501

Управляющие оператора, используемые для при программировании в 1С

Доклад

Информатика, кибернетика и программирование

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения

Русский

2015-01-15

25 KB

1 чел.

70. Управляющие оператора, используемые для при программировании в 1С

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения = (равно), <> (не равно), > (больше), < (меньше), <= (меньше либо равно), >=(больше или равно), при этом сравнение производится только над значениями одинаковых типов (то есть нельзя, например, сравнивать число и строку). Из нескольких сравнений можно построить более сложное условие с помощью булевых операций «и», «или», «не». Порядок сравнений можно определять с помощью круглых скобок.

Оператор ветвления

Если <Логическое_выражение> Тогда

ИначеЕсли <Логическое_выражение> Тогда

Иначе

КонецЕсли;

Циклы

Пока <Логическое_выражение> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Для <Имя_переменной> = <Выражение1> По <Выражение2> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Величина приращения счетчика при каждом выполнении цикла равна 1. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Обработка ошибок

Попытка

[Исключение]

КонецПопытки;

Работа с транзакциями

Транзакции применяются для выполнения длительных и критических для функционирования системы операций. В некоторых случаях система сама начинает транзакцию и специально описывать ее не надо. Например, это происходит при проведении документов: так как в программе могут работать одновременно несколько пользователей, то при записи документа (например, продажа товара со склада) недопустима ситуация «одновременного» проведения двух документов – все равно один из них должен быть проведен раньше, чем другой (иначе можно продать один и тот же товар два раза!). Поэтому система выполняет проведение документа в режиме транзакции, – база данных становится недоступной для записи остальных пользователей. Естественно, что при большом количестве пользователей, которые активно вводят данные в программу, работа системы замедляется. Одним из решений этой проблемы может быть установка версии для SQL, в этом случае процедуры записи выполняется на отдельном компьютере (сервере базы данных) с помощью MS SQL Server 7.0.

В остальных случаях транзакцию начать и зафиксировать с помощью следующих функций:

НачатьТранзакцию();

[ОтменитьТранзакцию();]

ЗафиксироватьТранзакцию();

Отмена транзакции применяется в случае обнаружения какой-то некорректной ситуации. В этом случае все изменения, внесенные в базы данных с момента начала транзакции, отменяются. Чтобы зафиксировать изменения необходимо выполнить функцию ЗафиксироватьТранзакцию().


 

А также другие работы, которые могут Вас заинтересовать

76103. Определение располагаемой мощности турбогенератора ТГВ – 300 76 KB
  К анормальным режимам работы синхронных машин связанные со значительными аварийными перегрузками или потерей возбуждения работа с недовозбуждением асинхронный ход работа при отказе системы охлаждения а также при появлении значительных несинусоидальности и несимметрии напряжения сети.
76104. Разработка и расчет телевизионного передатчика 3-5 каналов 412.69 KB
  Задачей данного курсового проекта является разработка и расчет ТВ передатчика предназначенного для работы в 3-ем 4-ом и 5-ом каналах 80МГц 88МГц 96МГц соответственно с выходной мощностью 10 Вт и нестабильностью рабочей частоты равной 90Гц.
76106. Разработка технологического процесса горячей объемной штамповки поковки удлиненной формы в плане на деталь «Рычаг» 2.2 MB
  Поковка рычага относится к поковкам удлиненной формы в плане и штампуется на двух видах универсального оборудования: штамповочном молоте и кривошипном горячештамповочном прессе. На горизонтально-ковочных машинах ее изготовление не возможно, так как она на имеет круглые поперечные сечения.
76107. Исследование устойчивости функционирования объектов экономики в ЧС 151.03 KB
  Цель работы — дать основные сведения по системе мероприятий по защите населения и территорий в ЧС, об основах организации их предупреждения и ликвидации. Наработка навыка решения задач по оценке радиационного и химического заражения, расчету устойчивости зданий и сооружений народного хозяйства.