75501

Управляющие оператора, используемые для при программировании в 1С

Доклад

Информатика, кибернетика и программирование

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения

Русский

2015-01-15

25 KB

1 чел.

70. Управляющие оператора, используемые для при программировании в 1С

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения = (равно), <> (не равно), > (больше), < (меньше), <= (меньше либо равно), >=(больше или равно), при этом сравнение производится только над значениями одинаковых типов (то есть нельзя, например, сравнивать число и строку). Из нескольких сравнений можно построить более сложное условие с помощью булевых операций «и», «или», «не». Порядок сравнений можно определять с помощью круглых скобок.

Оператор ветвления

Если <Логическое_выражение> Тогда

ИначеЕсли <Логическое_выражение> Тогда

Иначе

КонецЕсли;

Циклы

Пока <Логическое_выражение> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Для <Имя_переменной> = <Выражение1> По <Выражение2> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Величина приращения счетчика при каждом выполнении цикла равна 1. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Обработка ошибок

Попытка

[Исключение]

КонецПопытки;

Работа с транзакциями

Транзакции применяются для выполнения длительных и критических для функционирования системы операций. В некоторых случаях система сама начинает транзакцию и специально описывать ее не надо. Например, это происходит при проведении документов: так как в программе могут работать одновременно несколько пользователей, то при записи документа (например, продажа товара со склада) недопустима ситуация «одновременного» проведения двух документов – все равно один из них должен быть проведен раньше, чем другой (иначе можно продать один и тот же товар два раза!). Поэтому система выполняет проведение документа в режиме транзакции, – база данных становится недоступной для записи остальных пользователей. Естественно, что при большом количестве пользователей, которые активно вводят данные в программу, работа системы замедляется. Одним из решений этой проблемы может быть установка версии для SQL, в этом случае процедуры записи выполняется на отдельном компьютере (сервере базы данных) с помощью MS SQL Server 7.0.

В остальных случаях транзакцию начать и зафиксировать с помощью следующих функций:

НачатьТранзакцию();

[ОтменитьТранзакцию();]

ЗафиксироватьТранзакцию();

Отмена транзакции применяется в случае обнаружения какой-то некорректной ситуации. В этом случае все изменения, внесенные в базы данных с момента начала транзакции, отменяются. Чтобы зафиксировать изменения необходимо выполнить функцию ЗафиксироватьТранзакцию().


 

А также другие работы, которые могут Вас заинтересовать

70411. ДОПОМІЖНІ МАТЕРІАЛИ ПРИ ЗДІЙСНЕННІ АТЕСТАЦІЇ ПЕДАГОГІЧНИХ ПРАЦІВНИКІВ 525.5 KB
  На сьогоднішній день процедура вивчення роботи педагога в процесі атестації детально регламентується діючим Положенням так і численними практичними розробками схем показників та критеріїв оцінювання.
70418. УПРАВЛІННЯ РОЗВИТКОМ НАВАЧЛЬНОГО ЗАКЛАДУ 303.5 KB
  Основними проблемами функціонування навчального закладу за результатами самоекспертизи є: Недостатня мотивація учнів незацікавленість учнів навчанням. Зниження соціальної активності учнів. Зниження базового рівня вихованості значної кількості учнів.