75501

Управляющие оператора, используемые для при программировании в 1С

Доклад

Информатика, кибернетика и программирование

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения

Русский

2015-01-15

25 KB

1 чел.

70. Управляющие оператора, используемые для при программировании в 1С

Для управления логикой выполнения программы используются логические выражения и управляющие операторы. Логическое выражение записывается с помощью символов сравнения = (равно), <> (не равно), > (больше), < (меньше), <= (меньше либо равно), >=(больше или равно), при этом сравнение производится только над значениями одинаковых типов (то есть нельзя, например, сравнивать число и строку). Из нескольких сравнений можно построить более сложное условие с помощью булевых операций «и», «или», «не». Порядок сравнений можно определять с помощью круглых скобок.

Оператор ветвления

Если <Логическое_выражение> Тогда

ИначеЕсли <Логическое_выражение> Тогда

Иначе

КонецЕсли;

Циклы

Пока <Логическое_выражение> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Для <Имя_переменной> = <Выражение1> По <Выражение2> Цикл

[Прервать]

[Продолжить]

КонецЦикла;

Величина приращения счетчика при каждом выполнении цикла равна 1. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Обработка ошибок

Попытка

[Исключение]

КонецПопытки;

Работа с транзакциями

Транзакции применяются для выполнения длительных и критических для функционирования системы операций. В некоторых случаях система сама начинает транзакцию и специально описывать ее не надо. Например, это происходит при проведении документов: так как в программе могут работать одновременно несколько пользователей, то при записи документа (например, продажа товара со склада) недопустима ситуация «одновременного» проведения двух документов – все равно один из них должен быть проведен раньше, чем другой (иначе можно продать один и тот же товар два раза!). Поэтому система выполняет проведение документа в режиме транзакции, – база данных становится недоступной для записи остальных пользователей. Естественно, что при большом количестве пользователей, которые активно вводят данные в программу, работа системы замедляется. Одним из решений этой проблемы может быть установка версии для SQL, в этом случае процедуры записи выполняется на отдельном компьютере (сервере базы данных) с помощью MS SQL Server 7.0.

В остальных случаях транзакцию начать и зафиксировать с помощью следующих функций:

НачатьТранзакцию();

[ОтменитьТранзакцию();]

ЗафиксироватьТранзакцию();

Отмена транзакции применяется в случае обнаружения какой-то некорректной ситуации. В этом случае все изменения, внесенные в базы данных с момента начала транзакции, отменяются. Чтобы зафиксировать изменения необходимо выполнить функцию ЗафиксироватьТранзакцию().


 

А также другие работы, которые могут Вас заинтересовать

60367. СИНТЕЗ І РОЗПАД ГЛІКОГЕНУ. ГЕНЕТИЧНІ ПОРУШЕННЯ ОБМІНУ ГЛІКОГЕНУ 35 KB
  Вміти: визначати рівень глюкози в крові і трактувати одержані дані. Самостійна позааудиторна робота В зошитах для протоколів: написати структурні формули: а моносахаридів глюкози фруктози галактози рибози...
60368. Конкурс на кращу розробку виховного заходу 37.5 KB
  Під час підготовки до конкурсу студентам необхідно ретельно продумати тему і форму виховного заходу а також процедуру його представлення в аудиторії адже не кожен виховний захід можна провести в класі наприклад екскурсія.
60371. Report 35 KB
  The purpose of the report is to comment on... and to make recommendations for possible improvements. Although conditions are generally good, there are...