85788

Налаштування статичного та динамічного NAT

Лабораторная работа

Информатика, кибернетика и программирование

Технологія Network address translation (NAT - перетворення мережевих адрес) дозволяє представити внутрішню структуру IP адресації через глобальну унікальну IP адресу або пул ІР адрес, що дозволяє забезпечити доступ в Інтернет для корпоративних внутрішніх IP-мереж з внутрішніми IP-адресами ...

Украинкский

2015-03-30

225.5 KB

1 чел.

Виконав: ст.гр.ІМЗ-12 Окунєв Антон

Лабораторна робота №17.

Налаштування статичного та динамічного NAT

Мета роботи: Навчитися налаштовувати трансляцію мережевих адрес.

Теоретичні відомості

Технологія Network address translation (NAT - перетворення мережевих адрес) дозволяє представити внутрішню структуру IP адресації через глобальну унікальну IP адресу або пул ІР адрес, що дозволяє забезпечити доступ в Інтернет для корпоративних внутрішніх IP-мереж з внутрішніми IP-адресами (intranet), які не маршрутизуються в мережі Інтернеті. NAT також може використовуватися для забезпечення зв'язку територіально розподілених підрозділів організації через мережу Інтернет.

Для інтранет-адресації виділені наступні діапазони адрес:

  •  Class A: 10.0.0.0-10.255.255.255;
  •  Class B: 172.16.0.0-172.32.255.255;
  •  Class C: 192.168.1-192.168.255.255.

NAT перетворю.є внутрішню IP-адресу з внутрішнього адресного простору в IP-адресу в зовнішньому адресному просторі – публічну ІР-адресу. Публічною ІР-адресою називають доступну, унікальну ІР-адресу з мережі Internet. Для визначення публічних ІР-адрес створюються регіональні неприбуткові суспільні організації RIP. Публічні ІР-адреси видаються тільки провайдерам зв'язку, які можуть забезпечити технічні умови функціонування автономних систем.

NAT перетворює та відображає адреси з однієї області в іншу,  що забезпечує прозору маршрутизацію від вузла до вузла. NAT дозволяє заощаджувати ІР-адреси, траслюючи частину внутрішніх адрес (pool-адрес) в одну зовнішню публічну ІР-адресу та транслюючи в одну зовнішню публічну адресу.

Макет мережі

Адреси інтерфейсів

R1

R2

R3

Ethernet

10.1.1.2/24

10.1.1.1/24

Serial

175.10.1.1/24

175.10.1.2/24

R2(config)# ip nat inside source static 10.1.1.2 169.10.1.2

мережа інтерфейсу FastEthernet0/0 є внутрішньою

R2(config)# interface fa0/0

R2(config-if)# ip nat inside

мережуаінтерфейсу Serial2/0 є зовнішньою

R2(config-if)# interface s2/0

R2(config-if# ip nat outside

Для виведення таблиці переведення адрес

R2# show ip nat translations

Добавляємо до таблиці маршрутизації на R3 насуний запис

R3(config)# ip route 169.10.1.0 255.255.255.0 175.10.1.1

R1# telnet 175.10.1.2

Password:R3

R3> show users

Замість 169.10.1.2 можна використати і привести в дію адресу інтерфейсу Serial2/0 175.10.1.1

R2(config)# no ip nat inside source static 10.10.1.2 169.10.1.2

R2(config)# ip nat inside source static 10.10.1.2 175.10.1.1

R1# telnet 175.10.1.2

Password: R3

R3> show users

На маршрутизаторі R2 видаляємо попередню NAT команду статичної трансляції.

R2(config)# no ip nat inside source static 10.1.1.2 175.10.1.1

і налаштовуємо NAT для динамічного перетворення Ethernet-адреси маршуртизатора R1.

Використовуємо область адрес в діапазоні: 169.10.1.50 – 169.10.1.100. Визначаємо пул адрес

R2(config)# ip nat pool pooR1 169.10.1.50 169.10.1.100 netmask 255.255.255.0

R2(config)# ip nat inside source list 1 pool poolR1

Налаштовуємо і перевіряємо список доступу 1 для внутрішніх адрес, які будуть перетворюватись

R2(config)# access-list 1 permit 10.1.1.0 0.0.0.255

R2# show access-list

ip nat pool pooR1 169.10.1.50 169.10.1.100 netmask 255.255.255.0

ip nat inside source list 1 pool pooR1

ip classless

!

!

access-list 1 permit 10.1.1.0 0.0.0.255

Перевіряємо переведення, створивши telnet-з’єднання із R1 до маршрутизатора R3. Зайшовши по Telnet на R3 вводимо команду show users. Ми повинні побачити переведену IP-адресу 169.10.1.50

R1# telnet 175.10.1.2

Password: R3

На маршрутизаторі R2 видаляємо попередні NAT-команди динамічного перекладу і налаштовуємо трансляцію (переведення адрес портів) Ethernet-адреси маршрутизатора R1 (10.10.1.2) на адресу інтерфейсу serial2/0 (175.10.1.1) на маршрутизаторі R2.

R2 (config)# no ip nat pool pooR1 169.10.1.50 169.10.1.100 netmask 255.255.255.0

R2 (config)# no ip nat inside source list 1 pool pooR1

R2 (config)# ip nat inside source list 1 interface s2/0 overload

Перевірямо переведення, створивши telnet-з'єднання з R1 до маршрутизатора R3. Перебуваючи на маршрутизаторі R3, вводимо команду show users. Ми повинні побачити переведену IP-адресу 175.10.1.1.

R1# telnet 175.10.1.2

Password: R3

R3> show users

Виводимо список NAT-переведень на маршрутизаторі R2

R2# show ip nat translations

Висновок:

На даній лабораторній роботі я навчилася налаштовувати трансляцію мережевих адрес.


 

А также другие работы, которые могут Вас заинтересовать

28247. Личность, сознание, деятельность в Концепциях Московской психологической школы. (В.М. Леонтьев и др.) 60 KB
  Общая психология личности и персоналии. Понятие личности характеризуется двумя положениями: Л целостное и неповторимое единство. Эмпирицзм в исследованиях личности желание набрать максимальное количество данных и комплексно исследовать личностью Личность как субъект общественных отношений. Считал что никакое комплексное исследование не в состоянии заменить знанияисторию развития этой личности.
28248. Сознательное и бессознательное в личности: отечественный подход (школа установки Узнадзе) и зарубежный подход (психодинамические концепции) 51 KB
  Являясь исходной структурой психики ид выражает первичный принцип всей человеческой жизни немедленную разрядку психической энергии сдерживание которой приводит к напряжению в личностном функционировании. С целью преобразования и реализации потребностей в социально приемлемом контексте эго черпает из ид часть энергии обеспечивая безопасность и самосохранение организма. Освобождение некоторого количества энергии эго для решения проблем на более высоком уровне психики является одной из основных целей психоаналитической терапии. Трактуя...
28249. Гуманистический (К.Роджерс, А. Маслоу), экзистенциальный (В.Франкл, Р.Мэй, И. Ялом) и гештальт (Ф. Перлз, К.Левин) подходы к исследованию личности и психотерапия 68 KB
  Основные положения гуманистической психологии: 1человек должен изучаться в его целостности; 2каждый человек уникален поэтому анализ отдельных случаев не менее оправдан чем статистические обобщения; 3переживания человеком мира и себя в мире являются главной психологической реальностью; 4человеческая жизнь единый процесс становления и бытия человека; 5человек открыт к непрерывному развитию и самореализации которые являются частью его природы; 6человек обладает определенной степенью свободы от внешней детерминации благодаря смыслам и...
28250. Культурно-историческая психология (Выготский Л.С., Леонтьев А.Н.) 49 KB
  В основе теории лежат 2 гипотезы: об опосредованном характере психической деятельности о происхождении внутренних психических процессов из деятельности первоначально внешней и интерпсихической Выготский выдвигает предположение что в психике человека существует особенность соответствующая той роли которую играют труд употребление и создание орудий в его производственной деятельности. Эта особенность в опосредованном характере психической деятельности людей основа исторического подхода к изучению человека. Психическая деятельность...
28251. Гуманистическая психология (А.Маслоу, К.Роджерс и др.) 48 KB
  Бихевиоризм фактически сводит жизнедеятельность к манипуляциям и тем самым низводит человека до уровня стимульнореактивного механизма. Основные положения гуманистической психологии: человек должен изучаться в его целостности; каждый человек уникален поэтому анализ отдельных случаев не менее оправдан чем статистические обобщения; переживания человеком мира и себя в мире являются главной психологической реальностью; человеческая жизнь единый процесс становления и бытия человека; человек открыт к непрерывному развитию и самореализации...
28252. Когнитивная психология (Дж.Миллер, У.Найссер и др.) 40 KB
  КОГНИТИВНАЯ ПСИХОЛОГИЯ одно из ведущих направлений современной зарубежной психологии. Хотя ощущение и восприятие механическая а позже логическая память мышление и речь как психические функции действия или процессы были первыми объектами исследований в ранней экспериментальной психологии но все же первыми научными направлениями завоевавшими психологическое пространство в начале нашего века были бихевиоризм психоанализ и гештальтпсихология в меньшей степени интересовавшиеся указанными процессами как таковыми. Лишь к 60м годам...
28253. Виды ощущений (по Б.Г.Ананьеву) 39 KB
  Так тактильные вибрационные мышечные вестибулярные ощущения отражают определенные моменты и свойства механического движения различных тел в том числе и тела человека. Интерорецепция вкусовые болевые температурные ощущения специфически связаны с основными явлениями жизнедеятельности биологической формой движения материи. механические формы движения тактильные вибрационные мышечные вестибулярные молекулярные формы движения зрительные слуховые вибрационные температурные химические формы движения обонятельные...
28254. Эволюция и психологичсское значение дистантных ощущений. Отражение пространства при парной работе дистантных анализаторов 47 KB
  1 базальные ощущения тактилънокинестетическое осязание 2 ведущие зрение слух от них идет максимальная информация 3 сквозные ощущения кинестетические движение. Дистанционные ощущения в процессе эволюции развились позже контактных: вибро и хеморецепция обоняние слух зрение как повышение адапгивных возможностей организма ОТРАЖЕНИЕ ПРОСТРАНСТВА функция парных анализаторов напр. Бинокулярное зрение При раздражении несоответствующих диспарантных точек бинокулярное зрение или дизассоциируется раздваевается или...
28255. Особая роль осязания в структуре сенсорной организации человека и его значение в процессах познания и труда (Ананьев, Веккер, Ломов, Ярмоленко) 27 KB
  Осязание в процессах познания и труда которая в 1961 году была удостоена премии К. Осязание органически связано со всей структурой чувственной репрезентации человека. Осязание способность животных и человека воспринимать действие факторов внешней среды с помощью рецепторов кожи опорнодвигательного аппарата мышц сухожилий суставов и др. Осязание существенно расширяет представления организма об окружающем мире играет важную роль в его жизнедеятельности.