90594

Задачи линейного программирования (ЛП) в табличном редакторе Microsoft Exce

Практическая работа

Информатика, кибернетика и программирование

Ввести условие задачи: создать экранную форму для ввода условия задачи ввести исходные данные в экранную форму ввести зависимости из математической модели в экранную форму задать ЦФ ввести ограничения и граничные условия Решить задачу установить параметры решения задачи запустить задачу на решение...

Русский

2015-06-07

101.5 KB

0 чел.

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

НЕФТЕКАМСКИЙ ФИЛИАЛ

ФЕДЕРАЛЬНОГО ГОСУДАРСТВЕННОГО БЮДЖЕТНОГО ОБРАЗОВАТЕЛЬНОГО УЧРЕЖДЕНИЯ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«БАШКИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ»

Экономико-математический факультет

Кафедра математического моделирования и информационной безопасности

САМОСТОЯТЕЛЬНАЯ РАБОТА №1

по дисциплине «Методы принятия управленческих решений»

(Вариант:№11)

Выполнил: студент 1 курса

очной формы обучения

группы ГМУ-11

Мезенцева И.А

Проверил:

ст.пр. Зарипова Л.И.

Дата сдачи: 5.04.2014г.

Нефтекамск 2014
Задание.

Цель работы.

Приобретение навыков решения задач линейного программирования (ЛП) в табличном редакторе Microsoft Excel.

Порядок выполнения.

1.Вводим исходные данные.

Переменным задачи соответствуют ячейки:

 B3(x1); C3(x2); D3(x3); E3(x4); F3(x5).

Коэффициентам ЦФ соответствуют ячейки:

B5(c1=84); C5(c2=5.7); D5(c3=0); E5(c4=10); F5(c5=-3).

Правым частям ограничения соответствуют ячейки:

I9(b1=50); I10(b2=120); I11(b3=600); I12(b4=210).

2. В ячейку G5 вводим формулу, по которой будет рассчитываться значение целевой функции.

Целевая функция определяется выражением:

84x1+5.7x2+10x4-3x5

В ячейку G5 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B3:F3;B5:F5).

В ячейку G9 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B9:F9;B3:F3).

В ячейку G10 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B10:F10;B3:F3)

В ячейку G11 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B11:F11;B3:F3)

В ячейку G12 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B12:F12;B3:F3)

3.Устанавливаем параметры решения задачи. (В окне «Поиск решения»)

В графу «Установить ячейку» вводим $G$5  и приравниваем к максимальному значению.  В поле «Изменяя ячейки» вписываем адреса $B$3:$F$3. В поле «Ограничения» вписываем все ограничения целевой функции:

$B$3>=0;  $C$3>=0; $D$3>=0; $E$3>=0; $F$3>=0; $G$10<=120; $G$11=600; $G$12>=210; $G$9=50.

4.Решение задачи.

В окне «Поиск решения» нажимаем «Выполнить» получаем сообщение о решении задачи.

Ответом данной задачи линейного программирования являются следующие значения:


Вывод.

При выполнении данной работы я научилась решать задачи линейного программирования с помощью Microsoft Excel.

Для того чтобы решить задачу линейного программирования необходимо выполнить следующие действия.

1.Ввести условие задачи:

  1.  создать экранную форму для ввода условия задачи.
  2.  ввести исходные данные в экранную форму.
  3.  ввести  зависимости  из  математической  модели  в  экранную форму.
  4.  задать ЦФ.
  5.  ввести  ограничения  и  граничные  условия.

2.Решить задачу:

  1.  установить  параметры  решения  задачи.
  2.  запустить задачу на решение.
  3.  выбрать  формат  вывода  решения.


 

А также другие работы, которые могут Вас заинтересовать

43113. Модернизация электропривода скиповой лебёдки ЛС15 для доменной печи №1 ОАО «Косогорского металлургического завода» 6.15 MB
  Двухдвигательная скиповая лебёдка с возможностью работы от одного двигателя обуславливает разработку равноценной по надёжности системы управления. Применены три системы электропривода, две основных и одна резервная, что позволяет иметь семь вариантов электроуправления скиповой лебёдкой.
43114. Разработка инженерных сетей микрорайона города Пенза 307 KB
  Целью гидравлического расчёта является определение диаметров трубопроводов и потерь давления по длине трассы при известных расход теплоносителя и заданном располагаемом давлении на вводе в микрорайон, также увязка потерь давления по ответвлениям.
43115. Пресс-автомат для холодного выдавливания 250 KB
  Развитие современной науки и техники неразрывно связано с созданием новых машин, повышающих производительность и облегчающих труд человека на производстве. Главная задача, стоящая перед современным машиностроением- подготовка высококвалифицированных инженеров
43116. Разработка технологического процесса механической обработки детали «Корпус насоса» 678.5 KB
  Такт выпуска определяется по формуле: где годовая программа запуска изделий в производство шт; =28010 шт. Чтобы получить окончательный ответ относительно способа получения заготовки производится экономическое сравнение себестоимости получения деталей при данных методах литья по формуле 5. Стоимость заготовок получаемых такими методами как литьё по выплавляемым моделям и литьё под давлением можно с достаточной для курсового проектирования точностью определить по формуле: где СI базовая стоимость одной тонны...
43117. Проектирование привода ленточного конвейера 462 KB
  Применим индустриальное масло для тяжело нагруженных систем с антиокислительными, антикоррозийными, противоизносными и противозадирными присадками И-Т-Д-220, которое заливается в кратер редуктора до оси червяка.
43118. Проектирование специальных режущих инструментов 1.4 MB
  Графическое и математическое выражение фасонного профиля обрабатываемой детали определяется относительно координатных осей X и Y. Центр координатных осей О находится в точке пересечения левого края детали и ее оси вращения. Координатная ось X совмещается с осью вращения детали. Координатная ось Y проводится из центра координатных осей О перпендикулярно оси X.
43119. Кондуктор для сверления отверстия 10Н7 3.28 MB
  Частая смена объектов производства, связанная с нарастанием темпов технологического процесса, требует создание конструкций приспособлений, методов их расчёта и проектирования, обеспечивающих неуклонное сокращение сроков подготовки производства. Затраты на изготовление технологической оснастки составляют 15…20% от затрат на оборудования для технологического процесса обработки деталей машин или 10…24% от себестоимости машины. Станочные приспособления занимают наибольший удельный вес по стоимости и трудоёмкости изготовления в общем количестве различных типов технологической оснастки.
43120. Проектирование производственного здания «Завод по ремонту двигателей» 314.5 KB
  Проектирование начинается с задания. Задание на проектирование, которое определяется в основном технологическими процессами или назначением объекта, составляется с участием архитекторов, технологов и строителей-проектировщиков. В результате совместной разработки наряду с объемно-планировочной компоновкой, должны быть получены принципиальные решения конструктивной формы здания или сооружения. Эти принципиальные решения согласовываются с технологической и проектной организациями, после чего может быть начато проектирование.
43121. КИНЕМАТИЧЕСКИЙ РАСЧЕТ ПРИВОДА. РАСЧЕТ ЗУБЧАТЫХ ПЕРЕДАЧ 375 KB
  Определяем общий коэффициент полезного действия КПД привода где коэффициенты полезного действия ременной передачи цилиндрической передачи редуктора муфты и опор подшипников. где предел контактной выносливости для углеродистых сталей твердостью поверхностей зубьев менее НВ 350 и термической обработкой улучшением коэффициент долговечности при числе циклов нагружения больше базового что имеет место при длительной эксплуатации редуктора принимаем ; коэффициент безопасности; коэффициент учитывающий влияние...