90594

Задачи линейного программирования (ЛП) в табличном редакторе Microsoft Exce

Практическая работа

Информатика, кибернетика и программирование

Ввести условие задачи: создать экранную форму для ввода условия задачи ввести исходные данные в экранную форму ввести зависимости из математической модели в экранную форму задать ЦФ ввести ограничения и граничные условия Решить задачу установить параметры решения задачи запустить задачу на решение...

Русский

2015-06-07

101.5 KB

0 чел.

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

НЕФТЕКАМСКИЙ ФИЛИАЛ

ФЕДЕРАЛЬНОГО ГОСУДАРСТВЕННОГО БЮДЖЕТНОГО ОБРАЗОВАТЕЛЬНОГО УЧРЕЖДЕНИЯ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«БАШКИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ»

Экономико-математический факультет

Кафедра математического моделирования и информационной безопасности

САМОСТОЯТЕЛЬНАЯ РАБОТА №1

по дисциплине «Методы принятия управленческих решений»

(Вариант:№11)

Выполнил: студент 1 курса

очной формы обучения

группы ГМУ-11

Мезенцева И.А

Проверил:

ст.пр. Зарипова Л.И.

Дата сдачи: 5.04.2014г.

Нефтекамск 2014
Задание.

Цель работы.

Приобретение навыков решения задач линейного программирования (ЛП) в табличном редакторе Microsoft Excel.

Порядок выполнения.

1.Вводим исходные данные.

Переменным задачи соответствуют ячейки:

 B3(x1); C3(x2); D3(x3); E3(x4); F3(x5).

Коэффициентам ЦФ соответствуют ячейки:

B5(c1=84); C5(c2=5.7); D5(c3=0); E5(c4=10); F5(c5=-3).

Правым частям ограничения соответствуют ячейки:

I9(b1=50); I10(b2=120); I11(b3=600); I12(b4=210).

2. В ячейку G5 вводим формулу, по которой будет рассчитываться значение целевой функции.

Целевая функция определяется выражением:

84x1+5.7x2+10x4-3x5

В ячейку G5 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B3:F3;B5:F5).

В ячейку G9 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B9:F9;B3:F3).

В ячейку G10 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B10:F10;B3:F3)

В ячейку G11 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B11:F11;B3:F3)

В ячейку G12 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B12:F12;B3:F3)

3.Устанавливаем параметры решения задачи. (В окне «Поиск решения»)

В графу «Установить ячейку» вводим $G$5  и приравниваем к максимальному значению.  В поле «Изменяя ячейки» вписываем адреса $B$3:$F$3. В поле «Ограничения» вписываем все ограничения целевой функции:

$B$3>=0;  $C$3>=0; $D$3>=0; $E$3>=0; $F$3>=0; $G$10<=120; $G$11=600; $G$12>=210; $G$9=50.

4.Решение задачи.

В окне «Поиск решения» нажимаем «Выполнить» получаем сообщение о решении задачи.

Ответом данной задачи линейного программирования являются следующие значения:


Вывод.

При выполнении данной работы я научилась решать задачи линейного программирования с помощью Microsoft Excel.

Для того чтобы решить задачу линейного программирования необходимо выполнить следующие действия.

1.Ввести условие задачи:

  1.  создать экранную форму для ввода условия задачи.
  2.  ввести исходные данные в экранную форму.
  3.  ввести  зависимости  из  математической  модели  в  экранную форму.
  4.  задать ЦФ.
  5.  ввести  ограничения  и  граничные  условия.

2.Решить задачу:

  1.  установить  параметры  решения  задачи.
  2.  запустить задачу на решение.
  3.  выбрать  формат  вывода  решения.


 

А также другие работы, которые могут Вас заинтересовать

76642. Крещение Руси 34.5 KB
  Оно имеет длительную историю: распространение христианства на Руси началось задолго до крещения на Днепре и продолжалось еще в течение полутора веков. Православные источники связывают проникновение христианства на территорию Киевской Руси с миссионерской деятельностью апостола Андрея Первозванного в I веке н. Владимир предпринял первую религиозную реформу суть которой состояла в попытке слияния разнородных богов всех племен Киевской Руси в единый пантеон во главе с княжеским богом Перуном.
76643. Феодальная раздробленность Руси 27 KB
  Как и в Западной Европе тенденции к политической раздробленности на Руси проявились рано. Именно с этого времени историческая наука ведет отсчет феодальной раздробленности на Руси. В первые полтора века существования Киевской Руси дружина полностью находилась на содержании у князя.
76645. Русские земли в 15 в. и европейское средневековье. Складывание централизованного государства. Возвышение Москвы 39 KB
  Возвышение Москвы Как и в Западной Европе после периода феодальной раздробленности на Руси в XIVXV вв. На Руси хотя экономические связи между отдельными княжествами без сомнения развивались но общий всероссийский рынок возник позже только в XVII в. Таким образом политические процессы на Руси опережали экономические. Усилиями нескольких поколений выдающихся деятелей на Руси складывается такое государство.
76646. Россия в 16 в. в контексте развития европейской цивилизации. Иван-4 – первый царь Всея Руси. Опричина 35 KB
  Период опричнины В 1560 г. царь вводит новый порядок управления государством получивший название опричнины. Политическим и административным центром опричнины стал особый двор со своей Боярской думой и приказами. В опричнине была особая казна и особое опричное войско: первоначально одна тысяча к концу опричнины шесть тысяч.
76647. Россия в 16 в. в контексте развития европейской цивилизации. «Смутное время». Воцарение династии Романовых 38 KB
  Главной отраслью экономики России оставалось с х а основными с х культурами были рожь и овес. За счет освоения новых земель в Поволжье в Сибири на юге России производилось больше с х продукции чем в прошлом веке хотя методы обработки земли оставались прежними с помощью сохи бороны; плуг внедрялся медленно. период в истории России названный Смутным временем.
76648. Россия и мир в 18 в. Оформление Российского абсолютизма. Петр 1 27 KB
  В России в XVIII в. При Петре I в России окончательно утвердился абсолютизм Петр был провозглашен императором что означало усиление власти самого царя он стал монархом самодержавным и неограниченным. В России была проведена реформа государственного аппарата вместо Боярской думы учреждался Сенат в состав которого входили девять сановников ближайших Петру I. В России упразднялась должность патриарха наблюдение за церковью поручалось оберпрокурору Синода.
76649. Россия и мир в 18 в. Попытки модернизации и промышленный переворот. Дворцовые перевороты 33 KB
  Петр I умер 28 января 1725 г.Меншиков представитель новой родовой знати возвел на престол вдову Петра I Екатерину I. В его состав вошли соратники Петра I: А. После смерти Екатерины I наследным императором стал 12 летний Петр II внук Петра I.
76650. Первичные сигналы электросвязи и их параметры 162.04 KB
  Основными первичными сигналами электросвязи являются: телефонный звукового вещания факсимильный телевизионный телеграфный передачи данных. Описанием сигнала может служить некоторая функция времени. Однако такое полное определение сигнала не всегда требуется. Достаточно описание в виде нескольких параметров характеризующих основные свойства сигнала с точки зрения его передачи.