90594

Задачи линейного программирования (ЛП) в табличном редакторе Microsoft Exce

Практическая работа

Информатика, кибернетика и программирование

Ввести условие задачи: создать экранную форму для ввода условия задачи ввести исходные данные в экранную форму ввести зависимости из математической модели в экранную форму задать ЦФ ввести ограничения и граничные условия Решить задачу установить параметры решения задачи запустить задачу на решение...

Русский

2015-06-07

101.5 KB

0 чел.

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

НЕФТЕКАМСКИЙ ФИЛИАЛ

ФЕДЕРАЛЬНОГО ГОСУДАРСТВЕННОГО БЮДЖЕТНОГО ОБРАЗОВАТЕЛЬНОГО УЧРЕЖДЕНИЯ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«БАШКИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ»

Экономико-математический факультет

Кафедра математического моделирования и информационной безопасности

САМОСТОЯТЕЛЬНАЯ РАБОТА №1

по дисциплине «Методы принятия управленческих решений»

(Вариант:№11)

Выполнил: студент 1 курса

очной формы обучения

группы ГМУ-11

Мезенцева И.А

Проверил:

ст.пр. Зарипова Л.И.

Дата сдачи: 5.04.2014г.

Нефтекамск 2014
Задание.

Цель работы.

Приобретение навыков решения задач линейного программирования (ЛП) в табличном редакторе Microsoft Excel.

Порядок выполнения.

1.Вводим исходные данные.

Переменным задачи соответствуют ячейки:

 B3(x1); C3(x2); D3(x3); E3(x4); F3(x5).

Коэффициентам ЦФ соответствуют ячейки:

B5(c1=84); C5(c2=5.7); D5(c3=0); E5(c4=10); F5(c5=-3).

Правым частям ограничения соответствуют ячейки:

I9(b1=50); I10(b2=120); I11(b3=600); I12(b4=210).

2. В ячейку G5 вводим формулу, по которой будет рассчитываться значение целевой функции.

Целевая функция определяется выражением:

84x1+5.7x2+10x4-3x5

В ячейку G5 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B3:F3;B5:F5).

В ячейку G9 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B9:F9;B3:F3).

В ячейку G10 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B10:F10;B3:F3)

В ячейку G11 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B11:F11;B3:F3)

В ячейку G12 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B12:F12;B3:F3)

3.Устанавливаем параметры решения задачи. (В окне «Поиск решения»)

В графу «Установить ячейку» вводим $G$5  и приравниваем к максимальному значению.  В поле «Изменяя ячейки» вписываем адреса $B$3:$F$3. В поле «Ограничения» вписываем все ограничения целевой функции:

$B$3>=0;  $C$3>=0; $D$3>=0; $E$3>=0; $F$3>=0; $G$10<=120; $G$11=600; $G$12>=210; $G$9=50.

4.Решение задачи.

В окне «Поиск решения» нажимаем «Выполнить» получаем сообщение о решении задачи.

Ответом данной задачи линейного программирования являются следующие значения:


Вывод.

При выполнении данной работы я научилась решать задачи линейного программирования с помощью Microsoft Excel.

Для того чтобы решить задачу линейного программирования необходимо выполнить следующие действия.

1.Ввести условие задачи:

  1.  создать экранную форму для ввода условия задачи.
  2.  ввести исходные данные в экранную форму.
  3.  ввести  зависимости  из  математической  модели  в  экранную форму.
  4.  задать ЦФ.
  5.  ввести  ограничения  и  граничные  условия.

2.Решить задачу:

  1.  установить  параметры  решения  задачи.
  2.  запустить задачу на решение.
  3.  выбрать  формат  вывода  решения.


 

А также другие работы, которые могут Вас заинтересовать

13973. Анализ музыкальных произведений. Лекционный курс 679 KB
  В. В. Аннинская Лекции по курсу Анализ музыкальных произведений Учебное пособие Печатается по решению предметноцикловой комиссии Теория музыки музыкального училища им. Г.И. Шадриной Ульяновского государственного университета Рецензент – методис
13974. Башкирские музыкальные инструменты 73.5 KB
  Башкирские музыкальные инструменты. Башкирская инструментальная культура – наследие уходящее своими корнями в глубокую древность. Ее изучение началось сравнительно недавно первому подробному исследованию немногим более 100 лет а регулярный поиск и систематизация ин...
13975. Анатолий Константинович Лядов (1855-1914) 77.78 KB
  Будущий композитор родился в семье известного русского дирижёра Константина Лядова. Первые уроки музыки начал получать в пять лет от отца, а в 1870 году поступил в Петербургскую консерваторию в классы фортепиано и скрипки
13976. Биография П.И. Чайковского 16.76 KB
  Сообщение На тему: Биография П.И.Чайковского. Биография П.И.Чайковского Петр Ильич Чайковский родился в Предуралье в заводском поселке Воткинске. Его отец был горным инженером начальником завода. С раннего детства будущий...
13977. ДЕБЮССИ́ Клод Ашиль 17.21 KB
  ДЕБЮССИ́ Клод Ашиль 1862 1918 французский композитор пианист дирижер музыкальный критик. Основоположник муз. импрессионозма. Сочинениям присущи поэтичность изящество и прихотливость мелодии колористичность гармонии изысканность зыбкость муз. образов. Клод Ашиль
13978. Музыка как средство экранной выразительности 311 KB
  Содержание. Введение Глава 1. Средства выразительности видеорекламы Эстетические критерии художественной выразительности экранного творчества Формирование и развитие средств выразительности Современные средства экранной выразительности Г
13979. Развитие музыкальности детей младшего школьного возраста в процессе элементарного музицирования 1.94 MB
  ВЫПУСКНАЯ КВАЛИФИКАЦИОННАЯ РАБОТА Развитие музыкальности детей младшего школьного возраста в процессе элементарного музицирования План Введение Глава 1. Психолого-педагогические основы развития музыкальности детей младшего школьного в
13980. Рок-музыка 18.85 KB
  Рокмузыка Рокмузыка обобщающее название ряда направлений популярной музыки. Слово rock указывает на характерные для этих направлений ритмические ощущения связанные с определённой формой движения. Такие признаки рокмузыки как использование электромузыкальны
13981. Праздники в Индии 112.5 KB
  Праздники в Индии. Индия мультинациональное и мультикультурное государство поэтому здесь отмечаются праздники различных религий. Помимо религиозных в Индии имеется три официальных национальных праздника: День независимости Индии День Республики и День р...