90594

Задачи линейного программирования (ЛП) в табличном редакторе Microsoft Exce

Практическая работа

Информатика, кибернетика и программирование

Ввести условие задачи: создать экранную форму для ввода условия задачи ввести исходные данные в экранную форму ввести зависимости из математической модели в экранную форму задать ЦФ ввести ограничения и граничные условия Решить задачу установить параметры решения задачи запустить задачу на решение...

Русский

2015-06-07

101.5 KB

0 чел.

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

НЕФТЕКАМСКИЙ ФИЛИАЛ

ФЕДЕРАЛЬНОГО ГОСУДАРСТВЕННОГО БЮДЖЕТНОГО ОБРАЗОВАТЕЛЬНОГО УЧРЕЖДЕНИЯ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«БАШКИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ»

Экономико-математический факультет

Кафедра математического моделирования и информационной безопасности

САМОСТОЯТЕЛЬНАЯ РАБОТА №1

по дисциплине «Методы принятия управленческих решений»

(Вариант:№11)

Выполнил: студент 1 курса

очной формы обучения

группы ГМУ-11

Мезенцева И.А

Проверил:

ст.пр. Зарипова Л.И.

Дата сдачи: 5.04.2014г.

Нефтекамск 2014
Задание.

Цель работы.

Приобретение навыков решения задач линейного программирования (ЛП) в табличном редакторе Microsoft Excel.

Порядок выполнения.

1.Вводим исходные данные.

Переменным задачи соответствуют ячейки:

 B3(x1); C3(x2); D3(x3); E3(x4); F3(x5).

Коэффициентам ЦФ соответствуют ячейки:

B5(c1=84); C5(c2=5.7); D5(c3=0); E5(c4=10); F5(c5=-3).

Правым частям ограничения соответствуют ячейки:

I9(b1=50); I10(b2=120); I11(b3=600); I12(b4=210).

2. В ячейку G5 вводим формулу, по которой будет рассчитываться значение целевой функции.

Целевая функция определяется выражением:

84x1+5.7x2+10x4-3x5

В ячейку G5 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B3:F3;B5:F5).

В ячейку G9 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B9:F9;B3:F3).

В ячейку G10 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B10:F10;B3:F3)

В ячейку G11 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B11:F11;B3:F3)

В ячейку G12 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B12:F12;B3:F3)

3.Устанавливаем параметры решения задачи. (В окне «Поиск решения»)

В графу «Установить ячейку» вводим $G$5  и приравниваем к максимальному значению.  В поле «Изменяя ячейки» вписываем адреса $B$3:$F$3. В поле «Ограничения» вписываем все ограничения целевой функции:

$B$3>=0;  $C$3>=0; $D$3>=0; $E$3>=0; $F$3>=0; $G$10<=120; $G$11=600; $G$12>=210; $G$9=50.

4.Решение задачи.

В окне «Поиск решения» нажимаем «Выполнить» получаем сообщение о решении задачи.

Ответом данной задачи линейного программирования являются следующие значения:


Вывод.

При выполнении данной работы я научилась решать задачи линейного программирования с помощью Microsoft Excel.

Для того чтобы решить задачу линейного программирования необходимо выполнить следующие действия.

1.Ввести условие задачи:

  1.  создать экранную форму для ввода условия задачи.
  2.  ввести исходные данные в экранную форму.
  3.  ввести  зависимости  из  математической  модели  в  экранную форму.
  4.  задать ЦФ.
  5.  ввести  ограничения  и  граничные  условия.

2.Решить задачу:

  1.  установить  параметры  решения  задачи.
  2.  запустить задачу на решение.
  3.  выбрать  формат  вывода  решения.


 

А также другие работы, которые могут Вас заинтересовать

59462. Cценарій: Усний журнал “Народні символи України” 66 KB
  Частину журналу який висвітлює яке-небудь одне питання умовно прийнято називати сторінкою журналу. Щоб викликати інтерес до журналу можна зробити його своєрідний макет із твердого паперу відповідно оформивши його обкладинку і кожну сторінку.
59463. Cценарій: Андріївські вечорниці 30.5 KB
  Група дівчат середнього та хлопців старшого віку святково прибраний зал на сцені інтерєр укр. Катерина. Ой так хочеться все швидше їх розпочати і вареників наших покуштувати Катерина.
59464. Cценарій: Спортивне свято 451 KB
  Як називається місце гри в теніс ринг трек корт батут 28. Як називається прикраса що її носять на голові кольє діадема браслет кулон 33. Як називається сума сторін прямокутника Скільки дециметрів в 1 метрі Українська мова Скільки букв в українському алфавіті.
59465. Географічне положення та населення Європи 133 KB
  Фізико-географічне положення Європи Фізико-географічне положення іноді порівнюють з поштовою адресою: щоб Ваше послання знайшло адресата необхідно зазначити країну місто вулицю будинок квартиру. Не менш вдалим можна вважати порівняння фізико-географічного положення з долею...
59466. Європейські держави: минуле і сучасне 45.5 KB
  А точніше модель європейської цивілізації. Згадайте: Які риси і цінності притаманні цьому типу цивілізації Але Європа зовсім не зразу виробила цю модель. Вони вважали що це були темні страшні віки після загибелі античної цивілізації. Епоха зародження індустріальної цивілізації ХVІ кінець ХVІІІ ст.
59467. Захист прав людини у Європі та світі 70.5 KB
  Всі люди створені рівними і наділені Творцем певними невідємними правами до яких належать життя свобода і прагнення до щастя. Документ 2 З Декларації прав людини і громадянина. забуття прав людини і неповага до них є єдиними причинами суспільних негараздів і вад уряду.
59468. Європейський союз 149.5 KB
  Будівництво Європи без кордонів почалося тоді коли у 1951 році шість держав підписали в Парижі угоду про заснування Європейського обєднання вугілля і сталі Бельгія Італія Люксембург Нідерланди Німеччина та Франція продовжується сьогодні і триватиме ще не одне десятиліття.
59469. Європейська культурна спадщина 51 KB
  Якими міжнародними документами в Європі регулюються проблеми культурної спадщини Чому потрібно зберігати культурноісторичну спадщину ІІ. У 1991 році Рада Європи офіційно запровадила щорічні вересневі Дні європейської спадщини...
59470. Релігія в житті сучасного європейця 102.5 KB
  Релігія явище дуже складне і має соціальний характер тобто воно виникло в суспільстві цілком закономірно й існує разом з ним. Слово релігія походить від латинського religio що означає звязок.