90594

Задачи линейного программирования (ЛП) в табличном редакторе Microsoft Exce

Практическая работа

Информатика, кибернетика и программирование

Ввести условие задачи: создать экранную форму для ввода условия задачи ввести исходные данные в экранную форму ввести зависимости из математической модели в экранную форму задать ЦФ ввести ограничения и граничные условия Решить задачу установить параметры решения задачи запустить задачу на решение...

Русский

2015-06-07

101.5 KB

0 чел.

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

НЕФТЕКАМСКИЙ ФИЛИАЛ

ФЕДЕРАЛЬНОГО ГОСУДАРСТВЕННОГО БЮДЖЕТНОГО ОБРАЗОВАТЕЛЬНОГО УЧРЕЖДЕНИЯ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«БАШКИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ»

Экономико-математический факультет

Кафедра математического моделирования и информационной безопасности

САМОСТОЯТЕЛЬНАЯ РАБОТА №1

по дисциплине «Методы принятия управленческих решений»

(Вариант:№11)

Выполнил: студент 1 курса

очной формы обучения

группы ГМУ-11

Мезенцева И.А

Проверил:

ст.пр. Зарипова Л.И.

Дата сдачи: 5.04.2014г.

Нефтекамск 2014
Задание.

Цель работы.

Приобретение навыков решения задач линейного программирования (ЛП) в табличном редакторе Microsoft Excel.

Порядок выполнения.

1.Вводим исходные данные.

Переменным задачи соответствуют ячейки:

 B3(x1); C3(x2); D3(x3); E3(x4); F3(x5).

Коэффициентам ЦФ соответствуют ячейки:

B5(c1=84); C5(c2=5.7); D5(c3=0); E5(c4=10); F5(c5=-3).

Правым частям ограничения соответствуют ячейки:

I9(b1=50); I10(b2=120); I11(b3=600); I12(b4=210).

2. В ячейку G5 вводим формулу, по которой будет рассчитываться значение целевой функции.

Целевая функция определяется выражением:

84x1+5.7x2+10x4-3x5

В ячейку G5 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B3:F3;B5:F5).

В ячейку G9 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B9:F9;B3:F3).

В ячейку G10 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B10:F10;B3:F3)

В ячейку G11 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B11:F11;B3:F3)

В ячейку G12 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B12:F12;B3:F3)

3.Устанавливаем параметры решения задачи. (В окне «Поиск решения»)

В графу «Установить ячейку» вводим $G$5  и приравниваем к максимальному значению.  В поле «Изменяя ячейки» вписываем адреса $B$3:$F$3. В поле «Ограничения» вписываем все ограничения целевой функции:

$B$3>=0;  $C$3>=0; $D$3>=0; $E$3>=0; $F$3>=0; $G$10<=120; $G$11=600; $G$12>=210; $G$9=50.

4.Решение задачи.

В окне «Поиск решения» нажимаем «Выполнить» получаем сообщение о решении задачи.

Ответом данной задачи линейного программирования являются следующие значения:


Вывод.

При выполнении данной работы я научилась решать задачи линейного программирования с помощью Microsoft Excel.

Для того чтобы решить задачу линейного программирования необходимо выполнить следующие действия.

1.Ввести условие задачи:

  1.  создать экранную форму для ввода условия задачи.
  2.  ввести исходные данные в экранную форму.
  3.  ввести  зависимости  из  математической  модели  в  экранную форму.
  4.  задать ЦФ.
  5.  ввести  ограничения  и  граничные  условия.

2.Решить задачу:

  1.  установить  параметры  решения  задачи.
  2.  запустить задачу на решение.
  3.  выбрать  формат  вывода  решения.


 

А также другие работы, которые могут Вас заинтересовать

80069. Від Різдва до Водохреща 69.5 KB
  Мета: знайомити учнів з традиціями, звичаями та обрядами українського народу, що пов’язані Різдвяно-новорічними святами; розвивати акторські здібності учнів, уміння виразно читати поетичні та прозові твори; виховувати повагу до традицій нашого народу, милосердя, почуття прекрасного.
80070. ROAD SAFETY 49 KB
  It is a traffic-light. You can see it at the cross-roads in the big cities. Look. It has three colours: red, yellow and green. If you see a red colour you must stop. If you see a yellow colour you must wait. If you see a green colour you can cross the street.
80071. Классный час «Я – ребенок, я – личность» 49.5 KB
  Не скучайте не зевайте ничего не упускайте ученик в костюме скомороха Добрый день уважаемые гости Собрались мы сегодня поговорить о личности. Каждому из нас шестиклассников очень хорошо знакомо чувство обиды. Иногда кажется что тебя не понимают с твоим мнением не считаются забывают что ты личность
80072. СТОЇТЬ В СКОРБОТІ МАТИ – УКРАЇНА, БІЛЯ МОГИЛ СВОЇХ ДІТЕЙ СТОЇТЬ… 69.5 KB
  Світ мав би розколотися надвоє, сонце мало б перестати світити, земля перевернутися від того, що це мало місце! Але світ не розколовся і сонце сходить, Земля обертається, як їй належить. І ми ходимо по цій землі зі своїми тривогами і надіями, ми, єдині спадкоємці всього, що було.
80073. Дзвони Чорнобиля 31.5 KB
  Звичайний день. Всі люди йдуть у своєму напрямку: хто на роботу, хто до школи, а хто просто у своїх справах. Лише один вчений, відчувши погіршення самопочуття та плітки про вибух на АЕС, вирішив перевірити повітря на радіаційний фон.
80074. Природознавство. Річки 35 KB
  Мета: Поглибити знання учнів про кругообіг води в природі, ознайомити з складовими частинами річки, вміти знаходити лівий та правий берег, розвивати світогляд учнів, виховувати любов до рідного краю. Тип урока: Комбінований. Наочність: «Чарівна квітка», зошит з дидактичними завданнями, «Ніч на Дніпрі».
80075. Моя родина (урок довкілля в 3 класі) 43 KB
  Сім’я, мов сонечко, зігріває дитину від народження і до кінця днів. Сім’я – це гніздечко любові і тепла для кожного з нас. У родині має панувати злагода і повага до близьких, менші повинні шанувати старших, особливо бабусь і дідусів.
80076. Н у що б, здавалося, слова… 62.5 KB
  Яка прекрасна українська мова Виплекана колоссям землею виспівана птахами звеличена письменниками. Мова Яка ти багатогранна ніжна чиста як промінчики сонця що яскравим сяйвом осипають землю добром радістю плодами Ти квітуєш пелюстками слів у морозних думах полину даєш поетові дужі крила...
80077. Складання розповіді з елементами опису калини 62 KB
  Вчити дітей складати і записувати розповідь з елементами опису за планом. Розвивати усне та писемне мовлення; уміння описувати рослину, зокрема, калину, використовуючи прикметники, порівняння, слова, вжиті в переносному значенні; пізнавальну діяльність, творчі здібності.