90594

Задачи линейного программирования (ЛП) в табличном редакторе Microsoft Exce

Практическая работа

Информатика, кибернетика и программирование

Ввести условие задачи: создать экранную форму для ввода условия задачи ввести исходные данные в экранную форму ввести зависимости из математической модели в экранную форму задать ЦФ ввести ограничения и граничные условия Решить задачу установить параметры решения задачи запустить задачу на решение...

Русский

2015-06-07

101.5 KB

0 чел.

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

НЕФТЕКАМСКИЙ ФИЛИАЛ

ФЕДЕРАЛЬНОГО ГОСУДАРСТВЕННОГО БЮДЖЕТНОГО ОБРАЗОВАТЕЛЬНОГО УЧРЕЖДЕНИЯ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«БАШКИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ»

Экономико-математический факультет

Кафедра математического моделирования и информационной безопасности

САМОСТОЯТЕЛЬНАЯ РАБОТА №1

по дисциплине «Методы принятия управленческих решений»

(Вариант:№11)

Выполнил: студент 1 курса

очной формы обучения

группы ГМУ-11

Мезенцева И.А

Проверил:

ст.пр. Зарипова Л.И.

Дата сдачи: 5.04.2014г.

Нефтекамск 2014
Задание.

Цель работы.

Приобретение навыков решения задач линейного программирования (ЛП) в табличном редакторе Microsoft Excel.

Порядок выполнения.

1.Вводим исходные данные.

Переменным задачи соответствуют ячейки:

 B3(x1); C3(x2); D3(x3); E3(x4); F3(x5).

Коэффициентам ЦФ соответствуют ячейки:

B5(c1=84); C5(c2=5.7); D5(c3=0); E5(c4=10); F5(c5=-3).

Правым частям ограничения соответствуют ячейки:

I9(b1=50); I10(b2=120); I11(b3=600); I12(b4=210).

2. В ячейку G5 вводим формулу, по которой будет рассчитываться значение целевой функции.

Целевая функция определяется выражением:

84x1+5.7x2+10x4-3x5

В ячейку G5 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B3:F3;B5:F5).

В ячейку G9 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B9:F9;B3:F3).

В ячейку G10 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B10:F10;B3:F3)

В ячейку G11 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B11:F11;B3:F3)

В ячейку G12 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B12:F12;B3:F3)

3.Устанавливаем параметры решения задачи. (В окне «Поиск решения»)

В графу «Установить ячейку» вводим $G$5  и приравниваем к максимальному значению.  В поле «Изменяя ячейки» вписываем адреса $B$3:$F$3. В поле «Ограничения» вписываем все ограничения целевой функции:

$B$3>=0;  $C$3>=0; $D$3>=0; $E$3>=0; $F$3>=0; $G$10<=120; $G$11=600; $G$12>=210; $G$9=50.

4.Решение задачи.

В окне «Поиск решения» нажимаем «Выполнить» получаем сообщение о решении задачи.

Ответом данной задачи линейного программирования являются следующие значения:


Вывод.

При выполнении данной работы я научилась решать задачи линейного программирования с помощью Microsoft Excel.

Для того чтобы решить задачу линейного программирования необходимо выполнить следующие действия.

1.Ввести условие задачи:

  1.  создать экранную форму для ввода условия задачи.
  2.  ввести исходные данные в экранную форму.
  3.  ввести  зависимости  из  математической  модели  в  экранную форму.
  4.  задать ЦФ.
  5.  ввести  ограничения  и  граничные  условия.

2.Решить задачу:

  1.  установить  параметры  решения  задачи.
  2.  запустить задачу на решение.
  3.  выбрать  формат  вывода  решения.


 

А также другие работы, которые могут Вас заинтересовать

50100. Способи перенесення одного партнера двома і техніка їх виконання 45.5 KB
  Перенесення партнера: одного одним одного двома. Однією із різновидів перенесення вантажу є перенесення партнера. Способи перенесення партнера: одного двома; одного одним. Способи перенесення одного партнера двома і техніка їх виконання...
50103. Вычисления в MatLab 728.5 KB
  Пример выполнения работы Материалы для заданий 1 2 Потери пучка при прохождении через вещество В этой работе можно познакомиться с основным методом моделирования применяемым при исследовании прохождения пучков частиц через вещество методом статистического моделирования называемым методом МонтеКарло. При этом судьба каждой частицы разыгрывается с помощью случайного выбора а полученные для множества частиц результаты подвергаются статистической обработке. Метод применяется например при проектировании ядерных реакторов...
50104. Исследование метрологических возможностей моста Уитстона 194 KB
  Определение удельного сопротивления заданного материала. Так например мост Уитстона используется для определения изменения сопротивления тензорезистора тензодатчика измеряющего изменение давления температуры распределение деформаций изгиб или сжатиерастяжение в конструктивных элементах зданий сооружений в сводах подземных выработок и многое др. Измеряемое сопротивление Rx и три других переменных сопротивления R R1 и R2 соединяются так что образуют замкнутый четырехугольник BCD. Но можно подобрать сопротивления R R1 и R2...
50105. Градуювання термопари і спостереження явища Пельтьє 81.5 KB
  Для усix значень різниці температур Т2 Т1 визначити дійсні значення термоЕРС. На основі двох одержаних графіків визначити середнє значення абсолютної похибки градуювання термопари. Визначити питому термоЕРС для двох крайніх і середньої точки графіка за п. Визначити різницю термоЕРС і за таблицею що знаходиться на робочому місці визначити значення різниці температур контактів.
50106. СПЕКТРАЛЬНАЯ ХАРАКТЕРИСТИКА ПОЛУПРОВОДНИКОВОГО ФОТОЭЛЕМЕНТА 166.5 KB
  Тогда с учетом формул 6 и 7 для спектральной чувствительности фотоэлемента можно записать: 8 Согласно выражению 8 отношение спектральной чувствительности фотоэлемента γλ для произвольной длины волны λ к его чувствительности γγm для фиксированной длины волны λт будет равно: 9 В формуле 9 Um обозначает напряжение в цепи при освещении фотоэлемента светом с длиной волны λт и считается что в изучаемой спектральной области при постоянной величине входной щели монохроматора интервал длин волн dλ для разных λ изменяется...
50108. Техніка ударів по мячу головою 77 KB
  Техніка ударів по мячу головою. У другій фазі його тулуб швидко подається вперед і верхньою частиною голови він бє по мячу. Удар по мячу головою з місця Послідовність навчання Удар по нерухомому мячу.