90594

Задачи линейного программирования (ЛП) в табличном редакторе Microsoft Exce

Практическая работа

Информатика, кибернетика и программирование

Ввести условие задачи: создать экранную форму для ввода условия задачи ввести исходные данные в экранную форму ввести зависимости из математической модели в экранную форму задать ЦФ ввести ограничения и граничные условия Решить задачу установить параметры решения задачи запустить задачу на решение...

Русский

2015-06-07

101.5 KB

0 чел.

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

НЕФТЕКАМСКИЙ ФИЛИАЛ

ФЕДЕРАЛЬНОГО ГОСУДАРСТВЕННОГО БЮДЖЕТНОГО ОБРАЗОВАТЕЛЬНОГО УЧРЕЖДЕНИЯ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«БАШКИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ»

Экономико-математический факультет

Кафедра математического моделирования и информационной безопасности

САМОСТОЯТЕЛЬНАЯ РАБОТА №1

по дисциплине «Методы принятия управленческих решений»

(Вариант:№11)

Выполнил: студент 1 курса

очной формы обучения

группы ГМУ-11

Мезенцева И.А

Проверил:

ст.пр. Зарипова Л.И.

Дата сдачи: 5.04.2014г.

Нефтекамск 2014
Задание.

Цель работы.

Приобретение навыков решения задач линейного программирования (ЛП) в табличном редакторе Microsoft Excel.

Порядок выполнения.

1.Вводим исходные данные.

Переменным задачи соответствуют ячейки:

 B3(x1); C3(x2); D3(x3); E3(x4); F3(x5).

Коэффициентам ЦФ соответствуют ячейки:

B5(c1=84); C5(c2=5.7); D5(c3=0); E5(c4=10); F5(c5=-3).

Правым частям ограничения соответствуют ячейки:

I9(b1=50); I10(b2=120); I11(b3=600); I12(b4=210).

2. В ячейку G5 вводим формулу, по которой будет рассчитываться значение целевой функции.

Целевая функция определяется выражением:

84x1+5.7x2+10x4-3x5

В ячейку G5 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B3:F3;B5:F5).

В ячейку G9 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B9:F9;B3:F3).

В ячейку G10 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B10:F10;B3:F3)

В ячейку G11 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B11:F11;B3:F3)

В ячейку G12 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B12:F12;B3:F3)

3.Устанавливаем параметры решения задачи. (В окне «Поиск решения»)

В графу «Установить ячейку» вводим $G$5  и приравниваем к максимальному значению.  В поле «Изменяя ячейки» вписываем адреса $B$3:$F$3. В поле «Ограничения» вписываем все ограничения целевой функции:

$B$3>=0;  $C$3>=0; $D$3>=0; $E$3>=0; $F$3>=0; $G$10<=120; $G$11=600; $G$12>=210; $G$9=50.

4.Решение задачи.

В окне «Поиск решения» нажимаем «Выполнить» получаем сообщение о решении задачи.

Ответом данной задачи линейного программирования являются следующие значения:


Вывод.

При выполнении данной работы я научилась решать задачи линейного программирования с помощью Microsoft Excel.

Для того чтобы решить задачу линейного программирования необходимо выполнить следующие действия.

1.Ввести условие задачи:

  1.  создать экранную форму для ввода условия задачи.
  2.  ввести исходные данные в экранную форму.
  3.  ввести  зависимости  из  математической  модели  в  экранную форму.
  4.  задать ЦФ.
  5.  ввести  ограничения  и  граничные  условия.

2.Решить задачу:

  1.  установить  параметры  решения  задачи.
  2.  запустить задачу на решение.
  3.  выбрать  формат  вывода  решения.


 

А также другие работы, которые могут Вас заинтересовать

9282. История развития хирургии. Основные этапы зарождения и развития хирургии 19.34 KB
  Лекция №1 История развития хирургии. Основные этапы зарождения и развития хирургии Алиев Фуад Шамильевич. Хирургия (chier - рука, ergon - действие рукодействие, ремесло) - раздел клинической медицины, изучающий болезни и повреждения, при...
9283. Асептика. Основные принципы асептики. Хирургическая инфекция 15.67 KB
  Лекция №2 Асептика. Основные принципы асептики. Хирургическая инфекция. Впервые термин асептика ввел английский военный хирург Роберт Прингл в 1750г. Асептика - это комплекс мероприятий, Основные меры профилактики развития инфекционного проце...
9284. Антисептика 21.68 KB
  Лекция №3 Антисептика Термин был предложен 1750 г. Английским хирургом Дж. Принглом Антисептика - противогнилостный метод работы Еще в древности медики эмпирически пришли к выводу о необходимости обеззараживания ран Применяли прижига...
9285. Местная анестезия 17.05 KB
  Лекция №4 Местная анестезия В 1855 году австриец привез листья коки, его жевали и получали удовольствие. Кокаин – родоначальник местной анестезии. Египет –- мрамор+уксус. Сдавливание нервов. Дхлаждение кожи. Эфир. Баллон Ричардсона...
9286. Понятие боли. Общее обезболивание. Подготовка больных к наркозу 19.24 KB
  Лекция №5 Понятие боли. Общее обезболивание. Подготовка больных к наркозу. Боль - сторожевой пес здоровья. Ноцицепция: ноцирецепторы - рецепторы - воспринимают болевые ощущения. Раздражители: механические, термические, химические. При...
9287. Техника проведения наркоза. Осложнения наркоза 20.07 KB
  Лекция № 6 Техника проведения наркоза. Осложнения наркоза. Общая анестезия. Подготовка. Полное обследование Оценка общего состояния (риск операции и наркоза) Психологическая Медикаментозная Подготовка ЖКТ Премедик...
9288. Терминальные состояния 20.8 KB
  Лекция № 7 Терминальные состояния Реаниматология - наука о закономерностях угасания жизни, оживления организма, профилактике и лечении терминальных состояний. Интенсивная терапия - это лечение больного, находящегося в терминальном состояни...
9289. Методы сердечно-легочной реанимации 24.76 KB
  Лекция № 8 Методы сердечно-легочной реанимации Актуальность: Эффективность сердечно-легочной реанимации зависит от своевременности оказания медицинской помощи При начале реанимационных мероприятий после наступления клинической смерти. Для констатац...
9290. Кровотечение. Реакция организма на кровопотерю 21.25 KB
  Лекция №9 Кровотечение. Реакция организма на кровопотерю. Петехия - небольшое кровоизлияние в кожу. Пурпуре – кровоизлияние в слизистые оболочки. Экхимозы - обширное кровотечение в кожу или слизистые. Гематома - ограничивание кро...