90594

Задачи линейного программирования (ЛП) в табличном редакторе Microsoft Exce

Практическая работа

Информатика, кибернетика и программирование

Ввести условие задачи: создать экранную форму для ввода условия задачи ввести исходные данные в экранную форму ввести зависимости из математической модели в экранную форму задать ЦФ ввести ограничения и граничные условия Решить задачу установить параметры решения задачи запустить задачу на решение...

Русский

2015-06-07

101.5 KB

0 чел.

МИНИСТЕРСТВО ОБРАЗОВАНИЯ И НАУКИ РОССИЙСКОЙ ФЕДЕРАЦИИ

НЕФТЕКАМСКИЙ ФИЛИАЛ

ФЕДЕРАЛЬНОГО ГОСУДАРСТВЕННОГО БЮДЖЕТНОГО ОБРАЗОВАТЕЛЬНОГО УЧРЕЖДЕНИЯ

ВЫСШЕГО ПРОФЕССИОНАЛЬНОГО ОБРАЗОВАНИЯ

«БАШКИРСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ»

Экономико-математический факультет

Кафедра математического моделирования и информационной безопасности

САМОСТОЯТЕЛЬНАЯ РАБОТА №1

по дисциплине «Методы принятия управленческих решений»

(Вариант:№11)

Выполнил: студент 1 курса

очной формы обучения

группы ГМУ-11

Мезенцева И.А

Проверил:

ст.пр. Зарипова Л.И.

Дата сдачи: 5.04.2014г.

Нефтекамск 2014
Задание.

Цель работы.

Приобретение навыков решения задач линейного программирования (ЛП) в табличном редакторе Microsoft Excel.

Порядок выполнения.

1.Вводим исходные данные.

Переменным задачи соответствуют ячейки:

 B3(x1); C3(x2); D3(x3); E3(x4); F3(x5).

Коэффициентам ЦФ соответствуют ячейки:

B5(c1=84); C5(c2=5.7); D5(c3=0); E5(c4=10); F5(c5=-3).

Правым частям ограничения соответствуют ячейки:

I9(b1=50); I10(b2=120); I11(b3=600); I12(b4=210).

2. В ячейку G5 вводим формулу, по которой будет рассчитываться значение целевой функции.

Целевая функция определяется выражением:

84x1+5.7x2+10x4-3x5

В ячейку G5 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B3:F3;B5:F5).

В ячейку G9 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B9:F9;B3:F3).

В ячейку G10 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B10:F10;B3:F3)

В ячейку G11 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B11:F11;B3:F3)

В ячейку G12 вводим формулу и нажимаем Enter

=СУММПРОИЗВ(B12:F12;B3:F3)

3.Устанавливаем параметры решения задачи. (В окне «Поиск решения»)

В графу «Установить ячейку» вводим $G$5  и приравниваем к максимальному значению.  В поле «Изменяя ячейки» вписываем адреса $B$3:$F$3. В поле «Ограничения» вписываем все ограничения целевой функции:

$B$3>=0;  $C$3>=0; $D$3>=0; $E$3>=0; $F$3>=0; $G$10<=120; $G$11=600; $G$12>=210; $G$9=50.

4.Решение задачи.

В окне «Поиск решения» нажимаем «Выполнить» получаем сообщение о решении задачи.

Ответом данной задачи линейного программирования являются следующие значения:


Вывод.

При выполнении данной работы я научилась решать задачи линейного программирования с помощью Microsoft Excel.

Для того чтобы решить задачу линейного программирования необходимо выполнить следующие действия.

1.Ввести условие задачи:

  1.  создать экранную форму для ввода условия задачи.
  2.  ввести исходные данные в экранную форму.
  3.  ввести  зависимости  из  математической  модели  в  экранную форму.
  4.  задать ЦФ.
  5.  ввести  ограничения  и  граничные  условия.

2.Решить задачу:

  1.  установить  параметры  решения  задачи.
  2.  запустить задачу на решение.
  3.  выбрать  формат  вывода  решения.


 

А также другие работы, которые могут Вас заинтересовать

65319. ПРАВОВЕ РЕГУЛЮВАННЯ ВИКОНАННЯ ПОДАТКОВОГО ОБОВ’ЯЗКУ 150 KB
  Забезпечення реальної можливості здійснення податкового обовязку один із головних напрямків фінансової політики держави. Ефективність процедурноправового регулювання виконання податкового обовязку безпосередньо впливає в першу чергу на забезпечення безумовної...
65321. МЕТОДИ ПРИСКОРЕНОГО КРИПТОАНАЛІЗУ БСШ НА ОСНОВІ АНАЛІЗУ ПОКАЗНИКІВ СТІЙКОСТІ ЗМЕНШЕНИХ МОДЕЛЕЙ ПРОТОТИПІВ 554 KB
  Відмічене визначає актуальність теми дисертаційної роботи направленої на вдосконалення методик оцінки показників стійкості БСШ до атак диференційного і лінійного криптоаналізу в інтересах в першу чергу підвищення якості і надійності...
65322. МУЛЬТИАГЕНТНІ МЕТОДИ ПОБУДОВИ НЕЙРО-НЕЧІТКИХ МЕРЕЖ 1.04 MB
  Проте методи навчання що використовуються при побудові нейронечітких мереж характеризуються недоліками повязаними з проблемою встановлення параметрів навчання вимагають участі користувача вимогою диференційованості функцій належності до нечітких термів...
65323. МОДЕЛІ АВТОМАТИЗОВАНОГО СИСТЕМНОГО ПРОЕКТУВАННЯ АВТОМАТИЧНОЇ ТРАНСМІСІЇ 663.5 KB
  Метою роботи є підвищення ефективності синтезу АТ за рахунок розробки математичних моделей автоматизованого проектування АТ та її блоків системи автоматичного управління САУ та її елементів звязків між ними вибору програмного забезпечення...
65324. ОБГРУНТУВАННЯ ПАРАМЕТРІВ ЗАСОБІВ ІНДИВІДУАЛЬНОГО ПРОТИГАЗОТЕПЛОВОГО ЗАХИСТУ ГІРНИКІВ 341.5 KB
  Тому розробка і створення індивідуальних засобів протигазотеплового захисту гірників членів ДГК є актуальним науковотехнічним завданням вирішення якого дозволить підвищити безпеку та ефективність ведення робіт в умовах нагрівального мікроклімату.
65325. ПЕРЕТРАВНІСТЬ КОРМУ, ОБМІН РЕЧОВИН І ПРОДУКТИВНІСТЬ КУРЕЙ-НЕСУЧОК ЗА РІЗНОГО РІВНЯ ТА СПІВВІДНОШЕННЯ СІРКИ І СЕЛЕНУ В КОМБІКОРМІ 283 KB
  Доведена доцільність використання в якості джерела сірки сульфату натрію оптимальна кількість якого в комбікормах для курчатбройлерів та ремонтного молодняку курей становить 03 від маси корму для каченят і гусенят − 10 а для курейнесучок − 05 від маси комбікорму.
65326. НЕЙРОМЕРЕЖНА ОБРОБКА БАГАТОВИМІРНИХ СИГНАЛІВ 457 KB
  Обрана тема дисертаційної роботи є актуальною тому що штучні нейронні мережі ШНМ протягом останнього часу переконливо довели свою ефективність при вирішенні різноманітних задач адаптивної обробки інформації таких як апроксимація нелінійних функцій класифікація управління...
65327. ОРГАНІЗАЦІЯ РОЗСЛІДУВАННЯ ЗЛОЧИНІВ ТА ЇЇ МІСЦЕ У СТРУКТУРІ КРИМІНАЛІСТИКИ 147.5 KB
  Чільне місце серед функцій держави займає правоохоронна яка реалізується зокрема за допомогою організації розслідування злочинів. Організаційна діяльність дозволяє підвищувати ефективність розслідування сприяє його всебічності повноті та обєктивності...